Namespaces
Send Feedback

Namespaces

Namespace | Description
JanaBiz.Bridge |
JanaBiz.Db |
JanaBiz.Db.Exceptions |
JanaBiz.DbXml |
JanaBiz.DbXml.Exceptions |
Send feedback on this topic to Microsoft.


JanaBiz.Bridge Namespace

[image]

.NET Framework Class Library
JanaBiz.Bridge Namespace
Send Feedback

Classes

Class | Description
FlagsBase | The abstract class that represents a a flagsable value.
InvocationHandle | The abstract class that represents a Handle.


FlagsBase Class

[image]

.NET Framework Class Library
FlagsBase Class
Members See Also Send Feedback

The abstract class that represents a a flagsable value.

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class FlagsBase _
    Implements ICloneable
C#
public class FlagsBase : ICloneable
Visual C++
public ref class FlagsBase : ICloneable
JavaScript
JanaBiz.Bridge.FlagsBase = function();

Type.createClass(
    'JanaBiz.Bridge.FlagsBase',
    null,
    ICloneable);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.Db..::.DbTransactionConfig
JanaBiz.Db..::.DbVerifyConfig
JanaBiz.DbXml..::.XmlDocumentConfig
JanaBiz.DbXml..::.XmlManagerConfig

See Also

FlagsBase Members
JanaBiz.Bridge Namespace


FlagsBase Members

[image] [image]

.NET Framework Class Library
FlagsBase Members
FlagsBase Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The FlagsBase type exposes the following members.

Constructors

Name | Description
FlagsBase |

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

FlagsBase Class
JanaBiz.Bridge Namespace


FlagsBase Constructor

[image]

.NET Framework Class Library
FlagsBase Constructor
FlagsBase Class See Also Send Feedback

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public FlagsBase()
Visual C++
public:
FlagsBase()
JavaScript
JanaBiz.Bridge.FlagsBase = function();

See Also

FlagsBase Class
JanaBiz.Bridge Namespace


FlagsBase Methods

[image] [image]

.NET Framework Class Library
FlagsBase Methods
FlagsBase Class See Also Send Feedback

The FlagsBase type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

FlagsBase Class
JanaBiz.Bridge Namespace


ICloneable.Clone Method

[image]

.NET Framework Class Library
FlagsBase..::.ICloneable..::.Clone Method
FlagsBase Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone
JavaScript
JavaScript does not support explicit interface implementations.

Return Value

このインスタンスのコピーである新しいオブジェクト。

Implements

ICloneable..::.Clone()()()

See Also

FlagsBase Class
JanaBiz.Bridge Namespace


Clone Method

[image]

.NET Framework Class Library
FlagsBase..::.Clone Method
FlagsBase Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As FlagsBase
C#
public FlagsBase Clone()
Visual C++
public:
FlagsBase^ Clone()
JavaScript
function clone();

Return Value

このインスタンスのコピーである新しいオブジェクト。

See Also

FlagsBase Class
JanaBiz.Bridge Namespace


InvocationHandle Class

[image]

.NET Framework Class Library
InvocationHandle Class
Members See Also Send Feedback

The abstract class that represents a Handle.

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class InvocationHandle _
    Implements IDisposable
C#
public abstract class InvocationHandle : IDisposable
Visual C++
public ref class InvocationHandle abstract : IDisposable
JavaScript
JanaBiz.Bridge.InvocationHandle = function();

Type.createClass(
    'JanaBiz.Bridge.InvocationHandle',
    null,
    IDisposable);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.Db..::.DbEnvironment
JanaBiz.Db..::.DbTransaction
JanaBiz.DbXml..::.XmlArguments
JanaBiz.DbXml..::.XmlCompression
JanaBiz.DbXml..::.XmlContainer
JanaBiz.DbXml..::.XmlContainerConfig
JanaBiz.DbXml..::.XmlData
JanaBiz.DbXml..::.XmlDebugListener
JanaBiz.DbXml..::.XmlEventReader
JanaBiz.DbXml..::.XmlEventReaderToWriter
JanaBiz.DbXml..::.XmlEventWriter
JanaBiz.DbXml..::.XmlExternalFunction
JanaBiz.DbXml..::.XmlIndexDeclaration
JanaBiz.DbXml..::.XmlIndexLookup
JanaBiz.DbXml..::.XmlIndexSpecification
JanaBiz.DbXml..::.XmlInputStream
JanaBiz.DbXml..::.XmlManager
JanaBiz.DbXml..::.XmlMetaData
JanaBiz.DbXml..::.XmlMetaDataIterator
JanaBiz.DbXml..::.XmlNode
JanaBiz.DbXml..::.XmlQueryContext
JanaBiz.DbXml..::.XmlQueryExpression
JanaBiz.DbXml..::.XmlResolver
JanaBiz.DbXml..::.XmlResults
JanaBiz.DbXml..::.XmlStackFrame
JanaBiz.DbXml..::.XmlStatistics
JanaBiz.DbXml..::.XmlTransaction
JanaBiz.DbXml..::.XmlUpdateContext
JanaBiz.DbXml..::.XmlValue

See Also

InvocationHandle Members
JanaBiz.Bridge Namespace


InvocationHandle Members

[image] [image]

.NET Framework Class Library
InvocationHandle Members
InvocationHandle Class Methods See Also Send Feedback

The InvocationHandle type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Overrides Object..::.Finalize()()().)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

InvocationHandle Class
JanaBiz.Bridge Namespace


InvocationHandle Methods

[image] [image]

.NET Framework Class Library
InvocationHandle Methods
InvocationHandle Class See Also Send Feedback

The InvocationHandle type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Overrides Object..::.Finalize()()().)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

InvocationHandle Class
JanaBiz.Bridge Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
InvocationHandle..::.Dispose Method
InvocationHandle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。

See Also

InvocationHandle Class
InvocationHandle Members
JanaBiz.Bridge Namespace


Dispose Method

[image]

.NET Framework Class Library
InvocationHandle..::.Dispose Method
InvocationHandle Class See Also Send Feedback

アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Dispose
C#
public void Dispose()
Visual C++
public:
virtual void Dispose() sealed
JavaScript
function dispose();

Implements

IDisposable..::.Dispose()()()

See Also

InvocationHandle Class
Dispose Overload
JanaBiz.Bridge Namespace


Dispose Method (Boolean)

[image]

.NET Framework Class Library
InvocationHandle..::.Dispose Method (Boolean)
InvocationHandle Class See Also Send Feedback

アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
C#
protected virtual void Dispose(
    bool disposing
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)
JavaScript
function dispose(disposing);

Parameters

disposing
Type: System..::.Boolean
Disposing.

See Also

InvocationHandle Class
Dispose Overload
JanaBiz.Bridge Namespace


Finalize Method

[image]

.NET Framework Class Library
InvocationHandle..::.Finalize Method
InvocationHandle Class See Also Send Feedback

Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection.

Namespace: JanaBiz.Bridge
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Overrides Sub Finalize
C#
protected override void Finalize()
Visual C++
protected:
virtual void Finalize() override
JavaScript
function finalize();

See Also

InvocationHandle Class
JanaBiz.Bridge Namespace


JanaBiz.Db Namespace

[image]

.NET Framework Class Library
JanaBiz.Db Namespace
Send Feedback

Classes

Class | Description
DbEnvironment | A database environment.
DbEnvironmentConfig | Specifies the attributes of an environment.
DbTransaction | The DbTransaction class is the handle for a db transaction.
DbTransactionConfig | Specifies the attributes of a database environment transaction.
DbVerifyConfig | Specifies the attributes of a verification operation.

Delegates

Delegate | Description
ErrorHandler | A callback function to be called when an error occurs in the Berkeley DB library.
MessageHandler | A callback function to be called to display informational messages.

Enumerations

Enumeration | Description
DbLockDetectMode | Deadlock detection modes.
DbLockMode | Locking modes for database operations.


DbEnvironment Class

[image]

.NET Framework Class Library
DbEnvironment Class
Members See Also Send Feedback

A database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class DbEnvironment _
    Inherits InvocationHandle
C#
public class DbEnvironment : InvocationHandle
Visual C++
public ref class DbEnvironment : public InvocationHandle
JavaScript
JanaBiz.Db.DbEnvironment = function();

Type.createClass(
    'JanaBiz.Db.DbEnvironment',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Environments include support for some or all of caching, locking, logging and transactions.

To open an existing environment with default attributes the application may use a default environment configuration object or null:

Copy Code
            // Open an environment handle with default attributes.
            DbEnvironment env = new DbEnvironment(home, new EnvironmentConfig());
or
Copy Code
            DbEnvironment env = new DbEnvironment(home, null);

Note that many Environment objects may access a single environment. To create an environment or customize attributes, the application should customize the configuration class. For example:

Copy Code
            DbEnvironmentConfig envConfig = new DbEnvironmentConfig();
            envConfig.Transactional = true;
            envConfig.AllowCreate = true;
            envConfig.CacheSize = 1024*128;//128M
            DbEnvironment newlyCreatedEnv = new DbEnvironment(home, envConfig);

Environment handles are free-threaded unless Threaded is called to disable this before the environment is opened.

An environment handle is an Environment instance. More than one Environment instance may be created for the same physical directory, which is the same as saying that more than one Environment handle may be open at one time for a given environment.

The Environment handle should not be closed while any other handle remains open that is using it as a reference DbTransaction. Once Dispose()()() or Close()()() is called, this object may not be accessed again, regardless of whether or not it throws an exception.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.Db..::.DbEnvironment

See Also

DbEnvironment Members
JanaBiz.Db Namespace


DbEnvironment Members

[image] [image]

.NET Framework Class Library
DbEnvironment Members
DbEnvironment Class Constructors Methods Properties See Also Send Feedback

The DbEnvironment type exposes the following members.

Constructors

Name | Description
DbEnvironment | Initializes a new instance of the DbEnvironment class.

Methods

Name | Description
Checkpoint | Flushes the underlying memory pool, writes a checkpoint record to the log, and then flushes the log.
Close | Close the database environment, freeing any allocated resources and closing any underlying subsystems.
DetectDeadlocks | Runs one iteration of the deadlock detector.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArchiveDatabases | Return the names of the database files that need to be archived in order to recover the database from catastrophic failure.
GetArchiveLogFiles | Returns an array of log filenames.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Remove | Destroy a database environment.
RemoveOldLogFiles | Remove log files that are no longer needed.
ToString | (Inherited from Object.)

Properties

Name | Description
Config | The DbEnvironment object's configuration.
Home | The contarner environment home directory.
Version | Gets the version.
VersionMajor | Gets the version major.
VersionMinor | Gets the version minor.
VersionPatch | Gets the version patch.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


DbEnvironment Constructor

[image]

.NET Framework Class Library
DbEnvironment Constructor
DbEnvironment Class See Also Send Feedback

Initializes a new instance of the DbEnvironment class.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    home As String, _
    config As DbEnvironmentConfig _
)
C#
public DbEnvironment(
    string home,
    DbEnvironmentConfig config
)
Visual C++
public:
DbEnvironment(
    String^ home,
    DbEnvironmentConfig^ config
)
JavaScript
JanaBiz.Db.DbEnvironment = function(home, config);

Parameters

home
Type: System..::.String
The home.
config
Type: JanaBiz.Db..::.DbEnvironmentConfig
The config.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


DbEnvironment Methods

[image] [image]

.NET Framework Class Library
DbEnvironment Methods
DbEnvironment Class See Also Send Feedback

The DbEnvironment type exposes the following members.

Methods

Name | Description
Checkpoint | Flushes the underlying memory pool, writes a checkpoint record to the log, and then flushes the log.
Close | Close the database environment, freeing any allocated resources and closing any underlying subsystems.
DetectDeadlocks | Runs one iteration of the deadlock detector.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArchiveDatabases | Return the names of the database files that need to be archived in order to recover the database from catastrophic failure.
GetArchiveLogFiles | Returns an array of log filenames.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Remove | Destroy a database environment.
RemoveOldLogFiles | Remove log files that are no longer needed.
ToString | (Inherited from Object.)

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Checkpoint Method

[image]

.NET Framework Class Library
DbEnvironment..::.Checkpoint Method
DbEnvironment Class See Also Send Feedback

Flushes the underlying memory pool, writes a checkpoint record to the log, and then flushes the log.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Checkpoint ( _
    kBytes As Integer, _
    minutes As Integer, _
    force As Boolean _
)
C#
public void Checkpoint(
    int kBytes,
    int minutes,
    bool force
)
Visual C++
public:
void Checkpoint(
    int kBytes,
    int minutes,
    bool force
)
JavaScript
function checkpoint(kBytes, minutes, force);

Parameters

kBytes
Type: System..::.Int32
If the kbyte parameter is non-zero, a checkpoint will be done if more than kbyte kilobytes of log data have been written since the last checkpoint.
minutes
Type: System..::.Int32
If the min parameter is non-zero, a checkpoint will be done if more than min minutes have passed since the last checkpoint.
force
Type: System..::.Boolean
Force a checkpoint record, even if there has been no activity since the last checkpoint.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Close Method

[image]

.NET Framework Class Library
DbEnvironment..::.Close Method
DbEnvironment Class See Also Send Feedback

Close the database environment, freeing any allocated resources and closing any underlying subsystems.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

See Also

DbEnvironment Class
JanaBiz.Db Namespace


DetectDeadlocks Method

[image]

.NET Framework Class Library
DbEnvironment..::.DetectDeadlocks Method
DbEnvironment Class See Also Send Feedback

Runs one iteration of the deadlock detector.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function DetectDeadlocks ( _
    mode As DbLockDetectMode _
) As Integer
C#
public int DetectDeadlocks(
    DbLockDetectMode mode
)
Visual C++
public:
int DetectDeadlocks(
    DbLockDetectMode mode
)
JavaScript
function detectDeadlocks(mode);

Parameters

mode
Type: JanaBiz.Db..::.DbLockDetectMode
Which lock request(s) to reject.

Return Value

The number of lock requests that were rejected.

Remarks

The deadlock detector traverses the lock table and marks one of the participating lock requesters for rejection in each deadlock it finds.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
DbEnvironment..::.Dispose Method
DbEnvironment Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

DbEnvironment Class
DbEnvironment Members
JanaBiz.Db Namespace


GetArchiveDatabases Method

[image]

.NET Framework Class Library
DbEnvironment..::.GetArchiveDatabases Method
DbEnvironment Class See Also Send Feedback

Return the names of the database files that need to be archived in order to recover the database from catastrophic failure.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetArchiveDatabases As String()
C#
public string[] GetArchiveDatabases()
Visual C++
public:
array<String^>^ GetArchiveDatabases()
JavaScript
function getArchiveDatabases();

Return Value

Returns an array of database filenames.

Remarks

If any of the database files have not been accessed during the lifetime of the current log files, their names will not be included in this list. It is also possible that some of the files referred to by the log have since been deleted from the system.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


GetArchiveLogFiles Method

[image]

.NET Framework Class Library
DbEnvironment..::.GetArchiveLogFiles Method
DbEnvironment Class See Also Send Feedback

Returns an array of log filenames.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetArchiveLogFiles ( _
    includeInUse As Boolean _
) As String()
C#
public string[] GetArchiveLogFiles(
    bool includeInUse
)
Visual C++
public:
array<String^>^ GetArchiveLogFiles(
    bool includeInUse
)
JavaScript
function getArchiveLogFiles(includeInUse);

Parameters

includeInUse
Type: System..::.Boolean
Return all the log filenames, regardless of whether or not they are in use.

Return Value

Return the names of all of the log files that are no longer in use.

Remarks

This method returns the names of all of the log files that are no longer in use (for example, that are no longer involved in active transactions), and that may safely be archived for catastrophic recovery and then removed from the system. If there are no filenames to return, the method returns null.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Remove Method

[image]

.NET Framework Class Library
DbEnvironment..::.Remove Method
DbEnvironment Class See Also Send Feedback

Destroy a database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub Remove ( _
    home As String, _
    force As Boolean, _
    config As DbEnvironmentConfig _
)
C#
public static void Remove(
    string home,
    bool force,
    DbEnvironmentConfig config
)
Visual C++
public:
static void Remove(
    String^ home,
    bool force,
    DbEnvironmentConfig^ config
)
JavaScript
JanaBiz.Db.DbEnvironment.remove = function(home, force, config);

Parameters

home
Type: System..::.String
The database environment to be removed. On Windows platforms, this argument will be interpreted as a UTF-8 string, which is equivalent to ASCII for Latin characters.
force
Type: System..::.Boolean
The environment is removed, regardless of any processes that may still using it, and no locks are acquired during this process. (Generally, the force argument is specified only when applications were unable to shut down cleanly, and there is a risk that an application may have died holding a Berkeley DB mutex or lock.
config
Type: JanaBiz.Db..::.DbEnvironmentConfig
The configuration for this operation.

Remarks

If the environment is not in use, the environment regions, including any backing files, are removed. Any log or database files and the environment directory itself are not removed.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


RemoveOldLogFiles Method

[image]

.NET Framework Class Library
DbEnvironment..::.RemoveOldLogFiles Method
DbEnvironment Class See Also Send Feedback

Remove log files that are no longer needed.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveOldLogFiles
C#
public void RemoveOldLogFiles()
Visual C++
public:
void RemoveOldLogFiles()
JavaScript
function removeOldLogFiles();

Remarks

Automatic log file removal is likely to make catastrophic recovery impossible.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


DbEnvironment Properties

[image] [image]

.NET Framework Class Library
DbEnvironment Properties
DbEnvironment Class See Also Send Feedback

The DbEnvironment type exposes the following members.

Properties

Name | Description
Config | The DbEnvironment object's configuration.
Home | The contarner environment home directory.
Version | Gets the version.
VersionMajor | Gets the version major.
VersionMinor | Gets the version minor.
VersionPatch | Gets the version patch.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Config Property

[image]

.NET Framework Class Library
DbEnvironment..::.Config Property
DbEnvironment Class See Also Send Feedback

The DbEnvironment object's configuration.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Config As DbEnvironmentConfig
C#
public DbEnvironmentConfig Config { get; set; }
Visual C++
public:
property DbEnvironmentConfig^ Config {
    DbEnvironmentConfig^ get ();
    void set (DbEnvironmentConfig^ value);
}
JavaScript
function get_config();
function set_config(value);

Field Value

The config.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Home Property

[image]

.NET Framework Class Library
DbEnvironment..::.Home Property
DbEnvironment Class See Also Send Feedback

The contarner environment home directory.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Home As String
C#
public string Home { get; }
Visual C++
public:
property String^ Home {
    String^ get ();
}
JavaScript
function get_home();

Field Value

The contarner environment's home directory.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


Version Property

[image]

.NET Framework Class Library
DbEnvironment..::.Version Property
DbEnvironment Class See Also Send Feedback

Gets the version.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Version As String
C#
public static string Version { get; }
Visual C++
public:
static property String^ Version {
    String^ get ();
}
JavaScript
JanaBiz.Db.DbEnvironment.get_version = function();

Field Value

See Also

DbEnvironment Class
JanaBiz.Db Namespace


VersionMajor Property

[image]

.NET Framework Class Library
DbEnvironment..::.VersionMajor Property
DbEnvironment Class See Also Send Feedback

Gets the version major.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionMajor As Integer
C#
public static int VersionMajor { get; }
Visual C++
public:
static property int VersionMajor {
    int get ();
}
JavaScript
JanaBiz.Db.DbEnvironment.get_versionMajor = function();

Field Value

The release major number.

Remarks

If major is non-NULL, the major version of the Berkeley DB release is copied to the memory to which it refers.

This method may be called at any time during the life of the application.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


VersionMinor Property

[image]

.NET Framework Class Library
DbEnvironment..::.VersionMinor Property
DbEnvironment Class See Also Send Feedback

Gets the version minor.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionMinor As Integer
C#
public static int VersionMinor { get; }
Visual C++
public:
static property int VersionMinor {
    int get ();
}
JavaScript
JanaBiz.Db.DbEnvironment.get_versionMinor = function();

Field Value

The release minor number.

Remarks

If minor is non-NULL, the minor version of the Berkeley DB release is copied to the memory to which it refers.

This method may be called at any time during the life of the application.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


VersionPatch Property

[image]

.NET Framework Class Library
DbEnvironment..::.VersionPatch Property
DbEnvironment Class See Also Send Feedback

Gets the version patch.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionPatch As Integer
C#
public static int VersionPatch { get; }
Visual C++
public:
static property int VersionPatch {
    int get ();
}
JavaScript
JanaBiz.Db.DbEnvironment.get_versionPatch = function();

Field Value

Remarks

If patch is non-NULL, the patch version of the Berkeley DB release is copied to the memory to which it refers.

This method may be called at any time during the life of the application.

See Also

DbEnvironment Class
JanaBiz.Db Namespace


DbEnvironmentConfig Class

[image]

.NET Framework Class Library
DbEnvironmentConfig Class
Members See Also Send Feedback

Specifies the attributes of an environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class DbEnvironmentConfig _
    Implements ICloneable
C#
public class DbEnvironmentConfig : ICloneable
Visual C++
public ref class DbEnvironmentConfig : ICloneable
JavaScript
JanaBiz.Db.DbEnvironmentConfig = function();

Type.createClass(
    'JanaBiz.Db.DbEnvironmentConfig',
    null,
    ICloneable);

Remarks

To change the default settings for a database environment, an application creates a configuration object, customizes settings and uses it for environment construction. The set methods of this class validate the configuration values when the method is invoked. An IllegalArgumentException is thrown if the value is not valid for that attribute.

All commonly used environment attributes have convenience setter/getter methods defined in this class. For example, to change the default transaction timeout setting for an environment, the application should do the following:

Copy Code
            // customize an environment configuration
            DbEnvironmentConfig envConfig = new DbEnvironmentConfig();
            envConfig.TransactionTimeout=10000;  // will throw if timeout value is invalid
            // Open the environment.
            DbEnvironment myEnvironment = new DbEnvironment(home, envConfig);
Additional parameters are described in the example.properties file found at the top level of the distribution package. These additional parameters will not be needed by most applications. This category of properties can be specified for the EnvironmentConfig object through a Properties object read by EnvironmentConfig(Properties).

An EnvironmentConfig can be used to specify both mutable and immutable environment properties. Immutable properties may be specified when the first Environment handle (instance) is opened for a given physical environment. When more handles are opened for the same environment, the following rules apply: 1.Immutable properties must equal the original values specified when constructing an Environment handle for an already open environment. When a mismatch occurs, an exception is thrown. 2.Mutable properties are ignored when constructing an Environment handle for an already open environment.

After an Environment has been constructed, it's mutable properties may be changed using Config.

Inheritance Hierarchy

System..::.Object
JanaBiz.Db..::.DbEnvironmentConfig

See Also

DbEnvironmentConfig Members
JanaBiz.Db Namespace


DbEnvironmentConfig Members

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig Members
DbEnvironmentConfig Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DbEnvironmentConfig type exposes the following members.

Constructors

Name | Description
DbEnvironmentConfig | Overloaded.

Methods

Name | Description
AddDataDir | Add the path of a directory to be used as the location of the access method database files.
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。
CreateDefaultConfig | Create an DbEnvironmentConfig initialized with the default transactional settings.
Equals | Overloaded.
Finalize | (Inherited from Object.)
GetHashCode | 特定の型のハッシュ関数として機能します。 (Overrides Object..::.GetHashCode()()().)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Fields

Name | Description
Default | For internal use, to allow null as a valid value for the config parameter.

Properties

Name | Description
AllowCreate | Cause Berkeley DB subsystems to create any underlying files, as necessary.
CacheCount | The number of shared memory buffer pools, that is, the number of caches.
CacheMax | Gets or sets the maximum size of the cache.
CacheSize | The size(kb) of the shared memory buffer pool, that is, the cache.
CdbLockAllDatabases | The Concurrent Data Store applications are configured to perform locking on an environment-wide basis rather than on a per-database basis.
CreateDir | Gets or sets the path of a directory to be used as the location to create the access method database files. When the open function is used to create a file it will be created relative to this path.
DataDirs | The array of data directories.
DirectDatabaseIO | The database environment has been configured to not buffer database files.
DirectLogIO | The database environment has been configured to not buffer log files.
DsyncDatabases | Configure Berkeley DB to flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
DsyncLog | The database environment has been configured to flush log writes to the backing disk before returning from the write system call.
Encrypted | The database environment has been configured to perform encryption.
EncryptedPassword | The password used to perform encryption and decryption.
ErrorHandler | When an error occurs in the Berkeley DB library, an exception is thrown or an error return value is returned by the interface.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
ErrorWriter | When an error occurs in the Berkeley DB library, an exception is thrown or an errno value is returned by the interface.
InitializeCache | Initialize the shared memory buffer pool subsystem.
InitializeCDB | Initialize locking for the Berkeley DB Concurrent Data Store product.
InitializeLocking | Initialize the locking subsystem.
InitializeLogging | Initialize the logging subsystem.
InitializeRegions | In some applications, the expense of page-faulting the underlying shared memory regions can affect performance.
InitializeReplication | Initialize the replication subsystem.
JoinEnvironment | Join an existing environment.
LockDetectMode | If the deadlock detector is to be run whenever a lock conflict occurs, and specify what lock request(s) should be rejected.
LockDown | Lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockTimeout | Timeout values for locks in the database environment.
LogAutoRemove | If set, Berkeley DB will automatically remove log files that are no longer needed.
LogBufferSize | The size of the in-memory log buffer, in bytes.
LogDirectory | The path of a directory to be used as the location of logging files.
LogFileMode | The absolute file mode for created log files. This method is only useful for the rare Berkeley DB application that does not control its umask value.
LogInMemory | Maintain transaction logs in memory rather than on disk.
LogRegionSize | The size of the underlying logging area of the database environment, in bytes.
LogZero | If set, zero all pages of a log file when that log file is created. This has been shown to provide greater transaction throughput in some environments. The log file will be zeroed by the thread which needs to re-create the new log file. Other threads may not write to the log file while this is happening.
MaxLockers | The maximum number of locking entities supported by the Berkeley DB environment.
MaxLockObjects | The maximum number of locked objects supported by the Berkeley DB environment.
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxLogFileSize | The maximum size of a single file in the log, in bytes.
MaxMutexes | The total number of mutexes to allocate.
MaxOpenFiles | The maximum number of file descriptors the library will open concurrently when flushing dirty pages from the cache.
MaxWrite | The maximum number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MaxWriteSleep | The number of microseconds the thread of control should pause before scheduling further write operations.
MessageWriter | Gets or sets the message writer for displaying informational messages.
MmapSize | The maximum file size, in bytes, for a file to be mapped into the process address space.
Mode | On Windows systems, the mode parameter is ignored.
MpPageSize | The cache page size, in bytes.
MpTableSize | The cache table size, in bytes.
Multiversion | Configure the database environment to open all databases that are not using the queue access method for multiversion concurrency control.
MutexAlignment | The mutex alignment, in bytes.
MutexIncrement | The number of mutexes to allocate.
MutexTestAndSetSpins | The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.
NoLocking | If set, Berkeley DB will grant all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMap | If set, Berkeley DB will copy read-only database files into the local cache instead of potentially mapping them into process memory (see the description of the set_mp_mmapsize method for further information).
NoPanic | If set, Berkeley DB will ignore any panic state in the database environment.
Overwrite | Overwrite files stored in encrypted formats before deleting them.
PartitionLocks | The number of lock table partitions in the Berkeley DB environment.
Private | Specify that the environment will only be accessed by a single process (although that process may be multithreaded).
Register | Check if a process has failed while using the database environment.
RunFatalRecovery | Run catastrophic recovery on this environment before opening it for normal use.
RunRecovery | Run normal recovery on this environment before opening it for normal use.
SystemMemory | Allocate memory from system shared memory instead of from memory backed by the filesystem. See Shared Memory Regions for more information.
TemporaryDirectory | The path of a directory to be used as the location of temporary files.
Threaded | Cause the DbEnv handle returned by [!:DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.
Transactional | Initialize the transaction subsystem.
TransactionMaxActive | Configure the Berkeley DB database environment to support at least max active transactions.
TransactionNoSync | If set, Berkeley DB will not write or synchronously flush the log on transaction commit.
TransactionNotDurable | The system has been configured to not write log records.
TransactionNoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.
TransactionSnapshot | Configure the database environment to run transactions at snapshot isolation by default.
TransactionTimeout | Sets timeout values for transactions in the database environment.
TransactionTimestamp | Recover to the specified time rather than to the most current possible date.
TransactionWriteNoSync | If set, Berkeley DB will write, but will not synchronously flush, the log on transaction commit.
UseEnvironment | The Berkeley DB process' environment may be permitted to specify information to be used when naming files.
UseEnvironmentRoot | The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming. Because permitting users to specify which files are used can create security problems, if the UseEnvironmentRoot flag is set, environment information will be used for file naming only for users with appropriate permissions (for example, users with a user-ID of 0 on UNIX systems).
VerboseDeadlock | Display additional information when doing deadlock detection.
VerboseFileops | Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.
VerboseFileopsAll | Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.
VerboseRecovery | Display additional information when performing recovery.
VerboseRegister | Display additional information concerning support for the Register method.
VerboseWaitsFor | Display the waits-for table when doing deadlock detection.
YieldCPU | If set, Berkeley DB will yield the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DbEnvironmentConfig Constructor

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig Constructor
DbEnvironmentConfig Class See Also Send Feedback

Overload List

Name | Description
DbEnvironmentConfig()()() | Initializes a new instance of the DbEnvironmentConfig class.
DbEnvironmentConfig(DbEnvironment) |

See Also

DbEnvironmentConfig Class
DbEnvironmentConfig Members
JanaBiz.Db Namespace


DbEnvironmentConfig Constructor

[image]

.NET Framework Class Library
DbEnvironmentConfig Constructor
DbEnvironmentConfig Class See Also Send Feedback

Initializes a new instance of the DbEnvironmentConfig class.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbEnvironmentConfig()
Visual C++
public:
DbEnvironmentConfig()
JavaScript
JanaBiz.Db.DbEnvironmentConfig = function();

See Also

DbEnvironmentConfig Class
DbEnvironmentConfig Overload
JanaBiz.Db Namespace


DbEnvironmentConfig Constructor (DbEnvironment)

[image]

.NET Framework Class Library
DbEnvironmentConfig Constructor (DbEnvironment)
DbEnvironmentConfig Class See Also Send Feedback

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbEnv As DbEnvironment _
)
C#
public DbEnvironmentConfig(
    DbEnvironment dbEnv
)
Visual C++
public:
DbEnvironmentConfig(
    DbEnvironment^ dbEnv
)
JavaScript
JanaBiz.Db.DbEnvironmentConfig = function(dbEnv);

Parameters

dbEnv
Type: JanaBiz.Db..::.DbEnvironment

See Also

DbEnvironmentConfig Class
DbEnvironmentConfig Overload
JanaBiz.Db Namespace


DbEnvironmentConfig Fields

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig Fields
DbEnvironmentConfig Class See Also Send Feedback

The DbEnvironmentConfig type exposes the following members.

Fields

Name | Description
Default | For internal use, to allow null as a valid value for the config parameter.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Default Field

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Default Field
DbEnvironmentConfig Class See Also Send Feedback

For internal use, to allow null as a valid value for the config parameter.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Default As DbEnvironmentConfig
C#
public static readonly DbEnvironmentConfig Default
Visual C++
public:
static initonly DbEnvironmentConfig^ Default
JavaScript
JanaBiz.Db.DbEnvironmentConfig.default

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DbEnvironmentConfig Methods

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig Methods
DbEnvironmentConfig Class See Also Send Feedback

The DbEnvironmentConfig type exposes the following members.

Methods

Name | Description
AddDataDir | Add the path of a directory to be used as the location of the access method database files.
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。
CreateDefaultConfig | Create an DbEnvironmentConfig initialized with the default transactional settings.
Equals | Overloaded.
Finalize | (Inherited from Object.)
GetHashCode | 特定の型のハッシュ関数として機能します。 (Overrides Object..::.GetHashCode()()().)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Operators

Name | Description
Equality | Implements the operator ==.
Inequality | Implements the operator !=.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


ICloneable.Clone Method

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.ICloneable..::.Clone Method
DbEnvironmentConfig Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone
JavaScript
JavaScript does not support explicit interface implementations.

Return Value

このインスタンスのコピーである新しいオブジェクト。

Implements

ICloneable..::.Clone()()()

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


AddDataDir Method

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.AddDataDir Method
DbEnvironmentConfig Class See Also Send Feedback

Add the path of a directory to be used as the location of the access method database files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDataDir ( _
    dir As String _
)
C#
public void AddDataDir(
    string dir
)
Visual C++
public:
void AddDataDir(
    String^ dir
)
JavaScript
function addDataDir(dir);

Parameters

dir
Type: System..::.String

Remarks

Set the path of a directory to be used as the location of the access method database files. Paths set using this method are additive, and specifying more than one will result in each specified directory being searched for database files. If any directories are specified, created database files will always be created in the first path specified.

If no database directories are specified, database files must be named either by absolute paths or relative to the environment home directory.

The database environment's data directories may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_data_dir", one or more whitespace characters, and the directory name.

The DataDirs configures operations performed using the specified DbEnv handle, not all operations performed on the underlying database environment.

The method may be called at any time during the life of the application. If the database environment already exists when DbEnvironment is Initialized, the information specified to the method must be consistent with the existing environment or corruption can occur.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Clone Method

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Clone Method
DbEnvironmentConfig Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As DbEnvironmentConfig
C#
public DbEnvironmentConfig Clone()
Visual C++
public:
DbEnvironmentConfig^ Clone()
JavaScript
function clone();

Return Value

このインスタンスのコピーである新しいオブジェクト。

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CreateDefaultConfig Method

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CreateDefaultConfig Method
DbEnvironmentConfig Class See Also Send Feedback

Create an DbEnvironmentConfig initialized with the default transactional settings.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Function CreateDefaultConfig As DbEnvironmentConfig
C#
public static DbEnvironmentConfig CreateDefaultConfig()
Visual C++
public:
static DbEnvironmentConfig^ CreateDefaultConfig()
JavaScript
JanaBiz.Db.DbEnvironmentConfig.createDefaultConfig = function();

Return Value

an DbEnvironmentConfig

Remarks

Copy Code
            Private = true;
            AllowCreat = true;
            InitializeLocking = true;
            InitializeLogging = true;
            InitializeCache = true;
            Transactional = true;
            RunRecovery = true;

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Equality Operator

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Equality Operator
DbEnvironmentConfig Class See Also Send Feedback

Implements the operator ==.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    left As DbEnvironmentConfig, _
    right As DbEnvironmentConfig _
) As Boolean
C#
public static bool operator ==(
    DbEnvironmentConfig left,
    DbEnvironmentConfig right
)
Visual C++
public:
static bool operator ==(
    DbEnvironmentConfig^ left,
    DbEnvironmentConfig^ right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: JanaBiz.Db..::.DbEnvironmentConfig
The left.
right
Type: JanaBiz.Db..::.DbEnvironmentConfig
The right.

Return Value

The result of the operator.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Equals Method

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig..::.Equals Method
DbEnvironmentConfig Class See Also Send Feedback

Overload List

Name | Description
Equals(DbEnvironmentConfig) | 指定した Object が、現在の Object と等しいかどうかを判断します。
Equals(Object) | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Overrides Object..::.Equals(Object).)

See Also

DbEnvironmentConfig Class
DbEnvironmentConfig Members
JanaBiz.Db Namespace


Equals Method (DbEnvironmentConfig)

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Equals Method (DbEnvironmentConfig)
DbEnvironmentConfig Class See Also Send Feedback

指定した Object が、現在の Object と等しいかどうかを判断します。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As DbEnvironmentConfig _
) As Boolean
C#
public bool Equals(
    DbEnvironmentConfig other
)
Visual C++
public:
bool Equals(
    DbEnvironmentConfig^ other
)
JavaScript
function equals(other);

Parameters

other
Type: JanaBiz.Db..::.DbEnvironmentConfig
現在の Object と比較する Object。

Return Value

指定した Object が現在の Object と等しい場合は true。それ以外の場合は false。

Exceptions

Exception | Condition
System..::.NullReferenceException | other パラメータが null です。

See Also

DbEnvironmentConfig Class
Equals Overload
JanaBiz.Db Namespace


Equals Method (Object)

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Equals Method (Object)
DbEnvironmentConfig Class See Also Send Feedback

指定した Object が、現在の Object と等しいかどうかを判断します。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::.Object
現在の Object と比較する Object。

Return Value

指定した Object が現在の Object と等しい場合は true。それ以外の場合は false。

Exceptions

Exception | Condition
System..::.NullReferenceException | obj パラメータが null です。

See Also

DbEnvironmentConfig Class
Equals Overload
JanaBiz.Db Namespace


GetHashCode Method

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.GetHashCode Method
DbEnvironmentConfig Class See Also Send Feedback

特定の型のハッシュ関数として機能します。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

Return Value

現在の Object のハッシュ コード。

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Inequality Operator

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Inequality Operator
DbEnvironmentConfig Class See Also Send Feedback

Implements the operator !=.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As DbEnvironmentConfig, _
    right As DbEnvironmentConfig _
) As Boolean
C#
public static bool operator !=(
    DbEnvironmentConfig left,
    DbEnvironmentConfig right
)
Visual C++
public:
static bool operator !=(
    DbEnvironmentConfig^ left,
    DbEnvironmentConfig^ right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: JanaBiz.Db..::.DbEnvironmentConfig
The left.
right
Type: JanaBiz.Db..::.DbEnvironmentConfig
The right.

Return Value

The result of the operator.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DbEnvironmentConfig Properties

[image] [image]

.NET Framework Class Library
DbEnvironmentConfig Properties
DbEnvironmentConfig Class See Also Send Feedback

The DbEnvironmentConfig type exposes the following members.

Properties

Name | Description
AllowCreate | Cause Berkeley DB subsystems to create any underlying files, as necessary.
CacheCount | The number of shared memory buffer pools, that is, the number of caches.
CacheMax | Gets or sets the maximum size of the cache.
CacheSize | The size(kb) of the shared memory buffer pool, that is, the cache.
CdbLockAllDatabases | The Concurrent Data Store applications are configured to perform locking on an environment-wide basis rather than on a per-database basis.
CreateDir | Gets or sets the path of a directory to be used as the location to create the access method database files. When the open function is used to create a file it will be created relative to this path.
DataDirs | The array of data directories.
DirectDatabaseIO | The database environment has been configured to not buffer database files.
DirectLogIO | The database environment has been configured to not buffer log files.
DsyncDatabases | Configure Berkeley DB to flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
DsyncLog | The database environment has been configured to flush log writes to the backing disk before returning from the write system call.
Encrypted | The database environment has been configured to perform encryption.
EncryptedPassword | The password used to perform encryption and decryption.
ErrorHandler | When an error occurs in the Berkeley DB library, an exception is thrown or an error return value is returned by the interface.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
ErrorWriter | When an error occurs in the Berkeley DB library, an exception is thrown or an errno value is returned by the interface.
InitializeCache | Initialize the shared memory buffer pool subsystem.
InitializeCDB | Initialize locking for the Berkeley DB Concurrent Data Store product.
InitializeLocking | Initialize the locking subsystem.
InitializeLogging | Initialize the logging subsystem.
InitializeRegions | In some applications, the expense of page-faulting the underlying shared memory regions can affect performance.
InitializeReplication | Initialize the replication subsystem.
JoinEnvironment | Join an existing environment.
LockDetectMode | If the deadlock detector is to be run whenever a lock conflict occurs, and specify what lock request(s) should be rejected.
LockDown | Lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockTimeout | Timeout values for locks in the database environment.
LogAutoRemove | If set, Berkeley DB will automatically remove log files that are no longer needed.
LogBufferSize | The size of the in-memory log buffer, in bytes.
LogDirectory | The path of a directory to be used as the location of logging files.
LogFileMode | The absolute file mode for created log files. This method is only useful for the rare Berkeley DB application that does not control its umask value.
LogInMemory | Maintain transaction logs in memory rather than on disk.
LogRegionSize | The size of the underlying logging area of the database environment, in bytes.
LogZero | If set, zero all pages of a log file when that log file is created. This has been shown to provide greater transaction throughput in some environments. The log file will be zeroed by the thread which needs to re-create the new log file. Other threads may not write to the log file while this is happening.
MaxLockers | The maximum number of locking entities supported by the Berkeley DB environment.
MaxLockObjects | The maximum number of locked objects supported by the Berkeley DB environment.
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxLogFileSize | The maximum size of a single file in the log, in bytes.
MaxMutexes | The total number of mutexes to allocate.
MaxOpenFiles | The maximum number of file descriptors the library will open concurrently when flushing dirty pages from the cache.
MaxWrite | The maximum number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MaxWriteSleep | The number of microseconds the thread of control should pause before scheduling further write operations.
MessageWriter | Gets or sets the message writer for displaying informational messages.
MmapSize | The maximum file size, in bytes, for a file to be mapped into the process address space.
Mode | On Windows systems, the mode parameter is ignored.
MpPageSize | The cache page size, in bytes.
MpTableSize | The cache table size, in bytes.
Multiversion | Configure the database environment to open all databases that are not using the queue access method for multiversion concurrency control.
MutexAlignment | The mutex alignment, in bytes.
MutexIncrement | The number of mutexes to allocate.
MutexTestAndSetSpins | The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.
NoLocking | If set, Berkeley DB will grant all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMap | If set, Berkeley DB will copy read-only database files into the local cache instead of potentially mapping them into process memory (see the description of the set_mp_mmapsize method for further information).
NoPanic | If set, Berkeley DB will ignore any panic state in the database environment.
Overwrite | Overwrite files stored in encrypted formats before deleting them.
PartitionLocks | The number of lock table partitions in the Berkeley DB environment.
Private | Specify that the environment will only be accessed by a single process (although that process may be multithreaded).
Register | Check if a process has failed while using the database environment.
RunFatalRecovery | Run catastrophic recovery on this environment before opening it for normal use.
RunRecovery | Run normal recovery on this environment before opening it for normal use.
SystemMemory | Allocate memory from system shared memory instead of from memory backed by the filesystem. See Shared Memory Regions for more information.
TemporaryDirectory | The path of a directory to be used as the location of temporary files.
Threaded | Cause the DbEnv handle returned by [!:DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.
Transactional | Initialize the transaction subsystem.
TransactionMaxActive | Configure the Berkeley DB database environment to support at least max active transactions.
TransactionNoSync | If set, Berkeley DB will not write or synchronously flush the log on transaction commit.
TransactionNotDurable | The system has been configured to not write log records.
TransactionNoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.
TransactionSnapshot | Configure the database environment to run transactions at snapshot isolation by default.
TransactionTimeout | Sets timeout values for transactions in the database environment.
TransactionTimestamp | Recover to the specified time rather than to the most current possible date.
TransactionWriteNoSync | If set, Berkeley DB will write, but will not synchronously flush, the log on transaction commit.
UseEnvironment | The Berkeley DB process' environment may be permitted to specify information to be used when naming files.
UseEnvironmentRoot | The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming. Because permitting users to specify which files are used can create security problems, if the UseEnvironmentRoot flag is set, environment information will be used for file naming only for users with appropriate permissions (for example, users with a user-ID of 0 on UNIX systems).
VerboseDeadlock | Display additional information when doing deadlock detection.
VerboseFileops | Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.
VerboseFileopsAll | Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.
VerboseRecovery | Display additional information when performing recovery.
VerboseRegister | Display additional information concerning support for the Register method.
VerboseWaitsFor | Display the waits-for table when doing deadlock detection.
YieldCPU | If set, Berkeley DB will yield the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


AllowCreate Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.AllowCreate Property
DbEnvironmentConfig Class See Also Send Feedback

Cause Berkeley DB subsystems to create any underlying files, as necessary.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowCreate As Boolean
C#
public bool AllowCreate { get; set; }
Visual C++
public:
property bool AllowCreate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowCreate();
function set_allowCreate(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CacheCount Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CacheCount Property
DbEnvironmentConfig Class See Also Send Feedback

The number of shared memory buffer pools, that is, the number of caches.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheCount As Integer
C#
public int CacheCount { get; set; }
Visual C++
public:
property int CacheCount {
    int get ();
    void set (int value);
}
JavaScript
function get_cacheCount();
function set_cacheCount(value);

Remarks

It is possible to specify caches larger than 4GB and/or large enough they cannot be allocated contiguously on some architectures. For example, some releases of Solaris limit the amount of memory that may be allocated contiguously by a process. This method allows applications to break the cache broken up into a number of equally sized, separate pieces of memory.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CacheMax Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CacheMax Property
DbEnvironmentConfig Class See Also Send Feedback

Gets or sets the maximum size of the cache.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheMax As Long
C#
public long CacheMax { get; set; }
Visual C++
public:
property long long CacheMax {
    long long get ();
    void set (long long value);
}
JavaScript
function get_cacheMax();
function set_cacheMax(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CacheSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CacheSize Property
DbEnvironmentConfig Class See Also Send Feedback

The size(kb) of the shared memory buffer pool, that is, the cache.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CacheSize As Long
C#
public long CacheSize { get; set; }
Visual C++
public:
property long long CacheSize {
    long long get ();
    void set (long long value);
}
JavaScript
function get_cacheSize();
function set_cacheSize(value);

Remarks

The cache should be the size of the normal working data set of the application, with some small amount of additional memory for unusual situations.

The default cache size is 256KB, and may not be specified as less than 20KB. Any cache size less than 500MB is automatically increased by 25% to account for buffer pool overhead; cache sizes larger than 500MB are used as specified. The current maximum size of a single cache is 4GB. (All sizes are in powers-of-two, that is, 256KB is 2^18 not 256,000.)

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CdbLockAllDatabases Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CdbLockAllDatabases Property
DbEnvironmentConfig Class See Also Send Feedback

The Concurrent Data Store applications are configured to perform locking on an environment-wide basis rather than on a per-database basis.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CdbLockAllDatabases As Boolean
C#
public bool CdbLockAllDatabases { get; set; }
Visual C++
public:
property bool CdbLockAllDatabases {
    bool get ();
    void set (bool value);
}
JavaScript
function get_cdbLockAllDatabases();
function set_cdbLockAllDatabases(value);

Remarks

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all DbEnvironment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file.

The flag may be used to configure Berkeley DB only before the DbEnvironment is Initialized.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


CreateDir Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.CreateDir Property
DbEnvironmentConfig Class See Also Send Feedback

Gets or sets the path of a directory to be used as the location to create the access method database files. When the open function is used to create a file it will be created relative to this path.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CreateDir As String
C#
public string CreateDir { get; set; }
Visual C++
public:
property String^ CreateDir {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_createDir();
function set_createDir(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DataDirs Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.DataDirs Property
DbEnvironmentConfig Class See Also Send Feedback

The array of data directories.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DataDirs As String()
C#
public string[] DataDirs { get; set; }
Visual C++
public:
property array<String^>^ DataDirs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
JavaScript
function get_dataDirs();
function set_dataDirs(value);

Remarks

Set the path of a directory to be used as the location of the access method database files. Paths set using this method are additive, and specifying more than one will result in each specified directory being searched for database files. If any directories are specified, created database files will always be created in the first path specified.

If no database directories are specified, database files must be named either by absolute paths or relative to the environment home directory.

The database environment's data directories may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_data_dir", one or more whitespace characters, and the directory name.

The DataDirs configures operations performed using the specified DbEnvironment handle, not all operations performed on the underlying database environment.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DirectDatabaseIO Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.DirectDatabaseIO Property
DbEnvironmentConfig Class See Also Send Feedback

The database environment has been configured to not buffer database files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DirectDatabaseIO As Boolean
C#
public bool DirectDatabaseIO { get; set; }
Visual C++
public:
property bool DirectDatabaseIO {
    bool get ();
    void set (bool value);
}
JavaScript
function get_directDatabaseIO();
function set_directDatabaseIO(value);

Remarks

This is intended to avoid to avoid double caching.

This method only affects the specified Environment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all Environment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DirectLogIO Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.DirectLogIO Property
DbEnvironmentConfig Class See Also Send Feedback

The database environment has been configured to not buffer log files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DirectLogIO As Boolean
C#
public bool DirectLogIO { get; set; }
Visual C++
public:
property bool DirectLogIO {
    bool get ();
    void set (bool value);
}
JavaScript
function get_directLogIO();
function set_directLogIO(value);

Remarks

This is intended to avoid to avoid double caching.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all DbEnvironment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DsyncDatabases Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.DsyncDatabases Property
DbEnvironmentConfig Class See Also Send Feedback

Configure Berkeley DB to flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DsyncDatabases As Boolean
C#
public bool DsyncDatabases { get; set; }
Visual C++
public:
property bool DsyncDatabases {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dsyncDatabases();
function set_dsyncDatabases(value);

Remarks

This is only available on some systems (for example, systems supporting the IEEE/ANSI Std 1003.1 (POSIX) standard O_DSYNC flag, or systems supporting the Windows FILE_FLAG_WRITE_THROUGH flag). This flag may result in inaccurate file modification times and other file-level information for Berkeley DB database files. This flag will almost certainly result in a performance decrease on most systems. This flag is only applicable to certain filesysystem (for example, the Veritas VxFS filesystem), where the filesystem's support for trickling writes back to stable storage behaves badly (or more likely, has been misconfigured). The DsyncDatabases flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DsyncLog Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.DsyncLog Property
DbEnvironmentConfig Class See Also Send Feedback

The database environment has been configured to flush log writes to the backing disk before returning from the write system call.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DsyncLog As Boolean
C#
public bool DsyncLog { get; set; }
Visual C++
public:
property bool DsyncLog {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dsyncLog();
function set_dsyncLog(value);

Remarks

This configuration is only available on some systems (for example, systems supporting the POSIX standard O_DSYNC flag, or systems supporting the Win32 FILE_FLAG_WRITE_THROUGH flag). This configuration may result in inaccurate file modification times and other file-level information for Berkeley DB log files. This configuration may offer a performance increase on some systems and a performance decrease on others.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all DbEnvironment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Encrypted Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Encrypted Property
DbEnvironmentConfig Class See Also Send Feedback

The database environment has been configured to perform encryption.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Encrypted As Boolean
C#
public bool Encrypted { get; }
Visual C++
public:
property bool Encrypted {
    bool get ();
}
JavaScript
function get_encrypted();

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


EncryptedPassword Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.EncryptedPassword Property
DbEnvironmentConfig Class See Also Send Feedback

The password used to perform encryption and decryption.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property EncryptedPassword As String
C#
public string EncryptedPassword { get; set; }
Visual C++
public:
property String^ EncryptedPassword {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_encryptedPassword();
function set_encryptedPassword(value);

Remarks

S

Setting to null (default) turns off encryption

Berkeley DB uses the Rijndael/AES (also known as the Advanced Encryption Standard and Federal Information Processing Standard (FIPS) 197) algorithm for encryption or decryption.

The EncryptedPassword method configures a database environment, not only operations performed using the specified DbEnv handle.

The EncryptedPassword may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is Initialized, the information specified to EncryptedPassword must be consistent with the existing environment or an error will be returned.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


ErrorHandler Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.ErrorHandler Property
DbEnvironmentConfig Class See Also Send Feedback

When an error occurs in the Berkeley DB library, an exception is thrown or an error return value is returned by the interface.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ErrorHandler As ErrorHandler
C#
public ErrorHandler ErrorHandler { get; set; }
Visual C++
public:
property ErrorHandler^ ErrorHandler {
    ErrorHandler^ get ();
    void set (ErrorHandler^ value);
}
JavaScript
function get_errorHandler();
function set_errorHandler(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


ErrorPrefix Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.ErrorPrefix Property
DbEnvironmentConfig Class See Also Send Feedback

The prefix string that appears before error messages issued by Berkeley DB.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ErrorPrefix As String
C#
public string ErrorPrefix { get; set; }
Visual C++
public:
property String^ ErrorPrefix {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_errorPrefix();
function set_errorPrefix(value);

Remarks

The method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


ErrorWriter Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.ErrorWriter Property
DbEnvironmentConfig Class See Also Send Feedback

When an error occurs in the Berkeley DB library, an exception is thrown or an errno value is returned by the interface.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ErrorWriter As TextWriter
C#
public TextWriter ErrorWriter { get; set; }
Visual C++
public:
property TextWriter^ ErrorWriter {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
JavaScript
function get_errorWriter();
function set_errorWriter(value);

Remarks

The method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeCache Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeCache Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize the shared memory buffer pool subsystem.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeCache As Boolean
C#
public bool InitializeCache { get; set; }
Visual C++
public:
property bool InitializeCache {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeCache();
function set_initializeCache(value);

Remarks

This subsystem should be used whenever an application is using any Berkeley DB access method.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeCDB Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeCDB Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize locking for the Berkeley DB Concurrent Data Store product.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeCDB As Boolean
C#
public bool InitializeCDB { get; set; }
Visual C++
public:
property bool InitializeCDB {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeCDB();
function set_initializeCDB(value);

Remarks

In this mode, Berkeley DB provides multiple reader/single writer access. The only other subsystem that should be specified with the InitializeCDB flag is InitializeCache.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeLocking Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeLocking Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize the locking subsystem.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeLocking As Boolean
C#
public bool InitializeLocking { get; set; }
Visual C++
public:
property bool InitializeLocking {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeLocking();
function set_initializeLocking(value);

Remarks

This subsystem should be used when multiple processes or threads are going to be reading and writing a Berkeley DB database, so that they do not interfere with each other. If all threads are accessing the database(s) read-only, locking is unnecessary. When the InitializeLocking flag is specified, it is usually necessary to run a deadlock detector, as well.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeLogging Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeLogging Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize the logging subsystem.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeLogging As Boolean
C#
public bool InitializeLogging { get; set; }
Visual C++
public:
property bool InitializeLogging {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeLogging();
function set_initializeLogging(value);

Remarks

This subsystem should be used when recovery from application or system failure is necessary. If the log region is being created and log files are already present, the log files are reviewed; subsequent log writes are appended to the end of the log, rather than overwriting current log entries.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeRegions Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeRegions Property
DbEnvironmentConfig Class See Also Send Feedback

In some applications, the expense of page-faulting the underlying shared memory regions can affect performance.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeRegions As Boolean
C#
public bool InitializeRegions { get; set; }
Visual C++
public:
property bool InitializeRegions {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeRegions();
function set_initializeRegions(value);

Remarks

(For example, if the page-fault occurs while holding a lock, other lock requests can convoy, and overall throughput may decrease.) If set, Berkeley DB will page-fault shared regions into memory when initially creating or joining a Berkeley DB environment. In addition, Berkeley DB will write the shared regions when creating an environment, forcing the underlying virtual memory and filesystems to instantiate both the necessary memory and the necessary disk space. This can also avoid out-of-disk space failures later on.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


InitializeReplication Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.InitializeReplication Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize the replication subsystem.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property InitializeReplication As Boolean
C#
public bool InitializeReplication { get; set; }
Visual C++
public:
property bool InitializeReplication {
    bool get ();
    void set (bool value);
}
JavaScript
function get_initializeReplication();
function set_initializeReplication(value);

Remarks

This subsystem should be used whenever an application plans on using replication. The InitializeReplication flag requires the Transactional and InitializeLocking flags also be configured.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


JoinEnvironment Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.JoinEnvironment Property
DbEnvironmentConfig Class See Also Send Feedback

Join an existing environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property JoinEnvironment As Boolean
C#
public bool JoinEnvironment { get; set; }
Visual C++
public:
property bool JoinEnvironment {
    bool get ();
    void set (bool value);
}
JavaScript
function get_joinEnvironment();
function set_joinEnvironment(value);

Remarks

This option allows applications to join an existing environment without knowing which Berkeley DB subsystems the environment supports.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LockDetectMode Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LockDetectMode Property
DbEnvironmentConfig Class See Also Send Feedback

If the deadlock detector is to be run whenever a lock conflict occurs, and specify what lock request(s) should be rejected.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LockDetectMode As DbLockDetectMode
C#
public DbLockDetectMode LockDetectMode { get; set; }
Visual C++
public:
property DbLockDetectMode LockDetectMode {
    DbLockDetectMode get ();
    void set (DbLockDetectMode value);
}
JavaScript
function get_lockDetectMode();
function set_lockDetectMode(value);

Remarks

As transactions acquire locks on behalf of a single locker ID, rejecting a lock request associated with a transaction normally requires the transaction be aborted.

The database environment's deadlock detector configuration may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_lk_detect", one or more whitespace characters, and the method detect parameter as a string; for example, "set_lk_detect DB_LOCK_OLDEST". Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

The LockDetectMode configures a database environment, not only operations performed using the specified DbEnv handle.

Although the LockDetectMode may be called at any time during the life of the application, it should normally be called before making calls to the DbEnvironment being Initialized.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LockDown Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LockDown Property
DbEnvironmentConfig Class See Also Send Feedback

Lock shared Berkeley DB environment files and memory-mapped databases into memory.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LockDown As Boolean
C#
public bool LockDown { get; set; }
Visual C++
public:
property bool LockDown {
    bool get ();
    void set (bool value);
}
JavaScript
function get_lockDown();
function set_lockDown(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LockTimeout Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LockTimeout Property
DbEnvironmentConfig Class See Also Send Feedback

Timeout values for locks in the database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LockTimeout As Long
C#
public long LockTimeout { get; set; }
Visual C++
public:
property long long LockTimeout {
    long long get ();
    void set (long long value);
}
JavaScript
function get_lockTimeout();
function set_lockTimeout(value);

Remarks

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-lock or per-transaction basis.

The LockTimeout configures a database environment, not only operations performed using the specified DbEnv handle.

It must be specified as an unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes.

The LockTimeout method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogAutoRemove Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogAutoRemove Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will automatically remove log files that are no longer needed.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogAutoRemove As Boolean
C#
public bool LogAutoRemove { get; set; }
Visual C++
public:
property bool LogAutoRemove {
    bool get ();
    void set (bool value);
}
JavaScript
function get_logAutoRemove();
function set_logAutoRemove(value);

Remarks

Automatic log file removal is likely to make catastrophic recovery impossible.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

T The method may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is Initialized, the information specified to the flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogBufferSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogBufferSize Property
DbEnvironmentConfig Class See Also Send Feedback

The size of the in-memory log buffer, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogBufferSize As Integer
C#
public int LogBufferSize { get; set; }
Visual C++
public:
property int LogBufferSize {
    int get ();
    void set (int value);
}
JavaScript
function get_logBufferSize();
function set_logBufferSize(value);

Remarks

Log information is stored in-memory until the storage space fills up or transaction commit forces the information to be flushed to stable storage. In the presence of long-running transactions or transactions producing large amounts of data, larger buffer sizes can increase throughput.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogDirectory Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogDirectory Property
DbEnvironmentConfig Class See Also Send Feedback

The path of a directory to be used as the location of logging files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogDirectory As String
C#
public string LogDirectory { get; set; }
Visual C++
public:
property String^ LogDirectory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_logDirectory();
function set_logDirectory(value);

Remarks

Log files created by the Log Manager subsystem will be created in this directory. If no logging directory is specified, log files are created in the environment home directory.

For the greatest degree of recoverability from system or application failure, database files and log files should be located on separate physical devices.

The database environment's logging directory may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_lg_dir", one or more whitespace characters, and the directory name. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

This method configures only operations performed using a single a DbEnvironment handle, not an entire database environment.

This method may not be called after the environment has been opened. If joining an existing database environment, the information specified to this method must be consistent with the existing environment or corruption can occur.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogFileMode Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogFileMode Property
DbEnvironmentConfig Class See Also Send Feedback

The absolute file mode for created log files. This method is only useful for the rare Berkeley DB application that does not control its umask value.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogFileMode As Integer
C#
public int LogFileMode { get; set; }
Visual C++
public:
property int LogFileMode {
    int get ();
    void set (int value);
}
JavaScript
function get_logFileMode();
function set_logFileMode(value);

Remarks

Normally, if Berkeley DB applications set their umask appropriately, all processes in the application suite will have read permission on the log files created by any process in the application suite. However, if the Berkeley DB application is a library, a process using the library might set its umask to a value preventing other processes in the application suite from reading the log files it creates. In this rare case, this method can be used to set the mode of created log files to an absolute value.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogInMemory Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogInMemory Property
DbEnvironmentConfig Class See Also Send Feedback

Maintain transaction logs in memory rather than on disk.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogInMemory As Boolean
C#
public bool LogInMemory { get; set; }
Visual C++
public:
property bool LogInMemory {
    bool get ();
    void set (bool value);
}
JavaScript
function get_logInMemory();
function set_logInMemory(value);

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, integrity will not persist. All database files must be verified and/or restored from a replication group master or archival backup after application or system failure.

When in-memory logs are configured and no more log buffer space is available, Berkeley DB methods will throw a Exception. When choosing log buffer and file sizes for in-memory logs, applications should ensure the in-memory log buffer size is large enough that no transaction will ever span the entire buffer, and avoid a state where the in-memory buffer is full and no space can be freed because a transaction that started in the first log "file" is still active.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified Environment handle.

This method may not be called after the environment has been opened. If joining an existing database environment, any information specified to this method will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogRegionSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogRegionSize Property
DbEnvironmentConfig Class See Also Send Feedback

The size of the underlying logging area of the database environment, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogRegionSize As Integer
C#
public int LogRegionSize { get; set; }
Visual C++
public:
property int LogRegionSize {
    int get ();
    void set (int value);
}
JavaScript
function get_logRegionSize();
function set_logRegionSize(value);

Remarks

By default, or if the value is set to 0, the default size is 60KB. The log region is used to store filenames, and so may need to be increased in size if a large number of files will be opened and registered with the specified database environment's log manager.

The database environment's log region size may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_lg_regionmax", one or more whitespace characters, and the size in bytes. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

This method may not be called after the environment has been opened. If joining an existing database environment, any information specified to this method will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


LogZero Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.LogZero Property
DbEnvironmentConfig Class See Also Send Feedback

If set, zero all pages of a log file when that log file is created. This has been shown to provide greater transaction throughput in some environments. The log file will be zeroed by the thread which needs to re-create the new log file. Other threads may not write to the log file while this is happening.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LogZero As Boolean
C#
public bool LogZero { get; set; }
Visual C++
public:
property bool LogZero {
    bool get ();
    void set (bool value);
}
JavaScript
function get_logZero();
function set_logZero(value);

Remarks

This method configures the database environment, including all threads of control accessing the database environment.

This method may not be called after the environment has been opened.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxLockers Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxLockers Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum number of locking entities supported by the Berkeley DB environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxLockers As Integer
C#
public int MaxLockers { get; set; }
Visual C++
public:
property int MaxLockers {
    int get ();
    void set (int value);
}
JavaScript
function get_maxLockers();
function set_maxLockers(value);

Remarks

This value is used during environment creation to estimate how much space to allocate for various lock-table data structures. The default value is 1000 lockers.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

The method may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is Initialized, the information specified to this flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxLockObjects Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxLockObjects Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum number of locked objects supported by the Berkeley DB environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxLockObjects As Integer
C#
public int MaxLockObjects { get; set; }
Visual C++
public:
property int MaxLockObjects {
    int get ();
    void set (int value);
}
JavaScript
function get_maxLockObjects();
function set_maxLockObjects(value);

Remarks

This value is used during environment creation to estimate how much space to allocate for various lock-table data structures. The default value is 1000 objects.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

The method may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is Initialized, the information specified to this flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxLocks Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxLocks Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum number of locks supported by the Berkeley DB environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxLocks As Integer
C#
public int MaxLocks { get; set; }
Visual C++
public:
property int MaxLocks {
    int get ();
    void set (int value);
}
JavaScript
function get_maxLocks();
function set_maxLocks(value);

Remarks

This value is used during environment creation to estimate how much space to allocate for various lock-table data structures. The default value is 1000 locks.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

The method may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is Initialized, the information specified to this flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxLogFileSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxLogFileSize Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum size of a single file in the log, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxLogFileSize As Integer
C#
public int MaxLogFileSize { get; set; }
Visual C++
public:
property int MaxLogFileSize {
    int get ();
    void set (int value);
}
JavaScript
function get_maxLogFileSize();
function set_maxLogFileSize(value);

Remarks

The database environment's log file size may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_lg_max", one or more whitespace characters, and the size in bytes. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

The method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxMutexes Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxMutexes Property
DbEnvironmentConfig Class See Also Send Feedback

The total number of mutexes to allocate.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxMutexes As Integer
C#
public int MaxMutexes { get; set; }
Visual C++
public:
property int MaxMutexes {
    int get ();
    void set (int value);
}
JavaScript
function get_maxMutexes();
function set_maxMutexes(value);

Remarks

Berkeley DB allocates a default number of mutexes based on the initial configuration of the database environment. That default calculation may be too small if the application has an unusual need for mutexes (for example, if the application opens an unexpectedly large number of databases) or too large (if the application is trying to minimize its memory footprint). This method is used to specify an absolute number of mutexes to allocate.

Calling this method discards any value previously set using the MutexIncrement method.

The database environment's total number of mutexes may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "mutex_set_max", one or more whitespace characters, and the total number of mutexes. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

This method may not be called after the environment has been opened. If joining an existing database environment, any information specified to this method will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxOpenFiles Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxOpenFiles Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum number of file descriptors the library will open concurrently when flushing dirty pages from the cache.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxOpenFiles As Integer
C#
public int MaxOpenFiles { get; set; }
Visual C++
public:
property int MaxOpenFiles {
    int get ();
    void set (int value);
}
JavaScript
function get_maxOpenFiles();
function set_maxOpenFiles(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxWrite Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxWrite Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum number of sequential write operations scheduled by the library when flushing dirty pages from the cache.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxWrite As Integer
C#
public int MaxWrite { get; set; }
Visual C++
public:
property int MaxWrite {
    int get ();
    void set (int value);
}
JavaScript
function get_maxWrite();
function set_maxWrite(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MaxWriteSleep Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MaxWriteSleep Property
DbEnvironmentConfig Class See Also Send Feedback

The number of microseconds the thread of control should pause before scheduling further write operations.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MaxWriteSleep As Long
C#
public long MaxWriteSleep { get; set; }
Visual C++
public:
property long long MaxWriteSleep {
    long long get ();
    void set (long long value);
}
JavaScript
function get_maxWriteSleep();
function set_maxWriteSleep(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MessageWriter Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MessageWriter Property
DbEnvironmentConfig Class See Also Send Feedback

Gets or sets the message writer for displaying informational messages.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MessageWriter As TextWriter
C#
public TextWriter MessageWriter { get; set; }
Visual C++
public:
property TextWriter^ MessageWriter {
    TextWriter^ get ();
    void set (TextWriter^ value);
}
JavaScript
function get_messageWriter();
function set_messageWriter(value);

Remarks

There are interfaces in the Berkeley DB library which either directly output informational messages or statistical information, or configure the library to output such messages when performing other operations,

Copy Code
VerboseDeadlock = true
for example.

MessageWriter methods are used to display these messages for the application. In this case, the message will include a trailing newline character.

Setting messageWriter to null unconfigures the interface.

Alternatively, you can use MessageHandler to capture the additional information in a way that does not use output streams. You should not mix these approaches.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MmapSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MmapSize Property
DbEnvironmentConfig Class See Also Send Feedback

The maximum file size, in bytes, for a file to be mapped into the process address space.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MmapSize As Long
C#
public long MmapSize { get; set; }
Visual C++
public:
property long long MmapSize {
    long long get ();
    void set (long long value);
}
JavaScript
function get_mmapSize();
function set_mmapSize(value);

Remarks

If no value is specified, it defaults to 10MB.

Files that are opened read-only in the pool (and that satisfy a few other criteria) are, by default, mapped into the process address space instead of being copied into the local cache. This can result in better-than-usual performance because available virtual memory is normally much larger than the local cache, and page faults are faster than page copying on many systems. However, it can cause resource starvation in the presence of limited virtual memory, and it can result in immense process sizes in the presence of large databases.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Mode Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Mode Property
DbEnvironmentConfig Class See Also Send Feedback

On Windows systems, the mode parameter is ignored.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Mode As Integer
C#
public int Mode { get; set; }
Visual C++
public:
property int Mode {
    int get ();
    void set (int value);
}
JavaScript
function get_mode();
function set_mode(value);

Remarks

If is 0, the library will use a default mode of readable and writable by both owner and group.

Created files are owned by the process owner; the group ownership of created files is based on the system and directory defaults, and is not further specified by the library.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MpPageSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MpPageSize Property
DbEnvironmentConfig Class See Also Send Feedback

The cache page size, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MpPageSize As Integer
C#
public int MpPageSize { get; set; }
Visual C++
public:
property int MpPageSize {
    int get ();
    void set (int value);
}
JavaScript
function get_mpPageSize();
function set_mpPageSize(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MpTableSize Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MpTableSize Property
DbEnvironmentConfig Class See Also Send Feedback

The cache table size, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MpTableSize As Integer
C#
public int MpTableSize { get; set; }
Visual C++
public:
property int MpTableSize {
    int get ();
    void set (int value);
}
JavaScript
function get_mpTableSize();
function set_mpTableSize(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Multiversion Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Multiversion Property
DbEnvironmentConfig Class See Also Send Feedback

Configure the database environment to open all databases that are not using the queue access method for multiversion concurrency control.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Multiversion As Boolean
C#
public bool Multiversion { get; set; }
Visual C++
public:
property bool Multiversion {
    bool get ();
    void set (bool value);
}
JavaScript
function get_multiversion();
function set_multiversion(value);

Remarks

This method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MutexAlignment Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MutexAlignment Property
DbEnvironmentConfig Class See Also Send Feedback

The mutex alignment, in bytes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MutexAlignment As Integer
C#
public int MutexAlignment { get; set; }
Visual C++
public:
property int MutexAlignment {
    int get ();
    void set (int value);
}
JavaScript
function get_mutexAlignment();
function set_mutexAlignment(value);

Remarks

It is sometimes advantageous to align mutexes on specific byte boundaries in order to minimize cache line collisions. This method specifies an alignment for mutexes allocated by Berkeley DB.

The database environment's mutex alignment may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "mutex_set_align", one or more whitespace characters, and the mutex alignment in bytes. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

This method may not be called after the environment has been opened. If joining an existing database environment, any information specified to this method will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MutexIncrement Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MutexIncrement Property
DbEnvironmentConfig Class See Also Send Feedback

The number of mutexes to allocate.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MutexIncrement As Integer
C#
public int MutexIncrement { get; set; }
Visual C++
public:
property int MutexIncrement {
    int get ();
    void set (int value);
}
JavaScript
function get_mutexIncrement();
function set_mutexIncrement(value);

Remarks

Berkeley DB allocates a default number of mutexes based on the initial configuration of the database environment. That default calculation may be too small if the application has an unusual need for mutexes (for example, if the application opens an unexpectedly large number of databases) or too large (if the application is trying to minimize its memory footprint). This method configure the number of additional mutexes to allocate.

Calling this method discards any value previously set using the MaxMutexes method.

This method configures a database environment, including all threads of control accessing the database environment, not only the operations performed using a specified DbEnvironment handle.

This method may not be called after the environment has been opened. If joining an existing database environment, any information specified to this method will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


MutexTestAndSetSpins Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.MutexTestAndSetSpins Property
DbEnvironmentConfig Class See Also Send Feedback

The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property MutexTestAndSetSpins As Integer
C#
public int MutexTestAndSetSpins { get; set; }
Visual C++
public:
property int MutexTestAndSetSpins {
    int get ();
    void set (int value);
}
JavaScript
function get_mutexTestAndSetSpins();
function set_mutexTestAndSetSpins(value);

Remarks

The database environment's test-and-set spin count may also be set using the environment's DB_CONFIG file. The syntax of the entry in that file is a single line with the string "set_tas_spins", one or more whitespace characters, and the number of spins. Because the DB_CONFIG file is read when the database environment is opened, it will silently overrule configuration done before that time.

This method configures only operations performed using a single a DbEnvironment handle, not an entire database environment.

This method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


NoLocking Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.NoLocking Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will grant all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoLocking As Boolean
C#
public bool NoLocking { get; set; }
Visual C++
public:
property bool NoLocking {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noLocking();
function set_noLocking(value);

Remarks

The flag may be used to configure Berkeley DB at any time during the life of the application.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle).

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


NoMap Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.NoMap Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will copy read-only database files into the local cache instead of potentially mapping them into process memory (see the description of the set_mp_mmapsize method for further information).

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoMap As Boolean
C#
public bool NoMap { get; set; }
Visual C++
public:
property bool NoMap {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noMap();
function set_noMap(value);

Remarks

The flag may be used to configure Berkeley DB at any time during the life of the application.

For consistent behavior across the environment, all DbEnv handles opened in the environment must either set the DB_NOMMAP flag or the flag should be specified in the DB_CONFIG configuration file.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


NoPanic Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.NoPanic Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will ignore any panic state in the database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoPanic As Boolean
C#
public bool NoPanic { get; set; }
Visual C++
public:
property bool NoPanic {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noPanic();
function set_noPanic(value);

Remarks

Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing DbRunRecoveryException. This functionality should never be used for purposes other than debugging.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle).

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Overwrite Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Overwrite Property
DbEnvironmentConfig Class See Also Send Feedback

Overwrite files stored in encrypted formats before deleting them.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Overwrite As Boolean
C#
public bool Overwrite { get; set; }
Visual C++
public:
property bool Overwrite {
    bool get ();
    void set (bool value);
}
JavaScript
function get_overwrite();
function set_overwrite(value);

Remarks

For file overwriting to be effective, the underlying file must be stored on a fixed-block filesystem. Systems with journaling or logging filesystems will require operating system support and probably modification of the Berkeley DB sources.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle).

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


PartitionLocks Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.PartitionLocks Property
DbEnvironmentConfig Class See Also Send Feedback

The number of lock table partitions in the Berkeley DB environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property PartitionLocks As Integer
C#
public int PartitionLocks { get; set; }
Visual C++
public:
property int PartitionLocks {
    int get ();
    void set (int value);
}
JavaScript
function get_partitionLocks();
function set_partitionLocks(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Private Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Private Property
DbEnvironmentConfig Class See Also Send Feedback

Specify that the environment will only be accessed by a single process (although that process may be multithreaded).

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Private As Boolean
C#
public bool Private { get; set; }
Visual C++
public:
property bool Private {
    bool get ();
    void set (bool value);
}
JavaScript
function get_private();
function set_private(value);

Remarks

This has two effects on the database environment. First, all underlying data structures are allocated from per-process memory instead of from shared memory that is potentially accessible to more than a single process. Second, mutexes are only configured to work between threads.

This flag should not be specified if more than a single process is accessing the environment because it is likely to cause database corruption and unpredictable behavior. For example, if both a server application and the a Berkeley DB utility are expected to access the environment, the database environment should not be configured as private.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Register Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Register Property
DbEnvironmentConfig Class See Also Send Feedback

Check if a process has failed while using the database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Register As Boolean
C#
public bool Register { get; set; }
Visual C++
public:
property bool Register {
    bool get ();
    void set (bool value);
}
JavaScript
function get_register();
function set_register(value);

Remarks

Check to see if recovery needs to be performed before opening the database environment. (For this check to be accurate, all processes using the environment must specify Register when opening the environment.) If recovery needs to be performed for any reason (including the initial use of the Register flag), and RunRecovery is also specified, recovery will be performed and the open will proceed normally. If recovery needs to be performed and RunRecovery is not specified, DB_RUNRECOVERY will be returned. If recovery does not need to be performed, the RunRecovery flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


RunFatalRecovery Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.RunFatalRecovery Property
DbEnvironmentConfig Class See Also Send Feedback

Run catastrophic recovery on this environment before opening it for normal use.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property RunFatalRecovery As Boolean
C#
public bool RunFatalRecovery { get; set; }
Visual C++
public:
property bool RunFatalRecovery {
    bool get ();
    void set (bool value);
}
JavaScript
function get_runFatalRecovery();
function set_runFatalRecovery(value);

Remarks

A standard part of the recovery process is to remove the existing database environment and create a new one. Applications running recovery must be prepared to re-create the environment because underlying shared regions will be removed and re-created.

If the thread of control performing recovery does not specify the correct database environment initialization information (for example, the correct memory pool cache size), the result can be an application running in an environment with incorrect cache and other subsystem sizes. For this reason, the thread of control performing recovery should specify correct configuration information before recovering the environment; or it should remove the environment after recovery is completed, leaving creation of a correctly sized environment to a subsequent call.

All recovery processing must be single-threaded; that is, only a single thread of control may perform recovery or access a database environment while recovery is being performed. Because it is not an error to run recovery for an environment for which no recovery is required, it is reasonable programming practice for the thread of control responsible for performing recovery and creating the environment to always specify recovery during startup.

This method returns successfully if recovery is run no log files exist, so it is necessary to ensure that all necessary log files are present before running recovery.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


RunRecovery Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.RunRecovery Property
DbEnvironmentConfig Class See Also Send Feedback

Run normal recovery on this environment before opening it for normal use.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property RunRecovery As Boolean
C#
public bool RunRecovery { get; set; }
Visual C++
public:
property bool RunRecovery {
    bool get ();
    void set (bool value);
}
JavaScript
function get_runRecovery();
function set_runRecovery(value);

Remarks

A standard part of the recovery process is to remove the existing database environment and create a new one. Applications running recovery must be prepared to re-create the environment because underlying shared regions will be removed and re-created.

If the thread of control performing recovery does not specify the correct database environment initialization information (for example, the correct memory pool cache size), the result can be an application running in an environment with incorrect cache and other subsystem sizes. For this reason, the thread of control performing recovery should specify correct configuration information before recovering the environment; or it should remove the environment after recovery is completed, leaving creation of a correctly sized environment to a subsequent call.

All recovery processing must be single-threaded; that is, only a single thread of control may perform recovery or access a database environment while recovery is being performed. Because it is not an error to run recovery for an environment for which no recovery is required, it is reasonable programming practice for the thread of control responsible for performing recovery and creating the environment to always specify recovery during startup.

This method returns successfully if recovery is run no log files exist, so it is necessary to ensure that all necessary log files are present before running recovery.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


SystemMemory Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.SystemMemory Property
DbEnvironmentConfig Class See Also Send Feedback

Allocate memory from system shared memory instead of from memory backed by the filesystem. See Shared Memory Regions for more information.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property SystemMemory As Boolean
C#
public bool SystemMemory { get; set; }
Visual C++
public:
property bool SystemMemory {
    bool get ();
    void set (bool value);
}
JavaScript
function get_systemMemory();
function set_systemMemory(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TemporaryDirectory Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TemporaryDirectory Property
DbEnvironmentConfig Class See Also Send Feedback

The path of a directory to be used as the location of temporary files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TemporaryDirectory As String
C#
public string TemporaryDirectory { get; set; }
Visual C++
public:
property String^ TemporaryDirectory {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_temporaryDirectory();
function set_temporaryDirectory(value);

Remarks

The files created to back in-memory access method databases will be created relative to this path. These temporary files can be quite large, depending on the size of the database.

If no directory is specified, the following alternatives are checked in the specified order. The first existing directory path is used for all temporary files.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Threaded Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Threaded Property
DbEnvironmentConfig Class See Also Send Feedback

Cause the DbEnv handle returned by [!:DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Threaded As Boolean
C#
public bool Threaded { get; set; }
Visual C++
public:
property bool Threaded {
    bool get ();
    void set (bool value);
}
JavaScript
function get_threaded();
function set_threaded(value);

Remarks

This is the default; threading is always assumed in Java, so no special configuration is required.

The flag should be specified if the DbEnvironment handle will be concurrently used by multiple threads of control or if multiple DB handles, opened within the database environment, will be used concurrently.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


Transactional Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.Transactional Property
DbEnvironmentConfig Class See Also Send Feedback

Initialize the transaction subsystem.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Transactional As Boolean
C#
public bool Transactional { get; set; }
Visual C++
public:
property bool Transactional {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactional();
function set_transactional(value);

Remarks

This subsystem should be used when recovery and atomicity of multiple operations are important. The Transactional flag implies the InitializeLogging flag.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionMaxActive Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionMaxActive Property
DbEnvironmentConfig Class See Also Send Feedback

Configure the Berkeley DB database environment to support at least max active transactions.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionMaxActive As Integer
C#
public int TransactionMaxActive { get; set; }
Visual C++
public:
property int TransactionMaxActive {
    int get ();
    void set (int value);
}
JavaScript
function get_transactionMaxActive();
function set_transactionMaxActive(value);

Remarks

This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.

The flag configures a database environment, not only operations performed using the specified DbEnvironment handle.

The flag may not be called after the DbEnvironment is Initialized. If the database environment already exists when DbEnvironment is called, the information specified to this flag will be ignored.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionNoSync Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionNoSync Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will not write or synchronously flush the log on transaction commit.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionNoSync As Boolean
C#
public bool TransactionNoSync { get; set; }
Visual C++
public:
property bool TransactionNoSync {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionNoSync();
function set_transactionNoSync(value);

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, it is possible some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how many log updates can fit into the log buffer, how often the operating system flushes dirty buffers to disk, and how often the log is checkpointed.

This method only affects the specified DbEnvironment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all Environment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file. This method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionNotDurable Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionNotDurable Property
DbEnvironmentConfig Class See Also Send Feedback

The system has been configured to not write log records.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionNotDurable As Boolean
C#
public bool TransactionNotDurable { get; set; }
Visual C++
public:
property bool TransactionNotDurable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionNotDurable();
function set_transactionNotDurable(value);

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, integrity will not persist. All database files must be verified and/or restored from backup after a failure. In order to ensure integrity after application shut down, all database handles must be closed without specifying noSync, or all database changes must be flushed from the database environment cache using the Checkpoint(Int32, Int32, Boolean).

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionNoWait Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionNoWait Property
DbEnvironmentConfig Class See Also Send Feedback

If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionNoWait As Boolean
C#
public bool TransactionNoWait { get; set; }
Visual C++
public:
property bool TransactionNoWait {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionNoWait();
function set_transactionNoWait(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionSnapshot Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionSnapshot Property
DbEnvironmentConfig Class See Also Send Feedback

Configure the database environment to run transactions at snapshot isolation by default.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionSnapshot As Boolean
C#
public bool TransactionSnapshot { get; set; }
Visual C++
public:
property bool TransactionSnapshot {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionSnapshot();
function set_transactionSnapshot(value);

Remarks

The TransactionSnapshot flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionTimeout Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionTimeout Property
DbEnvironmentConfig Class See Also Send Feedback

Sets timeout values for transactions in the database environment.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionTimeout As Long
C#
public long TransactionTimeout { get; set; }
Visual C++
public:
property long long TransactionTimeout {
    long long get ();
    void set (long long value);
}
JavaScript
function get_transactionTimeout();
function set_transactionTimeout(value);

Remarks

Transaction timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. The lock is one requested on behalf of a transaction, normally by the database access methods underlying the application. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-transaction basis by TranstractionTimeout.

It must be specified as an unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes.

The method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionTimestamp Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionTimestamp Property
DbEnvironmentConfig Class See Also Send Feedback

Recover to the specified time rather than to the most current possible date.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionTimestamp As Nullable(Of DateTime)
C#
public Nullable<DateTime> TransactionTimestamp { get; set; }
Visual C++
public:
property Nullable<DateTime> TransactionTimestamp {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
JavaScript
function get_transactionTimestamp();
function set_transactionTimestamp(value);

Remarks

Once a database environment has been upgraded to a new version of Berkeley DB involving a log format change, it is no longer possible to recover to a specific time before that upgrade.

This method configures only operations performed using a single a DbEnvironment handle, not an entire database environment.

This method may not be called after the environment has been opened.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


TransactionWriteNoSync Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.TransactionWriteNoSync Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will write, but will not synchronously flush, the log on transaction commit.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionWriteNoSync As Boolean
C#
public bool TransactionWriteNoSync { get; set; }
Visual C++
public:
property bool TransactionWriteNoSync {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionWriteNoSync();
function set_transactionWriteNoSync(value);

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the system fails, it is possible some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how often the system flushes dirty buffers to disk and how often the log is checkpointed.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


UseEnvironment Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.UseEnvironment Property
DbEnvironmentConfig Class See Also Send Feedback

The Berkeley DB process' environment may be permitted to specify information to be used when naming files.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEnvironment As Boolean
C#
public bool UseEnvironment { get; set; }
Visual C++
public:
property bool UseEnvironment {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useEnvironment();
function set_useEnvironment(value);

Remarks

Because permitting users to specify which files are used can create security problems, environment information will be used in file naming for all users only if configured to do so.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


UseEnvironmentRoot Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.UseEnvironmentRoot Property
DbEnvironmentConfig Class See Also Send Feedback

The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming. Because permitting users to specify which files are used can create security problems, if the UseEnvironmentRoot flag is set, environment information will be used for file naming only for users with appropriate permissions (for example, users with a user-ID of 0 on UNIX systems).

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property UseEnvironmentRoot As Boolean
C#
public bool UseEnvironmentRoot { get; set; }
Visual C++
public:
property bool UseEnvironmentRoot {
    bool get ();
    void set (bool value);
}
JavaScript
function get_useEnvironmentRoot();
function set_useEnvironmentRoot(value);

Remarks

Because permitting users to specify which files are used can create security problems, environment information will be used in file naming for all users only if configured to do so.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseDeadlock Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseDeadlock Property
DbEnvironmentConfig Class See Also Send Feedback

Display additional information when doing deadlock detection.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseDeadlock As Boolean
C#
public bool VerboseDeadlock { get; set; }
Visual C++
public:
property bool VerboseDeadlock {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseDeadlock();
function set_verboseDeadlock(value);

Remarks

This method may be called at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseFileops Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseFileops Property
DbEnvironmentConfig Class See Also Send Feedback

Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseFileops As Boolean
C#
public bool VerboseFileops { get; set; }
Visual C++
public:
property bool VerboseFileops {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseFileops();
function set_verboseFileops(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseFileopsAll Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseFileopsAll Property
DbEnvironmentConfig Class See Also Send Feedback

Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseFileopsAll As Boolean
C#
public bool VerboseFileopsAll { get; set; }
Visual C++
public:
property bool VerboseFileopsAll {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseFileopsAll();
function set_verboseFileopsAll(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseRecovery Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseRecovery Property
DbEnvironmentConfig Class See Also Send Feedback

Display additional information when performing recovery.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseRecovery As Boolean
C#
public bool VerboseRecovery { get; set; }
Visual C++
public:
property bool VerboseRecovery {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseRecovery();
function set_verboseRecovery(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseRegister Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseRegister Property
DbEnvironmentConfig Class See Also Send Feedback

Display additional information concerning support for the Register method.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseRegister As Boolean
C#
public bool VerboseRegister { get; set; }
Visual C++
public:
property bool VerboseRegister {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseRegister();
function set_verboseRegister(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


VerboseWaitsFor Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.VerboseWaitsFor Property
DbEnvironmentConfig Class See Also Send Feedback

Display the waits-for table when doing deadlock detection.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property VerboseWaitsFor As Boolean
C#
public bool VerboseWaitsFor { get; set; }
Visual C++
public:
property bool VerboseWaitsFor {
    bool get ();
    void set (bool value);
}
JavaScript
function get_verboseWaitsFor();
function set_verboseWaitsFor(value);

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


YieldCPU Property

[image]

.NET Framework Class Library
DbEnvironmentConfig..::.YieldCPU Property
DbEnvironmentConfig Class See Also Send Feedback

If set, Berkeley DB will yield the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property YieldCPU As Boolean
C#
public bool YieldCPU { get; set; }
Visual C++
public:
property bool YieldCPU {
    bool get ();
    void set (bool value);
}
JavaScript
function get_yieldCPU();
function set_yieldCPU(value);

Remarks

This method only affects the specified Environment handle (and any other library handles opened within the scope of that handle). For consistent behavior across the environment, all Environment handles opened in the database environment must either call this method or the configuration should be specified in the database environment's DB_CONFIG configuration file.

The flag may be used to configure Berkeley DB at any time during the life of the application.

See Also

DbEnvironmentConfig Class
JanaBiz.Db Namespace


DbLockDetectMode Enumeration

[image]

.NET Framework Class Library
DbLockDetectMode Enumeration
See Also Send Feedback

Deadlock detection modes.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DbLockDetectMode
C#
public enum DbLockDetectMode
Visual C++
public enum class DbLockDetectMode
JavaScript
JanaBiz.Db.DbLockDetectMode = function();
JanaBiz.Db.DbLockDetectMode.createEnum('JanaBiz.Db.DbLockDetectMode', false);

Members

Member name | Description
None | None,turn off deadlock detection.
Default | Use whatever lock policy was specified when the database environment was created. If no lock policy has yet been specified, set the lock policy to Random.
Expire | Reject lock requests which have timed out. No other deadlock detection is performed.
MaxLocks | Reject the lock request for the locker ID with the most locks.
MaxWrite | Reject the lock request for the locker ID with the most write locks.
MinLocks | Reject the lock request for the locker ID with the fewest locks.
MinWrite | Reject the lock request for the locker ID with the fewest write locks.
Oldest | Reject the lock request for the locker ID with the oldest lock.
Random | Reject the lock request for a random locker ID.
Youngest | Reject the lock request for the locker ID with the youngest lock.

See Also

JanaBiz.Db Namespace


DbLockMode Enumeration

[image]

.NET Framework Class Library
DbLockMode Enumeration
See Also Send Feedback

Locking modes for database operations.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration DbLockMode
C#
[FlagsAttribute]
public enum DbLockMode
Visual C++
[FlagsAttribute]
public enum class DbLockMode
JavaScript
JanaBiz.Db.DbLockMode = function();
JanaBiz.Db.DbLockMode.createEnum('JanaBiz.Db.DbLockMode', true);

Members

Member name | Description
Default | Acquire read locks for read operations and write locks for write operations.
ReadModifyWrite | Acquire write locks instead of read locks when doing the retrieval.
ReadCommitted | Read committed isolation provides for cursor stability but not repeatable reads.
ReadUncommitted | Read modified but not yet committed data.
DirtyRead | Read modified but not yet committed data.
Degree2 | Degree 2 isolation provides for cursor stability but not repeatable reads.

Remarks

Locking modes are required parameters for operations that retrieve data or modify the database.

See Also

JanaBiz.Db Namespace


DbTransaction Class

[image]

.NET Framework Class Library
DbTransaction Class
Members See Also Send Feedback

The DbTransaction class is the handle for a db transaction.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class DbTransaction _
    Inherits InvocationHandle
C#
public class DbTransaction : InvocationHandle
Visual C++
public ref class DbTransaction : public InvocationHandle
JavaScript
JanaBiz.Db.DbTransaction = function();

Type.createClass(
    'JanaBiz.Db.DbTransaction',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Methods off the transaction handle are used to configure, Rollback()()() and Commit()()() the DbTransaction. DbTransaction handles are provided to other Berkeley DB methods in order to transactionally protect those operations.

Transaction handles are not free-threaded; transactions handles may be used by multiple threads, but only serially, that is, the application must serialize access to the handle. Once the Rollback()()() or Commit()()() methods are called, the handle may not be accessed again, regardless of the success or failure of the method. In addition, parent transactions may not issue any Berkeley DB operations while they have active child transactions (child transactions that have not yet been committed or aborted) , Rollback()()() and Commit()()().

To obtain a transaction with default attributes:

Copy Code
DbTransaction txn = myEnvironment.BeginTransaction();

To customize the attributes of a transaction:

Copy Code
            DbTransactionConfig config = new DbTransactionConfig();
            config.DirtyRead = true;
            DbTransaction txn = myEnvironment.BeginTransaction(null, config);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.Db..::.DbTransaction

See Also

DbTransaction Members
JanaBiz.Db Namespace


DbTransaction Members

[image] [image]

.NET Framework Class Library
DbTransaction Members
DbTransaction Class Methods Properties See Also Send Feedback

The DbTransaction type exposes the following members.

Methods

Name | Description
Commit | データベース トランザクションをコミットします。
CommitNoSync | End the transaction, not committing synchronously.
CommitSync | End the transaction, committing synchronously.
CommitWriteNoSync | End the transaction, writing but not flushing the log.
Discard | Free up all the per-process resources associated with the specified DbTransaction handle, neither committing nor aborting the transaction.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Prepare | Initiate the beginning of a two-phase commit.
Rollback | 保留中の状態からトランザクションをロールバックします。
ToString | (Inherited from Object.)

Properties

Name | Description
Id | Return the transaction's unique ID.
LockTimeout | Configure the lock request timeout value for the transaction
TranstractionTimeout | Configure the timeout value for the transaction lifetime.

See Also

DbTransaction Class
JanaBiz.Db Namespace


DbTransaction Methods

[image] [image]

.NET Framework Class Library
DbTransaction Methods
DbTransaction Class See Also Send Feedback

The DbTransaction type exposes the following members.

Methods

Name | Description
Commit | データベース トランザクションをコミットします。
CommitNoSync | End the transaction, not committing synchronously.
CommitSync | End the transaction, committing synchronously.
CommitWriteNoSync | End the transaction, writing but not flushing the log.
Discard | Free up all the per-process resources associated with the specified DbTransaction handle, neither committing nor aborting the transaction.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Prepare | Initiate the beginning of a two-phase commit.
Rollback | 保留中の状態からトランザクションをロールバックします。
ToString | (Inherited from Object.)

See Also

DbTransaction Class
JanaBiz.Db Namespace


Commit Method

[image]

.NET Framework Class Library
DbTransaction..::.Commit Method
DbTransaction Class See Also Send Feedback

データベース トランザクションをコミットします。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Commit
C#
public void Commit()
Visual C++
public:
void Commit()
JavaScript
function commit();

Exceptions

Exception | Condition
System..::.Exception | トランザクションのコミット中にエラーが発生しました。
System..::.InvalidOperationException | トランザクションは、既にコミットまたはロールバックされています。 または 接続が切断されています。

See Also

DbTransaction Class
JanaBiz.Db Namespace


CommitNoSync Method

[image]

.NET Framework Class Library
DbTransaction..::.CommitNoSync Method
DbTransaction Class See Also Send Feedback

End the transaction, not committing synchronously.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitNoSync
C#
public void CommitNoSync()
Visual C++
public:
void CommitNoSync()
JavaScript
function commitNoSync();

Remarks

This means the transaction will exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but it is possible this transaction may be undone during recovery.

See Also

DbTransaction Class
JanaBiz.Db Namespace


CommitSync Method

[image]

.NET Framework Class Library
DbTransaction..::.CommitSync Method
DbTransaction Class See Also Send Feedback

End the transaction, committing synchronously.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitSync
C#
public void CommitSync()
Visual C++
public:
void CommitSync()
JavaScript
function commitSync();

Remarks

This means the transaction will exhibit all of the ACID (atomicity, consistency, isolation, and durability) properties.

See Also

DbTransaction Class
JanaBiz.Db Namespace


CommitWriteNoSync Method

[image]

.NET Framework Class Library
DbTransaction..::.CommitWriteNoSync Method
DbTransaction Class See Also Send Feedback

End the transaction, writing but not flushing the log.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitWriteNoSync
C#
public void CommitWriteNoSync()
Visual C++
public:
void CommitWriteNoSync()
JavaScript
function commitWriteNoSync();

Remarks

This means the transaction will exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but it is possible this transaction may be undone during recovery in the event that the operating system crashes. This option provides more durability than an asynchronous commit and has less performance cost than a synchronous commit.

See Also

DbTransaction Class
JanaBiz.Db Namespace


Discard Method

[image]

.NET Framework Class Library
DbTransaction..::.Discard Method
DbTransaction Class See Also Send Feedback

Free up all the per-process resources associated with the specified DbTransaction handle, neither committing nor aborting the transaction.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Discard
C#
public void Discard()
Visual C++
public:
void Discard()
JavaScript
function discard();

See Also

DbTransaction Class
JanaBiz.Db Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
DbTransaction..::.Dispose Method
DbTransaction Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

DbTransaction Class
DbTransaction Members
JanaBiz.Db Namespace


Prepare Method

[image]

.NET Framework Class Library
DbTransaction..::.Prepare Method
DbTransaction Class See Also Send Feedback

Initiate the beginning of a two-phase commit.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Prepare ( _
    globalTransactionId As Byte() _
)
C#
public void Prepare(
    byte[] globalTransactionId
)
Visual C++
public:
void Prepare(
    array<unsigned char>^ globalTransactionId
)
JavaScript
function prepare(globalTransactionId);

Parameters

globalTransactionId
Type: array< System..::.Byte >[]()[]
The global transaction ID by which this transaction will be known.

See Also

DbTransaction Class
JanaBiz.Db Namespace


Rollback Method

[image]

.NET Framework Class Library
DbTransaction..::.Rollback Method
DbTransaction Class See Also Send Feedback

保留中の状態からトランザクションをロールバックします。

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Rollback
C#
public void Rollback()
Visual C++
public:
void Rollback()
JavaScript
function rollback();

Exceptions

Exception | Condition
System..::.Exception | トランザクションのコミット中にエラーが発生しました。
System..::.InvalidOperationException | トランザクションは、既にコミットまたはロールバックされています。 または 接続が切断されています。

See Also

DbTransaction Class
JanaBiz.Db Namespace


DbTransaction Properties

[image] [image]

.NET Framework Class Library
DbTransaction Properties
DbTransaction Class See Also Send Feedback

The DbTransaction type exposes the following members.

Properties

Name | Description
Id | Return the transaction's unique ID.
LockTimeout | Configure the lock request timeout value for the transaction
TranstractionTimeout | Configure the timeout value for the transaction lifetime.

See Also

DbTransaction Class
JanaBiz.Db Namespace


Id Property

[image]

.NET Framework Class Library
DbTransaction..::.Id Property
DbTransaction Class See Also Send Feedback

Return the transaction's unique ID.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Id As Integer
C#
public int Id { get; }
Visual C++
public:
property int Id {
    int get ();
}
JavaScript
function get_id();

See Also

DbTransaction Class
JanaBiz.Db Namespace


LockTimeout Property

[image]

.NET Framework Class Library
DbTransaction..::.LockTimeout Property
DbTransaction Class See Also Send Feedback

Configure the lock request timeout value for the transaction

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property LockTimeout As Long
C#
public long LockTimeout { set; }
Visual C++
public:
property long long LockTimeout {
    void set (long long value);
}
JavaScript
function set_lockTimeout(value);

Remarks

If a lock request cannot be granted in this time, the transaction may throw DbException.

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. For this reason, the accuracy of the timeout depends on how often deadlock detection is performed.

See Also

DbTransaction Class
JanaBiz.Db Namespace


TranstractionTimeout Property

[image]

.NET Framework Class Library
DbTransaction..::.TranstractionTimeout Property
DbTransaction Class See Also Send Feedback

Configure the timeout value for the transaction lifetime.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public WriteOnly Property TranstractionTimeout As Long
C#
public long TranstractionTimeout { set; }
Visual C++
public:
property long long TranstractionTimeout {
    void set (long long value);
}
JavaScript
function set_transtractionTimeout(value);

Remarks

If the transaction runs longer than this time, the transaction may may throw DbException.

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. For this reason, the accuracy of the timeout depends on how often deadlock detection is performed.

See Also

DbTransaction Class
JanaBiz.Db Namespace


DbTransactionConfig Class

[image]

.NET Framework Class Library
DbTransactionConfig Class
Members See Also Send Feedback

Specifies the attributes of a database environment transaction.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class DbTransactionConfig _
    Inherits FlagsBase
C#
public class DbTransactionConfig : FlagsBase
Visual C++
public ref class DbTransactionConfig : public FlagsBase
JavaScript
JanaBiz.Db.DbTransactionConfig = function();

Type.createClass(
    'JanaBiz.Db.DbTransactionConfig',
    JanaBiz.Bridge.FlagsBase);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.Db..::.DbTransactionConfig
JanaBiz.DbXml..::.XmlTransactionConfig

See Also

DbTransactionConfig Members
JanaBiz.Db Namespace


DbTransactionConfig Members

[image] [image]

.NET Framework Class Library
DbTransactionConfig Members
DbTransactionConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The DbTransactionConfig type exposes the following members.

Constructors

Name | Description
DbTransactionConfig |

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Degree2 | This transaction will have degree 2 isolation.
DirtyRead | All read operations performed by the transaction may read modified but not yet committed data.
NoSync | Do not synchronously flush the log when this transaction commits or prepares.
NoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.
ReadCommitted | The transaction for read committed isolation.
ReadUncommitted | The read operations performed by the transaction are configured to return modified but not yet committed data.
Sync | Synchronously flush the log when this transaction commits or prepares.
WriteNoSync | The transaction to write but not synchronously flush the log it when commits.Return if the transaction is configured to write but not synchronously flush the log it when commits.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


DbTransactionConfig Constructor

[image]

.NET Framework Class Library
DbTransactionConfig Constructor
DbTransactionConfig Class See Also Send Feedback

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbTransactionConfig()
Visual C++
public:
DbTransactionConfig()
JavaScript
JanaBiz.Db.DbTransactionConfig = function();

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


DbTransactionConfig Methods

[image] [image]

.NET Framework Class Library
DbTransactionConfig Methods
DbTransactionConfig Class See Also Send Feedback

The DbTransactionConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


DbTransactionConfig Properties

[image] [image]

.NET Framework Class Library
DbTransactionConfig Properties
DbTransactionConfig Class See Also Send Feedback

The DbTransactionConfig type exposes the following members.

Properties

Name | Description
Degree2 | This transaction will have degree 2 isolation.
DirtyRead | All read operations performed by the transaction may read modified but not yet committed data.
NoSync | Do not synchronously flush the log when this transaction commits or prepares.
NoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.
ReadCommitted | The transaction for read committed isolation.
ReadUncommitted | The read operations performed by the transaction are configured to return modified but not yet committed data.
Sync | Synchronously flush the log when this transaction commits or prepares.
WriteNoSync | The transaction to write but not synchronously flush the log it when commits.Return if the transaction is configured to write but not synchronously flush the log it when commits.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


Degree2 Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.Degree2 Property
DbTransactionConfig Class See Also Send Feedback

This transaction will have degree 2 isolation.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Degree2 As Boolean
C#
public bool Degree2 { get; set; }
Visual C++
public:
property bool Degree2 {
    bool get ();
    void set (bool value);
}
JavaScript
function get_degree2();
function set_degree2(value);

Remarks

This provides for cursor stability but not repeatable reads. Data items which have been previously read by this transaction may be deleted or modified by other transactions before this transaction completes.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


DirtyRead Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.DirtyRead Property
DbTransactionConfig Class See Also Send Feedback

All read operations performed by the transaction may read modified but not yet committed data.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DirtyRead As Boolean
C#
public bool DirtyRead { get; set; }
Visual C++
public:
property bool DirtyRead {
    bool get ();
    void set (bool value);
}
JavaScript
function get_dirtyRead();
function set_dirtyRead(value);

Remarks

Silently ignored if the DB_DIRTY_READ flag was not specified when the underlying database was opened.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


NoSync Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.NoSync Property
DbTransactionConfig Class See Also Send Feedback

Do not synchronously flush the log when this transaction commits or prepares.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoSync As Boolean
C#
public bool NoSync { get; set; }
Visual C++
public:
property bool NoSync {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noSync();
function set_noSync(value);

Remarks

This means the transaction will exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained but it is possible that this transaction may be undone during recovery.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


NoWait Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.NoWait Property
DbTransactionConfig Class See Also Send Feedback

If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoWait As Boolean
C#
public bool NoWait { get; set; }
Visual C++
public:
property bool NoWait {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noWait();
function set_noWait(value);

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


ReadCommitted Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.ReadCommitted Property
DbTransactionConfig Class See Also Send Feedback

The transaction for read committed isolation.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadCommitted As Boolean
C#
public bool ReadCommitted { get; set; }
Visual C++
public:
property bool ReadCommitted {
    bool get ();
    void set (bool value);
}
JavaScript
function get_readCommitted();
function set_readCommitted(value);

Remarks

This ensures the stability of the current data item read by the cursor but permits data read by this transaction to be modified or deleted prior to the commit of the transaction.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


ReadUncommitted Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.ReadUncommitted Property
DbTransactionConfig Class See Also Send Feedback

The read operations performed by the transaction are configured to return modified but not yet committed data.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadUncommitted As Boolean
C#
public bool ReadUncommitted { get; set; }
Visual C++
public:
property bool ReadUncommitted {
    bool get ();
    void set (bool value);
}
JavaScript
function get_readUncommitted();
function set_readUncommitted(value);

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


Sync Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.Sync Property
DbTransactionConfig Class See Also Send Feedback

Synchronously flush the log when this transaction commits or prepares.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Sync As Boolean
C#
public bool Sync { get; set; }
Visual C++
public:
property bool Sync {
    bool get ();
    void set (bool value);
}
JavaScript
function get_sync();
function set_sync(value);

Remarks

This means the transaction will exhibit all of the ACID (atomicity, consistency, isolation, and durability) properties.

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


WriteNoSync Property

[image]

.NET Framework Class Library
DbTransactionConfig..::.WriteNoSync Property
DbTransactionConfig Class See Also Send Feedback

The transaction to write but not synchronously flush the log it when commits.Return if the transaction is configured to write but not synchronously flush the log it when commits.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property WriteNoSync As Boolean
C#
public bool WriteNoSync { get; set; }
Visual C++
public:
property bool WriteNoSync {
    bool get ();
    void set (bool value);
}
JavaScript
function get_writeNoSync();
function set_writeNoSync(value);

See Also

DbTransactionConfig Class
JanaBiz.Db Namespace


DbVerifyConfig Class

[image]

.NET Framework Class Library
DbVerifyConfig Class
Members See Also Send Feedback

Specifies the attributes of a verification operation.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class DbVerifyConfig _
    Inherits FlagsBase
C#
public class DbVerifyConfig : FlagsBase
Visual C++
public ref class DbVerifyConfig : public FlagsBase
JavaScript
JanaBiz.Db.DbVerifyConfig = function();

Type.createClass(
    'JanaBiz.Db.DbVerifyConfig',
    JanaBiz.Bridge.FlagsBase);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.Db..::.DbVerifyConfig
JanaBiz.DbXml..::.XmlVerifyConfig

See Also

DbVerifyConfig Members
JanaBiz.Db Namespace


DbVerifyConfig Members

[image] [image]

.NET Framework Class Library
DbVerifyConfig Members
DbVerifyConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The DbVerifyConfig type exposes the following members.

Constructors

Name | Description
DbVerifyConfig |

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Aggressive | Output all the key/data pairs in the file that can be found.
NoOrderCheck | Skip the database checks for btree and duplicate sort order and for hashing.
OrderCheckOnly | Only perform the order check.
Printable | Use printable format for salvage.
Salvage | Write the key/data pairs from all databases in the file to the file stream named in the outfile parameter.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


DbVerifyConfig Constructor

[image]

.NET Framework Class Library
DbVerifyConfig Constructor
DbVerifyConfig Class See Also Send Feedback

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbVerifyConfig()
Visual C++
public:
DbVerifyConfig()
JavaScript
JanaBiz.Db.DbVerifyConfig = function();

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


DbVerifyConfig Methods

[image] [image]

.NET Framework Class Library
DbVerifyConfig Methods
DbVerifyConfig Class See Also Send Feedback

The DbVerifyConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


DbVerifyConfig Properties

[image] [image]

.NET Framework Class Library
DbVerifyConfig Properties
DbVerifyConfig Class See Also Send Feedback

The DbVerifyConfig type exposes the following members.

Properties

Name | Description
Aggressive | Output all the key/data pairs in the file that can be found.
NoOrderCheck | Skip the database checks for btree and duplicate sort order and for hashing.
OrderCheckOnly | Only perform the order check.
Printable | Use printable format for salvage.
Salvage | Write the key/data pairs from all databases in the file to the file stream named in the outfile parameter.

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


Aggressive Property

[image]

.NET Framework Class Library
DbVerifyConfig..::.Aggressive Property
DbVerifyConfig Class See Also Send Feedback

Output all the key/data pairs in the file that can be found.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Aggressive As Boolean
C#
public bool Aggressive { get; set; }
Visual C++
public:
property bool Aggressive {
    bool get ();
    void set (bool value);
}
JavaScript
function get_aggressive();
function set_aggressive(value);

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


NoOrderCheck Property

[image]

.NET Framework Class Library
DbVerifyConfig..::.NoOrderCheck Property
DbVerifyConfig Class See Also Send Feedback

Skip the database checks for btree and duplicate sort order and for hashing.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoOrderCheck As Boolean
C#
public bool NoOrderCheck { get; set; }
Visual C++
public:
property bool NoOrderCheck {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noOrderCheck();
function set_noOrderCheck(value);

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


OrderCheckOnly Property

[image]

.NET Framework Class Library
DbVerifyConfig..::.OrderCheckOnly Property
DbVerifyConfig Class See Also Send Feedback

Only perform the order check.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property OrderCheckOnly As Boolean
C#
public bool OrderCheckOnly { get; set; }
Visual C++
public:
property bool OrderCheckOnly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_orderCheckOnly();
function set_orderCheckOnly(value);

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


Printable Property

[image]

.NET Framework Class Library
DbVerifyConfig..::.Printable Property
DbVerifyConfig Class See Also Send Feedback

Use printable format for salvage.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Printable As Boolean
C#
public bool Printable { get; set; }
Visual C++
public:
property bool Printable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_printable();
function set_printable(value);

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


Salvage Property

[image]

.NET Framework Class Library
DbVerifyConfig..::.Salvage Property
DbVerifyConfig Class See Also Send Feedback

Write the key/data pairs from all databases in the file to the file stream named in the outfile parameter.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Salvage As Boolean
C#
public bool Salvage { get; set; }
Visual C++
public:
property bool Salvage {
    bool get ();
    void set (bool value);
}
JavaScript
function get_salvage();
function set_salvage(value);

See Also

DbVerifyConfig Class
JanaBiz.Db Namespace


ErrorHandler Delegate

[image]

.NET Framework Class Library
ErrorHandler Delegate
See Also Send Feedback

A callback function to be called when an error occurs in the Berkeley DB library.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub ErrorHandler ( _
    dbEnvironment As DbEnvironment, _
    errorPrefix As String, _
    message As String _
)
C#
public delegate void ErrorHandler(
    DbEnvironment dbEnvironment,
    string errorPrefix,
    string message
)
Visual C++
public delegate void ErrorHandler(
    DbEnvironment^ dbEnvironment,
    String^ errorPrefix,
    String^ message
)
JavaScript
function(dbEnvironment, errorPrefix, message);

Parameters

dbEnvironment
Type: JanaBiz.Db..::.DbEnvironment
errorPrefix
Type: System..::.String
message
Type: System..::.String

Remarks

When an error occurs in the Berkeley DB library, an exception is thrown. In some cases, however, the exception may be insufficient to completely describe the cause of the error, especially during initial application debugging.

In some cases, when an error occurs, Berkeley DB will invoke the ErrorHandler's object error method. It is up to this method to display the error message in an appropriate manner.

See Also

JanaBiz.Db Namespace


MessageHandler Delegate

[image]

.NET Framework Class Library
MessageHandler Delegate
See Also Send Feedback

A callback function to be called to display informational messages.

Namespace: JanaBiz.Db
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Delegate Sub MessageHandler ( _
    dbEnvironment As DbEnvironment, _
    message As String _
)
C#
public delegate void MessageHandler(
    DbEnvironment dbEnvironment,
    string message
)
Visual C++
public delegate void MessageHandler(
    DbEnvironment^ dbEnvironment,
    String^ message
)
JavaScript
function(dbEnvironment, message);

Parameters

dbEnvironment
Type: JanaBiz.Db..::.DbEnvironment
The enclosing database environment handle.
message
Type: System..::.String
An informational message string.

Remarks

There are interfaces in the Berkeley DB library which either directly output informational messages or statistical information, or configure the library to output such messages when performing other operations,

Copy Code
VerboseDeadlock = true
for example.

MessageWriter methods are used to display these messages for the application. In this case, the message will include a trailing newline character.

Setting messageWriter to null unconfigures the interface.

Alternatively, you can use MessageHandler to capture the additional information in a way that does not use output streams. You should not mix these approaches.

See Also

JanaBiz.Db Namespace


JanaBiz.Db.Exceptions Namespace

[image]

.NET Framework Class Library
JanaBiz.Db.Exceptions Namespace
Send Feedback

Classes

Class | Description
DbDeadlockException | DbDeadlockException is thrown to a thread of control when multiple threads competing for a lock are deadlocked, when a lock request has timed out or when a lock request would need to block and the transaction has been configured to not wait for locks.
DbException | The root of all database exceptions. Note that in some cases, certain methods return status values without issuing an exception. This occurs in situations that are not normally considered an error, but when some informational status is returned. For example, Database.get returns OperationStatus.NotFound when a requested key does not appear in the database.
DbLockNotGrantedException | A DbLockNotGrantedException is thrown when a lock requested using the Environment.getLock or Environment.lockVector methods, where the noWait flag or lock timers were configured, could not be granted before the wait-time expired. Additionally, LockNotGrantedException is thrown when a Concurrent Data Store database environment configured for lock timeouts was unable to grant a lock in the allowed time. Additionally, LockNotGrantedException is thrown when lock or transaction timeouts have been configured and a database operation has timed out.
DbMemoryException | A DbMemoryException is thrown when there is insufficient memory to complete an operation, and there is the possibility of recovering.
DbRunRecoveryException | Errors can occur in the Berkeley DB library where the only solution is to shut down the application and run recovery (for example, if Berkeley DB is unable to allocate heap memory). When a fatal error occurs in Berkeley DB, methods will throw a DbRunRecoveryException, at which point all subsequent Berkeley DB calls will also fail in the same way. When this occurs, recovery should be performed. The DbException errno value is set to DB_RUNRECOVERY.


DbDeadlockException Class

[image]

.NET Framework Class Library
DbDeadlockException Class
Members See Also Send Feedback

DbDeadlockException is thrown to a thread of control when multiple threads competing for a lock are deadlocked, when a lock request has timed out or when a lock request would need to block and the transaction has been configured to not wait for locks.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbDeadlockException _
    Inherits DbException
C#
[SerializableAttribute]
public class DbDeadlockException : DbException
Visual C++
[SerializableAttribute]
public ref class DbDeadlockException : public DbException
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function();

Type.createClass(
    'JanaBiz.Db.Exceptions.DbDeadlockException',
    JanaBiz.Db.Exceptions.DbException);

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.Db.Exceptions..::.DbException
JanaBiz.Db.Exceptions..::.DbDeadlockException

See Also

DbDeadlockException Members
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Members

[image] [image]

.NET Framework Class Library
DbDeadlockException Members
DbDeadlockException Class Constructors Methods Properties See Also Send Feedback

The DbDeadlockException type exposes the following members.

Constructors

Name | Description
DbDeadlockException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbDeadlockException Class
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor

[image] [image]

.NET Framework Class Library
DbDeadlockException Constructor
DbDeadlockException Class See Also Send Feedback

Overload List

Name | Description
DbDeadlockException()()() | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(Int32) | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(String) | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(Int32, String) | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(String, Exception) | Initializes a new instance of the DbDeadlockException class.
DbDeadlockException(Int32, String, Exception) | Initializes a new instance of the DbDeadlockException class.

See Also

DbDeadlockException Class
DbDeadlockException Members
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor

[image]

.NET Framework Class Library
DbDeadlockException Constructor
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbDeadlockException()
Visual C++
public:
DbDeadlockException()
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function();

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (Int32)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (Int32)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
C#
public DbDeadlockException(
    int errorCode
)
Visual C++
public:
DbDeadlockException(
    int errorCode
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(errorCode);

Parameters

errorCode
Type: System..::.Int32
The Db error code.

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (String)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (String)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbDeadlockException(
    string message
)
Visual C++
public:
DbDeadlockException(
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (Int32, String)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (Int32, String)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
C#
public DbDeadlockException(
    int errorCode,
    string message
)
Visual C++
public:
DbDeadlockException(
    int errorCode,
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(errorCode, message);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (SerializationInfo, StreamingContext)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbDeadlockException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbDeadlockException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (String, Exception)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbDeadlockException(
    string message,
    Exception innerException
)
Visual C++
public:
DbDeadlockException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Constructor (Int32, String, Exception)

[image]

.NET Framework Class Library
DbDeadlockException Constructor (Int32, String, Exception)
DbDeadlockException Class See Also Send Feedback

Initializes a new instance of the DbDeadlockException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbDeadlockException(
    int errorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbDeadlockException(
    int errorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbDeadlockException = function(errorCode, message, innerException);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbDeadlockException Class
DbDeadlockException Overload
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Methods

[image] [image]

.NET Framework Class Library
DbDeadlockException Methods
DbDeadlockException Class See Also Send Feedback

The DbDeadlockException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbDeadlockException Class
JanaBiz.Db.Exceptions Namespace


DbDeadlockException Properties

[image] [image]

.NET Framework Class Library
DbDeadlockException Properties
DbDeadlockException Class See Also Send Feedback

The DbDeadlockException type exposes the following members.

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbDeadlockException Class
JanaBiz.Db.Exceptions Namespace


DbException Class

[image]

.NET Framework Class Library
DbException Class
Members See Also Send Feedback

The root of all database exceptions. Note that in some cases, certain methods return status values without issuing an exception. This occurs in situations that are not normally considered an error, but when some informational status is returned. For example, Database.get returns OperationStatus.NotFound when a requested key does not appear in the database.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbException _
    Inherits ApplicationException _
    Implements ISerializable
C#
[SerializableAttribute]
public class DbException : ApplicationException,
    ISerializable
Visual C++
[SerializableAttribute]
public ref class DbException : public ApplicationException,
    ISerializable
JavaScript
JanaBiz.Db.Exceptions.DbException = function();

Type.createClass(
    'JanaBiz.Db.Exceptions.DbException',
    ApplicationException,
    ISerializable);

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.Db.Exceptions..::.DbException
JanaBiz.Db.Exceptions..::.DbDeadlockException
JanaBiz.Db.Exceptions..::.DbLockNotGrantedException
JanaBiz.Db.Exceptions..::.DbMemoryException
JanaBiz.Db.Exceptions..::.DbRunRecoveryException

See Also

DbException Members
JanaBiz.Db.Exceptions Namespace


DbException Members

[image] [image]

.NET Framework Class Library
DbException Members
DbException Class Constructors Methods Properties See Also Send Feedback

The DbException type exposes the following members.

Constructors

Name | Description
DbException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Code | エラーコードを取得します。
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbException Class
JanaBiz.Db.Exceptions Namespace


DbException Constructor

[image] [image]

.NET Framework Class Library
DbException Constructor
DbException Class See Also Send Feedback

Overload List

Name | Description
DbException()()() | Creates a new DbException instance.
DbException(Int32) | Creates a new DbException instance.
DbException(String) | Initializes a new instance of the DbException class.
DbException(Int32, String) | Creates a new DbException instance.
DbException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbException class.
DbException(String, Exception) | Initializes a new instance of the DbException class.
DbException(Int32, String, Exception) | Creates a new DbException instance.

See Also

DbException Class
DbException Members
JanaBiz.Db.Exceptions Namespace


DbException Constructor

[image]

.NET Framework Class Library
DbException Constructor
DbException Class See Also Send Feedback

Creates a new DbException instance.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbException()
Visual C++
public:
DbException()
JavaScript
JanaBiz.Db.Exceptions.DbException = function();

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (Int32)

[image]

.NET Framework Class Library
DbException Constructor (Int32)
DbException Class See Also Send Feedback

Creates a new DbException instance.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
C#
public DbException(
    int errorCode
)
Visual C++
public:
DbException(
    int errorCode
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(errorCode);

Parameters

errorCode
Type: System..::.Int32
The Db error code.

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (String)

[image]

.NET Framework Class Library
DbException Constructor (String)
DbException Class See Also Send Feedback

Initializes a new instance of the DbException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbException(
    string message
)
Visual C++
public:
DbException(
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (Int32, String)

[image]

.NET Framework Class Library
DbException Constructor (Int32, String)
DbException Class See Also Send Feedback

Creates a new DbException instance.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
C#
public DbException(
    int errorCode,
    string message
)
Visual C++
public:
DbException(
    int errorCode,
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(errorCode, message);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
Message.

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbException Constructor (SerializationInfo, StreamingContext)
DbException Class See Also Send Feedback

Initializes a new instance of the DbException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbException Constructor (String, Exception)
DbException Class See Also Send Feedback

Initializes a new instance of the DbException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbException(
    string message,
    Exception innerException
)
Visual C++
public:
DbException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Constructor (Int32, String, Exception)

[image]

.NET Framework Class Library
DbException Constructor (Int32, String, Exception)
DbException Class See Also Send Feedback

Creates a new DbException instance.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbException(
    int errorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbException(
    int errorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbException = function(errorCode, message, innerException);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbException Class
DbException Overload
JanaBiz.Db.Exceptions Namespace


DbException Methods

[image] [image]

.NET Framework Class Library
DbException Methods
DbException Class See Also Send Feedback

The DbException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbException Class
JanaBiz.Db.Exceptions Namespace


GetObjectData Method

[image]

.NET Framework Class Library
DbException..::.GetObjectData Method
DbException Class See Also Send Feedback

派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
JavaScript
function getObjectData(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
スローされている例外に関するシリアル化済みオブジェクト データを保持している SerializationInfo。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報を含んでいる StreamingContext。

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | info パラメータが null 参照 (Visual Basic の場合は nullNothingnullptra null reference (Nothing in Visual Basic)) です。

See Also

DbException Class
JanaBiz.Db.Exceptions Namespace


DbException Properties

[image] [image]

.NET Framework Class Library
DbException Properties
DbException Class See Also Send Feedback

The DbException type exposes the following members.

Properties

Name | Description
Code | エラーコードを取得します。
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbException Class
JanaBiz.Db.Exceptions Namespace


Code Property

[image]

.NET Framework Class Library
DbException..::.Code Property
DbException Class See Also Send Feedback

エラーコードを取得します。

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Code As Integer
C#
public int Code { get; }
Visual C++
public:
property int Code {
    int get ();
}
JavaScript
function get_code();

Field Value

エラーコード

See Also

DbException Class
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Class

[image]

.NET Framework Class Library
DbLockNotGrantedException Class
Members See Also Send Feedback

A DbLockNotGrantedException is thrown when a lock requested using the Environment.getLock or Environment.lockVector methods, where the noWait flag or lock timers were configured, could not be granted before the wait-time expired. Additionally, LockNotGrantedException is thrown when a Concurrent Data Store database environment configured for lock timeouts was unable to grant a lock in the allowed time. Additionally, LockNotGrantedException is thrown when lock or transaction timeouts have been configured and a database operation has timed out.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbLockNotGrantedException _
    Inherits DbException
C#
[SerializableAttribute]
public class DbLockNotGrantedException : DbException
Visual C++
[SerializableAttribute]
public ref class DbLockNotGrantedException : public DbException
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function();

Type.createClass(
    'JanaBiz.Db.Exceptions.DbLockNotGrantedException',
    JanaBiz.Db.Exceptions.DbException);

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.Db.Exceptions..::.DbException
JanaBiz.Db.Exceptions..::.DbLockNotGrantedException

See Also

DbLockNotGrantedException Members
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Members

[image] [image]

.NET Framework Class Library
DbLockNotGrantedException Members
DbLockNotGrantedException Class Constructors Methods Properties See Also Send Feedback

The DbLockNotGrantedException type exposes the following members.

Constructors

Name | Description
DbLockNotGrantedException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbLockNotGrantedException Class
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor

[image] [image]

.NET Framework Class Library
DbLockNotGrantedException Constructor
DbLockNotGrantedException Class See Also Send Feedback

Overload List

Name | Description
DbLockNotGrantedException()()() | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(Int32) | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(String) | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(Int32, String) | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(String, Exception) | Initializes a new instance of the DbLockNotGrantedException class.
DbLockNotGrantedException(Int32, String, Exception) | Initializes a new instance of the DbLockNotGrantedException class.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Members
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbLockNotGrantedException()
Visual C++
public:
DbLockNotGrantedException()
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function();

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (Int32)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (Int32)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
C#
public DbLockNotGrantedException(
    int errorCode
)
Visual C++
public:
DbLockNotGrantedException(
    int errorCode
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(errorCode);

Parameters

errorCode
Type: System..::.Int32
The Db error code.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (String)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (String)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbLockNotGrantedException(
    string message
)
Visual C++
public:
DbLockNotGrantedException(
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (Int32, String)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (Int32, String)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
C#
public DbLockNotGrantedException(
    int errorCode,
    string message
)
Visual C++
public:
DbLockNotGrantedException(
    int errorCode,
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(errorCode, message);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (SerializationInfo, StreamingContext)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbLockNotGrantedException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbLockNotGrantedException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (String, Exception)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbLockNotGrantedException(
    string message,
    Exception innerException
)
Visual C++
public:
DbLockNotGrantedException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Constructor (Int32, String, Exception)

[image]

.NET Framework Class Library
DbLockNotGrantedException Constructor (Int32, String, Exception)
DbLockNotGrantedException Class See Also Send Feedback

Initializes a new instance of the DbLockNotGrantedException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbLockNotGrantedException(
    int errorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbLockNotGrantedException(
    int errorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbLockNotGrantedException = function(errorCode, message, innerException);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbLockNotGrantedException Class
DbLockNotGrantedException Overload
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Methods

[image] [image]

.NET Framework Class Library
DbLockNotGrantedException Methods
DbLockNotGrantedException Class See Also Send Feedback

The DbLockNotGrantedException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbLockNotGrantedException Class
JanaBiz.Db.Exceptions Namespace


DbLockNotGrantedException Properties

[image] [image]

.NET Framework Class Library
DbLockNotGrantedException Properties
DbLockNotGrantedException Class See Also Send Feedback

The DbLockNotGrantedException type exposes the following members.

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbLockNotGrantedException Class
JanaBiz.Db.Exceptions Namespace


DbMemoryException Class

[image]

.NET Framework Class Library
DbMemoryException Class
Members See Also Send Feedback

A DbMemoryException is thrown when there is insufficient memory to complete an operation, and there is the possibility of recovering.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbMemoryException _
    Inherits DbException
C#
[SerializableAttribute]
public class DbMemoryException : DbException
Visual C++
[SerializableAttribute]
public ref class DbMemoryException : public DbException
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function();

Type.createClass(
    'JanaBiz.Db.Exceptions.DbMemoryException',
    JanaBiz.Db.Exceptions.DbException);

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.Db.Exceptions..::.DbException
JanaBiz.Db.Exceptions..::.DbMemoryException

See Also

DbMemoryException Members
JanaBiz.Db.Exceptions Namespace


DbMemoryException Members

[image] [image]

.NET Framework Class Library
DbMemoryException Members
DbMemoryException Class Constructors Methods Properties See Also Send Feedback

The DbMemoryException type exposes the following members.

Constructors

Name | Description
DbMemoryException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbMemoryException Class
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor

[image] [image]

.NET Framework Class Library
DbMemoryException Constructor
DbMemoryException Class See Also Send Feedback

Overload List

Name | Description
DbMemoryException()()() | Initializes a new instance of the DbMemoryException class.
DbMemoryException(Int32) | Initializes a new instance of the DbMemoryException class.
DbMemoryException(String) | Initializes a new instance of the DbMemoryException class.
DbMemoryException(Int32, String) | Initializes a new instance of the DbMemoryException class.
DbMemoryException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbMemoryException class.
DbMemoryException(String, Exception) | Initializes a new instance of the DbMemoryException class.
DbMemoryException(Int32, String, Exception) | Initializes a new instance of the DbMemoryException class.

See Also

DbMemoryException Class
DbMemoryException Members
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor

[image]

.NET Framework Class Library
DbMemoryException Constructor
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbMemoryException()
Visual C++
public:
DbMemoryException()
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function();

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (Int32)

[image]

.NET Framework Class Library
DbMemoryException Constructor (Int32)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
C#
public DbMemoryException(
    int errorCode
)
Visual C++
public:
DbMemoryException(
    int errorCode
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(errorCode);

Parameters

errorCode
Type: System..::.Int32
The Db error code.

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (String)

[image]

.NET Framework Class Library
DbMemoryException Constructor (String)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbMemoryException(
    string message
)
Visual C++
public:
DbMemoryException(
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (Int32, String)

[image]

.NET Framework Class Library
DbMemoryException Constructor (Int32, String)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
C#
public DbMemoryException(
    int errorCode,
    string message
)
Visual C++
public:
DbMemoryException(
    int errorCode,
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(errorCode, message);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbMemoryException Constructor (SerializationInfo, StreamingContext)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbMemoryException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbMemoryException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbMemoryException Constructor (String, Exception)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbMemoryException(
    string message,
    Exception innerException
)
Visual C++
public:
DbMemoryException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Constructor (Int32, String, Exception)

[image]

.NET Framework Class Library
DbMemoryException Constructor (Int32, String, Exception)
DbMemoryException Class See Also Send Feedback

Initializes a new instance of the DbMemoryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbMemoryException(
    int errorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbMemoryException(
    int errorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbMemoryException = function(errorCode, message, innerException);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbMemoryException Class
DbMemoryException Overload
JanaBiz.Db.Exceptions Namespace


DbMemoryException Methods

[image] [image]

.NET Framework Class Library
DbMemoryException Methods
DbMemoryException Class See Also Send Feedback

The DbMemoryException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbMemoryException Class
JanaBiz.Db.Exceptions Namespace


DbMemoryException Properties

[image] [image]

.NET Framework Class Library
DbMemoryException Properties
DbMemoryException Class See Also Send Feedback

The DbMemoryException type exposes the following members.

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbMemoryException Class
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Class

[image]

.NET Framework Class Library
DbRunRecoveryException Class
Members See Also Send Feedback

Errors can occur in the Berkeley DB library where the only solution is to shut down the application and run recovery (for example, if Berkeley DB is unable to allocate heap memory). When a fatal error occurs in Berkeley DB, methods will throw a DbRunRecoveryException, at which point all subsequent Berkeley DB calls will also fail in the same way. When this occurs, recovery should be performed. The DbException errno value is set to DB_RUNRECOVERY.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbRunRecoveryException _
    Inherits DbException
C#
[SerializableAttribute]
public class DbRunRecoveryException : DbException
Visual C++
[SerializableAttribute]
public ref class DbRunRecoveryException : public DbException
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function();

Type.createClass(
    'JanaBiz.Db.Exceptions.DbRunRecoveryException',
    JanaBiz.Db.Exceptions.DbException);

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.Db.Exceptions..::.DbException
JanaBiz.Db.Exceptions..::.DbRunRecoveryException

See Also

DbRunRecoveryException Members
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Members

[image] [image]

.NET Framework Class Library
DbRunRecoveryException Members
DbRunRecoveryException Class Constructors Methods Properties See Also Send Feedback

The DbRunRecoveryException type exposes the following members.

Constructors

Name | Description
DbRunRecoveryException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbRunRecoveryException Class
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor

[image] [image]

.NET Framework Class Library
DbRunRecoveryException Constructor
DbRunRecoveryException Class See Also Send Feedback

Overload List

Name | Description
DbRunRecoveryException()()() | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(Int32) | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(String) | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(Int32, String) | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(String, Exception) | Initializes a new instance of the DbRunRecoveryException class.
DbRunRecoveryException(Int32, String, Exception) | Initializes a new instance of the DbRunRecoveryException class.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Members
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbRunRecoveryException()
Visual C++
public:
DbRunRecoveryException()
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function();

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (Int32)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (Int32)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer _
)
C#
public DbRunRecoveryException(
    int errorCode
)
Visual C++
public:
DbRunRecoveryException(
    int errorCode
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(errorCode);

Parameters

errorCode
Type: System..::.Int32
The Db error code.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (String)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (String)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbRunRecoveryException(
    string message
)
Visual C++
public:
DbRunRecoveryException(
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (Int32, String)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (Int32, String)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String _
)
C#
public DbRunRecoveryException(
    int errorCode,
    string message
)
Visual C++
public:
DbRunRecoveryException(
    int errorCode,
    String^ message
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(errorCode, message);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (SerializationInfo, StreamingContext)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbRunRecoveryException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbRunRecoveryException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (String, Exception)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbRunRecoveryException(
    string message,
    Exception innerException
)
Visual C++
public:
DbRunRecoveryException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Constructor (Int32, String, Exception)

[image]

.NET Framework Class Library
DbRunRecoveryException Constructor (Int32, String, Exception)
DbRunRecoveryException Class See Also Send Feedback

Initializes a new instance of the DbRunRecoveryException class.

Namespace: JanaBiz.Db.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    errorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbRunRecoveryException(
    int errorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbRunRecoveryException(
    int errorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.Db.Exceptions.DbRunRecoveryException = function(errorCode, message, innerException);

Parameters

errorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbRunRecoveryException Class
DbRunRecoveryException Overload
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Methods

[image] [image]

.NET Framework Class Library
DbRunRecoveryException Methods
DbRunRecoveryException Class See Also Send Feedback

The DbRunRecoveryException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Inherited from DbException.)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbRunRecoveryException Class
JanaBiz.Db.Exceptions Namespace


DbRunRecoveryException Properties

[image] [image]

.NET Framework Class Library
DbRunRecoveryException Properties
DbRunRecoveryException Class See Also Send Feedback

The DbRunRecoveryException type exposes the following members.

Properties

Name | Description
Code | エラーコードを取得します。 (Inherited from DbException.)
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbRunRecoveryException Class
JanaBiz.Db.Exceptions Namespace


JanaBiz.DbXml Namespace

[image]

.NET Framework Class Library
JanaBiz.DbXml Namespace
Send Feedback

Classes

Class | Description
XmlArguments | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.
XmlArgumentsBase | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.
XmlCompression | XmlCompression is a base class for implementations of custom compression for a container.
XmlCompressionBase | XmlCompression is a base class for implementations of custom compression for a container.
XmlContainer | The XmlContainer class encapsulates a document container and its related indices and statistics.
XmlContainerConfig | Configuration settings for an XmlContainer instance.
XmlData | The XmlData.
XmlDebugListener | The XmlDebugListener class allows the user to track the progress of a query as it executes.
XmlDocument | The unit of storage within an XmlContainer. A document consists of content, a name, and a set of metadata attributes.
XmlDocumentConfig | Used to configure operations that operate on XmlDocument objects.
XmlEventReader | a class implementing a pull interface that enables input and output of XML content via pull events, rather than serialized XML.
XmlEventReaderBase | a class implementing a pull interface that enables input and output of XML content via pull events, rather than serialized XML.
XmlEventReaderToWriter | a class that associates an XmlEventReader with an XmlEventWriter, pushing events read from the XmlEventReader to the XmlEventWriter.
XmlEventWriter | The XmlEventWriter class enables applications to construct document content without using serialized XML.
XmlEventWriterBase | The XmlEventWriter class enables applications to construct document content without using serialized XML.
XmlExternalFunction | The XmlExternalFunction class is used to implement XQuery extension functions in .NET Framework. An implementor creates a subclass of XmlExternalFunction and returns an instance of the class from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32). Returned instances may be singleton objects which means the application must eventually free the memory, or new instances in which case the instance should delete itself in its Close()()() method.
XmlExternalFunctionBase | The XmlExternalFunction class is used to implement XQuery extension functions in .NET Framework. An implementor creates a subclass of XmlExternalFunction and returns an instance of the class from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32). Returned instances may be singleton objects which means the application must eventually free the memory, or new instances in which case the instance should delete itself in its Close()()() method.
XmlIndexDeclaration | An indexing strategy
XmlIndexLookup | The XmlIndexLookup class encapsulates the context within which an index lookup operation can be performed on an XmlContainer object.
XmlIndexSpecification | The XmlIndexSpecification class encapsulates the indexing specification of a container.
XmlInputStream | Used to read and write XML data.
XmlManager | Provides a high-level object used to manage various aspects of Berkeley DB XML usage.
XmlManagerConfig | Used to configure an XmlManager instance via its constructors.
XmlMetaData | Metadata item returned by MoveNext()()() and Current.
XmlMetaDataIterator | Provides an iterator over an XmlDocument's metadata.
XmlNode | The abstract class that represents a XmlNode.
XmlQueryContext | The XmlQueryContext class encapsulates the context within which a query is performed against an XmlContainer.
XmlQueryExpression | An XmlQueryExpression represents a parsed XQuery expression, and is created by a call to Prepare(String, XmlQueryContext).
XmlResolver | Provides an unimplemented base class that is used for file resolution policy.
XmlResults | The XmlResults class encapsulates the results of a query or other lookup operation. XmlResults is a collection of XmlValue objects, which may represent any one of the supported types.
XmlStackFrame | The XmlStackFrame class provides stack trace information about an executing query to the methods of XmlDebugListener. XmlStackFrame objects describe a stack frame in the stack trace and includes a pointer to the previous stack frame.
XmlStatistics | The XmlStatistics class encapsulates statistical information about the number of keys in existence for a given index.
XmlTransaction | The XmlTransaction class is the handle for a transaction. It encapsulates a DbTransaction object.
XmlTransactionConfig | A class that specifies the configuration of a XmlManager object.
XmlUpdateContext | The XmlUpdateContext class encapsulates the context within which update operations are performed against an XmlContainer.
XmlValue | The XmlValue class encapsulates the value of a node in an XML document.
XmlVerifyConfig | Specifies the attributes of a verification operation.

Enumerations

Enumeration | Description
LogCategory | Berkeley DB XML can be configured to generate a stream of messages to help application debugging.
LogLevel | Berkeley DB XML can be configured to generate a stream of messages to help application debugging.
XmlContainerConfig..::.ConfigState | The state of the container property.
XmlContainerType | Enumeration representing the storage model for a XmlContainer.
XmlEventType | XmlEventType の概要の説明です。
XmlIndexLookupOperation | The operation to be used on the upper bound.
XmlIndexSpecificationType | A series of XmlIndexSpecificationType values bitwise OR'd together to form the index strategy.
XmlNodeType | An enumeration for specifying node types.
XmlQueryContextEvaluationType | The evaluation type must be specified as either.
XmlQueryContextReturnType | The type parameter specifies which of documents or values to return.
XmlValueType | Enumeration representing the primitive schema type of the XmlValue.


LogCategory Enumeration

[image]

.NET Framework Class Library
LogCategory Enumeration
See Also Send Feedback

Berkeley DB XML can be configured to generate a stream of messages to help application debugging.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration LogCategory
C#
public enum LogCategory
Visual C++
public enum class LogCategory
JavaScript
JanaBiz.DbXml.LogCategory = function();
JanaBiz.DbXml.LogCategory.createEnum('JanaBiz.DbXml.LogCategory', false);

Members

Member name | Description
None | No message category.
Indexer | Indexer messages.
Query | Query processor messages.
Optimizer | Optimizer messages.
Dictionary | Dictionary messages.
Container | Container messages.
NodeStore | Node storage messages.
Manager | Manager messages.
All | All messages.

Remarks

The messages are categorized by subsystem, and by importance. The messages are sent to the output stream that is configured in the Berkeley DB environment associated with the XmlManager generating the message. The output is sent to std.cerr if no environment is associated with the XmlManager.

See Also

JanaBiz.DbXml Namespace


LogLevel Enumeration

[image]

.NET Framework Class Library
LogLevel Enumeration
See Also Send Feedback

Berkeley DB XML can be configured to generate a stream of messages to help application debugging.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration LogLevel
C#
public enum LogLevel
Visual C++
public enum class LogLevel
JavaScript
JanaBiz.DbXml.LogLevel = function();
JanaBiz.DbXml.LogLevel.createEnum('JanaBiz.DbXml.LogLevel', false);

Members

Member name | Description
None | No debug levels are enabled.
Debug | Program execution tracing messages.
Info | Informational, just for interest.
Warning | For warnings, bad things but recoverable.
Error | For errors that can't be recovered from.
All | All debug levels are enabled.

Remarks

The messages are categorized by subsystem, and by importance. The messages are sent to the output stream that is configured in the Berkeley DB environment associated with the XmlManager generating the message. The output is sent to std.cerr if no environment is associated with the XmlManager.

See Also


XmlArguments Class

[image]

.NET Framework Class Library
XmlArguments Class
Members See Also Send Feedback

The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlArguments _
    Inherits InvocationHandle
C#
public abstract class XmlArguments : InvocationHandle
Visual C++
public ref class XmlArguments abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlArguments = function();

Type.createClass(
    'JanaBiz.DbXml.XmlArguments',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlArguments
JanaBiz.DbXml..::.XmlArgumentsBase

See Also

XmlArguments Members


XmlArguments Members

[image] [image]

.NET Framework Class Library
XmlArguments Members
XmlArguments Class Methods Properties See Also Send Feedback

The XmlArguments type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArgument | Gets the argument at the specified index.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
NumberOfArgument | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.

See Also

XmlArguments Class


XmlArguments Methods

[image] [image]

.NET Framework Class Library
XmlArguments Methods
XmlArguments Class See Also Send Feedback

The XmlArguments type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArgument | Gets the argument at the specified index.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlArguments Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlArguments..::.Dispose Method
XmlArguments Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlArguments Class
XmlArguments Members


GetArgument Method

[image]

.NET Framework Class Library
XmlArguments..::.GetArgument Method
XmlArguments Class See Also Send Feedback

Gets the argument at the specified index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetArgument ( _
    index As UInteger _
) As XmlResults
C#
public abstract XmlResults GetArgument(
    uint index
)
Visual C++
public:
virtual XmlResults^ GetArgument(
    unsigned int index
) abstract
JavaScript
function getArgument(index);

Parameters

index
Type: System..::.UInt32
The index for the desired argument, zero-based.

Return Value

An XmlResults containing the argument values.

See Also

XmlArguments Class


XmlArguments Properties

[image] [image]

.NET Framework Class Library
XmlArguments Properties
XmlArguments Class See Also Send Feedback

The XmlArguments type exposes the following members.

Properties

Name | Description
NumberOfArgument | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.

See Also

XmlArguments Class


NumberOfArgument Property

[image]

.NET Framework Class Library
XmlArguments..::.NumberOfArgument Property
XmlArguments Class See Also Send Feedback

The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property NumberOfArgument As UInteger
C#
public abstract uint NumberOfArgument { get; }
Visual C++
public:
virtual property unsigned int NumberOfArgument {
    unsigned int get () abstract;
}
JavaScript
function get_numberOfArgument();

See Also

XmlArguments Class


XmlArgumentsBase Class

[image]

.NET Framework Class Library
XmlArgumentsBase Class
Members See Also Send Feedback

The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlArgumentsBase _
    Inherits XmlArguments
C#
public abstract class XmlArgumentsBase : XmlArguments
Visual C++
public ref class XmlArgumentsBase abstract : public XmlArguments
JavaScript
JanaBiz.DbXml.XmlArgumentsBase = function();

Type.createClass(
    'JanaBiz.DbXml.XmlArgumentsBase',
    JanaBiz.DbXml.XmlArguments);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlArguments
JanaBiz.DbXml..::.XmlArgumentsBase

See Also

XmlArgumentsBase Members


XmlArgumentsBase Members

[image] [image]

.NET Framework Class Library
XmlArgumentsBase Members
XmlArgumentsBase Class Methods Properties See Also Send Feedback

The XmlArgumentsBase type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArgument | Gets the argument at the specified index. (Inherited from XmlArguments.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
NumberOfArgument | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method. (Inherited from XmlArguments.)

See Also

XmlArgumentsBase Class


XmlArgumentsBase Methods

[image] [image]

.NET Framework Class Library
XmlArgumentsBase Methods
XmlArgumentsBase Class See Also Send Feedback

The XmlArgumentsBase type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetArgument | Gets the argument at the specified index. (Inherited from XmlArguments.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlArgumentsBase Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlArgumentsBase..::.Dispose Method
XmlArgumentsBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlArgumentsBase Class
XmlArgumentsBase Members


XmlArgumentsBase Properties

[image] [image]

.NET Framework Class Library
XmlArgumentsBase Properties
XmlArgumentsBase Class See Also Send Feedback

The XmlArgumentsBase type exposes the following members.

Properties

Name | Description
NumberOfArgument | The XmlArguments class is used by implementors of XmlExternalFunction to access function arguments passed to the Execute(XmlTransaction, XmlManager, XmlArguments) method. (Inherited from XmlArguments.)

See Also

XmlArgumentsBase Class


XmlCompression Class

[image]

.NET Framework Class Library
XmlCompression Class
Members See Also Send Feedback

XmlCompression is a base class for implementations of custom compression for a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlCompression _
    Inherits InvocationHandle
C#
public abstract class XmlCompression : InvocationHandle
Visual C++
public ref class XmlCompression abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlCompression = function();

Type.createClass(
    'JanaBiz.DbXml.XmlCompression',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Compression is only used by whole document storage containers. To use customized compression the implementation must be registered with the XmlManager using RegisterCompression(String, XmlCompression) and the container must be created by passing an XmlContainerConfig object to CreateContainer(String) that includes the name under which the instance was registered (see CompressionName).

Compression is a persistent attribute of a container. A container created with custom compression requires that the same named compression instance be registered with the XmlManager or any attempt to open the container will fail.

XmlCompression instances must be free-threaded and safe to use concurrently.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlCompression
JanaBiz.DbXml..::.XmlCompressionBase

See Also

XmlCompression Members


XmlCompression Members

[image] [image]

.NET Framework Class Library
XmlCompression Members
XmlCompression Class Methods See Also Send Feedback

The XmlCompression type exposes the following members.

Methods

Name | Description
Compress | This method is called to compress the source into the destination.
Decompress | This method is called to decompress the source into the destination.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlCompression Class


XmlCompression Methods

[image] [image]

.NET Framework Class Library
XmlCompression Methods
XmlCompression Class See Also Send Feedback

The XmlCompression type exposes the following members.

Methods

Name | Description
Compress | This method is called to compress the source into the destination.
Decompress | This method is called to decompress the source into the destination.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlCompression Class


Compress Method

[image]

.NET Framework Class Library
XmlCompression..::.Compress Method
XmlCompression Class See Also Send Feedback

This method is called to compress the source into the destination.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Compress ( _
    txn As XmlTransaction, _
    source As XmlData, _
    dest As XmlData _
) As Boolean
C#
public abstract bool Compress(
    XmlTransaction txn,
    XmlData source,
    XmlData dest
)
Visual C++
public:
virtual bool Compress(
    XmlTransaction^ txn,
    XmlData^ source,
    XmlData^ dest
) abstract
JavaScript
function compress(txn, source, dest);

Parameters

txn
Type: JanaBiz.DbXml..::.XmlTransaction
The active transaction. It may be null.
source
Type: JanaBiz.DbXml..::.XmlData
An XmlData object containing the content to be compressed.
dest
Type: JanaBiz.DbXml..::.XmlData
An XmlData object for the resulting compressed content.

Return Value

true on success, false on failure.

See Also

XmlCompression Class


Decompress Method

[image]

.NET Framework Class Library
XmlCompression..::.Decompress Method
XmlCompression Class See Also Send Feedback

This method is called to decompress the source into the destination.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Decompress ( _
    txn As XmlTransaction, _
    source As XmlData, _
    dest As XmlData _
) As Boolean
C#
public abstract bool Decompress(
    XmlTransaction txn,
    XmlData source,
    XmlData dest
)
Visual C++
public:
virtual bool Decompress(
    XmlTransaction^ txn,
    XmlData^ source,
    XmlData^ dest
) abstract
JavaScript
function decompress(txn, source, dest);

Parameters

txn
Type: JanaBiz.DbXml..::.XmlTransaction
The active transaction. It may be null.
source
Type: JanaBiz.DbXml..::.XmlData
An XmlData object containing the compressed content.
dest
Type: JanaBiz.DbXml..::.XmlData
An XmlData object for the resulting uncompressed content.

Return Value

true on success, false on failure.

See Also

XmlCompression Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlCompression..::.Dispose Method
XmlCompression Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlCompression Class
XmlCompression Members


XmlCompressionBase Class

[image]

.NET Framework Class Library
XmlCompressionBase Class
Members See Also Send Feedback

XmlCompression is a base class for implementations of custom compression for a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlCompressionBase _
    Inherits XmlCompression
C#
public abstract class XmlCompressionBase : XmlCompression
Visual C++
public ref class XmlCompressionBase abstract : public XmlCompression
JavaScript
JanaBiz.DbXml.XmlCompressionBase = function();

Type.createClass(
    'JanaBiz.DbXml.XmlCompressionBase',
    JanaBiz.DbXml.XmlCompression);

Remarks

Compression is only used by whole document storage containers. To use customized compression the implementation must be registered with the XmlManager using RegisterCompression(String, XmlCompression) and the container must be created by passing an XmlContainerConfig object to CreateContainer(String) that includes the name under which the instance was registered (see CompressionName).

Compression is a persistent attribute of a container. A container created with custom compression requires that the same named compression instance be registered with the XmlManager or any attempt to open the container will fail.

XmlCompression instances must be free-threaded and safe to use concurrently.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlCompression
JanaBiz.DbXml..::.XmlCompressionBase

See Also

XmlCompressionBase Members


XmlCompressionBase Members

[image] [image]

.NET Framework Class Library
XmlCompressionBase Members
XmlCompressionBase Class Constructors Methods See Also Send Feedback

The XmlCompressionBase type exposes the following members.

Constructors

Name | Description
XmlCompressionBase | Initializes a new instance of the XmlCompressionBase class.

Methods

Name | Description
Compress | This method is called to compress the source into the destination. (Inherited from XmlCompression.)
Decompress | This method is called to decompress the source into the destination. (Inherited from XmlCompression.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlCompressionBase Class


XmlCompressionBase Constructor

[image]

.NET Framework Class Library
XmlCompressionBase Constructor
XmlCompressionBase Class See Also Send Feedback

Initializes a new instance of the XmlCompressionBase class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected XmlCompressionBase()
Visual C++
protected:
XmlCompressionBase()
JavaScript
JanaBiz.DbXml.XmlCompressionBase = function();

See Also

XmlCompressionBase Class


XmlCompressionBase Methods

[image] [image]

.NET Framework Class Library
XmlCompressionBase Methods
XmlCompressionBase Class See Also Send Feedback

The XmlCompressionBase type exposes the following members.

Methods

Name | Description
Compress | This method is called to compress the source into the destination. (Inherited from XmlCompression.)
Decompress | This method is called to decompress the source into the destination. (Inherited from XmlCompression.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlCompressionBase Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlCompressionBase..::.Dispose Method
XmlCompressionBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlCompressionBase Class
XmlCompressionBase Members


XmlContainer Class

[image]

.NET Framework Class Library
XmlContainer Class
Members See Also Send Feedback

The XmlContainer class encapsulates a document container and its related indices and statistics.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlContainer _
    Inherits InvocationHandle
C#
public class XmlContainer : InvocationHandle
Visual C++
public ref class XmlContainer : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlContainer = function();

Type.createClass(
    'JanaBiz.DbXml.XmlContainer',
    JanaBiz.Bridge.InvocationHandle);

Remarks

XmlContainer exposes methods for managing (putting and deleting) XmlDocument objects, managing indices, and retrieving container statistics.

If the container has never before been opened, use CreateContainer(String) to instantiate an XmlContainer object. If the container already exists, use OpenContainer(String) instead. XmlContainers are always opened until the last referencing handle is destroyed.

You can delete containers using RemoveContainer(String) and rename containers using RenameContainer(String, String).

A copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

Once Dispose()()() or Close()()() is called, this object may not be accessed again, regardless of whether or not it throws an exception.

This object is free threaded, and can be safely shared among threads in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlContainer

See Also

XmlContainer Members


XmlContainer Members

[image] [image]

.NET Framework Class Library
XmlContainer Members
XmlContainer Class Methods Properties See Also Send Feedback

The XmlContainer type exposes the following members.

Methods

Name | Description
AddAlias | Adds a new named alias for the container.
AddDefaultIndex | Overloaded.
AddIndex | Overloaded.
Close | Close the container.
DeleteDefaultIndex | Overloaded.
DeleteDocument | Overloaded.
DeleteIndex | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAllDocuments | Overloaded.
GetAutoIndexing | Overloaded.
GetDocument | Overloaded.
GetHashCode | (Inherited from Object.)
GetIndexSpecification | Overloaded.
GetNode | Overloaded.
GetNumDocuments | Overloaded.
GetType | (Inherited from Object.)
LookupStatistics | Overloaded.
MemberwiseClone | (Inherited from Object.)
PutDocument | Overloaded.
PutDocumentAsEventWriter | Overloaded.
RemoveAlias | Removes the named alias from the container.
ReplaceDefaultIndex | Overloaded.
ReplaceIndex | Overloaded.
SetAutoIndexing | Overloaded.
SetIndexSpecification | Overloaded.
Sync | Flush database pages for the container to disk.
ToString | (Inherited from Object.)
UpdateDocument | Overloaded.

Properties

Name | Description
Config | The configuration object for the XmlContainer.
ContainerType | The container's type.
IsIndexNodes | Returns whether or not the container is indexing at the node level. Returns trueTruetruetrue (True in Visual Basic) if indexes are at the node level, falseFalsefalsefalse (False in Visual Basic) otherwise.
Name | The name of the XmlContainer.
PageSize | The underlying database page size for the container.
XmlManager | The XmlManager object for the XmlContainer.

See Also

XmlContainer Class


XmlContainer Methods

[image] [image]

.NET Framework Class Library
XmlContainer Methods
XmlContainer Class See Also Send Feedback

The XmlContainer type exposes the following members.

Methods

Name | Description
AddAlias | Adds a new named alias for the container.
AddDefaultIndex | Overloaded.
AddIndex | Overloaded.
Close | Close the container.
DeleteDefaultIndex | Overloaded.
DeleteDocument | Overloaded.
DeleteIndex | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAllDocuments | Overloaded.
GetAutoIndexing | Overloaded.
GetDocument | Overloaded.
GetHashCode | (Inherited from Object.)
GetIndexSpecification | Overloaded.
GetNode | Overloaded.
GetNumDocuments | Overloaded.
GetType | (Inherited from Object.)
LookupStatistics | Overloaded.
MemberwiseClone | (Inherited from Object.)
PutDocument | Overloaded.
PutDocumentAsEventWriter | Overloaded.
RemoveAlias | Removes the named alias from the container.
ReplaceDefaultIndex | Overloaded.
ReplaceIndex | Overloaded.
SetAutoIndexing | Overloaded.
SetIndexSpecification | Overloaded.
Sync | Flush database pages for the container to disk.
ToString | (Inherited from Object.)
UpdateDocument | Overloaded.

See Also

XmlContainer Class


AddAlias Method

[image]

.NET Framework Class Library
XmlContainer..::.AddAlias Method
XmlContainer Class See Also Send Feedback

Adds a new named alias for the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function AddAlias ( _
    alias As String _
) As Boolean
C#
public bool AddAlias(
    string alias
)
Visual C++
public:
bool AddAlias(
    String^ alias
)
JavaScript
function addAlias(alias);

Parameters

alias
Type: System..::.String
The alias to be added.

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the alias is added. Returns falseFalsefalsefalse (False in Visual Basic) if the alias is already present.

Remarks

The alias can be used to name the container in XQuery expressions. For removing an alias, see RemoveAlias(String).

See Also

XmlContainer Class


AddDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.AddDefaultIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
AddDefaultIndex(String, XmlUpdateContext) | Adds a default index to the container.
AddDefaultIndex(XmlTransaction, String, XmlUpdateContext) | Adds a default index to the container in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


AddDefaultIndex Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddDefaultIndex Method (String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds a default index to the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDefaultIndex ( _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void AddDefaultIndex(
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddDefaultIndex(
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function addDefaultIndex(index, updateContext);

Parameters

index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see AddDefaultIndex(String) for more information.

See Also

XmlContainer Class
AddDefaultIndex Overload


AddDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds a default index to the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDefaultIndex ( _
    transaction As XmlTransaction, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void AddDefaultIndex(
    XmlTransaction transaction,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddDefaultIndex(
    XmlTransaction^ transaction,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function addDefaultIndex(transaction, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see AddDefaultIndex(String) for more information.

See Also

XmlContainer Class
AddDefaultIndex Overload


AddIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.AddIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
AddIndex(String, String, String, XmlUpdateContext) | Adds an index of the specified type for the named document node.
AddIndex(XmlTransaction, String, String, String, XmlUpdateContext) | Adds an index of the specified type for the named document node in the scope of a transaction.
AddIndex(String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext) | Adds an index of the specified type for the named document node in the scope of a transaction.
AddIndex(XmlTransaction, String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext) | Adds an index of the specified type for the named document node in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


AddIndex Method (String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddIndex Method (String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds an index of the specified type for the named document node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void AddIndex(
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddIndex(
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function addIndex(uri, name, index, updateContext);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

These methods are for convenience -- see AddIndex(String, String, String) for more information.

See Also

XmlContainer Class
AddIndex Overload


AddIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds an index of the specified type for the named document node in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void AddIndex(
    XmlTransaction transaction,
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddIndex(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function addIndex(transaction, uri, name, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update XmlUpdateContext to use for the operation.

Remarks

These methods are for convenience -- see AddIndex(String, String, String) for more information.

See Also

XmlContainer Class
AddIndex Overload


AddIndex Method (String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddIndex Method (String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds an index of the specified type for the named document node in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    uri As String, _
    name As String, _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType, _
    updateContext As XmlUpdateContext _
)
C#
public void AddIndex(
    string uri,
    string name,
    XmlIndexSpecificationType type,
    XmlValueType syntax,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddIndex(
    String^ uri,
    String^ name,
    XmlIndexSpecificationType type,
    XmlValueType syntax,
    XmlUpdateContext^ updateContext
)
JavaScript
function addIndex(uri, name, type, syntax, updateContext);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
The type.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed. The value must be one of the XmlValueType types.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

These methods are for convenience -- see AddIndex(String, String, String) for more information.

See Also

XmlContainer Class
AddIndex Overload


AddIndex Method (XmlTransaction, String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.AddIndex Method (XmlTransaction, String, String, XmlIndexSpecificationType, XmlValueType, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Adds an index of the specified type for the named document node in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType, _
    updateContext As XmlUpdateContext _
)
C#
public void AddIndex(
    XmlTransaction transaction,
    string uri,
    string name,
    XmlIndexSpecificationType type,
    XmlValueType syntax,
    XmlUpdateContext updateContext
)
Visual C++
public:
void AddIndex(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    XmlIndexSpecificationType type,
    XmlValueType syntax,
    XmlUpdateContext^ updateContext
)
JavaScript
function addIndex(transaction, uri, name, type, syntax, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
The type.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed. The value must be one of the XmlValueType types.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

These methods are for convenience -- see AddIndex(String, String, String) for more information.

See Also

XmlContainer Class
AddIndex Overload


Close Method

[image]

.NET Framework Class Library
XmlContainer..::.Close Method
XmlContainer Class See Also Send Feedback

Close the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

Remarks

This method closes all databases that comprise the container, without waiting for a last reference to be released. This method also calls Dispose()()() to free native resources.

This function can be dangerous, as it forcibly closes DB resources. It should not be used unless absolutely necessary. Use Dispose()()() instead.

See Also

XmlContainer Class


DeleteDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.DeleteDefaultIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
DeleteDefaultIndex(String, XmlUpdateContext) | Deletes the default index for the container.
DeleteDefaultIndex(XmlTransaction, String, XmlUpdateContext) | Deletes the default index for the container in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


DeleteDefaultIndex Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDefaultIndex Method (String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Deletes the default index for the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDefaultIndex ( _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDefaultIndex(
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDefaultIndex(
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDefaultIndex(index, updateContext);

Parameters

index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience - see DeleteDefaultIndex(String) for more information.

See Also

XmlContainer Class
DeleteDefaultIndex Overload


DeleteDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Deletes the default index for the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDefaultIndex ( _
    transaction As XmlTransaction, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDefaultIndex(
    XmlTransaction transaction,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDefaultIndex(
    XmlTransaction^ transaction,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDefaultIndex(transaction, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience - see DeleteDefaultIndex(String) for more information.

See Also

XmlContainer Class
DeleteDefaultIndex Overload


DeleteDocument Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.DeleteDocument Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
DeleteDocument(XmlDocument, XmlUpdateContext) | Removes the specified XmlDocument from the container.
DeleteDocument(String, XmlUpdateContext) | Removes the named document from the container
DeleteDocument(XmlTransaction, XmlDocument, XmlUpdateContext) | Removes the specified XmlDocument from the container in the scope of a transaction.
DeleteDocument(XmlTransaction, String, XmlUpdateContext) | Removes the named document from the container in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


DeleteDocument Method (XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDocument Method (XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Removes the specified XmlDocument from the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDocument ( _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDocument(
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDocument(
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDocument(xmlDocument, updateContext);

Parameters

xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The XmlDocument to be deleted from the container. The name to be deleted is extracted from this parameter.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

See Also

XmlContainer Class
DeleteDocument Overload


DeleteDocument Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDocument Method (String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Removes the named document from the container

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDocument ( _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDocument(
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDocument(
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDocument(name, updateContext);

Parameters

name
Type: System..::.String
The name of the document to be deleted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

See Also

XmlContainer Class
DeleteDocument Overload


DeleteDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Removes the specified XmlDocument from the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDocument ( _
    transaction As XmlTransaction, _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDocument(
    XmlTransaction transaction,
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDocument(
    XmlTransaction^ transaction,
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDocument(transaction, xmlDocument, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The XmlDocument to be deleted from the container. The name to be deleted is extracted from this parameter.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

See Also

XmlContainer Class
DeleteDocument Overload


DeleteDocument Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteDocument Method (XmlTransaction, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Removes the named document from the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteDocument(
    XmlTransaction transaction,
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteDocument(transaction, name, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be deleted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

See Also

XmlContainer Class
DeleteDocument Overload


DeleteIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.DeleteIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
DeleteIndex(String, String, String, XmlUpdateContext) | Deletes an index of the specified type for the named document node.
DeleteIndex(XmlTransaction, String, String, String, XmlUpdateContext) | Deletes an index of the specified type for the named document node in the updateContext of a transaction.

See Also

XmlContainer Class
XmlContainer Members


DeleteIndex Method (String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteIndex Method (String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Deletes an index of the specified type for the named document node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteIndex ( _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteIndex(
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteIndex(
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteIndex(uri, name, index, updateContext);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see DeleteIndex(String, String, String) for more information.

See Also

XmlContainer Class
DeleteIndex Overload


DeleteIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.DeleteIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Deletes an index of the specified type for the named document node in the updateContext of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteIndex ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void DeleteIndex(
    XmlTransaction transaction,
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void DeleteIndex(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function deleteIndex(transaction, uri, name, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see DeleteIndex(String, String, String) for more information.

See Also

XmlContainer Class
DeleteIndex Overload


Dispose Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.Dispose Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlContainer Class
XmlContainer Members


GetAllDocuments Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetAllDocuments Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetAllDocuments()()() | Returns all XmlDocument objects in the container, without configuration options.
GetAllDocuments(XmlDocumentConfig) | Returns all XmlDocument objects in the container, with configuration options.
GetAllDocuments(XmlTransaction) | Returns all XmlDocument objects in the container, with configuration options, in the context of a transaction.
GetAllDocuments(XmlTransaction, XmlDocumentConfig) | Returns all XmlDocument objects in the container, with configuration options, in the context of a transaction.

See Also

XmlContainer Class
XmlContainer Members


GetAllDocuments Method

[image]

.NET Framework Class Library
XmlContainer..::.GetAllDocuments Method
XmlContainer Class See Also Send Feedback

Returns all XmlDocument objects in the container, without configuration options.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllDocuments As XmlResults
C#
public XmlResults GetAllDocuments()
Visual C++
public:
XmlResults^ GetAllDocuments()
JavaScript
function getAllDocuments();

Return Value

All XmlDocument objects in the container, without configuration options.

See Also

XmlContainer Class
GetAllDocuments Overload


GetAllDocuments Method (XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetAllDocuments Method (XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns all XmlDocument objects in the container, with configuration options.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllDocuments ( _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults GetAllDocuments(
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ GetAllDocuments(
    XmlDocumentConfig^ docConfig
)
JavaScript
function getAllDocuments(docConfig);

Parameters

docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

All XmlDocument objects in the container, with configuration options.

See Also

XmlContainer Class
GetAllDocuments Overload


GetAllDocuments Method (XmlTransaction)

[image]

.NET Framework Class Library
XmlContainer..::.GetAllDocuments Method (XmlTransaction)
XmlContainer Class See Also Send Feedback

Returns all XmlDocument objects in the container, with configuration options, in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllDocuments ( _
    transaction As XmlTransaction _
) As XmlResults
C#
public XmlResults GetAllDocuments(
    XmlTransaction transaction
)
Visual C++
public:
XmlResults^ GetAllDocuments(
    XmlTransaction^ transaction
)
JavaScript
function getAllDocuments(transaction);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().

Return Value

All XmlDocument objects in the container, with configuration options, in the context of a transaction.

See Also

XmlContainer Class
GetAllDocuments Overload


GetAllDocuments Method (XmlTransaction, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetAllDocuments Method (XmlTransaction, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns all XmlDocument objects in the container, with configuration options, in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAllDocuments ( _
    transaction As XmlTransaction, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults GetAllDocuments(
    XmlTransaction transaction,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ GetAllDocuments(
    XmlTransaction^ transaction,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getAllDocuments(transaction, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

All XmlDocument objects in the container, with configuration options, in the context of a transaction.

See Also

XmlContainer Class
GetAllDocuments Overload


GetAutoIndexing Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetAutoIndexing Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetAutoIndexing()()() | Retrieves the current state of automatic indexing for the container. The state can be modified using SetAutoIndexing(Boolean). See SetAutoIndexing(Boolean) for a description of the feature.
GetAutoIndexing(XmlTransaction) | Retrieves the current state of automatic indexing for the container in the scope of a transaction. The state can be modified using SetAutoIndexing(Boolean). The application must open the container before attempting to retrieve this value.

See Also

XmlContainer Class
XmlContainer Members


GetAutoIndexing Method

[image]

.NET Framework Class Library
XmlContainer..::.GetAutoIndexing Method
XmlContainer Class See Also Send Feedback

Retrieves the current state of automatic indexing for the container. The state can be modified using SetAutoIndexing(Boolean). See SetAutoIndexing(Boolean) for a description of the feature.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAutoIndexing As Boolean
C#
public bool GetAutoIndexing()
Visual C++
public:
bool GetAutoIndexing()
JavaScript
function getAutoIndexing();

Return Value

See Also

XmlContainer Class
GetAutoIndexing Overload


GetAutoIndexing Method (XmlTransaction)

[image]

.NET Framework Class Library
XmlContainer..::.GetAutoIndexing Method (XmlTransaction)
XmlContainer Class See Also Send Feedback

Retrieves the current state of automatic indexing for the container in the scope of a transaction. The state can be modified using SetAutoIndexing(Boolean). The application must open the container before attempting to retrieve this value.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetAutoIndexing ( _
    transaction As XmlTransaction _
) As Boolean
C#
public bool GetAutoIndexing(
    XmlTransaction transaction
)
Visual C++
public:
bool GetAutoIndexing(
    XmlTransaction^ transaction
)
JavaScript
function getAutoIndexing(transaction);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().

Return Value

See Also

XmlContainer Class
GetAutoIndexing Overload


GetDocument Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetDocument Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetDocument(String) | Returns the XmlDocument with the specified name.
GetDocument(XmlTransaction, String) | Returns the XmlDocument with the specified name in the scope of a transaction.
GetDocument(String, XmlDocumentConfig) | Returns the XmlDocument with the specified name, with configuration options.
GetDocument(XmlTransaction, String, XmlDocumentConfig) | Returns the XmlDocument with the specified name in the scope of a transaction, with configuration options.

See Also

XmlContainer Class
XmlContainer Members


GetDocument Method (String)

[image]

.NET Framework Class Library
XmlContainer..::.GetDocument Method (String)
XmlContainer Class See Also Send Feedback

Returns the XmlDocument with the specified name.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDocument ( _
    name As String _
) As XmlDocument
C#
public XmlDocument GetDocument(
    string name
)
Visual C++
public:
XmlDocument^ GetDocument(
    String^ name
)
JavaScript
function getDocument(name);

Parameters

name
Type: System..::.String
The name of the XmlDocument to be retrieved from the container.

Return Value

The XmlDocument with the specified name.

See Also

XmlContainer Class
GetDocument Overload


GetDocument Method (XmlTransaction, String)

[image]

.NET Framework Class Library
XmlContainer..::.GetDocument Method (XmlTransaction, String)
XmlContainer Class See Also Send Feedback

Returns the XmlDocument with the specified name in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDocument ( _
    transaction As XmlTransaction, _
    name As String _
) As XmlDocument
C#
public XmlDocument GetDocument(
    XmlTransaction transaction,
    string name
)
Visual C++
public:
XmlDocument^ GetDocument(
    XmlTransaction^ transaction,
    String^ name
)
JavaScript
function getDocument(transaction, name);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the XmlDocument to be retrieved from the container.

Return Value

The XmlDocument with the specified name in the scope of a transaction.

See Also

XmlContainer Class
GetDocument Overload


GetDocument Method (String, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetDocument Method (String, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns the XmlDocument with the specified name, with configuration options.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDocument ( _
    name As String, _
    docConfig As XmlDocumentConfig _
) As XmlDocument
C#
public XmlDocument GetDocument(
    string name,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlDocument^ GetDocument(
    String^ name,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getDocument(name, docConfig);

Parameters

name
Type: System..::.String
The name of the XmlDocument to be retrieved from the container.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation

Return Value

The XmlDocument with the specified name, with configuration options.

See Also

XmlContainer Class
GetDocument Overload


GetDocument Method (XmlTransaction, String, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetDocument Method (XmlTransaction, String, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns the XmlDocument with the specified name in the scope of a transaction, with configuration options.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    docConfig As XmlDocumentConfig _
) As XmlDocument
C#
public XmlDocument GetDocument(
    XmlTransaction transaction,
    string name,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlDocument^ GetDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getDocument(transaction, name, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the XmlDocument to be retrieved from the container.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

The XmlDocument with the specified name in the scope of a transaction, with configuration options.

See Also

XmlContainer Class
GetDocument Overload


GetIndexSpecification Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetIndexSpecification Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetIndexSpecification()()() | Retrieves the current index specification for the container.
GetIndexSpecification(XmlTransaction) | Retrieves the current index specification for the container in the scope of a transaction.
GetIndexSpecification(XmlTransaction, XmlDocumentConfig) | Retrieves the current index specification for the container in the scope of a transaction using the specified XmlDocumentConfig object.

See Also

XmlContainer Class
XmlContainer Members


GetIndexSpecification Method

[image]

.NET Framework Class Library
XmlContainer..::.GetIndexSpecification Method
XmlContainer Class See Also Send Feedback

Retrieves the current index specification for the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIndexSpecification As XmlIndexSpecification
C#
public XmlIndexSpecification GetIndexSpecification()
Visual C++
public:
XmlIndexSpecification^ GetIndexSpecification()
JavaScript
function getIndexSpecification();

Return Value

Return new XmlIndexSpecification.

Remarks

The index specification can be modified using SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext).

See Also

XmlContainer Class
GetIndexSpecification Overload


GetIndexSpecification Method (XmlTransaction)

[image]

.NET Framework Class Library
XmlContainer..::.GetIndexSpecification Method (XmlTransaction)
XmlContainer Class See Also Send Feedback

Retrieves the current index specification for the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIndexSpecification ( _
    transaction As XmlTransaction _
) As XmlIndexSpecification
C#
public XmlIndexSpecification GetIndexSpecification(
    XmlTransaction transaction
)
Visual C++
public:
XmlIndexSpecification^ GetIndexSpecification(
    XmlTransaction^ transaction
)
JavaScript
function getIndexSpecification(transaction);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().

Return Value

Return the XmlIndexSpecification.

Remarks

The index specification can be modified using SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext).

The application must open the container before attempting to retrieve its index specification.

See Also

XmlContainer Class
GetIndexSpecification Overload


GetIndexSpecification Method (XmlTransaction, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetIndexSpecification Method (XmlTransaction, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Retrieves the current index specification for the container in the scope of a transaction using the specified XmlDocumentConfig object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetIndexSpecification ( _
    transaction As XmlTransaction, _
    docConfig As XmlDocumentConfig _
) As XmlIndexSpecification
C#
public XmlIndexSpecification GetIndexSpecification(
    XmlTransaction transaction,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlIndexSpecification^ GetIndexSpecification(
    XmlTransaction^ transaction,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getIndexSpecification(transaction, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The parameter must be set to one of the following values: Acquire write locks instead of read locks when doing the retrieval.

Return Value

Return new XmlIndexSpecification.

See Also

XmlContainer Class
GetIndexSpecification Overload


GetNode Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetNode Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetNode(String) | Returns the XmlNode object associated with the specified handle.
GetNode(XmlTransaction, String) | Returns the XmlNode object associated with the specified handle.
GetNode(String, XmlDocumentConfig) | Returns the XmlNode object associated with the specified handle.
GetNode(XmlTransaction, String, XmlDocumentConfig) | Returns the XmlValue object associated with the specified handle.

See Also

XmlContainer Class
XmlContainer Members


GetNode Method (String)

[image]

.NET Framework Class Library
XmlContainer..::.GetNode Method (String)
XmlContainer Class See Also Send Feedback

Returns the XmlNode object associated with the specified handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNode ( _
    handle As String _
) As XmlNode
C#
public XmlNode GetNode(
    string handle
)
Visual C++
public:
XmlNode^ GetNode(
    String^ handle
)
JavaScript
function getNode(handle);

Parameters

handle
Type: System..::.String
The handle representing the node which must have been obtained using NodeHandle.

Return Value

Remarks

The handle must have been returned from NodeHandle on a node within this container, and the document must not have been modified in a way that invalidates the handle. If the handle is no longer valid an exception may be thrown, or in some cases, an incorrect node could be returned.

See Also

XmlContainer Class
GetNode Overload


GetNode Method (XmlTransaction, String)

[image]

.NET Framework Class Library
XmlContainer..::.GetNode Method (XmlTransaction, String)
XmlContainer Class See Also Send Feedback

Returns the XmlNode object associated with the specified handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNode ( _
    tran As XmlTransaction, _
    handle As String _
) As XmlNode
C#
public XmlNode GetNode(
    XmlTransaction tran,
    string handle
)
Visual C++
public:
XmlNode^ GetNode(
    XmlTransaction^ tran,
    String^ handle
)
JavaScript
function getNode(tran, handle);

Parameters

tran
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
handle
Type: System..::.String
The handle representing the node which must have been obtained using NodeHandle.

Return Value

Remarks

The handle must have been returned from NodeHandle on a node within this container, and the document must not have been modified in a way that invalidates the handle. If the handle is no longer valid an exception may be thrown, or in some cases, an incorrect node could be returned.

See Also

XmlContainer Class
GetNode Overload


GetNode Method (String, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetNode Method (String, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns the XmlNode object associated with the specified handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNode ( _
    handle As String, _
    docConfig As XmlDocumentConfig _
) As XmlNode
C#
public XmlNode GetNode(
    string handle,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlNode^ GetNode(
    String^ handle,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getNode(handle, docConfig);

Parameters

handle
Type: System..::.String
The handle representing the node which must have been obtained using NodeHandle.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig

The docConfig parameter must be set to 0 or one of the following values:

LazyDocs

Retrieve the document lazily. That is, retrieve document content and document metadata only on an as needed basis when reading the document.

LockMode

More information see : DbLockMode

Return Value

Remarks

The handle must have been returned from NodeHandle on a node within this container, and the document must not have been modified in a way that invalidates the handle. If the handle is no longer valid an exception may be thrown, or in some cases, an incorrect node could be returned.

See Also

XmlContainer Class
GetNode Overload


GetNode Method (XmlTransaction, String, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.GetNode Method (XmlTransaction, String, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Returns the XmlValue object associated with the specified handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNode ( _
    tran As XmlTransaction, _
    handle As String, _
    docConfig As XmlDocumentConfig _
) As XmlNode
C#
public XmlNode GetNode(
    XmlTransaction tran,
    string handle,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlNode^ GetNode(
    XmlTransaction^ tran,
    String^ handle,
    XmlDocumentConfig^ docConfig
)
JavaScript
function getNode(tran, handle, docConfig);

Parameters

tran
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
handle
Type: System..::.String
The handle representing the node which must have been obtained using NodeHandle.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig

The docConfig parameter must be set to 0 or one of the following values:

LazyDocs

Retrieve the document lazily. That is, retrieve document content and document metadata only on an as needed basis when reading the document.

LockMode

More information see : DbLockMode

Return Value

Remarks

The handle must have been returned from NodeHandle on a node within this container, and the document must not have been modified in a way that invalidates the handle. If the handle is no longer valid an exception may be thrown, or in some cases, an incorrect node could be returned.

See Also

XmlContainer Class
GetNode Overload


GetNumDocuments Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.GetNumDocuments Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
GetNumDocuments()()() | Returns the number of XmlDocument objects in the container.
GetNumDocuments(XmlTransaction) | Returns the number of XmlDocument objects in the container, in the context of a transaction.

See Also

XmlContainer Class
XmlContainer Members


GetNumDocuments Method

[image]

.NET Framework Class Library
XmlContainer..::.GetNumDocuments Method
XmlContainer Class See Also Send Feedback

Returns the number of XmlDocument objects in the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNumDocuments As Integer
C#
public int GetNumDocuments()
Visual C++
public:
int GetNumDocuments()
JavaScript
function getNumDocuments();

Return Value

Returns the number of XmlDocument objects in the container.

See Also

XmlContainer Class
GetNumDocuments Overload


GetNumDocuments Method (XmlTransaction)

[image]

.NET Framework Class Library
XmlContainer..::.GetNumDocuments Method (XmlTransaction)
XmlContainer Class See Also Send Feedback

Returns the number of XmlDocument objects in the container, in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNumDocuments ( _
    transaction As XmlTransaction _
) As Integer
C#
public int GetNumDocuments(
    XmlTransaction transaction
)
Visual C++
public:
int GetNumDocuments(
    XmlTransaction^ transaction
)
JavaScript
function getNumDocuments(transaction);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().

Return Value

The number of XmlDocument objects in the container, in the context of a transaction.

See Also

XmlContainer Class
GetNumDocuments Overload


LookupStatistics Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
LookupStatistics(String, String, String) | Returns an XmlStatistics object for the identified index.
LookupStatistics(XmlTransaction, String, String, String) | Returns an XmlStatistics object for the identified index.
LookupStatistics(String, String, String, XmlValue) | Returns an XmlStatistics object for the identified index.
LookupStatistics(XmlTransaction, String, String, String, XmlValue) | Returns an XmlStatistics object for the identified index.
LookupStatistics(String, String, String, String, String) | Lookup statistics for the identified edge index.
LookupStatistics(XmlTransaction, String, String, String, String, String) | Lookup statistics for the identified edge index in the scope of a transaction.
LookupStatistics(String, String, String, String, String, XmlValue) | Lookup statistics for the identified edge index.
LookupStatistics(XmlTransaction, String, String, String, String, String, XmlValue) | Lookup statistics for the identified edge index in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


LookupStatistics Method (String, String, String)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (String, String, String)
XmlContainer Class See Also Send Feedback

Returns an XmlStatistics object for the identified index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    uri As String, _
    name As String, _
    index As String _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    string uri,
    string name,
    string index
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function lookupStatistics(uri, name, index);

Parameters

uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.

Return Value

An XmlStatistics object for the identified index.

Remarks

This object identifies the number of keys (both total and unique) maintained for the identified index.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (XmlTransaction, String, String, String)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (XmlTransaction, String, String, String)
XmlContainer Class See Also Send Feedback

Returns an XmlStatistics object for the identified index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    index As String _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    XmlTransaction transaction,
    string uri,
    string name,
    string index
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function lookupStatistics(transaction, uri, name, index);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.

Return Value

An XmlStatistics object for the identified index.

Remarks

This object identifies the number of keys (both total and unique) maintained for the identified index.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (String, String, String, XmlValue)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (String, String, String, XmlValue)
XmlContainer Class See Also Send Feedback

Returns an XmlStatistics object for the identified index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    uri As String, _
    name As String, _
    index As String, _
    xmlValue As XmlValue _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    string uri,
    string name,
    string index,
    XmlValue xmlValue
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    String^ uri,
    String^ name,
    String^ index,
    XmlValue^ xmlValue
)
JavaScript
function lookupStatistics(uri, name, index, xmlValue);

Parameters

uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.
xmlValue
Type: JanaBiz.DbXml..::.XmlValue
Provides the value to which equality indices must be equal.

Return Value

An XmlStatistics object for the identified index.

Remarks

This object identifies the number of keys (both total and unique) maintained for the identified index.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (XmlTransaction, String, String, String, XmlValue)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (XmlTransaction, String, String, String, XmlValue)
XmlContainer Class See Also Send Feedback

Returns an XmlStatistics object for the identified index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    index As String, _
    xmlValue As XmlValue _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    XmlTransaction transaction,
    string uri,
    string name,
    string index,
    XmlValue xmlValue
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ index,
    XmlValue^ xmlValue
)
JavaScript
function lookupStatistics(transaction, uri, name, index, xmlValue);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.
xmlValue
Type: JanaBiz.DbXml..::.XmlValue
Provides the value to which equality indices must be equal.

Return Value

An XmlStatistics object for the identified index.

Remarks

This object identifies the number of keys (both total and unique) maintained for the identified index.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (String, String, String, String, String)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (String, String, String, String, String)
XmlContainer Class See Also Send Feedback

Lookup statistics for the identified edge index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    uri As String, _
    name As String, _
    parentUri As String, _
    parentName As String, _
    index As String _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    string uri,
    string name,
    string parentUri,
    string parentName,
    string index
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    String^ uri,
    String^ name,
    String^ parentUri,
    String^ parentName,
    String^ index
)
JavaScript
function lookupStatistics(uri, name, parentUri, parentName, index);

Parameters

uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
parentUri
Type: System..::.String
The namespace of the parent node to which this edge index is applied.
parentName
Type: System..::.String
The name of the parent node to which this edge index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.

Return Value

An XmlStatistics object for the identified index.

Remarks

Edge indices are indices maintained for those locations in a document where two nodes (a parent node and a child node) meet. See the Berkeley DB XML Getting Started Guide for details.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (XmlTransaction, String, String, String, String, String)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (XmlTransaction, String, String, String, String, String)
XmlContainer Class See Also Send Feedback

Lookup statistics for the identified edge index in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    parentUri As String, _
    parentName As String, _
    index As String _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    XmlTransaction transaction,
    string uri,
    string name,
    string parentUri,
    string parentName,
    string index
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ parentUri,
    String^ parentName,
    String^ index
)
JavaScript
function lookupStatistics(transaction, uri, name, parentUri, parentName, index);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
parentUri
Type: System..::.String
The namespace of the parent node to which this edge index is applied.
parentName
Type: System..::.String
The name of the parent node to which this edge index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.

Return Value

An XmlStatistics object for the identified index.

Remarks

Edge indices are indices maintained for those locations in a document where two nodes (a parent node and a child node) meet. See the Berkeley DB XML Getting Started Guide for details.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (String, String, String, String, String, XmlValue)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (String, String, String, String, String, XmlValue)
XmlContainer Class See Also Send Feedback

Lookup statistics for the identified edge index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    uri As String, _
    name As String, _
    parentUri As String, _
    parentName As String, _
    index As String, _
    xmlValue As XmlValue _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    string uri,
    string name,
    string parentUri,
    string parentName,
    string index,
    XmlValue xmlValue
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    String^ uri,
    String^ name,
    String^ parentUri,
    String^ parentName,
    String^ index,
    XmlValue^ xmlValue
)
JavaScript
function lookupStatistics(uri, name, parentUri, parentName, index, xmlValue);

Parameters

uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
parentUri
Type: System..::.String
The namespace of the parent node to which this edge index is applied.
parentName
Type: System..::.String
The name of the parent node to which this edge index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.
xmlValue
Type: JanaBiz.DbXml..::.XmlValue
Provides the value to which equality indices must be equal.

Return Value

An XmlStatistics object for the identified index.

Remarks

Edge indices are indices maintained for those locations in a document where two nodes (a parent node and a child node) meet. See the Berkeley DB XML Getting Started Guide for details.

See Also

XmlContainer Class
LookupStatistics Overload


LookupStatistics Method (XmlTransaction, String, String, String, String, String, XmlValue)

[image]

.NET Framework Class Library
XmlContainer..::.LookupStatistics Method (XmlTransaction, String, String, String, String, String, XmlValue)
XmlContainer Class See Also Send Feedback

Lookup statistics for the identified edge index in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function LookupStatistics ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    parentUri As String, _
    parentName As String, _
    index As String, _
    xmlValue As XmlValue _
) As XmlStatistics
C#
public XmlStatistics LookupStatistics(
    XmlTransaction transaction,
    string uri,
    string name,
    string parentUri,
    string parentName,
    string index,
    XmlValue xmlValue
)
Visual C++
public:
XmlStatistics^ LookupStatistics(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ parentUri,
    String^ parentName,
    String^ index,
    XmlValue^ xmlValue
)
JavaScript
function lookupStatistics(transaction, uri, name, parentUri, parentName, index, xmlValue);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to which this index is applied.
name
Type: System..::.String
The name of the node to which this index is applied.
parentUri
Type: System..::.String
The namespace of the parent node to which this edge index is applied.
parentName
Type: System..::.String
The name of the parent node to which this edge index is applied.
index
Type: System..::.String
Identifies the index for which you want the statistics returned. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications.
xmlValue
Type: JanaBiz.DbXml..::.XmlValue
Provides the value to which equality indices must be equal.

Return Value

An XmlStatistics object for the identified index.

Remarks

Edge indices are indices maintained for those locations in a document where two nodes (a parent node and a child node) meet. See the Berkeley DB XML Getting Started Guide for details.

See Also

XmlContainer Class
LookupStatistics Overload


PutDocument Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
PutDocument(XmlDocument, XmlUpdateContext) | Inserts an XmlDocument into the container.
PutDocument(XmlDocument, XmlUpdateContext, XmlDocumentConfig) | Inserts an XmlDocument into the container, with configuration options.
PutDocument(XmlTransaction, XmlDocument, XmlUpdateContext) | Inserts an XmlDocument into the container in the scope of a transaction.
PutDocument(String, XmlEventReader, XmlUpdateContext) | Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without XmlDocumentConfig and a transaction.
PutDocument(String, XmlInputStream, XmlUpdateContext) | Inserts a document into the container with a given name and content from a stream.
PutDocument(String, String, XmlUpdateContext) | Inserts a document into the container with a given name and string content.
PutDocument(XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig) | Inserts an XmlDocument into the container in the scope of a transaction.
PutDocument(XmlTransaction, String, XmlEventReader, XmlUpdateContext) | Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without XmlDocumentConfig.
PutDocument(XmlTransaction, String, XmlInputStream, XmlUpdateContext) | Inserts a document with given name and content into the container in the scope of a transaction.
PutDocument(XmlTransaction, String, String, XmlUpdateContext) | Inserts a document into the container with a given name and string content in the scope of a transaction.
PutDocument(String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without a transaction.
PutDocument(String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name and content into the container
PutDocument(String, String, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name and string content into the container.
PutDocument(XmlTransaction, String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content, within a transaction.
PutDocument(XmlTransaction, String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name and content into the container in the scope of a transaction.
PutDocument(XmlTransaction, String, String, XmlUpdateContext, XmlDocumentConfig) | Inserts a document with given name and string content into the container in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


PutDocument Method (XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts an XmlDocument into the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub PutDocument ( _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void PutDocument(
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void PutDocument(
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(xmlDocument, updateContext);

Parameters

xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlDocument, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlDocument, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts an XmlDocument into the container, with configuration options.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub PutDocument ( _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
)
C#
public void PutDocument(
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
void PutDocument(
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(xmlDocument, updateContext, docConfig);

Parameters

xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts an XmlDocument into the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub PutDocument ( _
    transaction As XmlTransaction, _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void PutDocument(
    XmlTransaction transaction,
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void PutDocument(
    XmlTransaction^ transaction,
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(transaction, xmlDocument, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, XmlEventReader, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, XmlEventReader, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without XmlDocumentConfig and a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    reader As XmlEventReader, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    string name,
    XmlEventReader reader,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    XmlEventReader^ reader,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(name, reader, updateContext);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
reader
Type: JanaBiz.DbXml..::.XmlEventReader
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return a string

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, XmlInputStream, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, XmlInputStream, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document into the container with a given name and content from a stream.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    adoptedInput As XmlInputStream, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    string name,
    XmlInputStream adoptedInput,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    XmlInputStream^ adoptedInput,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(name, adoptedInput, updateContext);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
adoptedInput
Type: JanaBiz.DbXml..::.XmlInputStream
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return the result

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document into the container with a given name and string content.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    contents As String, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    string name,
    string contents,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    String^ contents,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(name, contents, updateContext);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
contents
Type: System..::.String
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return the PutDocument(String, String, XmlUpdateContext)'s name.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts an XmlDocument into the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub PutDocument ( _
    transaction As XmlTransaction, _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
)
C#
public void PutDocument(
    XmlTransaction transaction,
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
void PutDocument(
    XmlTransaction^ transaction,
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(transaction, xmlDocument, updateContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, XmlEventReader, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, XmlEventReader, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without XmlDocumentConfig.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    reader As XmlEventReader, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    XmlEventReader reader,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlEventReader^ reader,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(transaction, name, reader, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
reader
Type: JanaBiz.DbXml..::.XmlEventReader
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return a string

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, XmlInputStream, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, XmlInputStream, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document with given name and content into the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    adoptedInput As XmlInputStream, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    XmlInputStream adoptedInput,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlInputStream^ adoptedInput,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(transaction, name, adoptedInput, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
adoptedInput
Type: JanaBiz.DbXml..::.XmlInputStream
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return the result

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Inserts a document into the container with a given name and string content in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    contents As String, _
    updateContext As XmlUpdateContext _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    string contents,
    XmlUpdateContext updateContext
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    String^ contents,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocument(transaction, name, contents, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
contents
Type: System..::.String
he content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Return Value

Return the PutDocument(String, String, XmlUpdateContext)'s name.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content without a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    reader As XmlEventReader, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    string name,
    XmlEventReader reader,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    XmlEventReader^ reader,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(name, reader, updateContext, docConfig);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
reader
Type: JanaBiz.DbXml..::.XmlEventReader
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Return a string

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name and content into the container

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    adoptedInput As XmlInputStream, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    string name,
    XmlInputStream adoptedInput,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    XmlInputStream^ adoptedInput,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(name, adoptedInput, updateContext, docConfig);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
adoptedInput
Type: JanaBiz.DbXml..::.XmlInputStream
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Return the result

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (String, String, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (String, String, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name and string content into the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    name As String, _
    contents As String, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    string name,
    string contents,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    String^ name,
    String^ contents,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(name, contents, updateContext, docConfig);

Parameters

name
Type: System..::.String
The name of the document to be inserted.
contents
Type: System..::.String
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Return the PutDocument(String, String, XmlUpdateContext)'s name.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, XmlEventReader, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name into the container, using the content retrieved from the given XmlEventReader as content, within a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    reader As XmlEventReader, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    XmlEventReader reader,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlEventReader^ reader,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(transaction, name, reader, updateContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
reader
Type: JanaBiz.DbXml..::.XmlEventReader
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Return a string

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, XmlInputStream, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name and content into the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    adoptedInput As XmlInputStream, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    XmlInputStream adoptedInput,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    XmlInputStream^ adoptedInput,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(transaction, name, adoptedInput, updateContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
adoptedInput
Type: JanaBiz.DbXml..::.XmlInputStream
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Return the result

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocument Method (XmlTransaction, String, String, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocument Method (XmlTransaction, String, String, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Inserts a document with given name and string content into the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocument ( _
    transaction As XmlTransaction, _
    name As String, _
    contents As String, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As String
C#
public string PutDocument(
    XmlTransaction transaction,
    string name,
    string contents,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
String^ PutDocument(
    XmlTransaction^ transaction,
    String^ name,
    String^ contents,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocument(transaction, name, contents, updateContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the document to be inserted.
contents
Type: System..::.String
The content of the document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation .

Return Value

Return the PutDocument(String, String, XmlUpdateContext)'s name.

Remarks

Note that the name used for the document must be unique in the container or an exception is thrown.

The configuration setting GenerateName, can be used to generate a name.

To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext).

See Also

XmlContainer Class
PutDocument Overload


PutDocumentAsEventWriter Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.PutDocumentAsEventWriter Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) | Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.
PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext, XmlDocumentConfig) | Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.
PutDocumentAsEventWriter(XmlTransaction, XmlDocument, XmlUpdateContext) | Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.
PutDocumentAsEventWriter(XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig) | Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.

See Also

XmlContainer Class
XmlContainer Members


PutDocumentAsEventWriter Method (XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocumentAsEventWriter Method (XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocumentAsEventWriter ( _
    document As XmlDocument, _
    updateContext As XmlUpdateContext _
) As XmlEventWriter
C#
public XmlEventWriter PutDocumentAsEventWriter(
    XmlDocument document,
    XmlUpdateContext updateContext
)
Visual C++
public:
XmlEventWriter^ PutDocumentAsEventWriter(
    XmlDocument^ document,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocumentAsEventWriter(document, updateContext);

Parameters

document
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Return Value

Remarks

The document content must be provided by the caller via calls to the returned XmlEventWriter object. When the content is completely written, Close()()() must be called to complete the operation.

Database resources are held for the duration of the operation, so it should not be delayed if at all possible.

Note that the name used for the document must be unique in the container or an exception is thrown. The configuration setting GenerateName, can be used to generate a name. To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext)

See Also

XmlContainer Class
PutDocumentAsEventWriter Overload


PutDocumentAsEventWriter Method (XmlDocument, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocumentAsEventWriter Method (XmlDocument, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocumentAsEventWriter ( _
    document As XmlDocument, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As XmlEventWriter
C#
public XmlEventWriter PutDocumentAsEventWriter(
    XmlDocument document,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlEventWriter^ PutDocumentAsEventWriter(
    XmlDocument^ document,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocumentAsEventWriter(document, updateContext, docConfig);

Parameters

document
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig

Configuration settings for this operation.The flags parameter must be set to 0 or the following value:

GenerateName

Generate a unique name. If no name is set for this XmlDocument, a system-defined unique name is generated. If a name is specified, a unique string is appended to that name to ensure uniqueness.

Return Value

Remarks

The document content must be provided by the caller via calls to the returned XmlEventWriter object. When the content is completely written, Close()()() must be called to complete the operation.

Database resources are held for the duration of the operation, so it should not be delayed if at all possible.

Note that the name used for the document must be unique in the container or an exception is thrown. The configuration setting GenerateName, can be used to generate a name. To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext)

See Also

XmlContainer Class
PutDocumentAsEventWriter Overload


PutDocumentAsEventWriter Method (XmlTransaction, XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocumentAsEventWriter Method (XmlTransaction, XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocumentAsEventWriter ( _
    txn As XmlTransaction, _
    document As XmlDocument, _
    updateContext As XmlUpdateContext _
) As XmlEventWriter
C#
public XmlEventWriter PutDocumentAsEventWriter(
    XmlTransaction txn,
    XmlDocument document,
    XmlUpdateContext updateContext
)
Visual C++
public:
XmlEventWriter^ PutDocumentAsEventWriter(
    XmlTransaction^ txn,
    XmlDocument^ document,
    XmlUpdateContext^ updateContext
)
JavaScript
function putDocumentAsEventWriter(txn, document, updateContext);

Parameters

txn
Type: JanaBiz.DbXml..::.XmlTransaction
The document to be inserted.
document
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Return Value

Remarks

The document content must be provided by the caller via calls to the returned XmlEventWriter object. When the content is completely written, Close()()() must be called to complete the operation.

Database resources are held for the duration of the operation, so it should not be delayed if at all possible.

Note that the name used for the document must be unique in the container or an exception is thrown. The configuration setting GenerateName, can be used to generate a name. To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext)

See Also

XmlContainer Class
PutDocumentAsEventWriter Overload


PutDocumentAsEventWriter Method (XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlContainer..::.PutDocumentAsEventWriter Method (XmlTransaction, XmlDocument, XmlUpdateContext, XmlDocumentConfig)
XmlContainer Class See Also Send Feedback

Prepares to insert an XmlDocument into the container, using the returned XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function PutDocumentAsEventWriter ( _
    txn As XmlTransaction, _
    document As XmlDocument, _
    updateContext As XmlUpdateContext, _
    docConfig As XmlDocumentConfig _
) As XmlEventWriter
C#
public XmlEventWriter PutDocumentAsEventWriter(
    XmlTransaction txn,
    XmlDocument document,
    XmlUpdateContext updateContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlEventWriter^ PutDocumentAsEventWriter(
    XmlTransaction^ txn,
    XmlDocument^ document,
    XmlUpdateContext^ updateContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function putDocumentAsEventWriter(txn, document, updateContext, docConfig);

Parameters

txn
Type: JanaBiz.DbXml..::.XmlTransaction
The document to be inserted.
document
Type: JanaBiz.DbXml..::.XmlDocument
The document to be inserted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig

Configuration settings for this operation.The flags parameter must be set to 0 or the following value:

GenerateName

Generate a unique name. If no name is set for this XmlDocument, a system-defined unique name is generated. If a name is specified, a unique string is appended to that name to ensure uniqueness.

Return Value

Remarks

The document content must be provided by the caller via calls to the returned XmlEventWriter object. When the content is completely written, Close()()() must be called to complete the operation.

Database resources are held for the duration of the operation, so it should not be delayed if at all possible.

Note that the name used for the document must be unique in the container or an exception is thrown. The configuration setting GenerateName, can be used to generate a name. To change a document that already exists in the container, use UpdateDocument(XmlDocument, XmlUpdateContext)

See Also

XmlContainer Class
PutDocumentAsEventWriter Overload


RemoveAlias Method

[image]

.NET Framework Class Library
XmlContainer..::.RemoveAlias Method
XmlContainer Class See Also Send Feedback

Removes the named alias from the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function RemoveAlias ( _
    alias As String _
) As Boolean
C#
public bool RemoveAlias(
    string alias
)
Visual C++
public:
bool RemoveAlias(
    String^ alias
)
JavaScript
function removeAlias(alias);

Parameters

alias
Type: System..::.String
The alias to be removed.

Return Value

Returns trueTruetruetrue (True in Visual Basic) if the alias is found, and matches the container.

Remarks

The alias must have been added using AddAlias(String). Returns trueTruetruetrue (True in Visual Basic) if the alias is found, and matches the container.

See Also

XmlContainer Class


ReplaceDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.ReplaceDefaultIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
ReplaceDefaultIndex(String, XmlUpdateContext) | Replaces the container's default index.
ReplaceDefaultIndex(XmlTransaction, String, XmlUpdateContext) | Replaces the container's default index in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


ReplaceDefaultIndex Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.ReplaceDefaultIndex Method (String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Replaces the container's default index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceDefaultIndex ( _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReplaceDefaultIndex(
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReplaceDefaultIndex(
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function replaceDefaultIndex(index, updateContext);

Parameters

index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see ReplaceDefaultIndex(String) for more information.

See Also

XmlContainer Class
ReplaceDefaultIndex Overload


ReplaceDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.ReplaceDefaultIndex Method (XmlTransaction, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Replaces the container's default index in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceDefaultIndex ( _
    transaction As XmlTransaction, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReplaceDefaultIndex(
    XmlTransaction transaction,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReplaceDefaultIndex(
    XmlTransaction^ transaction,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function replaceDefaultIndex(transaction, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see ReplaceDefaultIndex(String) for more information.

See Also

XmlContainer Class
ReplaceDefaultIndex Overload


ReplaceIndex Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.ReplaceIndex Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
ReplaceIndex(String, String, String, XmlUpdateContext) | Replaces an index of the specified type for the named document node.
ReplaceIndex(XmlTransaction, String, String, String, XmlUpdateContext) | Replaces an index of the specified type for the named document node in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


ReplaceIndex Method (String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.ReplaceIndex Method (String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Replaces an index of the specified type for the named document node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceIndex ( _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReplaceIndex(
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReplaceIndex(
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function replaceIndex(uri, name, index, updateContext);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see ReplaceIndex(String, String, String) for more information.

See Also

XmlContainer Class
ReplaceIndex Overload


ReplaceIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.ReplaceIndex Method (XmlTransaction, String, String, String, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Replaces an index of the specified type for the named document node in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceIndex ( _
    transaction As XmlTransaction, _
    uri As String, _
    name As String, _
    index As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReplaceIndex(
    XmlTransaction transaction,
    string uri,
    string name,
    string index,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReplaceIndex(
    XmlTransaction^ transaction,
    String^ uri,
    String^ name,
    String^ index,
    XmlUpdateContext^ updateContext
)
JavaScript
function replaceIndex(transaction, uri, name, index, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

Remarks

This method is for convenience -- see ReplaceIndex(String, String, String) for more information.

See Also

XmlContainer Class
ReplaceIndex Overload


SetAutoIndexing Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.SetAutoIndexing Method
XmlContainer Class See Also Send Feedback

Overload List

Name Description
SetAutoIndexing(Boolean)
Sets the current state of automatic indexing for the container. The state can be retrieved using GetAutoIndexing()()().

If the value on the container is true (the default for newly-created containers) then indexes are added automatically for leaf elements and attributes. The indexes added are "node-equality-string" and "node-equality-double" for elements and attributes. If auto-indexing is not desired it should be disabled using this interface upon container creation. Auto-indexing is recognized by insertion of new documents as well as updates of existing documents, including modification via XQuery Update. The auto-indexing state is persistent and will remain stable across container close/re-open operations. Indexes added via auto-indexing are normal indexes and can be removed using the normal mechanisms.

A significant implication of auto-indexing is that any operation that may add an index (e.g. PutDocument(String, String, XmlUpdateContext)) can have the side effect of reindexing the entire container. For this reason auto-indexing is not recommended for containers of heterogenous documents and that it be disabled once a representative set of documents has been inserted.

SetAutoIndexing(Boolean, XmlTransaction)
Sets the current state of automatic indexing for the container in the scope of a transaction. The state can be retrieved using GetAutoIndexing()()().
SetAutoIndexing(Boolean, XmlUpdateContext)
Sets the current state of automatic indexing for the container. The state can be retrieved using GetAutoIndexing()()().
SetAutoIndexing(XmlTransaction, Boolean, XmlUpdateContext)
Sets the auto-indexing state of the container.

See Also

XmlContainer Class
XmlContainer Members


SetAutoIndexing Method (Boolean)

[image]

.NET Framework Class Library
XmlContainer..::.SetAutoIndexing Method (Boolean)
XmlContainer Class See Also Send Feedback

Sets the current state of automatic indexing for the container. The state can be retrieved using GetAutoIndexing()()().

If the value on the container is true (the default for newly-created containers) then indexes are added automatically for leaf elements and attributes. The indexes added are "node-equality-string" and "node-equality-double" for elements and attributes. If auto-indexing is not desired it should be disabled using this interface upon container creation. Auto-indexing is recognized by insertion of new documents as well as updates of existing documents, including modification via XQuery Update. The auto-indexing state is persistent and will remain stable across container close/re-open operations. Indexes added via auto-indexing are normal indexes and can be removed using the normal mechanisms.

A significant implication of auto-indexing is that any operation that may add an index (e.g. PutDocument(String, String, XmlUpdateContext)) can have the side effect of reindexing the entire container. For this reason auto-indexing is not recommended for containers of heterogenous documents and that it be disabled once a representative set of documents has been inserted.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetAutoIndexing ( _
    value As Boolean _
)
C#
public void SetAutoIndexing(
    bool value
)
Visual C++
public:
void SetAutoIndexing(
    bool value
)
JavaScript
function setAutoIndexing(value);

Parameters

value
Type: System..::.Boolean
Set to true to enable auto-indexing, false otherwise.

See Also

XmlContainer Class
SetAutoIndexing Overload


SetAutoIndexing Method (Boolean, XmlTransaction)

[image]

.NET Framework Class Library
XmlContainer..::.SetAutoIndexing Method (Boolean, XmlTransaction)
XmlContainer Class See Also Send Feedback

Sets the current state of automatic indexing for the container in the scope of a transaction. The state can be retrieved using GetAutoIndexing()()().

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetAutoIndexing ( _
    value As Boolean, _
    transaction As XmlTransaction _
)
C#
public void SetAutoIndexing(
    bool value,
    XmlTransaction transaction
)
Visual C++
public:
void SetAutoIndexing(
    bool value,
    XmlTransaction^ transaction
)
JavaScript
function setAutoIndexing(value, transaction);

Parameters

value
Type: System..::.Boolean
Set to true to enable auto-indexing, false otherwise.
transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from [!:XmlManager.CreateTransaction()].

See Also

XmlContainer Class
SetAutoIndexing Overload


SetAutoIndexing Method (Boolean, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.SetAutoIndexing Method (Boolean, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Sets the current state of automatic indexing for the container. The state can be retrieved using GetAutoIndexing()()().

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetAutoIndexing ( _
    value As Boolean, _
    updateContext As XmlUpdateContext _
)
C#
public void SetAutoIndexing(
    bool value,
    XmlUpdateContext updateContext
)
Visual C++
public:
void SetAutoIndexing(
    bool value,
    XmlUpdateContext^ updateContext
)
JavaScript
function setAutoIndexing(value, updateContext);

Parameters

value
Type: System..::.Boolean
Set to true to enable auto-indexing, false otherwise.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext to use for the operation.

See Also

XmlContainer Class
SetAutoIndexing Overload


SetAutoIndexing Method (XmlTransaction, Boolean, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.SetAutoIndexing Method (XmlTransaction, Boolean, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Sets the auto-indexing state of the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetAutoIndexing ( _
    transaction As XmlTransaction, _
    value As Boolean, _
    updateContext As XmlUpdateContext _
)
C#
public void SetAutoIndexing(
    XmlTransaction transaction,
    bool value,
    XmlUpdateContext updateContext
)
Visual C++
public:
void SetAutoIndexing(
    XmlTransaction^ transaction,
    bool value,
    XmlUpdateContext^ updateContext
)
JavaScript
function setAutoIndexing(transaction, value, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from [!:XmlManager.CreateTransaction].
value
Type: System..::.Boolean
A boolean value indicating whether auto-indexing behavior should be enabled or disabled.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
he update context to use for the operation.

Remarks

If the value on the container is true (the default for newly-created containers) then indexes are added automatically for leaf elements and attributes. The indexes added are "node-equality-string" and "node-equality-double" for elements and attributes. If auto-indexing is not desired it should be disabled using this interface immediately after container creation. Auto-indexing is recognized by insertion of new documents as well as updates of existing documents, including modification via XQuery Update. The auto-indexing state is persistent and will remain stable across container close/re-open operations. Indexes added via auto-indexing are normal indexes and can be removed using the normal mechanisms.

A significant implication of auto-indexing is that any operation that may add an index (e.g. PutDocument(String, String, XmlUpdateContext)) can have the side effect of reindexing the entire container. For this reason auto-indexing is not recommended for containers of heterogenous documents and that it be disabled once a representative set of documents has been inserted.

See Also

XmlContainer Class
SetAutoIndexing Overload


SetIndexSpecification Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.SetIndexSpecification Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext) | Defines the type of indexing to be maintained for a container of documents.
SetIndexSpecification(XmlTransaction, XmlIndexSpecification, XmlUpdateContext) | Defines the type of indexing to be maintained for a container of documents in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


SetIndexSpecification Method (XmlIndexSpecification, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.SetIndexSpecification Method (XmlIndexSpecification, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Defines the type of indexing to be maintained for a container of documents.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetIndexSpecification ( _
    index As XmlIndexSpecification, _
    context As XmlUpdateContext _
)
C#
public void SetIndexSpecification(
    XmlIndexSpecification index,
    XmlUpdateContext context
)
Visual C++
public:
void SetIndexSpecification(
    XmlIndexSpecification^ index,
    XmlUpdateContext^ context
)
JavaScript
function setIndexSpecification(index, context);

Parameters

index
Type: JanaBiz.DbXml..::.XmlIndexSpecification
The indexing specification for the container.
context
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

The currently defined indexing specification can be retrieved with the GetIndexSpecification()()() method.

If the container is not empty then the contained documents are incrementally indexed.

Index keys for disabled index strategies are removed and index keys for enabled index strategies are added.

Note that the length of time taken to perform this re-indexing operation is proportional to the size of the container.

See Also

XmlContainer Class
SetIndexSpecification Overload


SetIndexSpecification Method (XmlTransaction, XmlIndexSpecification, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.SetIndexSpecification Method (XmlTransaction, XmlIndexSpecification, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Defines the type of indexing to be maintained for a container of documents in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetIndexSpecification ( _
    transaction As XmlTransaction, _
    index As XmlIndexSpecification, _
    context As XmlUpdateContext _
)
C#
public void SetIndexSpecification(
    XmlTransaction transaction,
    XmlIndexSpecification index,
    XmlUpdateContext context
)
Visual C++
public:
void SetIndexSpecification(
    XmlTransaction^ transaction,
    XmlIndexSpecification^ index,
    XmlUpdateContext^ context
)
JavaScript
function setIndexSpecification(transaction, index, context);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
index
Type: JanaBiz.DbXml..::.XmlIndexSpecification
The indexing specification for the container.
context
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

The currently defined indexing specification can be retrieved with the GetIndexSpecification()()() method.

If the container is not empty then the contained documents are incrementally indexed.

Index keys for disabled index strategies are removed and index keys for enabled index strategies are added.

Note that the length of time taken to perform this re-indexing operation is proportional to the size of the container.

See Also

XmlContainer Class
SetIndexSpecification Overload


Sync Method

[image]

.NET Framework Class Library
XmlContainer..::.Sync Method
XmlContainer Class See Also Send Feedback

Flush database pages for the container to disk.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Sync
C#
public void Sync()
Visual C++
public:
void Sync()
JavaScript
function sync();

See Also

XmlContainer Class


UpdateDocument Method

[image] [image]

.NET Framework Class Library
XmlContainer..::.UpdateDocument Method
XmlContainer Class See Also Send Feedback

Overload List

Name | Description
UpdateDocument(XmlDocument, XmlUpdateContext) | Updates an XmlDocument in the container.
UpdateDocument(XmlTransaction, XmlDocument, XmlUpdateContext) | Updates an XmlDocument in the container in the scope of a transaction.

See Also

XmlContainer Class
XmlContainer Members


UpdateDocument Method (XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.UpdateDocument Method (XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Updates an XmlDocument in the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateDocument ( _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void UpdateDocument(
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void UpdateDocument(
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function updateDocument(xmlDocument, updateContext);

Parameters

xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The XmlDocument to be updated in the container.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

The document must have been retrieved from the container using GetDocument(String), XmlManager.Query, or Execute(XmlQueryContext).

It is possible to use a constructed XmlDocument object, if its name is set to a valid name in the container.

The document must still exist within the container.

The document content is indexed according to the container indexing specification, with index keys being removed for the previous document content, and added for the updated document content.

See Also

XmlContainer Class
UpdateDocument Overload


UpdateDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlContainer..::.UpdateDocument Method (XmlTransaction, XmlDocument, XmlUpdateContext)
XmlContainer Class See Also Send Feedback

Updates an XmlDocument in the container in the scope of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpdateDocument ( _
    transaction As XmlTransaction, _
    xmlDocument As XmlDocument, _
    updateContext As XmlUpdateContext _
)
C#
public void UpdateDocument(
    XmlTransaction transaction,
    XmlDocument xmlDocument,
    XmlUpdateContext updateContext
)
Visual C++
public:
void UpdateDocument(
    XmlTransaction^ transaction,
    XmlDocument^ xmlDocument,
    XmlUpdateContext^ updateContext
)
JavaScript
function updateDocument(transaction, xmlDocument, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
xmlDocument
Type: JanaBiz.DbXml..::.XmlDocument
The XmlDocument to be updated in the container.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The update context to use for the operation.

Remarks

The document must have been retrieved from the container using GetDocument(String), XmlManager.Query, or Execute(XmlQueryContext).

It is possible to use a constructed XmlDocument object, if its name is set to a valid name in the container.

The document must still exist within the container.

The document content is indexed according to the container indexing specification, with index keys being removed for the previous document content, and added for the updated document content.

See Also

XmlContainer Class
UpdateDocument Overload


XmlContainer Properties

[image] [image]

.NET Framework Class Library
XmlContainer Properties
XmlContainer Class See Also Send Feedback

The XmlContainer type exposes the following members.

Properties

Name | Description
Config | The configuration object for the XmlContainer.
ContainerType | The container's type.
IsIndexNodes | Returns whether or not the container is indexing at the node level. Returns trueTruetruetrue (True in Visual Basic) if indexes are at the node level, falseFalsefalsefalse (False in Visual Basic) otherwise.
Name | The name of the XmlContainer.
PageSize | The underlying database page size for the container.
XmlManager | The XmlManager object for the XmlContainer.

See Also

XmlContainer Class


Config Property

[image]

.NET Framework Class Library
XmlContainer..::.Config Property
XmlContainer Class See Also Send Feedback

The configuration object for the XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Config As XmlContainerConfig
C#
public XmlContainerConfig Config { get; }
Visual C++
public:
property XmlContainerConfig^ Config {
    XmlContainerConfig^ get ();
}
JavaScript
function get_config();

Field Value

The configuration object for the XmlContainer.

See Also

XmlContainer Class


ContainerType Property

[image]

.NET Framework Class Library
XmlContainer..::.ContainerType Property
XmlContainer Class See Also Send Feedback

The container's type.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ContainerType As XmlContainerType
C#
public XmlContainerType ContainerType { get; }
Visual C++
public:
property XmlContainerType ContainerType {
    XmlContainerType get ();
}
JavaScript
function get_containerType();

Remarks

Possible return values are: NodeContainer or WholeDocContainer.

See Also

XmlContainer Class


IsIndexNodes Property

[image]

.NET Framework Class Library
XmlContainer..::.IsIndexNodes Property
XmlContainer Class See Also Send Feedback

Returns whether or not the container is indexing at the node level. Returns trueTruetruetrue (True in Visual Basic) if indexes are at the node level, falseFalsefalsefalse (False in Visual Basic) otherwise.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsIndexNodes As Boolean
C#
public bool IsIndexNodes { get; }
Visual C++
public:
property bool IsIndexNodes {
    bool get ();
}
JavaScript
function get_isIndexNodes();

Field Value

trueTruetruetrue (True in Visual Basic) if indexes are at the node level, falseFalsefalsefalse (False in Visual Basic) otherwise.

See Also

XmlContainer Class


Name Property

[image]

.NET Framework Class Library
XmlContainer..::.Name Property
XmlContainer Class See Also Send Feedback

The name of the XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}
JavaScript
function get_name();

Field Value

The name of the XmlContainer.

See Also

XmlContainer Class


PageSize Property

[image]

.NET Framework Class Library
XmlContainer..::.PageSize Property
XmlContainer Class See Also Send Feedback

The underlying database page size for the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageSize As Integer
C#
public int PageSize { get; }
Visual C++
public:
property int PageSize {
    int get ();
}
JavaScript
function get_pageSize();

Field Value

The underlying database page size for the container.

See Also

XmlContainer Class


XmlManager Property

[image]

.NET Framework Class Library
XmlContainer..::.XmlManager Property
XmlContainer Class See Also Send Feedback

The XmlManager object for the XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property XmlManager As XmlManager
C#
public XmlManager XmlManager { get; }
Visual C++
public:
property XmlManager^ XmlManager {
    XmlManager^ get ();
}
JavaScript
function get_xmlManager();

Field Value

The XmlManager object for the XmlContainer.

See Also

XmlContainer Class


XmlContainerConfig Class

[image]

.NET Framework Class Library
XmlContainerConfig Class
Members See Also Send Feedback

Configuration settings for an XmlContainer instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlContainerConfig _
    Inherits InvocationHandle
C#
public class XmlContainerConfig : InvocationHandle
Visual C++
public ref class XmlContainerConfig : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlContainerConfig = function();

Type.createClass(
    'JanaBiz.DbXml.XmlContainerConfig',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlContainerConfig

See Also

XmlContainerConfig Members


XmlContainerConfig Members

[image] [image]

.NET Framework Class Library
XmlContainerConfig Members
XmlContainerConfig Class Constructors Methods Fields Properties See Also Send Feedback

The XmlContainerConfig type exposes the following members.

Constructors

Name | Description
XmlContainerConfig | Initializes the XmlContainerConfig class.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | 現在の Object を表す String を返します。 (Overrides Object..::.ToString()()().)

Fields

Name | Description
DefaultCompression | The default compression algorithm.
NoCompression | Do not use compression.

Properties

Name Description
AllowCreate
Create the database.
AllowValidation
Whether documents are validated when loaded into the container, if they refer to a DTD or XML Schema.
Checksum
Do checksum verification of pages read into the cache from the backing filestore.
CompressionName
Gets or sets the name of the compression algorithm be used by the container. If the name is not the default then the name must match the name the algorithm was registered with the XmlManager using RegisterCompression(String, XmlCompression). This only effects container creation, after the container is created this value is silently ignored.
ContainerType
Whether documents are broken down into their component nodes, and these nodes are stored individually in the container, or stored intact with all white space and formatting is preserved.
Encrypted
Encrypt the database using the cryptographic password specified to the methods.
ExclusiveCreate
Return an error if the database already exists.
IndexNodes
Sets whether the index targets reference nodes or documents. The default setting is UseDefault. This value is ignored unless the container is being created or reindexed.
Multiversion
Configured to open all databases for multiversion concurrency control.
NoMMap
Do not map this database into process memory (see the method for further information).
PageSize
Get or sets the size in bytes of the pages used to store documents in the database. The size is specified in bytes in the range 512 bytes to 64K bytes. If no page size is specified the system will create containers with page size 8192 for node storage containers and 16384 for wholedoc storage containers. Page size affects the amount of I/O performed as well as granularity of locking as Berkeley DB performs page-level locking. These needs are often at odds with one another. The page size cannot be changed once a container has been created. This value is ignored unless the container is being created.
ReadOnly
Open the database for reading only.
ReadUncommitted
Configure the database to support read uncommitted.
SequenceIncrement
Gets or Sets the integer increment to be used when pre-allocating document ids for new documents created by PutDocument(String, String, XmlUpdateContext).

Every document added to an XmlContainer is assigned an internal unique ID, and BDB XML performs an internal database operation to obtain these IDs. In order to increase database concurrency and improve performance of ID allocation, BDB XML pre-allocates a sequence of these numbers. The size of this sequence is determined by the value specified here. The default ID sequence size is 5.

Be aware that when a container is closed, any unused IDs in the current sequence are lost. Under some extreme cases, this can result in a container to which documents can no longer be added. For example, setting this value to a very large number (such as, say, 1 million) and then repeatedly opening and closing the container while adding a few documents may eventually cause the container to run out of IDs. Once out of IDs, the container will never again be able to accept new documents. However, document IDs are 64-bit quantities so this is extremely unlikely.

You should almost always leave this value alone. However, if you are loading a large number of documents to a container all at once, you may find a small performance benefit to setting the sequence number to a larger value. If you do this, be aware that this value is persistent across container opens, so you should take care to reset the value to its default once you are done loading the documents.

Statistics
Sets whether the structural statistics are stored in the container. These statisitics are used in query optimization. The default setting is UseDefault and the default is to use statistics. This value is ignored unless the container is being created or reindexed.
Threaded
Cause the DbEnv handle returned by [!:JanaBiz.Db.DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.
Transactional
Initialize the transaction subsystem.
TransactionNotDurable
If set, Berkeley DB XML will not write log records for this database. This means that updates of this database exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, integrity will not persist. The database file must be verified and/or restored from backup after a failure.

See Also

XmlContainerConfig Class


XmlContainerConfig Constructor

[image]

.NET Framework Class Library
XmlContainerConfig Constructor
XmlContainerConfig Class See Also Send Feedback

Initializes the XmlContainerConfig class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlContainerConfig()
Visual C++
public:
XmlContainerConfig()
JavaScript
JanaBiz.DbXml.XmlContainerConfig = function();

See Also

XmlContainerConfig Class


XmlContainerConfig Fields

[image] [image]

.NET Framework Class Library
XmlContainerConfig Fields
XmlContainerConfig Class See Also Send Feedback

The XmlContainerConfig type exposes the following members.

Fields

Name | Description
DefaultCompression | The default compression algorithm.
NoCompression | Do not use compression.

See Also

XmlContainerConfig Class


DefaultCompression Field

[image]

.NET Framework Class Library
XmlContainerConfig..::.DefaultCompression Field
XmlContainerConfig Class See Also Send Feedback

The default compression algorithm.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly DefaultCompression As String
C#
public static readonly string DefaultCompression
Visual C++
public:
static initonly String^ DefaultCompression
JavaScript
JanaBiz.DbXml.XmlContainerConfig.defaultCompression

See Also

XmlContainerConfig Class


NoCompression Field

[image]

.NET Framework Class Library
XmlContainerConfig..::.NoCompression Field
XmlContainerConfig Class See Also Send Feedback

Do not use compression.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly NoCompression As String
C#
public static readonly string NoCompression
Visual C++
public:
static initonly String^ NoCompression
JavaScript
JanaBiz.DbXml.XmlContainerConfig.noCompression

See Also

XmlContainerConfig Class


XmlContainerConfig Methods

[image] [image]

.NET Framework Class Library
XmlContainerConfig Methods
XmlContainerConfig Class See Also Send Feedback

The XmlContainerConfig type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | 現在の Object を表す String を返します。 (Overrides Object..::.ToString()()().)

See Also

XmlContainerConfig Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlContainerConfig..::.Dispose Method
XmlContainerConfig Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlContainerConfig Class
XmlContainerConfig Members


ToString Method

[image]

.NET Framework Class Library
XmlContainerConfig..::.ToString Method
XmlContainerConfig Class See Also Send Feedback

現在の Object を表す String を返します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

現在の Object を表す String。

See Also

XmlContainerConfig Class


XmlContainerConfig Properties

[image] [image]

.NET Framework Class Library
XmlContainerConfig Properties
XmlContainerConfig Class See Also Send Feedback

The XmlContainerConfig type exposes the following members.

Properties

Name Description
AllowCreate
Create the database.
AllowValidation
Whether documents are validated when loaded into the container, if they refer to a DTD or XML Schema.
Checksum
Do checksum verification of pages read into the cache from the backing filestore.
CompressionName
Gets or sets the name of the compression algorithm be used by the container. If the name is not the default then the name must match the name the algorithm was registered with the XmlManager using RegisterCompression(String, XmlCompression). This only effects container creation, after the container is created this value is silently ignored.
ContainerType
Whether documents are broken down into their component nodes, and these nodes are stored individually in the container, or stored intact with all white space and formatting is preserved.
Encrypted
Encrypt the database using the cryptographic password specified to the methods.
ExclusiveCreate
Return an error if the database already exists.
IndexNodes
Sets whether the index targets reference nodes or documents. The default setting is UseDefault. This value is ignored unless the container is being created or reindexed.
Multiversion
Configured to open all databases for multiversion concurrency control.
NoMMap
Do not map this database into process memory (see the method for further information).
PageSize
Get or sets the size in bytes of the pages used to store documents in the database. The size is specified in bytes in the range 512 bytes to 64K bytes. If no page size is specified the system will create containers with page size 8192 for node storage containers and 16384 for wholedoc storage containers. Page size affects the amount of I/O performed as well as granularity of locking as Berkeley DB performs page-level locking. These needs are often at odds with one another. The page size cannot be changed once a container has been created. This value is ignored unless the container is being created.
ReadOnly
Open the database for reading only.
ReadUncommitted
Configure the database to support read uncommitted.
SequenceIncrement
Gets or Sets the integer increment to be used when pre-allocating document ids for new documents created by PutDocument(String, String, XmlUpdateContext).

Every document added to an XmlContainer is assigned an internal unique ID, and BDB XML performs an internal database operation to obtain these IDs. In order to increase database concurrency and improve performance of ID allocation, BDB XML pre-allocates a sequence of these numbers. The size of this sequence is determined by the value specified here. The default ID sequence size is 5.

Be aware that when a container is closed, any unused IDs in the current sequence are lost. Under some extreme cases, this can result in a container to which documents can no longer be added. For example, setting this value to a very large number (such as, say, 1 million) and then repeatedly opening and closing the container while adding a few documents may eventually cause the container to run out of IDs. Once out of IDs, the container will never again be able to accept new documents. However, document IDs are 64-bit quantities so this is extremely unlikely.

You should almost always leave this value alone. However, if you are loading a large number of documents to a container all at once, you may find a small performance benefit to setting the sequence number to a larger value. If you do this, be aware that this value is persistent across container opens, so you should take care to reset the value to its default once you are done loading the documents.

Statistics
Sets whether the structural statistics are stored in the container. These statisitics are used in query optimization. The default setting is UseDefault and the default is to use statistics. This value is ignored unless the container is being created or reindexed.
Threaded
Cause the DbEnv handle returned by [!:JanaBiz.Db.DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.
Transactional
Initialize the transaction subsystem.
TransactionNotDurable
If set, Berkeley DB XML will not write log records for this database. This means that updates of this database exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, integrity will not persist. The database file must be verified and/or restored from backup after a failure.

See Also

XmlContainerConfig Class


AllowCreate Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.AllowCreate Property
XmlContainerConfig Class See Also Send Feedback

Create the database.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowCreate As Boolean
C#
public bool AllowCreate { get; set; }
Visual C++
public:
property bool AllowCreate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowCreate();
function set_allowCreate(value);

See Also

XmlContainerConfig Class


AllowValidation Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.AllowValidation Property
XmlContainerConfig Class See Also Send Feedback

Whether documents are validated when loaded into the container, if they refer to a DTD or XML Schema.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowValidation As Boolean
C#
public bool AllowValidation { get; set; }
Visual C++
public:
property bool AllowValidation {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowValidation();
function set_allowValidation(value);

See Also

XmlContainerConfig Class


Checksum Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Checksum Property
XmlContainerConfig Class See Also Send Feedback

Do checksum verification of pages read into the cache from the backing filestore.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Checksum As Boolean
C#
public bool Checksum { get; set; }
Visual C++
public:
property bool Checksum {
    bool get ();
    void set (bool value);
}
JavaScript
function get_checksum();
function set_checksum(value);

See Also

XmlContainerConfig Class


CompressionName Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.CompressionName Property
XmlContainerConfig Class See Also Send Feedback

Gets or sets the name of the compression algorithm be used by the container. If the name is not the default then the name must match the name the algorithm was registered with the XmlManager using RegisterCompression(String, XmlCompression). This only effects container creation, after the container is created this value is silently ignored.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property CompressionName As String
C#
public string CompressionName { get; set; }
Visual C++
public:
property String^ CompressionName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_compressionName();
function set_compressionName(value);

See Also

XmlContainerConfig Class


ContainerType Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.ContainerType Property
XmlContainerConfig Class See Also Send Feedback

Whether documents are broken down into their component nodes, and these nodes are stored individually in the container, or stored intact with all white space and formatting is preserved.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ContainerType As XmlContainerType
C#
public XmlContainerType ContainerType { get; set; }
Visual C++
public:
property XmlContainerType ContainerType {
    XmlContainerType get ();
    void set (XmlContainerType value);
}
JavaScript
function get_containerType();
function set_containerType(value);

See Also

XmlContainerConfig Class


Encrypted Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Encrypted Property
XmlContainerConfig Class See Also Send Feedback

Encrypt the database using the cryptographic password specified to the methods.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Encrypted As Boolean
C#
public bool Encrypted { get; set; }
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
JavaScript
function get_encrypted();
function set_encrypted(value);

See Also

XmlContainerConfig Class


ExclusiveCreate Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.ExclusiveCreate Property
XmlContainerConfig Class See Also Send Feedback

Return an error if the database already exists.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ExclusiveCreate As Boolean
C#
public bool ExclusiveCreate { get; set; }
Visual C++
public:
property bool ExclusiveCreate {
    bool get ();
    void set (bool value);
}
JavaScript
function get_exclusiveCreate();
function set_exclusiveCreate(value);

Remarks

The ExclusiveCreate flag is only meaningful when specified with the allowCreate.

See Also

XmlContainerConfig Class


IndexNodes Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.IndexNodes Property
XmlContainerConfig Class See Also Send Feedback

Sets whether the index targets reference nodes or documents. The default setting is UseDefault. This value is ignored unless the container is being created or reindexed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property IndexNodes As XmlContainerConfig..::.ConfigState
C#
public XmlContainerConfig..::.ConfigState IndexNodes { get; set; }
Visual C++
public:
property XmlContainerConfig..::.ConfigState IndexNodes {
    XmlContainerConfig..::.ConfigState get ();
    void set (XmlContainerConfig..::.ConfigState value);
}
JavaScript
function get_indexNodes();
function set_indexNodes(value);

Remarks

If set to On it causes the indexer to create index targets that reference nodes rather than documents. This allows index lookups during query processing to more efficiently find target nodes and avoid walking the document tree. It can apply to both container types, and is the default for containers of type NodeContainer

If set to Off it causes the indexer to create index targets that reference documents rather than nodes. This can be more desirable for simple queries that only need to return documents and do relatively little navigation during querying. It can apply to both container types, and is the default for containers of type WholeDocContainer.

If set to UseDefault, then the container type will decide whether nodes or documents are referenced.

See Also

XmlContainerConfig Class


Multiversion Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Multiversion Property
XmlContainerConfig Class See Also Send Feedback

Configured to open all databases for multiversion concurrency control.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Multiversion As Boolean
C#
public bool Multiversion { get; set; }
Visual C++
public:
property bool Multiversion {
    bool get ();
    void set (bool value);
}
JavaScript
function get_multiversion();
function set_multiversion(value);

Remarks

Open the database with support for multiversion concurrency control. This will cause updates to the container to follow a copy-on-write protocol, which is required to support snapshot isolation. This flag requires that the container be transactionally protected during its open.

See Also

XmlContainerConfig Class


NoMMap Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.NoMMap Property
XmlContainerConfig Class See Also Send Feedback

Do not map this database into process memory (see the method for further information).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property NoMMap As Boolean
C#
public bool NoMMap { get; set; }
Visual C++
public:
property bool NoMMap {
    bool get ();
    void set (bool value);
}
JavaScript
function get_noMMap();
function set_noMMap(value);

See Also

XmlContainerConfig Class


PageSize Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.PageSize Property
XmlContainerConfig Class See Also Send Feedback

Get or sets the size in bytes of the pages used to store documents in the database. The size is specified in bytes in the range 512 bytes to 64K bytes. If no page size is specified the system will create containers with page size 8192 for node storage containers and 16384 for wholedoc storage containers. Page size affects the amount of I/O performed as well as granularity of locking as Berkeley DB performs page-level locking. These needs are often at odds with one another. The page size cannot be changed once a container has been created. This value is ignored unless the container is being created.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property PageSize As Long
C#
public long PageSize { get; set; }
Visual C++
public:
property long long PageSize {
    long long get ();
    void set (long long value);
}
JavaScript
function get_pageSize();
function set_pageSize(value);

See Also

XmlContainerConfig Class


ReadOnly Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.ReadOnly Property
XmlContainerConfig Class See Also Send Feedback

Open the database for reading only.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadOnly As Boolean
C#
public bool ReadOnly { get; set; }
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_readOnly();
function set_readOnly(value);

Remarks

Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.

See Also

XmlContainerConfig Class


ReadUncommitted Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.ReadUncommitted Property
XmlContainerConfig Class See Also Send Feedback

Configure the database to support read uncommitted.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReadUncommitted As Boolean
C#
public bool ReadUncommitted { get; set; }
Visual C++
public:
property bool ReadUncommitted {
    bool get ();
    void set (bool value);
}
JavaScript
function get_readUncommitted();
function set_readUncommitted(value);

Remarks

Read operations on the database may request the return of modified but not yet committed data.

If true, configure the database to support read uncommitted.

See Also

XmlContainerConfig Class


SequenceIncrement Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.SequenceIncrement Property
XmlContainerConfig Class See Also Send Feedback

Gets or Sets the integer increment to be used when pre-allocating document ids for new documents created by PutDocument(String, String, XmlUpdateContext).

Every document added to an XmlContainer is assigned an internal unique ID, and BDB XML performs an internal database operation to obtain these IDs. In order to increase database concurrency and improve performance of ID allocation, BDB XML pre-allocates a sequence of these numbers. The size of this sequence is determined by the value specified here. The default ID sequence size is 5.

Be aware that when a container is closed, any unused IDs in the current sequence are lost. Under some extreme cases, this can result in a container to which documents can no longer be added. For example, setting this value to a very large number (such as, say, 1 million) and then repeatedly opening and closing the container while adding a few documents may eventually cause the container to run out of IDs. Once out of IDs, the container will never again be able to accept new documents. However, document IDs are 64-bit quantities so this is extremely unlikely.

You should almost always leave this value alone. However, if you are loading a large number of documents to a container all at once, you may find a small performance benefit to setting the sequence number to a larger value. If you do this, be aware that this value is persistent across container opens, so you should take care to reset the value to its default once you are done loading the documents.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property SequenceIncrement As Long
C#
public long SequenceIncrement { get; set; }
Visual C++
public:
property long long SequenceIncrement {
    long long get ();
    void set (long long value);
}
JavaScript
function get_sequenceIncrement();
function set_sequenceIncrement(value);

See Also

XmlContainerConfig Class


Statistics Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Statistics Property
XmlContainerConfig Class See Also Send Feedback

Sets whether the structural statistics are stored in the container. These statisitics are used in query optimization. The default setting is UseDefault and the default is to use statistics. This value is ignored unless the container is being created or reindexed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Statistics As XmlContainerConfig..::.ConfigState
C#
public XmlContainerConfig..::.ConfigState Statistics { get; set; }
Visual C++
public:
property XmlContainerConfig..::.ConfigState Statistics {
    XmlContainerConfig..::.ConfigState get ();
    void set (XmlContainerConfig..::.ConfigState value);
}
JavaScript
function get_statistics();
function set_statistics(value);

Remarks

Structural statistics information is very useful for cost based query optimisation. Containers created with these statistics will take slightly longer to load and update, since the statistics must also be updated. In addition the statistics affect the concurrent behavior in the face of updates.

If the state is set to Off then the container is created without structural statistics. If the state is set to On or UseDefault the container is created with structural statistics.

See Also

XmlContainerConfig Class


Threaded Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Threaded Property
XmlContainerConfig Class See Also Send Feedback

Cause the DbEnv handle returned by [!:JanaBiz.Db.DbEnvironment.Open] to be free-threaded; that is, concurrently usable by multiple threads in the address space.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Threaded As Boolean
C#
public bool Threaded { get; set; }
Visual C++
public:
property bool Threaded {
    bool get ();
    void set (bool value);
}
JavaScript
function get_threaded();
function set_threaded(value);

See Also

XmlContainerConfig Class


Transactional Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.Transactional Property
XmlContainerConfig Class See Also Send Feedback

Initialize the transaction subsystem.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Transactional As Boolean
C#
public bool Transactional { get; set; }
Visual C++
public:
property bool Transactional {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactional();
function set_transactional(value);

Remarks

This subsystem should be used when recovery and atomicity of multiple operations are important.

See Also

XmlContainerConfig Class


TransactionNotDurable Property

[image]

.NET Framework Class Library
XmlContainerConfig..::.TransactionNotDurable Property
XmlContainerConfig Class See Also Send Feedback

If set, Berkeley DB XML will not write log records for this database. This means that updates of this database exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but if the application or system fails, integrity will not persist. The database file must be verified and/or restored from backup after a failure.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property TransactionNotDurable As Boolean
C#
public bool TransactionNotDurable { get; set; }
Visual C++
public:
property bool TransactionNotDurable {
    bool get ();
    void set (bool value);
}
JavaScript
function get_transactionNotDurable();
function set_transactionNotDurable(value);

See Also

XmlContainerConfig Class


XmlContainerConfig.ConfigState Enumeration

[image]

.NET Framework Class Library
XmlContainerConfig..::.ConfigState Enumeration
XmlContainerConfig Class See Also Send Feedback

The state of the container property.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration ConfigState
C#
public enum ConfigState
Visual C++
public enum class ConfigState
JavaScript
JanaBiz.DbXml.ConfigState = function();
JanaBiz.DbXml.ConfigState.createEnum('JanaBiz.DbXml.ConfigState', false);

Members

Member name | Description
On | The container property is turned on.
Off | The container property is turned off.
UseDefault | The container property is set to whatever the default is for the given container type.

See Also


XmlContainerType Enumeration

[image]

.NET Framework Class Library
XmlContainerType Enumeration
See Also Send Feedback

Enumeration representing the storage model for a XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlContainerType
C#
public enum XmlContainerType
Visual C++
public enum class XmlContainerType
JavaScript
JanaBiz.DbXml.XmlContainerType = function();
JanaBiz.DbXml.XmlContainerType.createEnum('JanaBiz.DbXml.XmlContainerType', false);

Members

Member name | Description
WholeDocContainer | Documents are stored intact; all white space and formatting is preserved.
NodeContainer | Documents are broken down into their component nodes, and these nodes are stored individually in the container.

See Also


XmlData Class

[image]

.NET Framework Class Library
XmlData Class
Members See Also Send Feedback

The XmlData.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlData _
    Inherits InvocationHandle
C#
public class XmlData : InvocationHandle
Visual C++
public ref class XmlData : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlData = function();

Type.createClass(
    'JanaBiz.DbXml.XmlData',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlData

See Also

XmlData Members


XmlData Members

[image] [image]

.NET Framework Class Library
XmlData Members
XmlData Class Constructors Methods Properties See Also Send Feedback

The XmlData type exposes the following members.

Constructors

Name | Description
XmlData | Overloaded.

Methods

Name | Description
AdoptBuffer | Takes ownership of the buffer in src, leaving src with an empty buffer.
Append | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Reserve | Ensures that the underlying buffer has at least size bytes, starting at offset 0. Existing data is not affected. If buffer expansion is needed and the object is a wrapper an exception is thrown.
Set | Overloaded.
ToString | (Inherited from Object.)

Properties

Name | Description
Data | Returns a copy of the data in the underlying buffer.
ReservedSize | Returns the size of the underlying buffer. This is at least the size of the actual data stored.
Size | Gets or sets the size of the data in the buffer in bytes. An exception will be thrown if the size is larger than the buffer.

See Also

XmlData Class


XmlData Constructor

[image] [image]

.NET Framework Class Library
XmlData Constructor
XmlData Class See Also Send Feedback

Overload List

Name | Description
XmlData()()() | Initializes a new instance of the XmlData class.
XmlData(array<Byte>[]()[]) | Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.
XmlData(array<Byte>[]()[], Int32) | Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

See Also

XmlData Class
XmlData Members


XmlData Constructor

[image]

.NET Framework Class Library
XmlData Constructor
XmlData Class See Also Send Feedback

Initializes a new instance of the XmlData class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlData()
Visual C++
public:
XmlData()
JavaScript
JanaBiz.DbXml.XmlData = function();

See Also

XmlData Class
XmlData Overload


XmlData Constructor (Byte[])

[image]

.NET Framework Class Library
XmlData Constructor (array<Byte>[]()[])
XmlData Class See Also Send Feedback

Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    data As Byte() _
)
C#
public XmlData(
    byte[] data
)
Visual C++
public:
XmlData(
    array<unsigned char>^ data
)
JavaScript
JanaBiz.DbXml.XmlData = function(data);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.

See Also

XmlData Class
XmlData Overload


XmlData Constructor (Byte[], Int32)

[image]

.NET Framework Class Library
XmlData Constructor (array<Byte>[]()[], Int32)
XmlData Class See Also Send Feedback

Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    data As Byte(), _
    size As Integer _
)
C#
public XmlData(
    byte[] data,
    int size
)
Visual C++
public:
XmlData(
    array<unsigned char>^ data,
    int size
)
JavaScript
JanaBiz.DbXml.XmlData = function(data, size);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.
size
Type: System..::.Int32
The number of bytes to copy.

See Also

XmlData Class
XmlData Overload


XmlData Methods

[image] [image]

.NET Framework Class Library
XmlData Methods
XmlData Class See Also Send Feedback

The XmlData type exposes the following members.

Methods

Name | Description
AdoptBuffer | Takes ownership of the buffer in src, leaving src with an empty buffer.
Append | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Reserve | Ensures that the underlying buffer has at least size bytes, starting at offset 0. Existing data is not affected. If buffer expansion is needed and the object is a wrapper an exception is thrown.
Set | Overloaded.
ToString | (Inherited from Object.)

See Also

XmlData Class


AdoptBuffer Method

[image]

.NET Framework Class Library
XmlData..::.AdoptBuffer Method
XmlData Class See Also Send Feedback

Takes ownership of the buffer in src, leaving src with an empty buffer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AdoptBuffer ( _
    src As XmlData _
)
C#
public void AdoptBuffer(
    XmlData src
)
Visual C++
public:
void AdoptBuffer(
    XmlData^ src
)
JavaScript
function adoptBuffer(src);

Parameters

src
Type: JanaBiz.DbXml..::.XmlData
The XmlData object from which to take the buffer.

See Also

XmlData Class


Append Method

[image] [image]

.NET Framework Class Library
XmlData..::.Append Method
XmlData Class See Also Send Feedback

Overload List

Name | Description
Append(array<Byte>[]()[]) | Copies size bytes from data to the end of the existing data in the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.
Append(array<Byte>[]()[], Int32) | Copies size bytes from data to the end of the existing data in the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

See Also

XmlData Class
XmlData Members


Append Method (Byte[])

[image]

.NET Framework Class Library
XmlData..::.Append Method (array<Byte>[]()[])
XmlData Class See Also Send Feedback

Copies size bytes from data to the end of the existing data in the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Append ( _
    data As Byte() _
)
C#
public void Append(
    byte[] data
)
Visual C++
public:
void Append(
    array<unsigned char>^ data
)
JavaScript
function append(data);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.

See Also

XmlData Class
Append Overload


Append Method (Byte[], Int32)

[image]

.NET Framework Class Library
XmlData..::.Append Method (array<Byte>[]()[], Int32)
XmlData Class See Also Send Feedback

Copies size bytes from data to the end of the existing data in the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Append ( _
    data As Byte(), _
    size As Integer _
)
C#
public void Append(
    byte[] data,
    int size
)
Visual C++
public:
void Append(
    array<unsigned char>^ data,
    int size
)
JavaScript
function append(data, size);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.
size
Type: System..::.Int32
The number of bytes to copy.

See Also

XmlData Class
Append Overload


Dispose Method

[image] [image]

.NET Framework Class Library
XmlData..::.Dispose Method
XmlData Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlData Class
XmlData Members


Reserve Method

[image]

.NET Framework Class Library
XmlData..::.Reserve Method
XmlData Class See Also Send Feedback

Ensures that the underlying buffer has at least size bytes, starting at offset 0. Existing data is not affected. If buffer expansion is needed and the object is a wrapper an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reserve ( _
    size As Integer _
)
C#
public void Reserve(
    int size
)
Visual C++
public:
void Reserve(
    int size
)
JavaScript
function reserve(size);

Parameters

size
Type: System..::.Int32
The number of bytes to reserve.

See Also

XmlData Class


Set Method

[image] [image]

.NET Framework Class Library
XmlData..::.Set Method
XmlData Class See Also Send Feedback

Overload List

Name | Description
Set(array<Byte>[]()[]) | Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.
Set(array<Byte>[]()[], Int32) | Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

See Also

XmlData Class
XmlData Members


Set Method (Byte[])

[image]

.NET Framework Class Library
XmlData..::.Set Method (array<Byte>[]()[])
XmlData Class See Also Send Feedback

Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Set ( _
    data As Byte() _
)
C#
public void Set(
    byte[] data
)
Visual C++
public:
void Set(
    array<unsigned char>^ data
)
JavaScript
function set(data);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.

See Also

XmlData Class
Set Overload


Set Method (Byte[], Int32)

[image]

.NET Framework Class Library
XmlData..::.Set Method (array<Byte>[]()[], Int32)
XmlData Class See Also Send Feedback

Copies size bytes from data to the start of the underlying buffer, which will expand to fit the data if it is not a wrapper, otherwise an exception will be thrown. This method will change the size of the data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Set ( _
    data As Byte(), _
    size As Integer _
)
C#
public void Set(
    byte[] data,
    int size
)
Visual C++
public:
void Set(
    array<unsigned char>^ data,
    int size
)
JavaScript
function set(data, size);

Parameters

data
Type: array< System..::.Byte >[]()[]
The data to be copied into the underlying buffer.
size
Type: System..::.Int32
The number of bytes to copy.

See Also

XmlData Class
Set Overload


XmlData Properties

[image] [image]

.NET Framework Class Library
XmlData Properties
XmlData Class See Also Send Feedback

The XmlData type exposes the following members.

Properties

Name | Description
Data | Returns a copy of the data in the underlying buffer.
ReservedSize | Returns the size of the underlying buffer. This is at least the size of the actual data stored.
Size | Gets or sets the size of the data in the buffer in bytes. An exception will be thrown if the size is larger than the buffer.

See Also

XmlData Class


Data Property

[image]

.NET Framework Class Library
XmlData..::.Data Property
XmlData Class See Also Send Feedback

Returns a copy of the data in the underlying buffer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
C#
public byte[] Data { get; }
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
}
JavaScript
function get_data();

See Also

XmlData Class


ReservedSize Property

[image]

.NET Framework Class Library
XmlData..::.ReservedSize Property
XmlData Class See Also Send Feedback

Returns the size of the underlying buffer. This is at least the size of the actual data stored.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReservedSize As Integer
C#
public int ReservedSize { get; }
Visual C++
public:
property int ReservedSize {
    int get ();
}
JavaScript
function get_reservedSize();

See Also

XmlData Class


Size Property

[image]

.NET Framework Class Library
XmlData..::.Size Property
XmlData Class See Also Send Feedback

Gets or sets the size of the data in the buffer in bytes. An exception will be thrown if the size is larger than the buffer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Size As Integer
C#
public int Size { get; set; }
Visual C++
public:
property int Size {
    int get ();
    void set (int value);
}
JavaScript
function get_size();
function set_size(value);

See Also

XmlData Class


XmlDebugListener Class

[image]

.NET Framework Class Library
XmlDebugListener Class
Members See Also Send Feedback

The XmlDebugListener class allows the user to track the progress of a query as it executes.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlDebugListener _
    Inherits InvocationHandle
C#
public class XmlDebugListener : InvocationHandle
Visual C++
public ref class XmlDebugListener : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlDebugListener = function();

Type.createClass(
    'JanaBiz.DbXml.XmlDebugListener',
    JanaBiz.Bridge.InvocationHandle);

Remarks

The XmlStackFrame argument to the methods of this class gives access to the point in the query plan corresponding to the current execution state, as well as the execution stack trace and parts of the dynamic context for that stack frame.

During evaluation of a query, BDB XML will evaluate the sub-expressions of the query. The Start(XmlStackFrame) method is called when evaluation of a sub-expression starts and the End(XmlStackFrame) method is called when it ends.

This can occur more than once for the same sub-expression if the expression is in a loop or in a function that is called more than once. When evaluating a sub-expression BDB XML calls into that sub-expression a number of times to retrieve parts of its result.

For eager evaluation, this will happen only once, but for lazy evalution this will happen once per item in the result. The Enter(XmlStackFrame) method is called when BDB XML requests results from a sub-expression and the Exit(XmlStackFrame) method is called when the results requested have been calculated.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlDebugListener

See Also

XmlDebugListener Members


XmlDebugListener Members

[image] [image]

.NET Framework Class Library
XmlDebugListener Members
XmlDebugListener Class Constructors Methods See Also Send Feedback

The XmlDebugListener type exposes the following members.

Constructors

Name | Description
XmlDebugListener | Initializes a new instance of the XmlDebugListener class.

Methods

Name | Description
Dispose | Overloaded.
End | This method is called when BDB XML ends evaluation of a sub-expression.
Enter | This method is called when BDB XML requests results from a sub-expression.
Equals | (Inherited from Object.)
Error | This method is called if an error occurs during query evaluation. It is normal to throw the DbXmlException argument at the end of an implementation of the method.
Exit | This method is called when a sub-expression has finished calculating the results requested.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Start | This method is called when BDB XML starts evaluation of a sub-expression.
ToString | (Inherited from Object.)

See Also

XmlDebugListener Class


XmlDebugListener Constructor

[image]

.NET Framework Class Library
XmlDebugListener Constructor
XmlDebugListener Class See Also Send Feedback

Initializes a new instance of the XmlDebugListener class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlDebugListener()
Visual C++
public:
XmlDebugListener()
JavaScript
JanaBiz.DbXml.XmlDebugListener = function();

See Also

XmlDebugListener Class


XmlDebugListener Methods

[image] [image]

.NET Framework Class Library
XmlDebugListener Methods
XmlDebugListener Class See Also Send Feedback

The XmlDebugListener type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
End | This method is called when BDB XML ends evaluation of a sub-expression.
Enter | This method is called when BDB XML requests results from a sub-expression.
Equals | (Inherited from Object.)
Error | This method is called if an error occurs during query evaluation. It is normal to throw the DbXmlException argument at the end of an implementation of the method.
Exit | This method is called when a sub-expression has finished calculating the results requested.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Start | This method is called when BDB XML starts evaluation of a sub-expression.
ToString | (Inherited from Object.)

See Also

XmlDebugListener Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlDebugListener..::.Dispose Method
XmlDebugListener Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlDebugListener Class
XmlDebugListener Members


End Method

[image]

.NET Framework Class Library
XmlDebugListener..::.End Method
XmlDebugListener Class See Also Send Feedback

This method is called when BDB XML ends evaluation of a sub-expression.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub End ( _
    stack As XmlStackFrame _
)
C#
public virtual void End(
    XmlStackFrame stack
)
Visual C++
public:
virtual void End(
    XmlStackFrame^ stack
)
JavaScript
function end(stack);

Parameters

stack
Type: JanaBiz.DbXml..::.XmlStackFrame
The XmlStackFrame for the current execution context.

See Also

XmlDebugListener Class


Enter Method

[image]

.NET Framework Class Library
XmlDebugListener..::.Enter Method
XmlDebugListener Class See Also Send Feedback

This method is called when BDB XML requests results from a sub-expression.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Enter ( _
    stack As XmlStackFrame _
)
C#
public virtual void Enter(
    XmlStackFrame stack
)
Visual C++
public:
virtual void Enter(
    XmlStackFrame^ stack
)
JavaScript
function enter(stack);

Parameters

stack
Type: JanaBiz.DbXml..::.XmlStackFrame
The XmlStackFrame for the current execution context.

See Also

XmlDebugListener Class


Error Method

[image]

.NET Framework Class Library
XmlDebugListener..::.Error Method
XmlDebugListener Class See Also Send Feedback

This method is called if an error occurs during query evaluation. It is normal to throw the DbXmlException argument at the end of an implementation of the method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Error ( _
    error As DbXmlException, _
    stack As XmlStackFrame _
)
C#
public virtual void Error(
    DbXmlException error,
    XmlStackFrame stack
)
Visual C++
public:
virtual void Error(
    DbXmlException^ error,
    XmlStackFrame^ stack
)
JavaScript
function error(error, stack);

Parameters

error
Type: JanaBiz.DbXml.Exceptions..::.DbXmlException
The DbXmlException representing the error.
stack
Type: JanaBiz.DbXml..::.XmlStackFrame
The XmlStackFrame for the current execution context.

See Also

XmlDebugListener Class


Exit Method

[image]

.NET Framework Class Library
XmlDebugListener..::.Exit Method
XmlDebugListener Class See Also Send Feedback

This method is called when a sub-expression has finished calculating the results requested.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Exit ( _
    stack As XmlStackFrame _
)
C#
public virtual void Exit(
    XmlStackFrame stack
)
Visual C++
public:
virtual void Exit(
    XmlStackFrame^ stack
)
JavaScript
function exit(stack);

Parameters

stack
Type: JanaBiz.DbXml..::.XmlStackFrame
The XmlStackFrame for the current execution context.

See Also

XmlDebugListener Class


Start Method

[image]

.NET Framework Class Library
XmlDebugListener..::.Start Method
XmlDebugListener Class See Also Send Feedback

This method is called when BDB XML starts evaluation of a sub-expression.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Sub Start ( _
    stack As XmlStackFrame _
)
C#
public virtual void Start(
    XmlStackFrame stack
)
Visual C++
public:
virtual void Start(
    XmlStackFrame^ stack
)
JavaScript
function start(stack);

Parameters

stack
Type: JanaBiz.DbXml..::.XmlStackFrame
The XmlStackFrame for the current execution context.

See Also

XmlDebugListener Class


XmlDocument Class

[image]

.NET Framework Class Library
XmlDocument Class
Members See Also Send Feedback

The unit of storage within an XmlContainer. A document consists of content, a name, and a set of metadata attributes.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlDocument _
    Inherits XmlNode
C#
public class XmlDocument : XmlNode
Visual C++
public ref class XmlDocument : public XmlNode
JavaScript
JanaBiz.DbXml.XmlDocument = function();

Type.createClass(
    'JanaBiz.DbXml.XmlDocument',
    JanaBiz.DbXml.XmlNode);

Remarks

The document content is a byte stream. It must be well formed XML, but need not be valid.

The document name is a unique identifier for the document. The name is specified when the document is first placed in the container. It can either be explicitly specified by the user, or it can be auto-generated by Berkeley DB XML. See PutDocument(String, String, XmlUpdateContext) for details.

The user can retrieve the document by name using GetDocument(String). In addition, the document name can be referenced in an XQuery expression using the doc() navigation function. For example, suppose your document's name is 'doc1.xml' and the container that it exists in is 'container1.bdbxml'. In this case, you can explicitly request the document by it's name using:

Copy Code
doc('dbxml:/container1.bdbxml/doc1.xml')

The user can create an empty XmlDocument object using CreateDocument()()(). This object can then be assigned a name, content, and metadata.

The metadata attributes provide a means of associating information with a document, without having to store it within the document itself. Example metadata attributes might be: document owner, creation time, receipt time, originating source, final destination, and next processing phase. They are analogous to the attributes of a file in a file system. Each metadata attribute consists of a name-value pair. The document's name is an implicit metadata attribute.

You can access the metadata for a given document by using either GetMetaData(String, String) or by iterating over the document's metadata. Use MetaDataIterator to retrieve an XmlMetaDataIterator object.

You can instantiate an empty XmlDocument object using CreateDocument()()().

A copy constructor is provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlNode
JanaBiz.DbXml..::.XmlDocument

See Also

XmlDocument Members


XmlDocument Members

[image] [image]

.NET Framework Class Library
XmlDocument Members
XmlDocument Class Methods Properties See Also Send Feedback

The XmlDocument type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
EncodingStringContent | Overloaded.
Equals | Overloaded.
FetchAllData | This method causes all document data and metadata to be retrieved.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetContentAsEventWriter | Retrieve content into an XmlEventWriter.
GetHashCode | (Inherited from Object.)
GetMetaData | Returns the value of the specified metadata.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
RemoveMetaData | Removes the identified metadata from the document.
SetMetaData | Sets the value of the specified document metadata.Support many times.
ToString | 現在の Object を表す String を返します。 (Overrides XmlNode..::.ToString()()().)

Properties

Name | Description
Attributes | Returns returns a XmlResults that contains all of the attributes appearing on this node. (Overrides XmlNode..::.Attributes.)
ContentAsEventReader | Returns the document's content as an XmlEventReader and Sets the document's content to the provided content.
DocumentElement | The document element of this document node, as defined by the W3C DOM specification.
FirstChild | Returns a XmlNode that current node's first child node. (Overrides XmlNode..::.FirstChild.)
LastChild | Returns a XmlNode that current node's last child node. (Overrides XmlNode..::.LastChild.)
LocalName | Returns the node's local name. (Overrides XmlNode..::.LocalName.)
MetaDataIterator | Returns an XmlMetaDataIterator.
Name | The name of the document.
NamespaceUri | Returns the URI used for the node's namespace. (Overrides XmlNode..::.NamespaceUri.)
NextSibling | Returns a XmlNode that the sibling node immediately following this node in the document. (Overrides XmlNode..::.NextSibling.)
NodeHandle | Returns a String handle that can be used to directly reference nodes within a document by using GetNode(String) (Inherited from XmlNode.)
NodeName | Returns the name of the node contained in this XmlValue. (Overrides XmlNode..::.NodeName.)
NodeType | Returns the short value for this node's XercesC GetNodeType. (Overrides XmlNode..::.NodeType.)
NodeValue | Returns the node's value. (Overrides XmlNode..::.NodeValue.)
OwnerDocument | The owner document of this node, as defined by the W3C DOM specification. (Overrides XmlNode..::.OwnerDocument.)
OwnerElement | The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node. (Overrides XmlNode..::.OwnerElement.)
ParentNode | Returns a XmlNode that current node's parent. (Overrides XmlNode..::.ParentNode.)
Prefix | Returns the prefix set for the node's namespace. (Overrides XmlNode..::.Prefix.)
PreviousSibling | Returns the sibling node immediately preceding this node in the document. (Overrides XmlNode..::.PreviousSibling.)
RawContent | The document's content as an XmlData.
StreamContent | The document's content as an XmlInputStream.
StringContent | The document's content as an string.

See Also

XmlDocument Class


XmlDocument Methods

[image] [image]

.NET Framework Class Library
XmlDocument Methods
XmlDocument Class See Also Send Feedback

The XmlDocument type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
EncodingStringContent | Overloaded.
Equals | Overloaded.
FetchAllData | This method causes all document data and metadata to be retrieved.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetContentAsEventWriter | Retrieve content into an XmlEventWriter.
GetHashCode | (Inherited from Object.)
GetMetaData | Returns the value of the specified metadata.
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
RemoveMetaData | Removes the identified metadata from the document.
SetMetaData | Sets the value of the specified document metadata.Support many times.
ToString | 現在の Object を表す String を返します。 (Overrides XmlNode..::.ToString()()().)

See Also

XmlDocument Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlDocument..::.Dispose Method
XmlDocument Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlDocument Class
XmlDocument Members


EncodingStringContent Method

[image] [image]

.NET Framework Class Library
XmlDocument..::.EncodingStringContent Method
XmlDocument Class See Also Send Feedback

Overload List

Name | Description
EncodingStringContent(String) | Encoding the content of string
EncodingStringContent(Encoding) | Encodings the content of the string.

See Also

XmlDocument Class
XmlDocument Members


EncodingStringContent Method (String)

[image]

.NET Framework Class Library
XmlDocument..::.EncodingStringContent Method (String)
XmlDocument Class See Also Send Feedback

Encoding the content of string

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function EncodingStringContent ( _
    encoding As String _
) As String
C#
public string EncodingStringContent(
    string encoding
)
Visual C++
public:
String^ EncodingStringContent(
    String^ encoding
)
JavaScript
function encodingStringContent(encoding);

Parameters

encoding
Type: System..::.String
The encoding.

Return Value

The content of the string.

See Also

XmlDocument Class
EncodingStringContent Overload


EncodingStringContent Method (Encoding)

[image]

.NET Framework Class Library
XmlDocument..::.EncodingStringContent Method (Encoding)
XmlDocument Class See Also Send Feedback

Encodings the content of the string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function EncodingStringContent ( _
    encoding As Encoding _
) As String
C#
public string EncodingStringContent(
    Encoding encoding
)
Visual C++
public:
String^ EncodingStringContent(
    Encoding^ encoding
)
JavaScript
function encodingStringContent(encoding);

Parameters

encoding
Type: System.Text..::.Encoding
The encoding.

Return Value

The content of the string.

See Also

XmlDocument Class
EncodingStringContent Overload


Equals Method

[image] [image]

.NET Framework Class Library
XmlDocument..::.Equals Method
XmlDocument Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Inherited from Object.)
Equals(XmlDocument) | Indicates whether some other XmlDocument object is "equal to" this one.

See Also

XmlDocument Class
XmlDocument Members


Equals Method (XmlDocument)

[image]

.NET Framework Class Library
XmlDocument..::.Equals Method (XmlDocument)
XmlDocument Class See Also Send Feedback

Indicates whether some other XmlDocument object is "equal to" this one.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    other As XmlDocument _
) As Boolean
C#
public bool Equals(
    XmlDocument other
)
Visual C++
public:
bool Equals(
    XmlDocument^ other
)
JavaScript
function equals(other);

Parameters

other
Type: JanaBiz.DbXml..::.XmlDocument
The reference XmlDocument object with which to compare.

Return Value

trueTruetruetrue (True in Visual Basic) if this object is the same as the obj argument; falseFalsefalsefalse (False in Visual Basic) otherwise.

See Also

XmlDocument Class
Equals Overload


FetchAllData Method

[image]

.NET Framework Class Library
XmlDocument..::.FetchAllData Method
XmlDocument Class See Also Send Feedback

This method causes all document data and metadata to be retrieved.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub FetchAllData
C#
public void FetchAllData()
Visual C++
public:
void FetchAllData()
JavaScript
function fetchAllData();

Remarks

Otherwise, if a document was retrieved lazily, then document content and metadata is only retrieved from the container on an as-needed basis.

Note that documents in node storage containers are implicitly lazy.

Note that if the document was not retrieved lazily, then use of this method has no significant performance impact.

However, if the document was retrieved lazily, then repeatedly calling this method on any given document may hurt your application's performance.

This is because each time this method is called, Berkeley DB XML must walk the entire document tree in order to ensure that it has retrieved the entire document.

See Also

XmlDocument Class


GetContentAsEventWriter Method

[image]

.NET Framework Class Library
XmlDocument..::.GetContentAsEventWriter Method
XmlDocument Class See Also Send Feedback

Retrieve content into an XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub GetContentAsEventWriter ( _
    writer As XmlEventWriter _
)
C#
public void GetContentAsEventWriter(
    XmlEventWriter writer
)
Visual C++
public:
void GetContentAsEventWriter(
    XmlEventWriter^ writer
)
JavaScript
function getContentAsEventWriter(writer);

Parameters

writer
Type: JanaBiz.DbXml..::.XmlEventWriter
The event writer to which the content events are written.

See Also

XmlDocument Class


GetMetaData Method

[image]

.NET Framework Class Library
XmlDocument..::.GetMetaData Method
XmlDocument Class See Also Send Feedback

Returns the value of the specified metadata.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetMetaData ( _
    uri As String, _
    name As String _
) As XmlMetaData
C#
public XmlMetaData GetMetaData(
    string uri,
    string name
)
Visual C++
public:
XmlMetaData^ GetMetaData(
    String^ uri,
    String^ name
)
JavaScript
function getMetaData(uri, name);

Parameters

uri
Type: System..::.String
The namespace within which the name resides.
name
Type: System..::.String
The name of the metadata.

Return Value

The MetaData with the given namespace URI and name, or a nullNothingnullptra null reference (Nothing in Visual Basic) reference.

Remarks

This method returns trueTruetruetrue (True in Visual Basic) if metadata is found for the XmlDocument that matches the given URI and name, and can be represented as an XmlValue; otherwise, it returns falseFalsefalsefalse (False in Visual Basic).

See Also

XmlDocument Class


RemoveMetaData Method

[image]

.NET Framework Class Library
XmlDocument..::.RemoveMetaData Method
XmlDocument Class See Also Send Feedback

Removes the identified metadata from the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveMetaData ( _
    uri As String, _
    name As String _
)
C#
public void RemoveMetaData(
    string uri,
    string name
)
Visual C++
public:
void RemoveMetaData(
    String^ uri,
    String^ name
)
JavaScript
function removeMetaData(uri, name);

Parameters

uri
Type: System..::.String
The namespace within which the name resides.
name
Type: System..::.String
The name of the metadata.

See Also

XmlDocument Class


SetMetaData Method

[image]

.NET Framework Class Library
XmlDocument..::.SetMetaData Method
XmlDocument Class See Also Send Feedback

Sets the value of the specified document metadata.Support many times.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetMetaData ( _
    metaData As XmlMetaData _
)
C#
public void SetMetaData(
    XmlMetaData metaData
)
Visual C++
public:
void SetMetaData(
    XmlMetaData^ metaData
)
JavaScript
function setMetaData(metaData);

Parameters

metaData
Type: JanaBiz.DbXml..::.XmlMetaData
The object to set.

Remarks

Document metadata comprises a name-value pair, which is stored with the document, but not as part of the document content.

A metadata name consists of a namespace URI and a name. The namespace URI is optional but it should be used to avoid naming collisions.

Document metadata can be queried using a query expression that uses the special XmlMetaData function within a predicate.

See Also

XmlDocument Class
JanaBiz.DbXml..::.XmlMetaData


ToString Method

[image]

.NET Framework Class Library
XmlDocument..::.ToString Method
XmlDocument Class See Also Send Feedback

現在の Object を表す String を返します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

現在の Object を表す String。

See Also

XmlDocument Class


XmlDocument Properties

[image] [image]

.NET Framework Class Library
XmlDocument Properties
XmlDocument Class See Also Send Feedback

The XmlDocument type exposes the following members.

Properties

Name | Description
Attributes | Returns returns a XmlResults that contains all of the attributes appearing on this node. (Overrides XmlNode..::.Attributes.)
ContentAsEventReader | Returns the document's content as an XmlEventReader and Sets the document's content to the provided content.
DocumentElement | The document element of this document node, as defined by the W3C DOM specification.
FirstChild | Returns a XmlNode that current node's first child node. (Overrides XmlNode..::.FirstChild.)
LastChild | Returns a XmlNode that current node's last child node. (Overrides XmlNode..::.LastChild.)
LocalName | Returns the node's local name. (Overrides XmlNode..::.LocalName.)
MetaDataIterator | Returns an XmlMetaDataIterator.
Name | The name of the document.
NamespaceUri | Returns the URI used for the node's namespace. (Overrides XmlNode..::.NamespaceUri.)
NextSibling | Returns a XmlNode that the sibling node immediately following this node in the document. (Overrides XmlNode..::.NextSibling.)
NodeHandle | Returns a String handle that can be used to directly reference nodes within a document by using GetNode(String) (Inherited from XmlNode.)
NodeName | Returns the name of the node contained in this XmlValue. (Overrides XmlNode..::.NodeName.)
NodeType | Returns the short value for this node's XercesC GetNodeType. (Overrides XmlNode..::.NodeType.)
NodeValue | Returns the node's value. (Overrides XmlNode..::.NodeValue.)
OwnerDocument | The owner document of this node, as defined by the W3C DOM specification. (Overrides XmlNode..::.OwnerDocument.)
OwnerElement | The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node. (Overrides XmlNode..::.OwnerElement.)
ParentNode | Returns a XmlNode that current node's parent. (Overrides XmlNode..::.ParentNode.)
Prefix | Returns the prefix set for the node's namespace. (Overrides XmlNode..::.Prefix.)
PreviousSibling | Returns the sibling node immediately preceding this node in the document. (Overrides XmlNode..::.PreviousSibling.)
RawContent | The document's content as an XmlData.
StreamContent | The document's content as an XmlInputStream.
StringContent | The document's content as an string.

See Also

XmlDocument Class


Attributes Property

[image]

.NET Framework Class Library
XmlDocument..::.Attributes Property
XmlDocument Class See Also Send Feedback

Returns returns a XmlResults that contains all of the attributes appearing on this node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Attributes As XmlResults
C#
public override XmlResults Attributes { get; }
Visual C++
public:
virtual property XmlResults^ Attributes {
    XmlResults^ get () override;
}
JavaScript
function get_attributes();

See Also

XmlDocument Class


ContentAsEventReader Property

[image]

.NET Framework Class Library
XmlDocument..::.ContentAsEventReader Property
XmlDocument Class See Also Send Feedback

Returns the document's content as an XmlEventReader and Sets the document's content to the provided content.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ContentAsEventReader As XmlEventReader
C#
public XmlEventReader ContentAsEventReader { get; set; }
Visual C++
public:
property XmlEventReader^ ContentAsEventReader {
    XmlEventReader^ get ();
    void set (XmlEventReader^ value);
}
JavaScript
function get_contentAsEventReader();
function set_contentAsEventReader(value);

Return Value

See Also

XmlDocument Class


DocumentElement Property

[image]

.NET Framework Class Library
XmlDocument..::.DocumentElement Property
XmlDocument Class See Also Send Feedback

The document element of this document node, as defined by the W3C DOM specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DocumentElement As XmlNode
C#
public XmlNode DocumentElement { get; }
Visual C++
public:
property XmlNode^ DocumentElement {
    XmlNode^ get ();
}
JavaScript
function get_documentElement();

Field Value

The document element of this document node.

See Also

XmlDocument Class


FirstChild Property

[image]

.NET Framework Class Library
XmlDocument..::.FirstChild Property
XmlDocument Class See Also Send Feedback

Returns a XmlNode that current node's first child node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property FirstChild As XmlNode
C#
public override XmlNode FirstChild { get; }
Visual C++
public:
virtual property XmlNode^ FirstChild {
    XmlNode^ get () override;
}
JavaScript
function get_firstChild();

See Also

XmlDocument Class


LastChild Property

[image]

.NET Framework Class Library
XmlDocument..::.LastChild Property
XmlDocument Class See Also Send Feedback

Returns a XmlNode that current node's last child node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property LastChild As XmlNode
C#
public override XmlNode LastChild { get; }
Visual C++
public:
virtual property XmlNode^ LastChild {
    XmlNode^ get () override;
}
JavaScript
function get_lastChild();

Return Value

See Also

XmlDocument Class


LocalName Property

[image]

.NET Framework Class Library
XmlDocument..::.LocalName Property
XmlDocument Class See Also Send Feedback

Returns the node's local name.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property LocalName As String
C#
public override string LocalName { get; }
Visual C++
public:
virtual property String^ LocalName {
    String^ get () override;
}
JavaScript
function get_localName();

Remarks

For example, if a node has the namespace prefix, "prefix," and its qualified name is prefix:name, then 'name' is the local name.

See Also

XmlDocument Class


MetaDataIterator Property

[image]

.NET Framework Class Library
XmlDocument..::.MetaDataIterator Property
XmlDocument Class See Also Send Feedback

Returns an XmlMetaDataIterator.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MetaDataIterator As XmlMetaDataIterator
C#
public XmlMetaDataIterator MetaDataIterator { get; }
Visual C++
public:
property XmlMetaDataIterator^ MetaDataIterator {
    XmlMetaDataIterator^ get ();
}
JavaScript
function get_metaDataIterator();

Field Value

an XmlMetaDataIterator.

Remarks

Using this iterator, you can examine the individual metadata items set for the document by looping over them using the method.

See Also

XmlDocument Class


Name Property

[image]

.NET Framework Class Library
XmlDocument..::.Name Property
XmlDocument Class See Also Send Feedback

The name of the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name { get; set; }
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_name();
function set_name(value);

Field Value

The name of the document.

See Also

XmlDocument Class


NamespaceUri Property

[image]

.NET Framework Class Library
XmlDocument..::.NamespaceUri Property
XmlDocument Class See Also Send Feedback

Returns the URI used for the node's namespace.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NamespaceUri As String
C#
public override string NamespaceUri { get; }
Visual C++
public:
virtual property String^ NamespaceUri {
    String^ get () override;
}
JavaScript
function get_namespaceUri();

See Also

XmlDocument Class


NextSibling Property

[image]

.NET Framework Class Library
XmlDocument..::.NextSibling Property
XmlDocument Class See Also Send Feedback

Returns a XmlNode that the sibling node immediately following this node in the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NextSibling As XmlNode
C#
public override XmlNode NextSibling { get; }
Visual C++
public:
virtual property XmlNode^ NextSibling {
    XmlNode^ get () override;
}
JavaScript
function get_nextSibling();

Remarks

If the current node had no siblings following it in the document, a null node is returned.

See Also

XmlDocument Class


NodeName Property

[image]

.NET Framework Class Library
XmlDocument..::.NodeName Property
XmlDocument Class See Also Send Feedback

Returns the name of the node contained in this XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NodeName As String
C#
public override string NodeName { get; }
Visual C++
public:
virtual property String^ NodeName {
    String^ get () override;
}
JavaScript
function get_nodeName();

See Also

XmlDocument Class


NodeType Property

[image]

.NET Framework Class Library
XmlDocument..::.NodeType Property
XmlDocument Class See Also Send Feedback

Returns the short value for this node's XercesC GetNodeType.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NodeType As XmlNodeType
C#
public override XmlNodeType NodeType { get; }
Visual C++
public:
virtual property XmlNodeType NodeType {
    XmlNodeType get () override;
}
JavaScript
function get_nodeType();

See Also

XmlDocument Class


NodeValue Property

[image]

.NET Framework Class Library
XmlDocument..::.NodeValue Property
XmlDocument Class See Also Send Feedback

Returns the node's value.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property NodeValue As String
C#
public override string NodeValue { get; }
Visual C++
public:
virtual property String^ NodeValue {
    String^ get () override;
}
JavaScript
function get_nodeValue();

See Also

XmlDocument Class


OwnerDocument Property

[image]

.NET Framework Class Library
XmlDocument..::.OwnerDocument Property
XmlDocument Class See Also Send Feedback

The owner document of this node, as defined by the W3C DOM specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property OwnerDocument As XmlDocument
C#
public override XmlDocument OwnerDocument { get; }
Visual C++
public:
virtual property XmlDocument^ OwnerDocument {
    XmlDocument^ get () override;
}
JavaScript
function get_ownerDocument();

See Also

XmlDocument Class


OwnerElement Property

[image]

.NET Framework Class Library
XmlDocument..::.OwnerElement Property
XmlDocument Class See Also Send Feedback

The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property OwnerElement As XmlNode
C#
public override XmlNode OwnerElement { get; }
Visual C++
public:
virtual property XmlNode^ OwnerElement {
    XmlNode^ get () override;
}
JavaScript
function get_ownerElement();

See Also

XmlDocument Class


ParentNode Property

[image]

.NET Framework Class Library
XmlDocument..::.ParentNode Property
XmlDocument Class See Also Send Feedback

Returns a XmlNode that current node's parent.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property ParentNode As XmlNode
C#
public override XmlNode ParentNode { get; }
Visual C++
public:
virtual property XmlNode^ ParentNode {
    XmlNode^ get () override;
}
JavaScript
function get_parentNode();

See Also

XmlDocument Class


Prefix Property

[image]

.NET Framework Class Library
XmlDocument..::.Prefix Property
XmlDocument Class See Also Send Feedback

Returns the prefix set for the node's namespace.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Prefix As String
C#
public override string Prefix { get; }
Visual C++
public:
virtual property String^ Prefix {
    String^ get () override;
}
JavaScript
function get_prefix();

See Also

XmlDocument Class


PreviousSibling Property

[image]

.NET Framework Class Library
XmlDocument..::.PreviousSibling Property
XmlDocument Class See Also Send Feedback

Returns the sibling node immediately preceding this node in the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property PreviousSibling As XmlNode
C#
public override XmlNode PreviousSibling { get; }
Visual C++
public:
virtual property XmlNode^ PreviousSibling {
    XmlNode^ get () override;
}
JavaScript
function get_previousSibling();

See Also

XmlDocument Class


RawContent Property

[image]

.NET Framework Class Library
XmlDocument..::.RawContent Property
XmlDocument Class See Also Send Feedback

The document's content as an XmlData.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property RawContent As XmlData
C#
public XmlData RawContent { get; set; }
Visual C++
public:
property XmlData^ RawContent {
    XmlData^ get ();
    void set (XmlData^ value);
}
JavaScript
function get_rawContent();
function set_rawContent(value);

Field Value

The document's content as an XmlData.

See Also

XmlDocument Class


StreamContent Property

[image]

.NET Framework Class Library
XmlDocument..::.StreamContent Property
XmlDocument Class See Also Send Feedback

The document's content as an XmlInputStream.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property StreamContent As XmlInputStream
C#
public XmlInputStream StreamContent { get; set; }
Visual C++
public:
property XmlInputStream^ StreamContent {
    XmlInputStream^ get ();
    void set (XmlInputStream^ value);
}
JavaScript
function get_streamContent();
function set_streamContent(value);

Field Value

The document's content as an XmlInputStream.

See Also

XmlDocument Class


StringContent Property

[image]

.NET Framework Class Library
XmlDocument..::.StringContent Property
XmlDocument Class See Also Send Feedback

The document's content as an string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property StringContent As String
C#
public string StringContent { get; set; }
Visual C++
public:
property String^ StringContent {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_stringContent();
function set_stringContent(value);

Field Value

The document's content as an string.

See Also

XmlDocument Class


XmlDocumentConfig Class

[image]

.NET Framework Class Library
XmlDocumentConfig Class
Members See Also Send Feedback

Used to configure operations that operate on XmlDocument objects.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlDocumentConfig _
    Inherits FlagsBase
C#
public class XmlDocumentConfig : FlagsBase
Visual C++
public ref class XmlDocumentConfig : public FlagsBase
JavaScript
JanaBiz.DbXml.XmlDocumentConfig = function();

Type.createClass(
    'JanaBiz.DbXml.XmlDocumentConfig',
    JanaBiz.Bridge.FlagsBase);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.DbXml..::.XmlDocumentConfig

See Also

XmlDocumentConfig Members


XmlDocumentConfig Members

[image] [image]

.NET Framework Class Library
XmlDocumentConfig Members
XmlDocumentConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlDocumentConfig type exposes the following members.

Constructors

Name | Description
XmlDocumentConfig | Initializes a new instance of the XmlDocumentConfig class.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
AutoCommit | whether XmlDocument update is auto commit or not
DbReadModifyWrite | Acquire write locks instead of read locks when doing the read, if locking is configured. Setting this flag can eliminate deadlock during a read-modify-write cycle by acquiring the write lock during the read part of the cycle so that another thread of control acquiring a read lock for the same item, in its own read-modify-write cycle, will not result in deadlock.
Degree2 | Degree 2 isolation provides for cursor stability but not repeatable reads.
DirtyRead | Read modified but not yet committed data.
DocumentProjection | DBXML_DOCUMENT_PROJECTION is set or not When parsing a document in order to execute a query, use static analysis of the query to materialize only those portions of the document relevant to the query. This can significantly enhance performance of queries against documents from containers of type XmlContainer::WholedocContainer and documents not in a container. It should not be used if arbitrary navigation of the resulting nodes is to be performed, as not all nodes in the original document will be present and unexepcted results could be returned. This flag has no effect on documents in containers of type XmlContainer::NodeContainer.
GenerateName | Whether to automatically generate a name for the document.
LazyDocs | Whether to retrieve the document lazily.
LockMode | The lock mode for the operation.
ReadCommitted | Read committed isolation provides for cursor stability but not repeatable reads.
ReadUncommitted | Configure the database to support read uncommitted.
ReverseOrder | Whether to sort index lookups in reverse order.
WellFormedOnly | Whether operations that may parse a document use only a well-formed scanner, avoiding the expense of reading any referenced schema or DTD.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlDocumentConfig Class


XmlDocumentConfig Constructor

[image]

.NET Framework Class Library
XmlDocumentConfig Constructor
XmlDocumentConfig Class See Also Send Feedback

Initializes a new instance of the XmlDocumentConfig class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlDocumentConfig()
Visual C++
public:
XmlDocumentConfig()
JavaScript
JanaBiz.DbXml.XmlDocumentConfig = function();

See Also

XmlDocumentConfig Class


XmlDocumentConfig Methods

[image] [image]

.NET Framework Class Library
XmlDocumentConfig Methods
XmlDocumentConfig Class See Also Send Feedback

The XmlDocumentConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlDocumentConfig Class


XmlDocumentConfig Properties

[image] [image]

.NET Framework Class Library
XmlDocumentConfig Properties
XmlDocumentConfig Class See Also Send Feedback

The XmlDocumentConfig type exposes the following members.

Properties

Name | Description
AutoCommit | whether XmlDocument update is auto commit or not
DbReadModifyWrite | Acquire write locks instead of read locks when doing the read, if locking is configured. Setting this flag can eliminate deadlock during a read-modify-write cycle by acquiring the write lock during the read part of the cycle so that another thread of control acquiring a read lock for the same item, in its own read-modify-write cycle, will not result in deadlock.
Degree2 | Degree 2 isolation provides for cursor stability but not repeatable reads.
DirtyRead | Read modified but not yet committed data.
DocumentProjection | DBXML_DOCUMENT_PROJECTION is set or not When parsing a document in order to execute a query, use static analysis of the query to materialize only those portions of the document relevant to the query. This can significantly enhance performance of queries against documents from containers of type XmlContainer::WholedocContainer and documents not in a container. It should not be used if arbitrary navigation of the resulting nodes is to be performed, as not all nodes in the original document will be present and unexepcted results could be returned. This flag has no effect on documents in containers of type XmlContainer::NodeContainer.
GenerateName | Whether to automatically generate a name for the document.
LazyDocs | Whether to retrieve the document lazily.
LockMode | The lock mode for the operation.
ReadCommitted | Read committed isolation provides for cursor stability but not repeatable reads.
ReadUncommitted | Configure the database to support read uncommitted.
ReverseOrder | Whether to sort index lookups in reverse order.
WellFormedOnly | Whether operations that may parse a document use only a well-formed scanner, avoiding the expense of reading any referenced schema or DTD.

See Also

XmlDocumentConfig Class


AutoCommit Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.AutoCommit Property
XmlDocumentConfig Class See Also Send Feedback

whether XmlDocument update is auto commit or not

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoCommit As Boolean
C#
public bool AutoCommit { get; set; }
Visual C++
public:
property bool AutoCommit {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoCommit();
function set_autoCommit(value);

See Also

XmlDocumentConfig Class


DbReadModifyWrite Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.DbReadModifyWrite Property
XmlDocumentConfig Class See Also Send Feedback

Acquire write locks instead of read locks when doing the read, if locking is configured. Setting this flag can eliminate deadlock during a read-modify-write cycle by acquiring the write lock during the read part of the cycle so that another thread of control acquiring a read lock for the same item, in its own read-modify-write cycle, will not result in deadlock.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbReadModifyWrite As Boolean
C#
public bool DbReadModifyWrite { get; }
Visual C++
public:
property bool DbReadModifyWrite {
    bool get ();
}
JavaScript
function get_dbReadModifyWrite();

See Also

XmlDocumentConfig Class


Degree2 Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.Degree2 Property
XmlDocumentConfig Class See Also Send Feedback

Degree 2 isolation provides for cursor stability but not repeatable reads.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Degree2 As Boolean
C#
public bool Degree2 { get; }
Visual C++
public:
property bool Degree2 {
    bool get ();
}
JavaScript
function get_degree2();

Remarks

Data items which have been previously read by this cursor or transaction may be deleted or modified by other transactions before the cursor is closed or the transaction completes.

See Also

XmlDocumentConfig Class


DirtyRead Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.DirtyRead Property
XmlDocumentConfig Class See Also Send Feedback

Read modified but not yet committed data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DirtyRead As Boolean
C#
public bool DirtyRead { get; }
Visual C++
public:
property bool DirtyRead {
    bool get ();
}
JavaScript
function get_dirtyRead();

See Also

XmlDocumentConfig Class


DocumentProjection Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.DocumentProjection Property
XmlDocumentConfig Class See Also Send Feedback

DBXML_DOCUMENT_PROJECTION is set or not When parsing a document in order to execute a query, use static analysis of the query to materialize only those portions of the document relevant to the query. This can significantly enhance performance of queries against documents from containers of type XmlContainer::WholedocContainer and documents not in a container. It should not be used if arbitrary navigation of the resulting nodes is to be performed, as not all nodes in the original document will be present and unexepcted results could be returned. This flag has no effect on documents in containers of type XmlContainer::NodeContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DocumentProjection As Boolean
C#
public bool DocumentProjection { get; set; }
Visual C++
public:
property bool DocumentProjection {
    bool get ();
    void set (bool value);
}
JavaScript
function get_documentProjection();
function set_documentProjection(value);

See Also

XmlDocumentConfig Class


GenerateName Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.GenerateName Property
XmlDocumentConfig Class See Also Send Feedback

Whether to automatically generate a name for the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property GenerateName As Boolean
C#
public bool GenerateName { get; set; }
Visual C++
public:
property bool GenerateName {
    bool get ();
    void set (bool value);
}
JavaScript
function get_generateName();
function set_generateName(value);

See Also

XmlDocumentConfig Class


LazyDocs Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.LazyDocs Property
XmlDocumentConfig Class See Also Send Feedback

Whether to retrieve the document lazily.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LazyDocs As Boolean
C#
public bool LazyDocs { get; set; }
Visual C++
public:
property bool LazyDocs {
    bool get ();
    void set (bool value);
}
JavaScript
function get_lazyDocs();
function set_lazyDocs(value);

Remarks

That is, retrieve document content and document metadata only on an as needed basis when reading the document.

See Also

XmlDocumentConfig Class


LockMode Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.LockMode Property
XmlDocumentConfig Class See Also Send Feedback

The lock mode for the operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property LockMode As DbLockMode
C#
public DbLockMode LockMode { get; set; }
Visual C++
public:
property DbLockMode LockMode {
    DbLockMode get ();
    void set (DbLockMode value);
}
JavaScript
function get_lockMode();
function set_lockMode(value);

See Also

XmlDocumentConfig Class


ReadCommitted Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.ReadCommitted Property
XmlDocumentConfig Class See Also Send Feedback

Read committed isolation provides for cursor stability but not repeatable reads.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadCommitted As Boolean
C#
public bool ReadCommitted { get; }
Visual C++
public:
property bool ReadCommitted {
    bool get ();
}
JavaScript
function get_readCommitted();

Remarks

Data items which have been previously read by this transaction may be deleted or modified by other transactions before the cursor is closed or the transaction completes.

See Also

XmlDocumentConfig Class


ReadUncommitted Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.ReadUncommitted Property
XmlDocumentConfig Class See Also Send Feedback

Configure the database to support read uncommitted.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReadUncommitted As Boolean
C#
public bool ReadUncommitted { get; }
Visual C++
public:
property bool ReadUncommitted {
    bool get ();
}
JavaScript
function get_readUncommitted();

Remarks

Read operations on the database may request the return of modified but not yet committed data.

If true, configure the database to support read uncommitted.

See Also

XmlDocumentConfig Class


ReverseOrder Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.ReverseOrder Property
XmlDocumentConfig Class See Also Send Feedback

Whether to sort index lookups in reverse order.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReverseOrder As Boolean
C#
public bool ReverseOrder { get; set; }
Visual C++
public:
property bool ReverseOrder {
    bool get ();
    void set (bool value);
}
JavaScript
function get_reverseOrder();
function set_reverseOrder(value);

See Also

XmlDocumentConfig Class


WellFormedOnly Property

[image]

.NET Framework Class Library
XmlDocumentConfig..::.WellFormedOnly Property
XmlDocumentConfig Class See Also Send Feedback

Whether operations that may parse a document use only a well-formed scanner, avoiding the expense of reading any referenced schema or DTD.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property WellFormedOnly As Boolean
C#
public bool WellFormedOnly { get; set; }
Visual C++
public:
property bool WellFormedOnly {
    bool get ();
    void set (bool value);
}
JavaScript
function get_wellFormedOnly();
function set_wellFormedOnly(value);

See Also

XmlDocumentConfig Class


XmlEventReader Class

[image]

.NET Framework Class Library
XmlEventReader Class
Members See Also Send Feedback

a class implementing a pull interface that enables input and output of XML content via pull events, rather than serialized XML.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlEventReader _
    Inherits InvocationHandle
C#
public abstract class XmlEventReader : InvocationHandle
Visual C++
public ref class XmlEventReader abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlEventReader = function();

Type.createClass(
    'JanaBiz.DbXml.XmlEventReader',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Used to read XML as events rather than serialized text. You can obtain an instance of this object using one of ContentAsEventReader, ToEventReader()()().

You use instances of this class with PutDocument(String, String, XmlUpdateContext), ContentAsEventReader and XmlEventReaderToWriter.This class implements an iterator-style interface, and you an manually retrieve its state using HasNext()()() and Next()()() ,along with accessor methods. When done with the object, its resources must be released using Close()()().

The event types are declared as static int in this class. This class allows applications direct access to the content model of stored XML without the overhead of re-parsing the document text.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlEventReader
JanaBiz.DbXml..::.XmlEventReaderBase

See Also

XmlEventReader Members


XmlEventReader Members

[image] [image]

.NET Framework Class Library
XmlEventReader Members
XmlEventReader Class Methods Properties See Also Send Feedback

The XmlEventReader type exposes the following members.

Methods

Name | Description
Close | Free the resources associated with this object
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAttributeLocalName | Return the local name of the attribute specified by the index parameter.
GetAttributeNamespaceURI | Return the local name of the attribute specified by the index parameter.
GetAttributePrefix | Return the namespace URI of the attribute specified by the index parameter.
GetAttributeValue | Return the text value of the attribute specified by the index parameter.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
HasEmptyElementInfo | Return whether the implementation keeps track of empty elements.
HasEntityEscapeInfo | Return whether the object is able to accurately determine if a given text value may require escaping of entities.
HasNext | Return true if there is another valid event remaining
IsAttributeSpecified | Return whether the attribute specified by the index is specified in the document (vs defaulted).
MemberwiseClone | (Inherited from Object.)
NeedsEntityEscape | Overloaded.
Next | Move to the next event, returning its type.
NextTag | Move to the next event that is of type StartElement, EndElement, returning its type.
ToString | (Inherited from Object.)

Properties

Name | Description
AttributeCount | Return the number of attributes for a StartElement event.
Encoding | Return the character encoding.
EncodingSet | Return whether the encoding is explicitly set in the XML declaration for the document.
EventType | Return the event type of the current position.
ExpandEntities | Determine whether you will read events that are part of an expanded entity reference and Tell the object whether you want to read events that are part of an expanded entity reference.
IsEmptyElement | Return whether the current event is StartElement with an empty element.
IsStandalone | Return whether the document is standalone.
IsWhiteSpace | Return whether the current text value is entirely white space.
LocalName | Return the local name of the StartElement event at the current position.
NamespaceURI | Return the namespace URI of the StartElement event at the current position.
Prefix | Return the namespace prefix of the StartElement event at the current position.
ReportEntityInfo | Tell the object whether you want to read events indicating the start and end of entity references and expansion and Determine whether you will read events indicating the start and end of entity references and expansion.
StandaloneSet | Return whether the standalone is set in the XML declaration for the document.
SystemId | Return the system ID of the document, if available.
Value | Return the text value of the current event.
Version | Return the XML version string.

See Also

XmlEventReader Class


XmlEventReader Methods

[image] [image]

.NET Framework Class Library
XmlEventReader Methods
XmlEventReader Class See Also Send Feedback

The XmlEventReader type exposes the following members.

Methods

Name | Description
Close | Free the resources associated with this object
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAttributeLocalName | Return the local name of the attribute specified by the index parameter.
GetAttributeNamespaceURI | Return the local name of the attribute specified by the index parameter.
GetAttributePrefix | Return the namespace URI of the attribute specified by the index parameter.
GetAttributeValue | Return the text value of the attribute specified by the index parameter.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
HasEmptyElementInfo | Return whether the implementation keeps track of empty elements.
HasEntityEscapeInfo | Return whether the object is able to accurately determine if a given text value may require escaping of entities.
HasNext | Return true if there is another valid event remaining
IsAttributeSpecified | Return whether the attribute specified by the index is specified in the document (vs defaulted).
MemberwiseClone | (Inherited from Object.)
NeedsEntityEscape | Overloaded.
Next | Move to the next event, returning its type.
NextTag | Move to the next event that is of type StartElement, EndElement, returning its type.
ToString | (Inherited from Object.)

See Also

XmlEventReader Class


Close Method

[image]

.NET Framework Class Library
XmlEventReader..::.Close Method
XmlEventReader Class See Also Send Feedback

Free the resources associated with this object

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Close
C#
public abstract void Close()
Visual C++
public:
virtual void Close() abstract
JavaScript
function close();

See Also

XmlEventReader Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlEventReader..::.Dispose Method
XmlEventReader Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlEventReader Class
XmlEventReader Members


GetAttributeLocalName Method

[image]

.NET Framework Class Library
XmlEventReader..::.GetAttributeLocalName Method
XmlEventReader Class See Also Send Feedback

Return the local name of the attribute specified by the index parameter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetAttributeLocalName ( _
    index As Integer _
) As String
C#
public abstract string GetAttributeLocalName(
    int index
)
Visual C++
public:
virtual String^ GetAttributeLocalName(
    int index
) abstract
JavaScript
function getAttributeLocalName(index);

Parameters

index
Type: System..::.Int32
The index into the attribute list.

Return Value

Return the local name of the attribute specified by the index parameter.

See Also

XmlEventReader Class


GetAttributeNamespaceURI Method

[image]

.NET Framework Class Library
XmlEventReader..::.GetAttributeNamespaceURI Method
XmlEventReader Class See Also Send Feedback

Return the local name of the attribute specified by the index parameter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetAttributeNamespaceURI ( _
    index As Integer _
) As String
C#
public abstract string GetAttributeNamespaceURI(
    int index
)
Visual C++
public:
virtual String^ GetAttributeNamespaceURI(
    int index
) abstract
JavaScript
function getAttributeNamespaceURI(index);

Parameters

index
Type: System..::.Int32
The index into the attribute list.

Return Value

Return the local name of the attribute specified by the index parameter.

See Also

XmlEventReader Class


GetAttributePrefix Method

[image]

.NET Framework Class Library
XmlEventReader..::.GetAttributePrefix Method
XmlEventReader Class See Also Send Feedback

Return the namespace URI of the attribute specified by the index parameter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetAttributePrefix ( _
    index As Integer _
) As String
C#
public abstract string GetAttributePrefix(
    int index
)
Visual C++
public:
virtual String^ GetAttributePrefix(
    int index
) abstract
JavaScript
function getAttributePrefix(index);

Parameters

index
Type: System..::.Int32
The index into the attribute list.

Return Value

Return the namespace URI of the attribute specified by the index parameter.

See Also

XmlEventReader Class


GetAttributeValue Method

[image]

.NET Framework Class Library
XmlEventReader..::.GetAttributeValue Method
XmlEventReader Class See Also Send Feedback

Return the text value of the attribute specified by the index parameter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function GetAttributeValue ( _
    index As Integer _
) As String
C#
public abstract string GetAttributeValue(
    int index
)
Visual C++
public:
virtual String^ GetAttributeValue(
    int index
) abstract
JavaScript
function getAttributeValue(index);

Parameters

index
Type: System..::.Int32
The index into the attribute list.

Return Value

Return the text value of the attribute specified by the index parameter.

See Also

XmlEventReader Class


HasEmptyElementInfo Method

[image]

.NET Framework Class Library
XmlEventReader..::.HasEmptyElementInfo Method
XmlEventReader Class See Also Send Feedback

Return whether the implementation keeps track of empty elements.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function HasEmptyElementInfo As Boolean
C#
public abstract bool HasEmptyElementInfo()
Visual C++
public:
virtual bool HasEmptyElementInfo() abstract
JavaScript
function hasEmptyElementInfo();

Return Value

If the implementation keeps track of empty elements return trueTruetruetrue (True in Visual Basic),otherwise return falseFalsefalsefalse (False in Visual Basic)

See Also

XmlEventReader Class


HasEntityEscapeInfo Method

[image]

.NET Framework Class Library
XmlEventReader..::.HasEntityEscapeInfo Method
XmlEventReader Class See Also Send Feedback

Return whether the object is able to accurately determine if a given text value may require escaping of entities.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function HasEntityEscapeInfo As Boolean
C#
public abstract bool HasEntityEscapeInfo()
Visual C++
public:
virtual bool HasEntityEscapeInfo() abstract
JavaScript
function hasEntityEscapeInfo();

Return Value

If the object is able to accurately determine if a given text value may require escaping of entities return trueTruetruetrue (True in Visual Basic),otherwise return falseFalsefalsefalse (False in Visual Basic).

See Also

XmlEventReader Class


HasNext Method

[image]

.NET Framework Class Library
XmlEventReader..::.HasNext Method
XmlEventReader Class See Also Send Feedback

Return true if there is another valid event remaining

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function HasNext As Boolean
C#
public abstract bool HasNext()
Visual C++
public:
virtual bool HasNext() abstract
JavaScript
function hasNext();

Return Value

If there is another valid event remaining return trueTruetruetrue (True in Visual Basic),else return falseFalsefalsefalse (False in Visual Basic)

See Also

XmlEventReader Class


IsAttributeSpecified Method

[image]

.NET Framework Class Library
XmlEventReader..::.IsAttributeSpecified Method
XmlEventReader Class See Also Send Feedback

Return whether the attribute specified by the index is specified in the document (vs defaulted).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function IsAttributeSpecified ( _
    index As Integer _
) As Boolean
C#
public abstract bool IsAttributeSpecified(
    int index
)
Visual C++
public:
virtual bool IsAttributeSpecified(
    int index
) abstract
JavaScript
function isAttributeSpecified(index);

Parameters

index
Type: System..::.Int32
The index into the attribute list.

Return Value

If the attribute specified by the index is specified in the document, return trueTruetruetrue (True in Visual Basic),else return falseFalsefalsefalse (False in Visual Basic).

See Also

XmlEventReader Class


NeedsEntityEscape Method

[image] [image]

.NET Framework Class Library
XmlEventReader..::.NeedsEntityEscape Method
XmlEventReader Class See Also Send Feedback

Overload List

Name | Description
NeedsEntityEscape()()() | Return whether the text value of the current event requires escaping.
NeedsEntityEscape(Int32) | Return whether the text value of the attribute specified by the index parameter requires escaping.

See Also

XmlEventReader Class
XmlEventReader Members


NeedsEntityEscape Method

[image]

.NET Framework Class Library
XmlEventReader..::.NeedsEntityEscape Method
XmlEventReader Class See Also Send Feedback

Return whether the text value of the current event requires escaping.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function NeedsEntityEscape As Boolean
C#
public abstract bool NeedsEntityEscape()
Visual C++
public:
virtual bool NeedsEntityEscape() abstract
JavaScript
function needsEntityEscape();

Return Value

If the text value of the current event requires escaping return trueTruetruetrue (True in Visual Basic),else return falseFalsefalsefalse (False in Visual Basic).

See Also

XmlEventReader Class
NeedsEntityEscape Overload


NeedsEntityEscape Method (Int32)

[image]

.NET Framework Class Library
XmlEventReader..::.NeedsEntityEscape Method (Int32)
XmlEventReader Class See Also Send Feedback

Return whether the text value of the attribute specified by the index parameter requires escaping.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function NeedsEntityEscape ( _
    index As Integer _
) As Boolean
C#
public abstract bool NeedsEntityEscape(
    int index
)
Visual C++
public:
virtual bool NeedsEntityEscape(
    int index
) abstract
JavaScript
function needsEntityEscape(index);

Parameters

index
Type: System..::.Int32
If the current event is StartElement, index is the attribute index used to specify an attribute. If the current event is Characters, it is ignored.

Return Value

If the text value of the attribute specified by the index parameter requires escaping return trueTruetruetrue (True in Visual Basic),else return falseFalsefalsefalse (False in Visual Basic).

See Also

XmlEventReader Class
NeedsEntityEscape Overload


Next Method

[image]

.NET Framework Class Library
XmlEventReader..::.Next Method
XmlEventReader Class See Also Send Feedback

Move to the next event, returning its type.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Next As XmlEventType
C#
public abstract XmlEventType Next()
Visual C++
public:
virtual XmlEventType Next() abstract
JavaScript
function next();

See Also

XmlEventReader Class


NextTag Method

[image]

.NET Framework Class Library
XmlEventReader..::.NextTag Method
XmlEventReader Class See Also Send Feedback

Move to the next event that is of type StartElement, EndElement, returning its type.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function NextTag As XmlEventType
C#
public abstract XmlEventType NextTag()
Visual C++
public:
virtual XmlEventType NextTag() abstract
JavaScript
function nextTag();

See Also

XmlEventReader Class


XmlEventReader Properties

[image] [image]

.NET Framework Class Library
XmlEventReader Properties
XmlEventReader Class See Also Send Feedback

The XmlEventReader type exposes the following members.

Properties

Name | Description
AttributeCount | Return the number of attributes for a StartElement event.
Encoding | Return the character encoding.
EncodingSet | Return whether the encoding is explicitly set in the XML declaration for the document.
EventType | Return the event type of the current position.
ExpandEntities | Determine whether you will read events that are part of an expanded entity reference and Tell the object whether you want to read events that are part of an expanded entity reference.
IsEmptyElement | Return whether the current event is StartElement with an empty element.
IsStandalone | Return whether the document is standalone.
IsWhiteSpace | Return whether the current text value is entirely white space.
LocalName | Return the local name of the StartElement event at the current position.
NamespaceURI | Return the namespace URI of the StartElement event at the current position.
Prefix | Return the namespace prefix of the StartElement event at the current position.
ReportEntityInfo | Tell the object whether you want to read events indicating the start and end of entity references and expansion and Determine whether you will read events indicating the start and end of entity references and expansion.
StandaloneSet | Return whether the standalone is set in the XML declaration for the document.
SystemId | Return the system ID of the document, if available.
Value | Return the text value of the current event.
Version | Return the XML version string.

See Also

XmlEventReader Class


AttributeCount Property

[image]

.NET Framework Class Library
XmlEventReader..::.AttributeCount Property
XmlEventReader Class See Also Send Feedback

Return the number of attributes for a StartElement event.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property AttributeCount As Integer
C#
public abstract int AttributeCount { get; }
Visual C++
public:
virtual property int AttributeCount {
    int get () abstract;
}
JavaScript
function get_attributeCount();

See Also

XmlEventReader Class


Encoding Property

[image]

.NET Framework Class Library
XmlEventReader..::.Encoding Property
XmlEventReader Class See Also Send Feedback

Return the character encoding.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Encoding As String
C#
public abstract string Encoding { get; }
Visual C++
public:
virtual property String^ Encoding {
    String^ get () abstract;
}
JavaScript
function get_encoding();

See Also

XmlEventReader Class


EncodingSet Property

[image]

.NET Framework Class Library
XmlEventReader..::.EncodingSet Property
XmlEventReader Class See Also Send Feedback

Return whether the encoding is explicitly set in the XML declaration for the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property EncodingSet As Boolean
C#
public abstract bool EncodingSet { get; }
Visual C++
public:
virtual property bool EncodingSet {
    bool get () abstract;
}
JavaScript
function get_encodingSet();

See Also

XmlEventReader Class


EventType Property

[image]

.NET Framework Class Library
XmlEventReader..::.EventType Property
XmlEventReader Class See Also Send Feedback

Return the event type of the current position.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property EventType As XmlEventType
C#
public abstract XmlEventType EventType { get; }
Visual C++
public:
virtual property XmlEventType EventType {
    XmlEventType get () abstract;
}
JavaScript
function get_eventType();

See Also

XmlEventReader Class


ExpandEntities Property

[image]

.NET Framework Class Library
XmlEventReader..::.ExpandEntities Property
XmlEventReader Class See Also Send Feedback

Determine whether you will read events that are part of an expanded entity reference and Tell the object whether you want to read events that are part of an expanded entity reference.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property ExpandEntities As Boolean
C#
public abstract bool ExpandEntities { get; set; }
Visual C++
public:
virtual property bool ExpandEntities {
    bool get () abstract;
    void set (bool value) abstract;
}
JavaScript
function get_expandEntities();
function set_expandEntities(value);

See Also

XmlEventReader Class


IsEmptyElement Property

[image]

.NET Framework Class Library
XmlEventReader..::.IsEmptyElement Property
XmlEventReader Class See Also Send Feedback

Return whether the current event is StartElement with an empty element.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsEmptyElement As Boolean
C#
public abstract bool IsEmptyElement { get; }
Visual C++
public:
virtual property bool IsEmptyElement {
    bool get () abstract;
}
JavaScript
function get_isEmptyElement();

See Also

XmlEventReader Class


IsStandalone Property

[image]

.NET Framework Class Library
XmlEventReader..::.IsStandalone Property
XmlEventReader Class See Also Send Feedback

Return whether the document is standalone.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsStandalone As Boolean
C#
public abstract bool IsStandalone { get; }
Visual C++
public:
virtual property bool IsStandalone {
    bool get () abstract;
}
JavaScript
function get_isStandalone();

See Also

XmlEventReader Class


IsWhiteSpace Property

[image]

.NET Framework Class Library
XmlEventReader..::.IsWhiteSpace Property
XmlEventReader Class See Also Send Feedback

Return whether the current text value is entirely white space.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property IsWhiteSpace As Boolean
C#
public abstract bool IsWhiteSpace { get; }
Visual C++
public:
virtual property bool IsWhiteSpace {
    bool get () abstract;
}
JavaScript
function get_isWhiteSpace();

See Also

XmlEventReader Class


LocalName Property

[image]

.NET Framework Class Library
XmlEventReader..::.LocalName Property
XmlEventReader Class See Also Send Feedback

Return the local name of the StartElement event at the current position.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property LocalName As String
C#
public abstract string LocalName { get; }
Visual C++
public:
virtual property String^ LocalName {
    String^ get () abstract;
}
JavaScript
function get_localName();

See Also

XmlEventReader Class


NamespaceURI Property

[image]

.NET Framework Class Library
XmlEventReader..::.NamespaceURI Property
XmlEventReader Class See Also Send Feedback

Return the namespace URI of the StartElement event at the current position.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property NamespaceURI As String
C#
public abstract string NamespaceURI { get; }
Visual C++
public:
virtual property String^ NamespaceURI {
    String^ get () abstract;
}
JavaScript
function get_namespaceURI();

See Also

XmlEventReader Class


Prefix Property

[image]

.NET Framework Class Library
XmlEventReader..::.Prefix Property
XmlEventReader Class See Also Send Feedback

Return the namespace prefix of the StartElement event at the current position.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Prefix As String
C#
public abstract string Prefix { get; }
Visual C++
public:
virtual property String^ Prefix {
    String^ get () abstract;
}
JavaScript
function get_prefix();

See Also

XmlEventReader Class


ReportEntityInfo Property

[image]

.NET Framework Class Library
XmlEventReader..::.ReportEntityInfo Property
XmlEventReader Class See Also Send Feedback

Tell the object whether you want to read events indicating the start and end of entity references and expansion and Determine whether you will read events indicating the start and end of entity references and expansion.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Property ReportEntityInfo As Boolean
C#
public abstract bool ReportEntityInfo { get; set; }
Visual C++
public:
virtual property bool ReportEntityInfo {
    bool get () abstract;
    void set (bool value) abstract;
}
JavaScript
function get_reportEntityInfo();
function set_reportEntityInfo(value);

See Also

XmlEventReader Class


StandaloneSet Property

[image]

.NET Framework Class Library
XmlEventReader..::.StandaloneSet Property
XmlEventReader Class See Also Send Feedback

Return whether the standalone is set in the XML declaration for the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property StandaloneSet As Boolean
C#
public abstract bool StandaloneSet { get; }
Visual C++
public:
virtual property bool StandaloneSet {
    bool get () abstract;
}
JavaScript
function get_standaloneSet();

See Also

XmlEventReader Class


SystemId Property

[image]

.NET Framework Class Library
XmlEventReader..::.SystemId Property
XmlEventReader Class See Also Send Feedback

Return the system ID of the document, if available.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property SystemId As String
C#
public abstract string SystemId { get; }
Visual C++
public:
virtual property String^ SystemId {
    String^ get () abstract;
}
JavaScript
function get_systemId();

See Also

XmlEventReader Class


Value Property

[image]

.NET Framework Class Library
XmlEventReader..::.Value Property
XmlEventReader Class See Also Send Feedback

Return the text value of the current event.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Value As String
C#
public abstract string Value { get; }
Visual C++
public:
virtual property String^ Value {
    String^ get () abstract;
}
JavaScript
function get_value();

See Also

XmlEventReader Class


Version Property

[image]

.NET Framework Class Library
XmlEventReader..::.Version Property
XmlEventReader Class See Also Send Feedback

Return the XML version string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride ReadOnly Property Version As String
C#
public abstract string Version { get; }
Visual C++
public:
virtual property String^ Version {
    String^ get () abstract;
}
JavaScript
function get_version();

See Also

XmlEventReader Class


XmlEventReaderBase Class

[image]

.NET Framework Class Library
XmlEventReaderBase Class
Members See Also Send Feedback

a class implementing a pull interface that enables input and output of XML content via pull events, rather than serialized XML.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlEventReaderBase _
    Inherits XmlEventReader
C#
public abstract class XmlEventReaderBase : XmlEventReader
Visual C++
public ref class XmlEventReaderBase abstract : public XmlEventReader
JavaScript
JanaBiz.DbXml.XmlEventReaderBase = function();

Type.createClass(
    'JanaBiz.DbXml.XmlEventReaderBase',
    JanaBiz.DbXml.XmlEventReader);

Remarks

Used to read XML as events rather than serialized text. You can obtain an instance of this object using one of ContentAsEventReader, ToEventReader()()().

You use instances of this class with PutDocument(String, String, XmlUpdateContext), ContentAsEventReader and XmlEventReaderToWriter.This class implements an iterator-style interface, and you an manually retrieve its state using HasNext()()() and Next()()() ,along with accessor methods. When done with the object, its resources must be released using Close()()().

The event types are declared as static int in this class. This class allows applications direct access to the content model of stored XML without the overhead of re-parsing the document text.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlEventReader
JanaBiz.DbXml..::.XmlEventReaderBase

See Also

XmlEventReaderBase Members


XmlEventReaderBase Members

[image] [image]

.NET Framework Class Library
XmlEventReaderBase Members
XmlEventReaderBase Class Constructors Methods Properties See Also Send Feedback

The XmlEventReaderBase type exposes the following members.

Constructors

Name | Description
XmlEventReaderBase | Initializes a new instance of the XmlEventReaderBase class.

Methods

Name | Description
Close | Free the resources associated with this object (Inherited from XmlEventReader.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAttributeLocalName | Return the local name of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributeNamespaceURI | Return the local name of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributePrefix | Return the namespace URI of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributeValue | Return the text value of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
HasEmptyElementInfo | Return whether the implementation keeps track of empty elements. (Inherited from XmlEventReader.)
HasEntityEscapeInfo | Return whether the object is able to accurately determine if a given text value may require escaping of entities. (Inherited from XmlEventReader.)
HasNext | Return true if there is another valid event remaining (Inherited from XmlEventReader.)
IsAttributeSpecified | Return whether the attribute specified by the index is specified in the document (vs defaulted). (Inherited from XmlEventReader.)
MemberwiseClone | (Inherited from Object.)
NeedsEntityEscape | Overloaded.
Next | Move to the next event, returning its type. (Inherited from XmlEventReader.)
NextTag | Move to the next event that is of type StartElement, EndElement, returning its type. (Inherited from XmlEventReader.)
ToString | (Inherited from Object.)

Properties

Name | Description
AttributeCount | Return the number of attributes for a StartElement event. (Inherited from XmlEventReader.)
Encoding | Return the character encoding. (Inherited from XmlEventReader.)
EncodingSet | Return whether the encoding is explicitly set in the XML declaration for the document. (Inherited from XmlEventReader.)
EventType | Return the event type of the current position. (Inherited from XmlEventReader.)
ExpandEntities | Determine whether you will read events that are part of an expanded entity reference and Tell the object whether you want to read events that are part of an expanded entity reference. (Inherited from XmlEventReader.)
IsEmptyElement | Return whether the current event is StartElement with an empty element. (Inherited from XmlEventReader.)
IsStandalone | Return whether the document is standalone. (Inherited from XmlEventReader.)
IsWhiteSpace | Return whether the current text value is entirely white space. (Inherited from XmlEventReader.)
LocalName | Return the local name of the StartElement event at the current position. (Inherited from XmlEventReader.)
NamespaceURI | Return the namespace URI of the StartElement event at the current position. (Inherited from XmlEventReader.)
Prefix | Return the namespace prefix of the StartElement event at the current position. (Inherited from XmlEventReader.)
ReportEntityInfo | Tell the object whether you want to read events indicating the start and end of entity references and expansion and Determine whether you will read events indicating the start and end of entity references and expansion. (Inherited from XmlEventReader.)
StandaloneSet | Return whether the standalone is set in the XML declaration for the document. (Inherited from XmlEventReader.)
SystemId | Return the system ID of the document, if available. (Inherited from XmlEventReader.)
Value | Return the text value of the current event. (Inherited from XmlEventReader.)
Version | Return the XML version string. (Inherited from XmlEventReader.)

See Also

XmlEventReaderBase Class


XmlEventReaderBase Constructor

[image]

.NET Framework Class Library
XmlEventReaderBase Constructor
XmlEventReaderBase Class See Also Send Feedback

Initializes a new instance of the XmlEventReaderBase class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlEventReaderBase()
Visual C++
public:
XmlEventReaderBase()
JavaScript
JanaBiz.DbXml.XmlEventReaderBase = function();

See Also

XmlEventReaderBase Class


XmlEventReaderBase Methods

[image] [image]

.NET Framework Class Library
XmlEventReaderBase Methods
XmlEventReaderBase Class See Also Send Feedback

The XmlEventReaderBase type exposes the following members.

Methods

Name | Description
Close | Free the resources associated with this object (Inherited from XmlEventReader.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetAttributeLocalName | Return the local name of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributeNamespaceURI | Return the local name of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributePrefix | Return the namespace URI of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetAttributeValue | Return the text value of the attribute specified by the index parameter. (Inherited from XmlEventReader.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
HasEmptyElementInfo | Return whether the implementation keeps track of empty elements. (Inherited from XmlEventReader.)
HasEntityEscapeInfo | Return whether the object is able to accurately determine if a given text value may require escaping of entities. (Inherited from XmlEventReader.)
HasNext | Return true if there is another valid event remaining (Inherited from XmlEventReader.)
IsAttributeSpecified | Return whether the attribute specified by the index is specified in the document (vs defaulted). (Inherited from XmlEventReader.)
MemberwiseClone | (Inherited from Object.)
NeedsEntityEscape | Overloaded.
Next | Move to the next event, returning its type. (Inherited from XmlEventReader.)
NextTag | Move to the next event that is of type StartElement, EndElement, returning its type. (Inherited from XmlEventReader.)
ToString | (Inherited from Object.)

See Also

XmlEventReaderBase Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlEventReaderBase..::.Dispose Method
XmlEventReaderBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlEventReaderBase Class
XmlEventReaderBase Members


NeedsEntityEscape Method

[image] [image]

.NET Framework Class Library
XmlEventReaderBase..::.NeedsEntityEscape Method
XmlEventReaderBase Class See Also Send Feedback

Overload List

Name | Description
NeedsEntityEscape()()() | Return whether the text value of the current event requires escaping. (Inherited from XmlEventReader.)
NeedsEntityEscape(Int32) | Return whether the text value of the attribute specified by the index parameter requires escaping. (Inherited from XmlEventReader.)

See Also

XmlEventReaderBase Class
XmlEventReaderBase Members


XmlEventReaderBase Properties

[image] [image]

.NET Framework Class Library
XmlEventReaderBase Properties
XmlEventReaderBase Class See Also Send Feedback

The XmlEventReaderBase type exposes the following members.

Properties

Name | Description
AttributeCount | Return the number of attributes for a StartElement event. (Inherited from XmlEventReader.)
Encoding | Return the character encoding. (Inherited from XmlEventReader.)
EncodingSet | Return whether the encoding is explicitly set in the XML declaration for the document. (Inherited from XmlEventReader.)
EventType | Return the event type of the current position. (Inherited from XmlEventReader.)
ExpandEntities | Determine whether you will read events that are part of an expanded entity reference and Tell the object whether you want to read events that are part of an expanded entity reference. (Inherited from XmlEventReader.)
IsEmptyElement | Return whether the current event is StartElement with an empty element. (Inherited from XmlEventReader.)
IsStandalone | Return whether the document is standalone. (Inherited from XmlEventReader.)
IsWhiteSpace | Return whether the current text value is entirely white space. (Inherited from XmlEventReader.)
LocalName | Return the local name of the StartElement event at the current position. (Inherited from XmlEventReader.)
NamespaceURI | Return the namespace URI of the StartElement event at the current position. (Inherited from XmlEventReader.)
Prefix | Return the namespace prefix of the StartElement event at the current position. (Inherited from XmlEventReader.)
ReportEntityInfo | Tell the object whether you want to read events indicating the start and end of entity references and expansion and Determine whether you will read events indicating the start and end of entity references and expansion. (Inherited from XmlEventReader.)
StandaloneSet | Return whether the standalone is set in the XML declaration for the document. (Inherited from XmlEventReader.)
SystemId | Return the system ID of the document, if available. (Inherited from XmlEventReader.)
Value | Return the text value of the current event. (Inherited from XmlEventReader.)
Version | Return the XML version string. (Inherited from XmlEventReader.)

See Also

XmlEventReaderBase Class


XmlEventReaderToWriter Class

[image]

.NET Framework Class Library
XmlEventReaderToWriter Class
Members See Also Send Feedback

a class that associates an XmlEventReader with an XmlEventWriter, pushing events read from the XmlEventReader to the XmlEventWriter.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlEventReaderToWriter _
    Inherits InvocationHandle
C#
public class XmlEventReaderToWriter : InvocationHandle
Visual C++
public ref class XmlEventReaderToWriter : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlEventReaderToWriter = function();

Type.createClass(
    'JanaBiz.DbXml.XmlEventReaderToWriter',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlEventReaderToWriter

See Also

XmlEventReaderToWriter Members


XmlEventReaderToWriter Members

[image] [image]

.NET Framework Class Library
XmlEventReaderToWriter Members
XmlEventReaderToWriter Class Constructors Methods See Also Send Feedback

The XmlEventReaderToWriter type exposes the following members.

Constructors

Name | Description
XmlEventReaderToWriter | Overloaded.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Start | Perform the operation. This method will read events from the reader, writing them to the writer, until there are no further events available.
ToString | (Inherited from Object.)

See Also

XmlEventReaderToWriter Class


XmlEventReaderToWriter Constructor

[image] [image]

.NET Framework Class Library
XmlEventReaderToWriter Constructor
XmlEventReaderToWriter Class See Also Send Feedback

Overload List

Name | Description
XmlEventReaderToWriter(XmlEventReader, XmlEventWriter) | Construct an XmlEventReaderToWriter instance from the parameters.
XmlEventReaderToWriter(XmlEventReader, XmlEventWriter, Boolean) | Construct an XmlEventReaderToWriter instance from the parameters.
XmlEventReaderToWriter(XmlEventReader, XmlEventWriter, Boolean, Boolean) | The XmlEventReaderToWriter class enables events read from an XmlEventReader to be written directly to an XmlEventWriter. This is useful for processing XML document content, efficient copying, and other application integration tasks. Use XmlEventReaderToWriter::start to begin processing.

See Also

XmlEventReaderToWriter Class
XmlEventReaderToWriter Members


XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter)

[image]

.NET Framework Class Library
XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter)
XmlEventReaderToWriter Class See Also Send Feedback

Construct an XmlEventReaderToWriter instance from the parameters.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As XmlEventReader, _
    writer As XmlEventWriter _
)
C#
public XmlEventReaderToWriter(
    XmlEventReader reader,
    XmlEventWriter writer
)
Visual C++
public:
XmlEventReaderToWriter(
    XmlEventReader^ reader,
    XmlEventWriter^ writer
)
JavaScript
JanaBiz.DbXml.XmlEventReaderToWriter = function(reader, writer);

Parameters

reader
Type: JanaBiz.DbXml..::.XmlEventReader
An XmlEventReader object from which events will be read. To create the reader, use one of ContentAsEventReader, ToEventReader()()(), or implement an application-defined class derived from XmlEventReader.
writer
Type: JanaBiz.DbXml..::.XmlEventWriter
The XmlEventWriter to which events are written. This object is always donated, and the caller can no longer use it.

See Also

XmlEventReaderToWriter Class
XmlEventReaderToWriter Overload


XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter, Boolean)

[image]

.NET Framework Class Library
XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter, Boolean)
XmlEventReaderToWriter Class See Also Send Feedback

Construct an XmlEventReaderToWriter instance from the parameters.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As XmlEventReader, _
    writer As XmlEventWriter, _
    ownsReader As Boolean _
)
C#
public XmlEventReaderToWriter(
    XmlEventReader reader,
    XmlEventWriter writer,
    bool ownsReader
)
Visual C++
public:
XmlEventReaderToWriter(
    XmlEventReader^ reader,
    XmlEventWriter^ writer,
    bool ownsReader
)
JavaScript
JanaBiz.DbXml.XmlEventReaderToWriter = function(reader, writer, ownsReader);

Parameters

reader
Type: JanaBiz.DbXml..::.XmlEventReader
An XmlEventReader object from which events will be read. To create the reader, use one of ContentAsEventReader, ToEventReader()()(), or implement an application-defined class derived from XmlEventReader.
writer
Type: JanaBiz.DbXml..::.XmlEventWriter
The XmlEventWriter to which events are written. This object is always donated, and the caller can no longer use it.
ownsReader
Type: System..::.Boolean
Set to true if the reader is donated to the object, which means the constructed object is responsible for calling Close()()().

See Also

XmlEventReaderToWriter Class
XmlEventReaderToWriter Overload


XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter, Boolean, Boolean)

[image]

.NET Framework Class Library
XmlEventReaderToWriter Constructor (XmlEventReader, XmlEventWriter, Boolean, Boolean)
XmlEventReaderToWriter Class See Also Send Feedback

The XmlEventReaderToWriter class enables events read from an XmlEventReader to be written directly to an XmlEventWriter. This is useful for processing XML document content, efficient copying, and other application integration tasks. Use XmlEventReaderToWriter::start to begin processing.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    reader As XmlEventReader, _
    writer As XmlEventWriter, _
    ownsReader As Boolean, _
    ownsWriter As Boolean _
)
C#
public XmlEventReaderToWriter(
    XmlEventReader reader,
    XmlEventWriter writer,
    bool ownsReader,
    bool ownsWriter
)
Visual C++
public:
XmlEventReaderToWriter(
    XmlEventReader^ reader,
    XmlEventWriter^ writer,
    bool ownsReader,
    bool ownsWriter
)
JavaScript
JanaBiz.DbXml.XmlEventReaderToWriter = function(reader, writer, ownsReader, ownsWriter);

Parameters

reader
Type: JanaBiz.DbXml..::.XmlEventReader
An XmlEventReader object from which events will be read. To create the reader, use one of XmlDocument::getContentAsEventReader, XmlValue::asEventReader, or implement an application-defined class derived from XmlEventReader
writer
Type: JanaBiz.DbXml..::.XmlEventWriter
An XmlEventWriter object to which events will be written. When all events are processed, XmlEventWriter::close is called on the object unless the ownsWriter parameter is false. To create the writer, use one of XmlContainer::putDocumentAsEventWriter, or implement an application-defined class derived from XmlEventWriter
ownsReader
Type: System..::.Boolean
If true (the default), XmlEventReader::close will be called when all events have been processed; otherwise, the reader is left intact upon completion
ownsWriter
Type: System..::.Boolean
If true (the default), XmlEventWriter::close will be called when all events have been processed; otherwise, the writer is left intact upon completion. Setting this parameter to false allows applications to apply a number of XmlEventReader objects to the same XmlEventWriter

See Also

XmlEventReaderToWriter Class
XmlEventReaderToWriter Overload


XmlEventReaderToWriter Methods

[image] [image]

.NET Framework Class Library
XmlEventReaderToWriter Methods
XmlEventReaderToWriter Class See Also Send Feedback

The XmlEventReaderToWriter type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Start | Perform the operation. This method will read events from the reader, writing them to the writer, until there are no further events available.
ToString | (Inherited from Object.)

See Also

XmlEventReaderToWriter Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlEventReaderToWriter..::.Dispose Method
XmlEventReaderToWriter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlEventReaderToWriter Class
XmlEventReaderToWriter Members


Start Method

[image]

.NET Framework Class Library
XmlEventReaderToWriter..::.Start Method
XmlEventReaderToWriter Class See Also Send Feedback

Perform the operation. This method will read events from the reader, writing them to the writer, until there are no further events available.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Start
C#
public void Start()
Visual C++
public:
void Start()
JavaScript
function start();

Remarks

When complete, it will call Close()()() and, if ownsReader was true during construction, Close()()().

See Also

XmlEventReaderToWriter Class


XmlEventType Enumeration

[image]

.NET Framework Class Library
XmlEventType Enumeration
See Also Send Feedback

XmlEventType の概要の説明です。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlEventType
C#
public enum XmlEventType
Visual C++
public enum class XmlEventType
JavaScript
JanaBiz.DbXml.XmlEventType = function();
JanaBiz.DbXml.XmlEventType.createEnum('JanaBiz.DbXml.XmlEventType', false);

Members

Member name | Description
StartElement | Start element event
EndElement | End element event
Characters | Character (text) event
CDATA | CDATA event
Comment | Comment event
Whitespace | Ignorable whitespace event
StartDocument | Start document event
EndDocument | End document event
StartEntityReference | Start entity reference event
EndEntityReference | End entity reference event
ProcessingInstruction | Processing instruction event
DTD | DTD event

See Also


XmlEventWriter Class

[image]

.NET Framework Class Library
XmlEventWriter Class
Members See Also Send Feedback

The XmlEventWriter class enables applications to construct document content without using serialized XML.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlEventWriter _
    Inherits InvocationHandle
C#
public abstract class XmlEventWriter : InvocationHandle
Visual C++
public ref class XmlEventWriter abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlEventWriter = function();

Type.createClass(
    'JanaBiz.DbXml.XmlEventWriter',
    JanaBiz.Bridge.InvocationHandle);

Remarks

allows use of application-provided parsers and other XML processing mechanisms. The XmlEventWriter is a push-style interface, with content written via explicit interfaces.

The XmlEventWriter maintains state based on information written, and an exception is thrown if an operation is performed that is not valid for the current state. All strings must be null-terminated const unsigned char * values encoded in UTF-8. The values are copied by the underlying implementation, as necessary. When a document is completed, the Close()()() method must be called to finalize the operation and release resources.

Used to create XML content as events rather than serialized text. You can obtain an instance of this object using one of PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) or GetContentAsEventWriter(XmlEventWriter) . It can also be used by XmlEventReaderToWriter.

Once you acquire an instance of this class, use its methods to write content, and when the document has been completed, call the Close()()() method to finish putting the document in the container. Some methods will do this implicitly. All text written must be encoded as UTF-8 or a subset.

Documents created in this manner are not subject to validation. This class allows applications to directly create content without involving a parser. It also allows use of an external parser to generate events that are pushed into BDB XML content

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlEventWriter
JanaBiz.DbXml..::.XmlEventWriterBase

See Also

XmlEventWriter Members


XmlEventWriter Members

[image] [image]

.NET Framework Class Library
XmlEventWriter Members
XmlEventWriter Class Methods See Also Send Feedback

The XmlEventWriter type exposes the following members.

Methods

Name | Description
Close | Complete the PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) operation, and free the resources associated with this object. This call must be made when you are done with this object.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteAttribute | Write an attribute to the event stream. If state of the object is not able to accept an attribute, an exception is thrown.
WriteDTD | Write a DTD (internal subset). If state of the object is not able to accept a DTD event, an exception is thrown.
WriteEndDocument | Write the EndDocument event.
WriteEndElement | Write an EndElement event. If state of the object is not able to accept a EndElement event, an exception is thrown.
WriteEndEntity | Write an event indicating the end of content expanded by an entity reference. If the state of the object is not able to accept a writeEndEntity event, an exception is thrown.
WriteProcessingInstruction | Write a ProcessingInstruction event. If state of the object is not able to accept a ProcessingInstruction event, an exception is thrown.
WriteStartDocument | Write the StartDocument event. If the state of the object is not able to accept a StartDocument event, an exception is thrown.
WriteStartElement | Write a StartElement event. If state of the object is not able to accept a StartElement event, an exception is thrown.
WriteStartEntity | Write an event indicating the start of an entity reference. If the state of the object is not able to accept a writeStartEntity event, an exception is thrown.
WriteText | Write a text event. If state of the object is not able to accept a text event, an exception is thrown.

See Also

XmlEventWriter Class


XmlEventWriter Methods

[image] [image]

.NET Framework Class Library
XmlEventWriter Methods
XmlEventWriter Class See Also Send Feedback

The XmlEventWriter type exposes the following members.

Methods

Name | Description
Close | Complete the PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) operation, and free the resources associated with this object. This call must be made when you are done with this object.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteAttribute | Write an attribute to the event stream. If state of the object is not able to accept an attribute, an exception is thrown.
WriteDTD | Write a DTD (internal subset). If state of the object is not able to accept a DTD event, an exception is thrown.
WriteEndDocument | Write the EndDocument event.
WriteEndElement | Write an EndElement event. If state of the object is not able to accept a EndElement event, an exception is thrown.
WriteEndEntity | Write an event indicating the end of content expanded by an entity reference. If the state of the object is not able to accept a writeEndEntity event, an exception is thrown.
WriteProcessingInstruction | Write a ProcessingInstruction event. If state of the object is not able to accept a ProcessingInstruction event, an exception is thrown.
WriteStartDocument | Write the StartDocument event. If the state of the object is not able to accept a StartDocument event, an exception is thrown.
WriteStartElement | Write a StartElement event. If state of the object is not able to accept a StartElement event, an exception is thrown.
WriteStartEntity | Write an event indicating the start of an entity reference. If the state of the object is not able to accept a writeStartEntity event, an exception is thrown.
WriteText | Write a text event. If state of the object is not able to accept a text event, an exception is thrown.

See Also

XmlEventWriter Class


Close Method

[image]

.NET Framework Class Library
XmlEventWriter..::.Close Method
XmlEventWriter Class See Also Send Feedback

Complete the PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) operation, and free the resources associated with this object. This call must be made when you are done with this object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Close
C#
public abstract void Close()
Visual C++
public:
virtual void Close() abstract
JavaScript
function close();

See Also

XmlEventWriter Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlEventWriter..::.Dispose Method
XmlEventWriter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlEventWriter Class
XmlEventWriter Members


WriteAttribute Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteAttribute Method
XmlEventWriter Class See Also Send Feedback

Write an attribute to the event stream. If state of the object is not able to accept an attribute, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteAttribute ( _
    localName As String, _
    prefix As String, _
    uri As String, _
    strValue As String, _
    isSpecified As Boolean _
)
C#
public abstract void WriteAttribute(
    string localName,
    string prefix,
    string uri,
    string strValue,
    bool isSpecified
)
Visual C++
public:
virtual void WriteAttribute(
    String^ localName,
    String^ prefix,
    String^ uri,
    String^ strValue,
    bool isSpecified
) abstract
JavaScript
function writeAttribute(localName, prefix, uri, strValue, isSpecified);

Parameters

localName
Type: System..::.String
The localName of the attribute.
prefix
Type: System..::.String
The namespace prefix of the attribute,or NULL.
uri
Type: System..::.String
The namespace uri of the attribute,or NULL.
strValue
Type: System..::.String
The value of the attribute.
isSpecified
Type: System..::.Boolean
A boolean indicating whether the attribute is specified. in the document (vs defaulted)

See Also

XmlEventWriter Class


WriteDTD Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteDTD Method
XmlEventWriter Class See Also Send Feedback

Write a DTD (internal subset). If state of the object is not able to accept a DTD event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteDTD ( _
    dtd As String _
)
C#
public abstract void WriteDTD(
    string dtd
)
Visual C++
public:
virtual void WriteDTD(
    String^ dtd
) abstract
JavaScript
function writeDTD(dtd);

Parameters

dtd
Type: System..::.String
The DTD text.

Remarks

Note: the DTD is not parsed or used in any way by the system. It is stored as pure text in order to return it if the document is returned at a later time.

See Also

XmlEventWriter Class


WriteEndDocument Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteEndDocument Method
XmlEventWriter Class See Also Send Feedback

Write the EndDocument event.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteEndDocument
C#
public abstract void WriteEndDocument()
Visual C++
public:
virtual void WriteEndDocument() abstract
JavaScript
function writeEndDocument();

Remarks

If the state of the object is not able to accept a EndDocument event, an exception is thrown. This must be the last event written.

See Also

XmlEventWriter Class


WriteEndElement Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteEndElement Method
XmlEventWriter Class See Also Send Feedback

Write an EndElement event. If state of the object is not able to accept a EndElement event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteEndElement ( _
    localName As String, _
    prefix As String, _
    uri As String _
)
C#
public abstract void WriteEndElement(
    string localName,
    string prefix,
    string uri
)
Visual C++
public:
virtual void WriteEndElement(
    String^ localName,
    String^ prefix,
    String^ uri
) abstract
JavaScript
function writeEndElement(localName, prefix, uri);

Parameters

localName
Type: System..::.String
The localName of the element.
prefix
Type: System..::.String
The namespace prefix of the element.
uri
Type: System..::.String
The namespace uri of the element.

Remarks

This call must not be made for empty elements, as determined by the isEmpty parameter to WriteStartElement(String, String, String, Int32, Boolean).

See Also

XmlEventWriter Class


WriteEndEntity Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteEndEntity Method
XmlEventWriter Class See Also Send Feedback

Write an event indicating the end of content expanded by an entity reference. If the state of the object is not able to accept a writeEndEntity event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteEndEntity ( _
    name As String _
)
C#
public abstract void WriteEndEntity(
    string name
)
Visual C++
public:
virtual void WriteEndEntity(
    String^ name
) abstract
JavaScript
function writeEndEntity(name);

Parameters

name
Type: System..::.String
The entity reference text. E.g. if the entity reference is "&foo;" this value should be "foo".

Remarks

Most applications will not use this method. See the notes in WriteStartEntity(String, Boolean) for details.

See Also

XmlEventWriter Class


WriteProcessingInstruction Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteProcessingInstruction Method
XmlEventWriter Class See Also Send Feedback

Write a ProcessingInstruction event. If state of the object is not able to accept a ProcessingInstruction event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteProcessingInstruction ( _
    target As String, _
    data As String _
)
C#
public abstract void WriteProcessingInstruction(
    string target,
    string data
)
Visual C++
public:
virtual void WriteProcessingInstruction(
    String^ target,
    String^ data
) abstract
JavaScript
function writeProcessingInstruction(target, data);

Parameters

target
Type: System..::.String
The ProcessingInstruction target.
data
Type: System..::.String
The ProcessingInstruction data.

See Also

XmlEventWriter Class


WriteStartDocument Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteStartDocument Method
XmlEventWriter Class See Also Send Feedback

Write the StartDocument event. If the state of the object is not able to accept a StartDocument event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteStartDocument ( _
    version As String, _
    encoding As String, _
    standalone As String _
)
C#
public abstract void WriteStartDocument(
    string version,
    string encoding,
    string standalone
)
Visual C++
public:
virtual void WriteStartDocument(
    String^ version,
    String^ encoding,
    String^ standalone
) abstract
JavaScript
function writeStartDocument(version, encoding, standalone);

Parameters

version
Type: System..::.String
The XML version string ('1.0' or '1.1' typically).
encoding
Type: System..::.String
The encoding used by the document. This must be UTF-8 or a compatible subset, as all content is treated as UTF-8.
standalone
Type: System..::.String
Set to the desired value of 'yes' or 'no', or null.

Remarks

This must be the first event written. All parameters are optional and may be null, in which case, default values are assumed. If they are set, they will be returned in the document when it is retrieved.

See Also

XmlEventWriter Class


WriteStartElement Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteStartElement Method
XmlEventWriter Class See Also Send Feedback

Write a StartElement event. If state of the object is not able to accept a StartElement event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteStartElement ( _
    localName As String, _
    prefix As String, _
    uri As String, _
    numAttributes As Integer, _
    isEmpty As Boolean _
)
C#
public abstract void WriteStartElement(
    string localName,
    string prefix,
    string uri,
    int numAttributes,
    bool isEmpty
)
Visual C++
public:
virtual void WriteStartElement(
    String^ localName,
    String^ prefix,
    String^ uri,
    int numAttributes,
    bool isEmpty
) abstract
JavaScript
function writeStartElement(localName, prefix, uri, numAttributes, isEmpty);

Parameters

localName
Type: System..::.String
The localName of the element.
prefix
Type: System..::.String
The namespace prefix of the element.
uri
Type: System..::.String
The namespace uri of the element.
numAttributes
Type: System..::.Int32
The number of attributes the element has. This number is used to determine whether or not to accept calls to WriteAttribute(String, String, String, String, Boolean).
isEmpty
Type: System..::.Boolean
This is true if the element is empty (has neither child elements nor text content). If an element is noted as empty, the caller must not make a corresponding call to WriteEndElement(String, String, String).

See Also

XmlEventWriter Class


WriteStartEntity Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteStartEntity Method
XmlEventWriter Class See Also Send Feedback

Write an event indicating the start of an entity reference. If the state of the object is not able to accept a writeStartEntity event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteStartEntity ( _
    name As String, _
    expandedInfoFollows As Boolean _
)
C#
public abstract void WriteStartEntity(
    string name,
    bool expandedInfoFollows
)
Visual C++
public:
virtual void WriteStartEntity(
    String^ name,
    bool expandedInfoFollows
) abstract
JavaScript
function writeStartEntity(name, expandedInfoFollows);

Parameters

name
Type: System..::.String
The entity reference text. E.g. if the entity reference is "&foo;" this value should be "foo".
expandedInfoFollows
Type: System..::.Boolean
If the expanded entity text will follow as further events, set this boolean to true. This allows the writing of the entity reference alone, without the expanded content.

Remarks

Most applications will not use this method. In most cases, a caller will already have expanded entity content, and may not know that it came from an entity reference. In such cases, this event will never be written. If an application does know when expanded content starts and ends, BDB XML will accept that information, and maintain it, so that a document can be serialized back to its unexpanded form (just the entity reference itself). This event is used to note such information, and is used with WriteEndEntity(String) to track when entities start and end.

See Also

XmlEventWriter Class


WriteText Method

[image]

.NET Framework Class Library
XmlEventWriter..::.WriteText Method
XmlEventWriter Class See Also Send Feedback

Write a text event. If state of the object is not able to accept a text event, an exception is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub WriteText ( _
    type As XmlEventType, _
    text As String _
)
C#
public abstract void WriteText(
    XmlEventType type,
    string text
)
Visual C++
public:
virtual void WriteText(
    XmlEventType type,
    String^ text
) abstract
JavaScript
function writeText(type, text);

Parameters

type
Type: JanaBiz.DbXml..::.XmlEventType
The type of the event -- must be one of XmlEventReader::Characters, XmlEventReader::Whitespace, XmlEventReader::CDATA, or XmlEventReader::Comment.
text
Type: System..::.String
The text string value.

Remarks

This method is used for several event types, including Characters, CDATA, Comment, and Whitespace

See Also

XmlEventWriter Class


XmlEventWriterBase Class

[image]

.NET Framework Class Library
XmlEventWriterBase Class
Members See Also Send Feedback

The XmlEventWriter class enables applications to construct document content without using serialized XML.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlEventWriterBase _
    Inherits XmlEventWriter
C#
public abstract class XmlEventWriterBase : XmlEventWriter
Visual C++
public ref class XmlEventWriterBase abstract : public XmlEventWriter
JavaScript
JanaBiz.DbXml.XmlEventWriterBase = function();

Type.createClass(
    'JanaBiz.DbXml.XmlEventWriterBase',
    JanaBiz.DbXml.XmlEventWriter);

Remarks

allows use of application-provided parsers and other XML processing mechanisms. The XmlEventWriter is a push-style interface, with content written via explicit interfaces.

The XmlEventWriter maintains state based on information written, and an exception is thrown if an operation is performed that is not valid for the current state. All strings must be null-terminated const unsigned char * values encoded in UTF-8. The values are copied by the underlying implementation, as necessary. When a document is completed, the Close()()() method must be called to finalize the operation and release resources.

Used to create XML content as events rather than serialized text. You can obtain an instance of this object using one of PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) or GetContentAsEventWriter(XmlEventWriter) . It can also be used by XmlEventReaderToWriter.

Once you acquire an instance of this class, use its methods to write content, and when the document has been completed, call the Close()()() method to finish putting the document in the container. Some methods will do this implicitly. All text written must be encoded as UTF-8 or a subset.

Documents created in this manner are not subject to validation. This class allows applications to directly create content without involving a parser. It also allows use of an external parser to generate events that are pushed into BDB XML content

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlEventWriter
JanaBiz.DbXml..::.XmlEventWriterBase

See Also

XmlEventWriterBase Members


XmlEventWriterBase Members

[image] [image]

.NET Framework Class Library
XmlEventWriterBase Members
XmlEventWriterBase Class Constructors Methods See Also Send Feedback

The XmlEventWriterBase type exposes the following members.

Constructors

Name | Description
XmlEventWriterBase | Initializes the XmlEventWriter class.

Methods

Name | Description
Close | Complete the PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) operation, and free the resources associated with this object. This call must be made when you are done with this object. (Inherited from XmlEventWriter.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteAttribute | Write an attribute to the event stream. If state of the object is not able to accept an attribute, an exception is thrown. (Inherited from XmlEventWriter.)
WriteDTD | Write a DTD (internal subset). If state of the object is not able to accept a DTD event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteEndDocument | Write the EndDocument event. (Inherited from XmlEventWriter.)
WriteEndElement | Write an EndElement event. If state of the object is not able to accept a EndElement event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteEndEntity | Write an event indicating the end of content expanded by an entity reference. If the state of the object is not able to accept a writeEndEntity event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteProcessingInstruction | Write a ProcessingInstruction event. If state of the object is not able to accept a ProcessingInstruction event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartDocument | Write the StartDocument event. If the state of the object is not able to accept a StartDocument event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartElement | Write a StartElement event. If state of the object is not able to accept a StartElement event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartEntity | Write an event indicating the start of an entity reference. If the state of the object is not able to accept a writeStartEntity event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteText | Write a text event. If state of the object is not able to accept a text event, an exception is thrown. (Inherited from XmlEventWriter.)

See Also

XmlEventWriterBase Class


XmlEventWriterBase Constructor

[image]

.NET Framework Class Library
XmlEventWriterBase Constructor
XmlEventWriterBase Class See Also Send Feedback

Initializes the XmlEventWriter class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlEventWriterBase()
Visual C++
public:
XmlEventWriterBase()
JavaScript
JanaBiz.DbXml.XmlEventWriterBase = function();

See Also

XmlEventWriterBase Class


XmlEventWriterBase Methods

[image] [image]

.NET Framework Class Library
XmlEventWriterBase Methods
XmlEventWriterBase Class See Also Send Feedback

The XmlEventWriterBase type exposes the following members.

Methods

Name | Description
Close | Complete the PutDocumentAsEventWriter(XmlDocument, XmlUpdateContext) operation, and free the resources associated with this object. This call must be made when you are done with this object. (Inherited from XmlEventWriter.)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)
WriteAttribute | Write an attribute to the event stream. If state of the object is not able to accept an attribute, an exception is thrown. (Inherited from XmlEventWriter.)
WriteDTD | Write a DTD (internal subset). If state of the object is not able to accept a DTD event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteEndDocument | Write the EndDocument event. (Inherited from XmlEventWriter.)
WriteEndElement | Write an EndElement event. If state of the object is not able to accept a EndElement event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteEndEntity | Write an event indicating the end of content expanded by an entity reference. If the state of the object is not able to accept a writeEndEntity event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteProcessingInstruction | Write a ProcessingInstruction event. If state of the object is not able to accept a ProcessingInstruction event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartDocument | Write the StartDocument event. If the state of the object is not able to accept a StartDocument event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartElement | Write a StartElement event. If state of the object is not able to accept a StartElement event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteStartEntity | Write an event indicating the start of an entity reference. If the state of the object is not able to accept a writeStartEntity event, an exception is thrown. (Inherited from XmlEventWriter.)
WriteText | Write a text event. If state of the object is not able to accept a text event, an exception is thrown. (Inherited from XmlEventWriter.)

See Also

XmlEventWriterBase Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlEventWriterBase..::.Dispose Method
XmlEventWriterBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlEventWriterBase Class
XmlEventWriterBase Members


XmlExternalFunction Class

[image]

.NET Framework Class Library
XmlExternalFunction Class
Members See Also Send Feedback

The XmlExternalFunction class is used to implement XQuery extension functions in .NET Framework. An implementor creates a subclass of XmlExternalFunction and returns an instance of the class from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32). Returned instances may be singleton objects which means the application must eventually free the memory, or new instances in which case the instance should delete itself in its Close()()() method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlExternalFunction _
    Inherits InvocationHandle
C#
public abstract class XmlExternalFunction : InvocationHandle
Visual C++
public ref class XmlExternalFunction abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlExternalFunction = function();

Type.createClass(
    'JanaBiz.DbXml.XmlExternalFunction',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlExternalFunction
JanaBiz.DbXml..::.XmlExternalFunctionBase

See Also

XmlExternalFunction Members


XmlExternalFunction Members

[image] [image]

.NET Framework Class Library
XmlExternalFunction Members
XmlExternalFunction Class Methods See Also Send Feedback

The XmlExternalFunction type exposes the following members.

Methods

Name | Description
Close | This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | This method is called from within a query to execute the function for which the instance was implemented. It returns an XmlResults object used by the query for further processing.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlExternalFunction Class


XmlExternalFunction Methods

[image] [image]

.NET Framework Class Library
XmlExternalFunction Methods
XmlExternalFunction Class See Also Send Feedback

The XmlExternalFunction type exposes the following members.

Methods

Name | Description
Close | This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | This method is called from within a query to execute the function for which the instance was implemented. It returns an XmlResults object used by the query for further processing.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlExternalFunction Class


Close Method

[image]

.NET Framework Class Library
XmlExternalFunction..::.Close Method
XmlExternalFunction Class See Also Send Feedback

This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Sub Close
C#
public abstract void Close()
Visual C++
public:
virtual void Close() abstract
JavaScript
function close();

See Also

XmlExternalFunction Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlExternalFunction..::.Dispose Method
XmlExternalFunction Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlExternalFunction Class
XmlExternalFunction Members


Execute Method

[image]

.NET Framework Class Library
XmlExternalFunction..::.Execute Method
XmlExternalFunction Class See Also Send Feedback

This method is called from within a query to execute the function for which the instance was implemented. It returns an XmlResults object used by the query for further processing.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustOverride Function Execute ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    arguments As XmlArguments _
) As XmlResults
C#
public abstract XmlResults Execute(
    XmlTransaction transaction,
    XmlManager manager,
    XmlArguments arguments
)
Visual C++
public:
virtual XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    XmlArguments^ arguments
) abstract
JavaScript
function execute(transaction, manager, arguments);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
The XmlTransaction in which the operation is running.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager instance controlling the operation.
arguments
Type: JanaBiz.DbXml..::.XmlArguments
The XmlArguments object that can be used to retrieve the function arguments.

Return Value

An XmlResults object containing the results of executing the function on the given arguments.

See Also

XmlExternalFunction Class


XmlExternalFunctionBase Class

[image]

.NET Framework Class Library
XmlExternalFunctionBase Class
Members See Also Send Feedback

The XmlExternalFunction class is used to implement XQuery extension functions in .NET Framework. An implementor creates a subclass of XmlExternalFunction and returns an instance of the class from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32). Returned instances may be singleton objects which means the application must eventually free the memory, or new instances in which case the instance should delete itself in its Close()()() method.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlExternalFunctionBase _
    Inherits XmlExternalFunction
C#
public abstract class XmlExternalFunctionBase : XmlExternalFunction
Visual C++
public ref class XmlExternalFunctionBase abstract : public XmlExternalFunction
JavaScript
JanaBiz.DbXml.XmlExternalFunctionBase = function();

Type.createClass(
    'JanaBiz.DbXml.XmlExternalFunctionBase',
    JanaBiz.DbXml.XmlExternalFunction);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlExternalFunction
JanaBiz.DbXml..::.XmlExternalFunctionBase

See Also

XmlExternalFunctionBase Members


XmlExternalFunctionBase Members

[image] [image]

.NET Framework Class Library
XmlExternalFunctionBase Members
XmlExternalFunctionBase Class Constructors Methods See Also Send Feedback

The XmlExternalFunctionBase type exposes the following members.

Constructors

Name | Description
XmlExternalFunctionBase | Overloaded.

Methods

Name | Description
Close | This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks. (Overrides XmlExternalFunction..::.Close()()().)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | This method is called from within a query to execute the function for which the instance was implemented. It returns an XmlResults object used by the query for further processing. (Inherited from XmlExternalFunction.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlExternalFunctionBase Class


XmlExternalFunctionBase Constructor

[image] [image]

.NET Framework Class Library
XmlExternalFunctionBase Constructor
XmlExternalFunctionBase Class See Also Send Feedback

Overload List

Name | Description
XmlExternalFunctionBase()()() | Initializes a new instance of the XmlExternalFunctionBase class.
XmlExternalFunctionBase(IntPtr, Boolean) | Initializes a new instance of the XmlExternalFunctionBase class.

See Also

XmlExternalFunctionBase Class
XmlExternalFunctionBase Members


XmlExternalFunctionBase Constructor

[image]

.NET Framework Class Library
XmlExternalFunctionBase Constructor
XmlExternalFunctionBase Class See Also Send Feedback

Initializes a new instance of the XmlExternalFunctionBase class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected XmlExternalFunctionBase()
Visual C++
protected:
XmlExternalFunctionBase()
JavaScript
JanaBiz.DbXml.XmlExternalFunctionBase = function();

See Also

XmlExternalFunctionBase Class
XmlExternalFunctionBase Overload


XmlExternalFunctionBase Constructor (IntPtr, Boolean)

[image]

.NET Framework Class Library
XmlExternalFunctionBase Constructor (IntPtr, Boolean)
XmlExternalFunctionBase Class See Also Send Feedback

Initializes a new instance of the XmlExternalFunctionBase class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    handle As IntPtr, _
    handleOwned As Boolean _
)
C#
protected XmlExternalFunctionBase(
    IntPtr handle,
    bool handleOwned
)
Visual C++
protected:
XmlExternalFunctionBase(
    IntPtr handle,
    bool handleOwned
)
JavaScript
JanaBiz.DbXml.XmlExternalFunctionBase = function(handle, handleOwned);

Parameters

handle
Type: System..::.IntPtr
The handle.
handleOwned
Type: System..::.Boolean
if set to true [handle owned].

See Also

XmlExternalFunctionBase Class
XmlExternalFunctionBase Overload


XmlExternalFunctionBase Methods

[image] [image]

.NET Framework Class Library
XmlExternalFunctionBase Methods
XmlExternalFunctionBase Class See Also Send Feedback

The XmlExternalFunctionBase type exposes the following members.

Methods

Name | Description
Close | This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks. (Overrides XmlExternalFunction..::.Close()()().)
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | This method is called from within a query to execute the function for which the instance was implemented. It returns an XmlResults object used by the query for further processing. (Inherited from XmlExternalFunction.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlExternalFunctionBase Class


Close Method

[image]

.NET Framework Class Library
XmlExternalFunctionBase..::.Close Method
XmlExternalFunctionBase Class See Also Send Feedback

This method is called when the query has finished using the object. It allows the implementation to clean up if necessary. If a new instance of XmlExternalFunction is returned from ResolveExternalFunction(XmlTransaction, XmlManager, String, String, UInt32) then this method will probably need to delete itself to avoid memory leaks.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close
C#
public override void Close()
Visual C++
public:
virtual void Close() override
JavaScript
function close();

See Also

XmlExternalFunctionBase Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlExternalFunctionBase..::.Dispose Method
XmlExternalFunctionBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlExternalFunctionBase Class
XmlExternalFunctionBase Members


XmlIndexDeclaration Class

[image]

.NET Framework Class Library
XmlIndexDeclaration Class
Members See Also Send Feedback

An indexing strategy

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlIndexDeclaration _
    Inherits InvocationHandle
C#
public class XmlIndexDeclaration : InvocationHandle
Visual C++
public ref class XmlIndexDeclaration : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlIndexDeclaration = function();

Type.createClass(
    'JanaBiz.DbXml.XmlIndexDeclaration',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Returned by Find(String, String).

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlIndexDeclaration

See Also

XmlIndexDeclaration Members


XmlIndexDeclaration Members

[image] [image]

.NET Framework Class Library
XmlIndexDeclaration Members
XmlIndexDeclaration Class Methods Properties See Also Send Feedback

The XmlIndexDeclaration type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Index | A comma-separated list of strings that represent the indexing strategy.
Name | The name of the element or attribute node to be indexed.
Uri | The namespace of the node to be indexed.

See Also

XmlIndexDeclaration Class


XmlIndexDeclaration Methods

[image] [image]

.NET Framework Class Library
XmlIndexDeclaration Methods
XmlIndexDeclaration Class See Also Send Feedback

The XmlIndexDeclaration type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlIndexDeclaration Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlIndexDeclaration..::.Dispose Method
XmlIndexDeclaration Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlIndexDeclaration Class
XmlIndexDeclaration Members


XmlIndexDeclaration Properties

[image] [image]

.NET Framework Class Library
XmlIndexDeclaration Properties
XmlIndexDeclaration Class See Also Send Feedback

The XmlIndexDeclaration type exposes the following members.

Properties

Name | Description
Index | A comma-separated list of strings that represent the indexing strategy.
Name | The name of the element or attribute node to be indexed.
Uri | The namespace of the node to be indexed.

See Also

XmlIndexDeclaration Class


Index Property

[image]

.NET Framework Class Library
XmlIndexDeclaration..::.Index Property
XmlIndexDeclaration Class See Also Send Feedback

A comma-separated list of strings that represent the indexing strategy.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Index As String
C#
public string Index { get; }
Visual C++
public:
property String^ Index {
    String^ get ();
}
JavaScript
function get_index();

Remarks

The strings must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence, equality, or substring.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
             none
             anyURI
             base64Binary
             boolean
             date
             dateTime
             dayTimeDuration
             decimal
             double
             duration
             float
             gDay
             gMonth
             gMonthDay
             gYear
             gYearMonth
             hexBinary
             Notation
             QName
             string
             time
             yearMonthDuration
             untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

unique-node-element-presence node-element-equality-string edge-element-presence-none node-element-equality-float

See Also

XmlIndexDeclaration Class


Name Property

[image]

.NET Framework Class Library
XmlIndexDeclaration..::.Name Property
XmlIndexDeclaration Class See Also Send Feedback

The name of the element or attribute node to be indexed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}
JavaScript
function get_name();

See Also

XmlIndexDeclaration Class


Uri Property

[image]

.NET Framework Class Library
XmlIndexDeclaration..::.Uri Property
XmlIndexDeclaration Class See Also Send Feedback

The namespace of the node to be indexed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Uri As String
C#
public string Uri { get; }
Visual C++
public:
property String^ Uri {
    String^ get ();
}
JavaScript
function get_uri();

Remarks

The default namespace is selected by passing an empty string for the namespace.

See Also

XmlIndexDeclaration Class


XmlIndexLookup Class

[image]

.NET Framework Class Library
XmlIndexLookup Class
Members See Also Send Feedback

The XmlIndexLookup class encapsulates the context within which an index lookup operation can be performed on an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlIndexLookup _
    Inherits InvocationHandle
C#
public class XmlIndexLookup : InvocationHandle
Visual C++
public ref class XmlIndexLookup : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlIndexLookup = function();

Type.createClass(
    'JanaBiz.DbXml.XmlIndexLookup',
    JanaBiz.Bridge.InvocationHandle);

Remarks

The lookup is performed using an XmlIndexLookup object, and a series of methods of that object that specify how the lookup is to be performed. Using these methods, it is possible to specify inequality lookups, range lookups, and simple value lookups, as well as the sort order of the results. By default, results are returned in the sort order of the index.

XmlIndexLookup objects are created using CreateIndexLookup(XmlContainer, String, String, String).

XmlIndexLookup objects are not thread-safe, and may not be shared among threads while being configured. A constructed, read-only object may be shared among threads for multiple calls to Execute(XmlQueryContext).

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlIndexLookup

See Also

XmlIndexLookup Members


XmlIndexLookup Members

[image] [image]

.NET Framework Class Library
XmlIndexLookup Members
XmlIndexLookup Class Methods Properties See Also Send Feedback

The XmlIndexLookup type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
SetHighBound | Sets the operation and value to be used for the upper bound for a range index lookup operation.
SetLowBound | Sets the operation and value to be used for the index lookup operation.
SetNode | Sets the name of the node to be used along with the indexing strategy for the index lookup operation.
SetParent | Sets the name of the parent node to be used for an edge index lookup operation.
ToString | (Inherited from Object.)

Properties

Name | Description
HighBoundOperation | Gets the operation to be used for the upper bound for a range index lookup operation.
HighBoundValue | Gets the value to be used for the upper bound for a range index lookup operation.
Index | The indexing strategy to be used for the index lookup operation.
LowBoundOperation | Gets the operation to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.
LowBoundValue | Gets the value to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.
NodeName | Gets the name of the node to be used along with the indexing strategy for the index lookup operation.
NodeUri | Gets the uri of the node to be used along with the indexing strategy for the index lookup operation.
ParentName | Gets the name of the parent node to be used for an edge index lookup operation.
ParentUri | Gets the uri of the parent node to be used for an edge index lookup operation.
XmlContainer | The container on which the index lookup operation is to be performed.

See Also

XmlIndexLookup Class


XmlIndexLookup Methods

[image] [image]

.NET Framework Class Library
XmlIndexLookup Methods
XmlIndexLookup Class See Also Send Feedback

The XmlIndexLookup type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
SetHighBound | Sets the operation and value to be used for the upper bound for a range index lookup operation.
SetLowBound | Sets the operation and value to be used for the index lookup operation.
SetNode | Sets the name of the node to be used along with the indexing strategy for the index lookup operation.
SetParent | Sets the name of the parent node to be used for an edge index lookup operation.
ToString | (Inherited from Object.)

See Also

XmlIndexLookup Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlIndexLookup..::.Dispose Method
XmlIndexLookup Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlIndexLookup Class
XmlIndexLookup Members


Execute Method

[image] [image]

.NET Framework Class Library
XmlIndexLookup..::.Execute Method
XmlIndexLookup Class See Also Send Feedback

Overload List

Name | Description
Execute(XmlQueryContext) | Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.
Execute(XmlQueryContext, XmlDocumentConfig) | Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.
Execute(XmlTransaction, XmlQueryContext) | Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.
Execute(XmlTransaction, XmlQueryContext, XmlDocumentConfig) | Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.

See Also

XmlIndexLookup Class
XmlIndexLookup Members


Execute Method (XmlQueryContext)

[image]

.NET Framework Class Library
XmlIndexLookup..::.Execute Method (XmlQueryContext)
XmlIndexLookup Class See Also Send Feedback

Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    context As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlQueryContext context
)
Visual C++
public:
XmlResults^ Execute(
    XmlQueryContext^ context
)
JavaScript
function execute(context);

Parameters

context
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for the operation.

Return Value

Return the new XmlResults.

See Also

XmlIndexLookup Class
Execute Overload


Execute Method (XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlIndexLookup..::.Execute Method (XmlQueryContext, XmlDocumentConfig)
XmlIndexLookup Class See Also Send Feedback

Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    context As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlQueryContext context,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlQueryContext^ context,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(context, docConfig);

Parameters

context
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The XmlDocumentConfig object specifying configuration settings for this operation.

Return Value

Return the new XmlResults.

See Also

XmlIndexLookup Class
Execute Overload


Execute Method (XmlTransaction, XmlQueryContext)

[image]

.NET Framework Class Library
XmlIndexLookup..::.Execute Method (XmlTransaction, XmlQueryContext)
XmlIndexLookup Class See Also Send Feedback

Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    context As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlQueryContext context
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlQueryContext^ context
)
JavaScript
function execute(transaction, context);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
context
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for the operation.

Return Value

Return the new XmlResults.

See Also

XmlIndexLookup Class
Execute Overload


Execute Method (XmlTransaction, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlIndexLookup..::.Execute Method (XmlTransaction, XmlQueryContext, XmlDocumentConfig)
XmlIndexLookup Class See Also Send Feedback

Executes the index lookup operation specified by the configuration of the XmlIndexLookup object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    context As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlQueryContext context,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlQueryContext^ context,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(transaction, context, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
context
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for the operation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The XmlDocumentConfig object specifying configuration settings for this operation.

Return Value

Return the new XmlResults.

See Also

XmlIndexLookup Class
Execute Overload


SetHighBound Method

[image]

.NET Framework Class Library
XmlIndexLookup..::.SetHighBound Method
XmlIndexLookup Class See Also Send Feedback

Sets the operation and value to be used for the upper bound for a range index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetHighBound ( _
    value As XmlValue, _
    op As XmlIndexLookupOperation _
)
C#
public void SetHighBound(
    XmlValue value,
    XmlIndexLookupOperation op
)
Visual C++
public:
void SetHighBound(
    XmlValue^ value,
    XmlIndexLookupOperation op
)
JavaScript
function setHighBound(value, op);

Parameters

value
Type: JanaBiz.DbXml..::.XmlValue
The value to be used for the upper bound.
op
Type: JanaBiz.DbXml..::.XmlIndexLookupOperation
The operation to be used on the upper bound.

Remarks

The high bound must be specified to indicate a range lookup.

See Also

XmlIndexLookup Class


SetLowBound Method

[image]

.NET Framework Class Library
XmlIndexLookup..::.SetLowBound Method
XmlIndexLookup Class See Also Send Feedback

Sets the operation and value to be used for the index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetLowBound ( _
    value As XmlValue, _
    op As XmlIndexLookupOperation _
)
C#
public void SetLowBound(
    XmlValue value,
    XmlIndexLookupOperation op
)
Visual C++
public:
void SetLowBound(
    XmlValue^ value,
    XmlIndexLookupOperation op
)
JavaScript
function setLowBound(value, op);

Parameters

value
Type: JanaBiz.DbXml..::.XmlValue
The value to be used for the lower bound.
op
Type: JanaBiz.DbXml..::.XmlIndexLookupOperation
Selects the operation to be performed.

Remarks

If the operation is a simple inequality lookup, the lower bound is used as the single value and operation for the lookup. If the operation is a range lookup, in which an upper bound is specified, the lower bound is used as the lower boundary value and operation for the lookup.

See Also

XmlIndexLookup Class


SetNode Method

[image]

.NET Framework Class Library
XmlIndexLookup..::.SetNode Method
XmlIndexLookup Class See Also Send Feedback

Sets the name of the node to be used along with the indexing strategy for the index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetNode ( _
    uri As String, _
    name As String _
)
C#
public void SetNode(
    string uri,
    string name
)
Visual C++
public:
void SetNode(
    String^ uri,
    String^ name
)
JavaScript
function setNode(uri, name);

Parameters

uri
Type: System..::.String
The namespace of the node to be used.
name
Type: System..::.String
The name of the element or attribute node to be used.

See Also

XmlIndexLookup Class


SetParent Method

[image]

.NET Framework Class Library
XmlIndexLookup..::.SetParent Method
XmlIndexLookup Class See Also Send Feedback

Sets the name of the parent node to be used for an edge index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetParent ( _
    uri As String, _
    name As String _
)
C#
public void SetParent(
    string uri,
    string name
)
Visual C++
public:
void SetParent(
    String^ uri,
    String^ name
)
JavaScript
function setParent(uri, name);

Parameters

uri
Type: System..::.String
The namespace of the parent node to be used.
name
Type: System..::.String
The name of the parent element node to be used.

Remarks

If the index is not an edge index, this configuration is ignored.

See Also

XmlIndexLookup Class


XmlIndexLookup Properties

[image] [image]

.NET Framework Class Library
XmlIndexLookup Properties
XmlIndexLookup Class See Also Send Feedback

The XmlIndexLookup type exposes the following members.

Properties

Name | Description
HighBoundOperation | Gets the operation to be used for the upper bound for a range index lookup operation.
HighBoundValue | Gets the value to be used for the upper bound for a range index lookup operation.
Index | The indexing strategy to be used for the index lookup operation.
LowBoundOperation | Gets the operation to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.
LowBoundValue | Gets the value to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.
NodeName | Gets the name of the node to be used along with the indexing strategy for the index lookup operation.
NodeUri | Gets the uri of the node to be used along with the indexing strategy for the index lookup operation.
ParentName | Gets the name of the parent node to be used for an edge index lookup operation.
ParentUri | Gets the uri of the parent node to be used for an edge index lookup operation.
XmlContainer | The container on which the index lookup operation is to be performed.

See Also

XmlIndexLookup Class


HighBoundOperation Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.HighBoundOperation Property
XmlIndexLookup Class See Also Send Feedback

Gets the operation to be used for the upper bound for a range index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HighBoundOperation As XmlIndexLookupOperation
C#
public XmlIndexLookupOperation HighBoundOperation { get; }
Visual C++
public:
property XmlIndexLookupOperation HighBoundOperation {
    XmlIndexLookupOperation get ();
}
JavaScript
function get_highBoundOperation();

Return Value

Return the XmlIndexLookup.

See Also

XmlIndexLookup Class


HighBoundValue Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.HighBoundValue Property
XmlIndexLookup Class See Also Send Feedback

Gets the value to be used for the upper bound for a range index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HighBoundValue As XmlValue
C#
public XmlValue HighBoundValue { get; }
Visual C++
public:
property XmlValue^ HighBoundValue {
    XmlValue^ get ();
}
JavaScript
function get_highBoundValue();

Return Value

Return the new XmlValue.

See Also

XmlIndexLookup Class


Index Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.Index Property
XmlIndexLookup Class See Also Send Feedback

The indexing strategy to be used for the index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property Index As String
C#
public string Index { get; set; }
Visual C++
public:
property String^ Index {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_index();
function set_index(value);

Remarks

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

See Also

XmlIndexLookup Class


LowBoundOperation Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.LowBoundOperation Property
XmlIndexLookup Class See Also Send Feedback

Gets the operation to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LowBoundOperation As XmlIndexLookupOperation
C#
public XmlIndexLookupOperation LowBoundOperation { get; }
Visual C++
public:
property XmlIndexLookupOperation LowBoundOperation {
    XmlIndexLookupOperation get ();
}
JavaScript
function get_lowBoundOperation();

Return Value

Return the XmlIndexLookup_GetLowBoundOperation.

See Also

XmlIndexLookup Class


LowBoundValue Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.LowBoundValue Property
XmlIndexLookup Class See Also Send Feedback

Gets the value to be used for the lower bound for a range index lookup operation, or the single operation for a simple inequality lookup.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LowBoundValue As XmlValue
C#
public XmlValue LowBoundValue { get; }
Visual C++
public:
property XmlValue^ LowBoundValue {
    XmlValue^ get ();
}
JavaScript
function get_lowBoundValue();

Return Value

Return the new XmlValue.

See Also

XmlIndexLookup Class


NodeName Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.NodeName Property
XmlIndexLookup Class See Also Send Feedback

Gets the name of the node to be used along with the indexing strategy for the index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NodeName As String
C#
public string NodeName { get; }
Visual C++
public:
property String^ NodeName {
    String^ get ();
}
JavaScript
function get_nodeName();

Return Value

Return the XmlIndexLookup

See Also

XmlIndexLookup Class


NodeUri Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.NodeUri Property
XmlIndexLookup Class See Also Send Feedback

Gets the uri of the node to be used along with the indexing strategy for the index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NodeUri As String
C#
public string NodeUri { get; }
Visual C++
public:
property String^ NodeUri {
    String^ get ();
}
JavaScript
function get_nodeUri();

Return Value

Return the XmlIndexLookup

See Also

XmlIndexLookup Class


ParentName Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.ParentName Property
XmlIndexLookup Class See Also Send Feedback

Gets the name of the parent node to be used for an edge index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentName As String
C#
public string ParentName { get; }
Visual C++
public:
property String^ ParentName {
    String^ get ();
}
JavaScript
function get_parentName();

Return Value

Return the XmlIndexLookup

See Also

XmlIndexLookup Class


ParentUri Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.ParentUri Property
XmlIndexLookup Class See Also Send Feedback

Gets the uri of the parent node to be used for an edge index lookup operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParentUri As String
C#
public string ParentUri { get; }
Visual C++
public:
property String^ ParentUri {
    String^ get ();
}
JavaScript
function get_parentUri();

Return Value

Return the XmlIndexLookup

See Also

XmlIndexLookup Class


XmlContainer Property

[image]

.NET Framework Class Library
XmlIndexLookup..::.XmlContainer Property
XmlIndexLookup Class See Also Send Feedback

The container on which the index lookup operation is to be performed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property XmlContainer As XmlContainer
C#
public XmlContainer XmlContainer { get; set; }
Visual C++
public:
property XmlContainer^ XmlContainer {
    XmlContainer^ get ();
    void set (XmlContainer^ value);
}
JavaScript
function get_xmlContainer();
function set_xmlContainer(value);

See Also

XmlIndexLookup Class


XmlIndexLookupOperation Enumeration

[image]

.NET Framework Class Library
XmlIndexLookupOperation Enumeration
See Also Send Feedback

The operation to be used on the upper bound.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlIndexLookupOperation
C#
public enum XmlIndexLookupOperation
Visual C++
public enum class XmlIndexLookupOperation
JavaScript
JanaBiz.DbXml.XmlIndexLookupOperation = function();
JanaBiz.DbXml.XmlIndexLookupOperation.createEnum('JanaBiz.DbXml.XmlIndexLookupOperation', false);

Members

Member name | Description
None | Empty/no operation
Equal | Operation equal (==)
GreaterThan | Operation greater than (>)
GreaterThanOrEqual | Operation greater than or equal (>=)
LessThan | Operation less than (<)
LessThanOrEqual | Operation less than or equal (<=)

See Also


XmlIndexSpecification Class

[image]

.NET Framework Class Library
XmlIndexSpecification Class
Members See Also Send Feedback

The XmlIndexSpecification class encapsulates the indexing specification of a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlIndexSpecification _
    Inherits InvocationHandle _
    Implements IEnumerator
C#
public class XmlIndexSpecification : InvocationHandle,
    IEnumerator
Visual C++
public ref class XmlIndexSpecification : public InvocationHandle,
    IEnumerator
JavaScript
JanaBiz.DbXml.XmlIndexSpecification = function();

Type.createClass(
    'JanaBiz.DbXml.XmlIndexSpecification',
    JanaBiz.Bridge.InvocationHandle,
    IEnumerator);

Remarks

An indexing specification can be retrieved with the GetIndexSpecification()()() method, and modified using the SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext) method.

The XmlIndexSpecification class provides an interface for manipulating the indexing specification through the AddIndex(String, String, String), DeleteIndex(String, String, String), and ReplaceIndex(String, String, String) methods. The class interface also provides the MoveNext()()(),Current and Reset()()() methods for iterating through the specified indices. The Find(String, String) method can be used to search for the indexing strategy for a known node.

Finally, you can set a default index specification for a container using AddDefaultIndex(String). You can replace and delete the default index using ReplaceDefaultIndex(String) and DeleteDefaultIndex(String).

Note that adding an index to a container results in re-indexing all of the documents in that container, which can take a very long time. It is good practice to design an application to add useful indices before populating a container.

A copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlIndexSpecification

See Also

XmlIndexSpecification Members


XmlIndexSpecification Members

[image] [image]

.NET Framework Class Library
XmlIndexSpecification Members
XmlIndexSpecification Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlIndexSpecification type exposes the following members.

Methods

Name | Description
AddDefaultIndex | Overloaded.
AddIndex | Overloaded.
DeleteDefaultIndex | Overloaded.
DeleteIndex | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
Find | Returns the indexing strategies for a named document or metadata node.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
ReplaceDefaultIndex | Overloaded.
ReplaceIndex | Overloaded.
Reset | Resets the index specification iterator to the beginning of the index list.
ToString | (Inherited from Object.)

Properties

Name | Description
AutoIndexing | Gets or sets the state of automatic indexing to the specified value. The change will not have any effect unless SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext) is called with this object.
Current | コレクション内の現在の要素を取得します。
DefaultIndex | Retrieves the default index.

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlIndexSpecification Class


XmlIndexSpecification Methods

[image] [image]

.NET Framework Class Library
XmlIndexSpecification Methods
XmlIndexSpecification Class See Also Send Feedback

The XmlIndexSpecification type exposes the following members.

Methods

Name | Description
AddDefaultIndex | Overloaded.
AddIndex | Overloaded.
DeleteDefaultIndex | Overloaded.
DeleteIndex | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
Find | Returns the indexing strategies for a named document or metadata node.
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
ReplaceDefaultIndex | Overloaded.
ReplaceIndex | Overloaded.
Reset | Resets the index specification iterator to the beginning of the index list.
ToString | (Inherited from Object.)

See Also

XmlIndexSpecification Class


AddDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.AddDefaultIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
AddDefaultIndex(String) | Adds a single indexing strategy to the default index
AddDefaultIndex(XmlIndexSpecificationType, XmlValueType) | Adds an indexing strategy to the default index specification.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


AddDefaultIndex Method (String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.AddDefaultIndex Method (String)
XmlIndexSpecification Class See Also Send Feedback

Adds a single indexing strategy to the default index

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDefaultIndex ( _
    index As String _
)
C#
public void AddDefaultIndex(
    string index
)
Visual C++
public:
void AddDefaultIndex(
    String^ index
)
JavaScript
function addDefaultIndex(index);

Parameters

index
Type: System..::.String
///

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

See Also

XmlIndexSpecification Class
AddDefaultIndex Overload


AddDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.AddDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Adds an indexing strategy to the default index specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddDefaultIndex ( _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void AddDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void AddDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function addDefaultIndex(type, syntax);

Parameters

type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

Remarks

That is, the index provided on this method is applied to all nodes in a container, except for those for which an explicit index is already declared.

See Also

XmlIndexSpecification Class
AddDefaultIndex Overload


AddIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.AddIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
AddIndex(String, String, String) | Adds an index to the index specification.
AddIndex(String, String, XmlIndexSpecificationType, XmlValueType) | Identifies an indexing strategy to set for the identified node.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


AddIndex Method (String, String, String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.AddIndex Method (String, String, String)
XmlIndexSpecification Class See Also Send Feedback

Adds an index to the index specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    uri As String, _
    name As String, _
    index As String _
)
C#
public void AddIndex(
    string uri,
    string name,
    string index
)
Visual C++
public:
void AddIndex(
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function addIndex(uri, name, index);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

Remarks

You then set the index specification using SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext).

You identify the indexing strategy that you want to add to the index specification in one of two ways. The first way is to provide a string that identifies the desired indexing strategy. The second is to use XmlIndexSpecification and XmlValue constants to identify the same information.

See Also

XmlIndexSpecification Class
AddIndex Overload


AddIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.AddIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Identifies an indexing strategy to set for the identified node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub AddIndex ( _
    uri As String, _
    name As String, _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void AddIndex(
    string uri,
    string name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void AddIndex(
    String^ uri,
    String^ name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function addIndex(uri, name, type, syntax);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of XmlIndexSpecificationType values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

Remarks

The strategy is set using enumeration values for the index and the syntax.

See Also

XmlIndexSpecification Class
AddIndex Overload


DeleteDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteDefaultIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
DeleteDefaultIndex(String) | Deletes one or more indexing strategies to the default index.
DeleteDefaultIndex(XmlIndexSpecificationType, XmlValueType) | Delete the identified index from the default index specification.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


DeleteDefaultIndex Method (String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteDefaultIndex Method (String)
XmlIndexSpecification Class See Also Send Feedback

Deletes one or more indexing strategies to the default index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDefaultIndex ( _
    index As String _
)
C#
public void DeleteDefaultIndex(
    string index
)
Visual C++
public:
void DeleteDefaultIndex(
    String^ index
)
JavaScript
function deleteDefaultIndex(index);

Parameters

index
Type: System..::.String
A comma-separated list of strings that represent the indexing strategy.

See Also

XmlIndexSpecification Class
DeleteDefaultIndex Overload


DeleteDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Delete the identified index from the default index specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteDefaultIndex ( _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void DeleteDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void DeleteDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function deleteDefaultIndex(type, syntax);

Parameters

type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

Remarks

You can add additional indices to the default index specification using AddDefaultIndex(String).

See Also

XmlIndexSpecification Class
DeleteDefaultIndex Overload


DeleteIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
DeleteIndex(String, String, String) | Deletes indexing strategies for a named document or metadata node.
DeleteIndex(String, String, XmlIndexSpecificationType, XmlValueType) | Deletes a single index strategy from the identified node.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


DeleteIndex Method (String, String, String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteIndex Method (String, String, String)
XmlIndexSpecification Class See Also Send Feedback

Deletes indexing strategies for a named document or metadata node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteIndex ( _
    uri As String, _
    name As String, _
    index As String _
)
C#
public void DeleteIndex(
    string uri,
    string name,
    string index
)
Visual C++
public:
void DeleteIndex(
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function deleteIndex(uri, name, index);

Parameters

uri
Type: System..::.String
The namespace of the node for which you want the index deleted.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String
///

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

Remarks

To delete an index set for metadata, specify the URI and name used when the metadata was added to the document.

See Also

XmlIndexSpecification Class
DeleteIndex Overload


DeleteIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.DeleteIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Deletes a single index strategy from the identified node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DeleteIndex ( _
    uri As String, _
    name As String, _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void DeleteIndex(
    string uri,
    string name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void DeleteIndex(
    String^ uri,
    String^ name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function deleteIndex(uri, name, type, syntax);

Parameters

uri
Type: System..::.String
The namespace of the node for which you want the index deleted.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

See Also

XmlIndexSpecification Class
DeleteIndex Overload


Dispose Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.Dispose Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


Find Method

[image]

.NET Framework Class Library
XmlIndexSpecification..::.Find Method
XmlIndexSpecification Class See Also Send Feedback

Returns the indexing strategies for a named document or metadata node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Find ( _
    uri As String, _
    name As String _
) As XmlIndexDeclaration
C#
public XmlIndexDeclaration Find(
    string uri,
    string name
)
Visual C++
public:
XmlIndexDeclaration^ Find(
    String^ uri,
    String^ name
)
JavaScript
function find(uri, name);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.

Return Value

Return the indexing strategies for a named document or metadata node.

Remarks

This method returns trueTruetruetrue (True in Visual Basic) if an index for the node is found; otherwise, it returns falseFalsefalsefalse (False in Visual Basic).

See Also

XmlIndexSpecification Class


MoveNext Method

[image]

.NET Framework Class Library
XmlIndexSpecification..::.MoveNext Method
XmlIndexSpecification Class See Also Send Feedback

列挙子をコレクションの次の要素に進めます。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveNext As Boolean
C#
public bool MoveNext()
Visual C++
public:
virtual bool MoveNext() sealed
JavaScript
function moveNext();

Return Value

列挙子が次の要素に正常に進んだ場合は trueTruetruetrue (True in Visual Basic)。列挙子がコレクションの末尾を越えた場合は falseFalsefalsefalse (False in Visual Basic)。

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が作成された後に、コレクションが変更されました。

See Also

XmlIndexSpecification Class


ReplaceDefaultIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceDefaultIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
ReplaceDefaultIndex(String) | Identifies one or more indexing strategies to set for the default index.
ReplaceDefaultIndex(XmlIndexSpecificationType, XmlValueType) | Replaces the default indexing strategy for the container.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


ReplaceDefaultIndex Method (String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceDefaultIndex Method (String)
XmlIndexSpecification Class See Also Send Feedback

Identifies one or more indexing strategies to set for the default index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceDefaultIndex ( _
    index As String _
)
C#
public void ReplaceDefaultIndex(
    string index
)
Visual C++
public:
void ReplaceDefaultIndex(
    String^ index
)
JavaScript
function replaceDefaultIndex(index);

Parameters

index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

Remarks

The strategies are identified as a space-separated listing of strings.

See Also

XmlIndexSpecification Class
ReplaceDefaultIndex Overload


ReplaceDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceDefaultIndex Method (XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Replaces the default indexing strategy for the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceDefaultIndex ( _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void ReplaceDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void ReplaceDefaultIndex(
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function replaceDefaultIndex(type, syntax);

Parameters

type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

Remarks

The default index specification is used for all nodes in a document. You can add additional indices for specific document nodes using AddIndex(String, String, String).

See Also

XmlIndexSpecification Class
ReplaceDefaultIndex Overload


ReplaceIndex Method

[image] [image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceIndex Method
XmlIndexSpecification Class See Also Send Feedback

Overload List

Name | Description
ReplaceIndex(String, String, String) | Replaces the indexing strategies for a named document or metadata node.
ReplaceIndex(String, String, XmlIndexSpecificationType, XmlValueType) | Replaces the indexing strategies for a named document or metadata node.

See Also

XmlIndexSpecification Class
XmlIndexSpecification Members


ReplaceIndex Method (String, String, String)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceIndex Method (String, String, String)
XmlIndexSpecification Class See Also Send Feedback

Replaces the indexing strategies for a named document or metadata node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceIndex ( _
    uri As String, _
    name As String, _
    index As String _
)
C#
public void ReplaceIndex(
    string uri,
    string name,
    string index
)
Visual C++
public:
void ReplaceIndex(
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function replaceIndex(uri, name, index);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

Remarks

All existing indexing strategies for that node are deleted, and the indexing strategy identified by this method is set for the node.

Identifies one or more indexing strategies to set for the identified node. The strategies are identified using a space-separated listing of strings.

See Also

XmlIndexSpecification Class
ReplaceIndex Overload


ReplaceIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)

[image]

.NET Framework Class Library
XmlIndexSpecification..::.ReplaceIndex Method (String, String, XmlIndexSpecificationType, XmlValueType)
XmlIndexSpecification Class See Also Send Feedback

Replaces the indexing strategies for a named document or metadata node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReplaceIndex ( _
    uri As String, _
    name As String, _
    type As XmlIndexSpecificationType, _
    syntax As XmlValueType _
)
C#
public void ReplaceIndex(
    string uri,
    string name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
Visual C++
public:
void ReplaceIndex(
    String^ uri,
    String^ name,
    XmlIndexSpecificationType type,
    XmlValueType syntax
)
JavaScript
function replaceIndex(uri, name, type, syntax);

Parameters

uri
Type: System..::.String
The namespace of the node to be indexed.
name
Type: System..::.String
The name of the element or attribute node to be indexed.
type
Type: JanaBiz.DbXml..::.XmlIndexSpecificationType
A series of values bitwise OR'd together to form the index strategy.
syntax
Type: JanaBiz.DbXml..::.XmlValueType
Identifies the type of information being indexed.

Remarks

All existing indexing strategies for that node are deleted, and the indexing strategy identified by this method is set for the node.

See Also

XmlIndexSpecification Class
ReplaceIndex Overload


Reset Method

[image]

.NET Framework Class Library
XmlIndexSpecification..::.Reset Method
XmlIndexSpecification Class See Also Send Feedback

Resets the index specification iterator to the beginning of the index list.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset
C#
public void Reset()
Visual C++
public:
virtual void Reset() sealed
JavaScript
function reset();

Implements

IEnumerator..::.Reset()()()

Remarks

Use MoveNext()()() to iterate through the indices contained in the index specification.

See Also

XmlIndexSpecification Class


XmlIndexSpecification Properties

[image] [image]

.NET Framework Class Library
XmlIndexSpecification Properties
XmlIndexSpecification Class See Also Send Feedback

The XmlIndexSpecification type exposes the following members.

Properties

Name | Description
AutoIndexing | Gets or sets the state of automatic indexing to the specified value. The change will not have any effect unless SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext) is called with this object.
Current | コレクション内の現在の要素を取得します。
DefaultIndex | Retrieves the default index.

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlIndexSpecification Class


IEnumerator.Current Property

[image]

.NET Framework Class Library
XmlIndexSpecification..::.IEnumerator..::.Current Property
XmlIndexSpecification Class See Also Send Feedback

コレクション内の現在の要素を取得します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
C#
Object IEnumerator.Current { get; }
Visual C++
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
JavaScript
JavaScript does not support explicit interface implementations.

Field Value

Implements

IEnumerator..::.Current

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が、コレクションの最初の要素の前、または最後の要素の後に位置しています。

See Also

XmlIndexSpecification Class


AutoIndexing Property

[image]

.NET Framework Class Library
XmlIndexSpecification..::.AutoIndexing Property
XmlIndexSpecification Class See Also Send Feedback

Gets or sets the state of automatic indexing to the specified value. The change will not have any effect unless SetIndexSpecification(XmlIndexSpecification, XmlUpdateContext) is called with this object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AutoIndexing As Boolean
C#
public bool AutoIndexing { get; set; }
Visual C++
public:
property bool AutoIndexing {
    bool get ();
    void set (bool value);
}
JavaScript
function get_autoIndexing();
function set_autoIndexing(value);

See Also

XmlIndexSpecification Class


Current Property

[image]

.NET Framework Class Library
XmlIndexSpecification..::.Current Property
XmlIndexSpecification Class See Also Send Feedback

コレクション内の現在の要素を取得します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As XmlIndexDeclaration
C#
public XmlIndexDeclaration Current { get; }
Visual C++
public:
property XmlIndexDeclaration^ Current {
    XmlIndexDeclaration^ get ();
}
JavaScript
function get_current();

Field Value

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が、コレクションの最初の要素の前、または最後の要素の後に位置しています。

See Also

XmlIndexSpecification Class


DefaultIndex Property

[image]

.NET Framework Class Library
XmlIndexSpecification..::.DefaultIndex Property
XmlIndexSpecification Class See Also Send Feedback

Retrieves the default index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DefaultIndex As String
C#
public string DefaultIndex { get; }
Visual C++
public:
property String^ DefaultIndex {
    String^ get ();
}
JavaScript
function get_defaultIndex();

Return Value

Remarks

The default index is the index used by all nodes in the document in the absence of any other index.

See Also

XmlIndexSpecification Class


XmlIndexSpecificationType Enumeration

[image]

.NET Framework Class Library
XmlIndexSpecificationType Enumeration
Example See Also Send Feedback

A series of XmlIndexSpecificationType values bitwise OR'd together to form the index strategy.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration XmlIndexSpecificationType
C#
[FlagsAttribute]
public enum XmlIndexSpecificationType
Visual C++
[FlagsAttribute]
public enum class XmlIndexSpecificationType
JavaScript
JanaBiz.DbXml.XmlIndexSpecificationType = function();
JanaBiz.DbXml.XmlIndexSpecificationType.createEnum('JanaBiz.DbXml.XmlIndexSpecificationType', true);

Members

Member name | Description
UniqueOff | The indexed value need not be unique container-wide.
UniqueOn | The indexed value must be unique container-wide.
PathNone | No node type.
PathNode | Node path type.
PathEdge | Edge path type.
NodeNone | No node type.
NodeElement | Element node type.
NodeAttribute | Attribute node type.
NodeMetaData | Metadata node type.
KeyNone | No key type.
KeyPresence | Presence key type.
KeyEquality | Equality key type.
KeySubstring | Substring key type.

Remarks

Note that if XmlIndexSpecificationType.NodeMetaData is used, then XmlIndexSpecificationType.PathNode must also be used as well.

Examples

For example:

XmlIndexSpecificationType.PathNode | XmlIndexSpecificationType.NodeElement | XmlIndexSpecificationType.KeySubstring

See Also


XmlInputStream Class

[image]

.NET Framework Class Library
XmlInputStream Class
Members See Also Send Feedback

Used to read and write XML data.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlInputStream _
    Inherits InvocationHandle
C#
public class XmlInputStream : InvocationHandle
Visual C++
public ref class XmlInputStream : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlInputStream = function();

Type.createClass(
    'JanaBiz.DbXml.XmlInputStream',
    JanaBiz.Bridge.InvocationHandle);

Remarks

You can obtain an instance of this object using one of CreateLocalFileInputStream(String), CreateInputStream(Stream), CreateStandardInputStream()()(), CreateURLInputStream(String, String), or StreamContent. You use instances of this class with PutDocument(String, String, XmlUpdateContext) and StreamContent.

You can manually retrieve the contents of the input stream using ReadBytes(array<Byte>[]()[], Int32) and CurrentPosition.

XmlInputStream is a pure virtual interface. In C++, you can subclass XmlInputStream, and pass an instance of your class to any of the methods that take it as a parameter, such as PutDocument(String, String, XmlUpdateContext). This is especially useful for streaming XML from an application directly into Berkeley DB XML without first converting it to a string.

Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent. If the input stream is passed to either of these methods, it will be adopted, and deleted. If it is not passed, it is the responsibility of the user to delete the object.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlInputStream

See Also

XmlInputStream Members


XmlInputStream Members

[image] [image]

.NET Framework Class Library
XmlInputStream Members
XmlInputStream Class Methods Properties See Also Send Feedback

The XmlInputStream type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ReadBytes | Reads maxToRead number of bytes from the input stream and places those bytes in toFill.
ToString | (Inherited from Object.)

Properties

Name | Description
Adopted | Gets a value indicating whether this XmlInputStream is adopted.
CurrentPosition | Returns the number of bytes currently read from the beginning of the input stream.

See Also

XmlInputStream Class


XmlInputStream Methods

[image] [image]

.NET Framework Class Library
XmlInputStream Methods
XmlInputStream Class See Also Send Feedback

The XmlInputStream type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ReadBytes | Reads maxToRead number of bytes from the input stream and places those bytes in toFill.
ToString | (Inherited from Object.)

See Also

XmlInputStream Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlInputStream..::.Dispose Method
XmlInputStream Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlInputStream Class
XmlInputStream Members


ReadBytes Method

[image]

.NET Framework Class Library
XmlInputStream..::.ReadBytes Method
XmlInputStream Class See Also Send Feedback

Reads maxToRead number of bytes from the input stream and places those bytes in toFill.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ReadBytes ( _
    toFill As Byte(), _
    maxToRead As Integer _
) As Integer
C#
public virtual int ReadBytes(
    byte[] toFill,
    int maxToRead
)
Visual C++
public:
virtual int ReadBytes(
    array<unsigned char>^ toFill,
    int maxToRead
)
JavaScript
function readBytes(toFill, maxToRead);

Parameters

toFill
Type: array< System..::.Byte >[]()[]
Specifies a pointer to a buffer used to place the bytes read from the input stream.
maxToRead
Type: System..::.Int32
Identifies the maximum number of bytes to read from the input stream.

Return Value

The number of bytes read, or 0 if the end of the stream has been reached.

Remarks

Returns the number of bytes read, or 0 if the end of the stream has been reached.

See Also

XmlInputStream Class


XmlInputStream Properties

[image] [image]

.NET Framework Class Library
XmlInputStream Properties
XmlInputStream Class See Also Send Feedback

The XmlInputStream type exposes the following members.

Properties

Name | Description
Adopted | Gets a value indicating whether this XmlInputStream is adopted.
CurrentPosition | Returns the number of bytes currently read from the beginning of the input stream.

See Also

XmlInputStream Class


Adopted Property

[image]

.NET Framework Class Library
XmlInputStream..::.Adopted Property
XmlInputStream Class See Also Send Feedback

Gets a value indicating whether this XmlInputStream is adopted.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adopted As Boolean
C#
public bool Adopted { get; }
Visual C++
public:
property bool Adopted {
    bool get ();
}
JavaScript
function get_adopted();

Field Value

trueTruetruetrue (True in Visual Basic) if adopted; otherwise, flase.

See Also

XmlInputStream Class


CurrentPosition Property

[image]

.NET Framework Class Library
XmlInputStream..::.CurrentPosition Property
XmlInputStream Class See Also Send Feedback

Returns the number of bytes currently read from the beginning of the input stream.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property CurrentPosition As Integer
C#
public virtual int CurrentPosition { get; }
Visual C++
public:
virtual property int CurrentPosition {
    int get ();
}
JavaScript
function get_currentPosition();

Return Value

The number of bytes currently read from the beginning of the input stream.

See Also

XmlInputStream Class


XmlManager Class

[image]

.NET Framework Class Library
XmlManager Class
Members See Also Send Feedback

Provides a high-level object used to manage various aspects of Berkeley DB XML usage.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlManager _
    Inherits InvocationHandle
C#
public class XmlManager : InvocationHandle
Visual C++
public ref class XmlManager : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlManager = function();

Type.createClass(
    'JanaBiz.DbXml.XmlManager',
    JanaBiz.Bridge.InvocationHandle);

Remarks

An XmlManager object is used to perform activities such as container management (including creation and open), preparing XQuery queries, executing one-off queries, creating transaction objects, creating update and query context objects, and creating input streams.

A copy constructor is provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

Once Dispose()()() or Close()()() is called, this object may not be accessed again, regardless of whether or not it throws an exception.

This object is free threaded, and can be safely shared among threads in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlManager

See Also

XmlManager Members


XmlManager Members

[image] [image]

.NET Framework Class Library
XmlManager Members
XmlManager Class Constructors Methods Properties See Also Send Feedback

The XmlManager type exposes the following members.

Constructors

Name | Description
XmlManager | Overloaded.

Methods

Name | Description
Close | Close the XmlManager, freeing any allocated resources and closing any underlying subsystems.
CompactContainer | Overloaded.
CreateContainer | Overloaded.
CreateDocument | Instantiate a XmlDocument object.
CreateIndexLookup | Overloaded.
CreateInputStream | Returns a XmlInputStream for the Stream.
CreateLocalFileInputStream | Returns a XmlInputStream to the file filename.
CreateQueryContext | Overloaded.
CreateResults | Instantiates an new, empty XmlResults object.
CreateStandardInputStream | Returns an XmlInputStream to the console.
CreateTransaction | Overloaded.
CreateUpdateContext | Instantiates a new, default, XmlUpdateContext object
CreateURLInputStream | Overloaded.
Dispose | Overloaded.
DumpContainer | Dumps the contents of the specified container to the specified output stream. The container can be reconstructed by a call to LoadContainer(String, String, XmlUpdateContext).
Equals | (Inherited from Object.)
ExistsContainer | See if a container exists. Returns the format version if it is a valid container.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LoadContainer | Loads data from the specified file into the container.
MemberwiseClone | (Inherited from Object.)
OpenContainer | Overloaded.
Prepare | Overloaded.
Query | Overloaded.
RegisterCompression | Identifies by name an XmlCompression object to be used for compression. This object is used to compress document data before it is stored in the database and to decompress it after it is retrieved from the database. The registered compression will be used for data in any container that is created using an XmlContainerConfig object that has the compression name set as the registered name. When a container is created with user defined compression whenever it is opened again the user defined compression must be registered under the same name or the attempt to open the container will fail.
RegisterResolver | Identifies an XmlResolver object to be used for file resolution.
ReindexContainer | Overloaded.
RemoveContainer | Overloaded.
RenameContainer | Overloaded.
SetLogCategory | Enable or disable a category of log messages.
SetLogLevel | Enable or disable log messages of a given level of importance.
ToString | (Inherited from Object.)
TruncateContainer | Overloaded.
UpgradeContainer | Upgrades the container from a previous version of Berkeley DB XML, or Berkeley DB, to the current version.
VerifyContainer | Overloaded.

Properties

Name | Description
Config | The configuration object for this XmlManager instance.
DbEnvironment | Returns the DbEnvironment object for the XmlManager.
DefaultCompressionName | Gets or sets the name of the default compression algorithm used by containers. If the compression algorithm is users implemented then it must be registered with the XmlManager using the given name using the function RegisterCompression(String, XmlCompression).
DefaultContainerConfig | The default flags used for containers opened and created by this XmlManager object.
DefaultContainerType | The default type used for containers opened and created by this XmlManager object.
DefaultPageSize | The size of the pages used to store documents in the database.
DefaultSequenceIncrement | The integer increment to be used when pre-allocating document ids for new documents
Home | Returns the home directory for the underlying database environment.
ImplicitTimezone | Gets the implicit timezone to be used for XQuery expressions, in offset in minutes from GMT and Sets the implicit timezone to be used for queries referring to dates and times in the context of the XmlManager.
Version | Gets the Berkeley DB XML release number.
VersionMajor | Gets the release's major version number.
VersionMinor | Gets the release's minor version number.
VersionPatch | Gets the release's patch version number.

See Also

XmlManager Class


XmlManager Constructor

[image] [image]

.NET Framework Class Library
XmlManager Constructor
XmlManager Class See Also Send Feedback

Overload List

Name | Description
XmlManager()()() | Creates a new XmlManager instance.
XmlManager(DbEnvironment) | Initializes a new instance of the XmlManager class.
XmlManager(XmlManagerConfig) | Creates a new XmlManager instance.
XmlManager(DbEnvironment, XmlManagerConfig) | Creates a new XmlManager instance.

See Also

XmlManager Class
XmlManager Members


XmlManager Constructor

[image]

.NET Framework Class Library
XmlManager Constructor
XmlManager Class See Also Send Feedback

Creates a new XmlManager instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlManager()
Visual C++
public:
XmlManager()
JavaScript
JanaBiz.DbXml.XmlManager = function();

Remarks

Constructor that uses a private internal database environment. No external processes can join the environment, but the XmlManager object can be shared between threads within the opening process.

Note that for this form of the constructor, the environment home is located in either the current working directory, or in the directory identified by the Home variable.

See Also

XmlManager Class
XmlManager Overload


XmlManager Constructor (DbEnvironment)

[image]

.NET Framework Class Library
XmlManager Constructor (DbEnvironment)
XmlManager Class See Also Send Feedback

Initializes a new instance of the XmlManager class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    environment As DbEnvironment _
)
C#
public XmlManager(
    DbEnvironment environment
)
Visual C++
public:
XmlManager(
    DbEnvironment^ environment
)
JavaScript
JanaBiz.DbXml.XmlManager = function(environment);

Parameters

environment
Type: JanaBiz.Db..::.DbEnvironment
The environment handle to use for the underlying database environment. The handle provided here must be opened.

Remarks

Constructor that uses a private internal database environment. No external processes can join the environment, but the XmlManager object can be shared between threads within the opening process.

Note that for this form of the constructor, the environment home is located in either the current working directory, or in the directory identified by the Home variable.

See Also

XmlManager Class
XmlManager Overload


XmlManager Constructor (XmlManagerConfig)

[image]

.NET Framework Class Library
XmlManager Constructor (XmlManagerConfig)
XmlManager Class See Also Send Feedback

Creates a new XmlManager instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    config As XmlManagerConfig _
)
C#
public XmlManager(
    XmlManagerConfig config
)
Visual C++
public:
XmlManager(
    XmlManagerConfig^ config
)
JavaScript
JanaBiz.DbXml.XmlManager = function(config);

Parameters

config
Type: JanaBiz.DbXml..::.XmlManagerConfig
The configuration settings for this XmlManager instance.

Remarks

Constructor that uses a private internal database environment. No external processes can join the environment, but the XmlManager object can be shared between threads within the opening process.

Note that for this form of the constructor, the environment home is located in either the current working directory, or in the directory identified by the Home variable.

See Also

XmlManager Class
XmlManager Overload


XmlManager Constructor (DbEnvironment, XmlManagerConfig)

[image]

.NET Framework Class Library
XmlManager Constructor (DbEnvironment, XmlManagerConfig)
XmlManager Class See Also Send Feedback

Creates a new XmlManager instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    environment As DbEnvironment, _
    config As XmlManagerConfig _
)
C#
public XmlManager(
    DbEnvironment environment,
    XmlManagerConfig config
)
Visual C++
public:
XmlManager(
    DbEnvironment^ environment,
    XmlManagerConfig^ config
)
JavaScript
JanaBiz.DbXml.XmlManager = function(environment, config);

Parameters

environment
Type: JanaBiz.Db..::.DbEnvironment
The environment handle to use for the underlying database environment. The handle provided here must be opened.
config
Type: JanaBiz.DbXml..::.XmlManagerConfig
The configuration settings for this XmlManager instance.

Remarks

Constructor that uses a private internal database environment. No external processes can join the environment, but the XmlManager object can be shared between threads within the opening process.

Note that for this form of the constructor, the environment home is located in either the current working directory, or in the directory identified by the Home variable.

See Also

XmlManager Class
XmlManager Overload


XmlManager Methods

[image] [image]

.NET Framework Class Library
XmlManager Methods
XmlManager Class See Also Send Feedback

The XmlManager type exposes the following members.

Methods

Name | Description
Close | Close the XmlManager, freeing any allocated resources and closing any underlying subsystems.
CompactContainer | Overloaded.
CreateContainer | Overloaded.
CreateDocument | Instantiate a XmlDocument object.
CreateIndexLookup | Overloaded.
CreateInputStream | Returns a XmlInputStream for the Stream.
CreateLocalFileInputStream | Returns a XmlInputStream to the file filename.
CreateQueryContext | Overloaded.
CreateResults | Instantiates an new, empty XmlResults object.
CreateStandardInputStream | Returns an XmlInputStream to the console.
CreateTransaction | Overloaded.
CreateUpdateContext | Instantiates a new, default, XmlUpdateContext object
CreateURLInputStream | Overloaded.
Dispose | Overloaded.
DumpContainer | Dumps the contents of the specified container to the specified output stream. The container can be reconstructed by a call to LoadContainer(String, String, XmlUpdateContext).
Equals | (Inherited from Object.)
ExistsContainer | See if a container exists. Returns the format version if it is a valid container.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
LoadContainer | Loads data from the specified file into the container.
MemberwiseClone | (Inherited from Object.)
OpenContainer | Overloaded.
Prepare | Overloaded.
Query | Overloaded.
RegisterCompression | Identifies by name an XmlCompression object to be used for compression. This object is used to compress document data before it is stored in the database and to decompress it after it is retrieved from the database. The registered compression will be used for data in any container that is created using an XmlContainerConfig object that has the compression name set as the registered name. When a container is created with user defined compression whenever it is opened again the user defined compression must be registered under the same name or the attempt to open the container will fail.
RegisterResolver | Identifies an XmlResolver object to be used for file resolution.
ReindexContainer | Overloaded.
RemoveContainer | Overloaded.
RenameContainer | Overloaded.
SetLogCategory | Enable or disable a category of log messages.
SetLogLevel | Enable or disable log messages of a given level of importance.
ToString | (Inherited from Object.)
TruncateContainer | Overloaded.
UpgradeContainer | Upgrades the container from a previous version of Berkeley DB XML, or Berkeley DB, to the current version.
VerifyContainer | Overloaded.

See Also

XmlManager Class


Close Method

[image]

.NET Framework Class Library
XmlManager..::.Close Method
XmlManager Class See Also Send Feedback

Close the XmlManager, freeing any allocated resources and closing any underlying subsystems.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Close
C#
public void Close()
Visual C++
public:
void Close()
JavaScript
function close();

See Also

XmlManager Class


CompactContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CompactContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CompactContainer(String, XmlUpdateContext) | Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.
CompactContainer(XmlTransaction, String, XmlUpdateContext) | Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

See Also

XmlManager Class
XmlManager Members


CompactContainer Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.CompactContainer Method (String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompactContainer ( _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void CompactContainer(
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void CompactContainer(
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function compactContainer(name, updateContext);

Parameters

name
Type: System..::.String
The name of the container to be compacted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext

See Also

XmlManager Class
CompactContainer Overload


CompactContainer Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.CompactContainer Method (XmlTransaction, String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CompactContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void CompactContainer(
    XmlTransaction transaction,
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void CompactContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function compactContainer(transaction, name, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the container to be compacted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext

See Also

XmlManager Class
CompactContainer Overload


CreateContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CreateContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CreateContainer(String) | Creates and opens a container, returning a handle to an XmlContainer object.
CreateContainer(XmlTransaction, String) | Creates and opens a container in the context of a transaction, returning a handle to an XmlContainer object.
CreateContainer(String, XmlContainerConfig) | Creates a container, returning a handle to an XmlContainer object.
CreateContainer(XmlTransaction, String, XmlContainerConfig) | Creates a container in the scope of a transaction, returning a handle to an XmlContainer object.

See Also

XmlManager Class
XmlManager Members


CreateContainer Method (String)

[image]

.NET Framework Class Library
XmlManager..::.CreateContainer Method (String)
XmlManager Class See Also Send Feedback

Creates and opens a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateContainer ( _
    name As String _
) As XmlContainer
C#
public XmlContainer CreateContainer(
    string name
)
Visual C++
public:
XmlContainer^ CreateContainer(
    String^ name
)
JavaScript
function createContainer(name);

Parameters

name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.

Return Value

Remarks

If the container already exists at the time this method is called, an exception is thrown. The container is set up to use node-level storage unless DefaultContainerType has been set.

Use OpenContainer(String) to open a container that has already been created.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
CreateContainer Overload


CreateContainer Method (XmlTransaction, String)

[image]

.NET Framework Class Library
XmlManager..::.CreateContainer Method (XmlTransaction, String)
XmlManager Class See Also Send Feedback

Creates and opens a container in the context of a transaction, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateContainer ( _
    transaction As XmlTransaction, _
    name As String _
) As XmlContainer
C#
public XmlContainer CreateContainer(
    XmlTransaction transaction,
    string name
)
Visual C++
public:
XmlContainer^ CreateContainer(
    XmlTransaction^ transaction,
    String^ name
)
JavaScript
function createContainer(transaction, name);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
The transaction handle to use for this container creation.
name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.

Return Value

Remarks

If the container already exists at the time this method is called, an exception is thrown. The container is set up to use node-level storage unless DefaultContainerType has been set.

Use OpenContainer(String) to open a container that has already been created.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
CreateContainer Overload


CreateContainer Method (String, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.CreateContainer Method (String, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Creates a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateContainer ( _
    name As String, _
    containerConfig As XmlContainerConfig _
) As XmlContainer
C#
public XmlContainer CreateContainer(
    string name,
    XmlContainerConfig containerConfig
)
Visual C++
public:
XmlContainer^ CreateContainer(
    String^ name,
    XmlContainerConfig^ containerConfig
)
JavaScript
function createContainer(name, containerConfig);

Parameters

name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
The configuration settings for the container.

Return Value

Remarks

If the container already exists at the time this method is called, an exception is thrown. The container is set up to use node-level storage unless DefaultContainerType has been set.

Use OpenContainer(String) to open a container that has already been created.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
CreateContainer Overload


CreateContainer Method (XmlTransaction, String, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.CreateContainer Method (XmlTransaction, String, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Creates a container in the scope of a transaction, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    containerConfig As XmlContainerConfig _
) As XmlContainer
C#
public XmlContainer CreateContainer(
    XmlTransaction transaction,
    string name,
    XmlContainerConfig containerConfig
)
Visual C++
public:
XmlContainer^ CreateContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlContainerConfig^ containerConfig
)
JavaScript
function createContainer(transaction, name, containerConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
The transaction handle to use for this container creation.
name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
The configuration settings for the container.

Return Value

Remarks

If the container already exists at the time this method is called, an exception is thrown. The container is set up to use node-level storage unless DefaultContainerType has been set.

Use OpenContainer(String) to open a container that has already been created.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
CreateContainer Overload


CreateDocument Method

[image]

.NET Framework Class Library
XmlManager..::.CreateDocument Method
XmlManager Class See Also Send Feedback

Instantiate a XmlDocument object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateDocument As XmlDocument
C#
public XmlDocument CreateDocument()
Visual C++
public:
XmlDocument^ CreateDocument()
JavaScript
function createDocument();

Return Value

See Also

XmlManager Class


CreateIndexLookup Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CreateIndexLookup Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CreateIndexLookup(XmlContainer, String, String, String) | Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.
CreateIndexLookup(XmlContainer, String, String, String, XmlIndexLookupOperation) | Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.
CreateIndexLookup(XmlContainer, String, String, String, XmlValue) | Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.
CreateIndexLookup(XmlContainer, String, String, String, XmlValue, XmlIndexLookupOperation) | Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.

See Also

XmlManager Class
XmlManager Members


CreateIndexLookup Method (XmlContainer, String, String, String)

[image]

.NET Framework Class Library
XmlManager..::.CreateIndexLookup Method (XmlContainer, String, String, String)
XmlManager Class See Also Send Feedback

Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateIndexLookup ( _
    container As XmlContainer, _
    uri As String, _
    name As String, _
    index As String _
) As XmlIndexLookup
C#
public XmlIndexLookup CreateIndexLookup(
    XmlContainer container,
    string uri,
    string name,
    string index
)
Visual C++
public:
XmlIndexLookup^ CreateIndexLookup(
    XmlContainer^ container,
    String^ uri,
    String^ name,
    String^ index
)
JavaScript
function createIndexLookup(container, uri, name, index);

Parameters

container
Type: JanaBiz.DbXml..::.XmlContainer
The target container for the lookup operation.
uri
Type: System..::.String
The namespace of the node to be used. The default namespace is selected by passing a null string.
name
Type: System..::.String
The name of the element or attribute node to be used.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

Return Value

Remarks

The constructed object can be further configured, and used with the Execute(XmlQueryContext) method to perform the lookup operation.

See Also

XmlManager Class
CreateIndexLookup Overload


CreateIndexLookup Method (XmlContainer, String, String, String, XmlIndexLookupOperation)

[image]

.NET Framework Class Library
XmlManager..::.CreateIndexLookup Method (XmlContainer, String, String, String, XmlIndexLookupOperation)
XmlManager Class See Also Send Feedback

Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateIndexLookup ( _
    container As XmlContainer, _
    uri As String, _
    name As String, _
    index As String, _
    op As XmlIndexLookupOperation _
) As XmlIndexLookup
C#
public XmlIndexLookup CreateIndexLookup(
    XmlContainer container,
    string uri,
    string name,
    string index,
    XmlIndexLookupOperation op
)
Visual C++
public:
XmlIndexLookup^ CreateIndexLookup(
    XmlContainer^ container,
    String^ uri,
    String^ name,
    String^ index,
    XmlIndexLookupOperation op
)
JavaScript
function createIndexLookup(container, uri, name, index, op);

Parameters

container
Type: JanaBiz.DbXml..::.XmlContainer
The target container for the lookup operation.
uri
Type: System..::.String
The namespace of the node to be used. The default namespace is selected by passing a null string.
name
Type: System..::.String
The name of the element or attribute node to be used.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

op
Type: JanaBiz.DbXml..::.XmlIndexLookupOperation
The comparison operation to be performed. See XmlIndexLookup for valid operations.

Return Value

Remarks

The constructed object can be further configured, and used with the Execute(XmlQueryContext) method to perform the lookup operation.

See Also

XmlManager Class
CreateIndexLookup Overload


CreateIndexLookup Method (XmlContainer, String, String, String, XmlValue)

[image]

.NET Framework Class Library
XmlManager..::.CreateIndexLookup Method (XmlContainer, String, String, String, XmlValue)
XmlManager Class See Also Send Feedback

Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateIndexLookup ( _
    container As XmlContainer, _
    uri As String, _
    name As String, _
    index As String, _
    xmlValue As XmlValue _
) As XmlIndexLookup
C#
public XmlIndexLookup CreateIndexLookup(
    XmlContainer container,
    string uri,
    string name,
    string index,
    XmlValue xmlValue
)
Visual C++
public:
XmlIndexLookup^ CreateIndexLookup(
    XmlContainer^ container,
    String^ uri,
    String^ name,
    String^ index,
    XmlValue^ xmlValue
)
JavaScript
function createIndexLookup(container, uri, name, index, xmlValue);

Parameters

container
Type: JanaBiz.DbXml..::.XmlContainer
The target container for the lookup operation.
uri
Type: System..::.String
The namespace of the node to be used. The default namespace is selected by passing a null string.
name
Type: System..::.String
The name of the element or attribute node to be used.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

xmlValue
Type: JanaBiz.DbXml..::.XmlValue
The value to be used as the single value for an equality or inequality lookup, or as the lower bound of a range lookup. An empty value is specified using an uninitialized XmlValue object.

Return Value

Remarks

The constructed object can be further configured, and used with the Execute(XmlQueryContext) method to perform the lookup operation.

See Also

XmlManager Class
CreateIndexLookup Overload


CreateIndexLookup Method (XmlContainer, String, String, String, XmlValue, XmlIndexLookupOperation)

[image]

.NET Framework Class Library
XmlManager..::.CreateIndexLookup Method (XmlContainer, String, String, String, XmlValue, XmlIndexLookupOperation)
XmlManager Class See Also Send Feedback

Returns a XmlIndexLookup object that can be executed to perform and index lookup on a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateIndexLookup ( _
    container As XmlContainer, _
    uri As String, _
    name As String, _
    index As String, _
    xmlValue As XmlValue, _
    op As XmlIndexLookupOperation _
) As XmlIndexLookup
C#
public XmlIndexLookup CreateIndexLookup(
    XmlContainer container,
    string uri,
    string name,
    string index,
    XmlValue xmlValue,
    XmlIndexLookupOperation op
)
Visual C++
public:
XmlIndexLookup^ CreateIndexLookup(
    XmlContainer^ container,
    String^ uri,
    String^ name,
    String^ index,
    XmlValue^ xmlValue,
    XmlIndexLookupOperation op
)
JavaScript
function createIndexLookup(container, uri, name, index, xmlValue, op);

Parameters

container
Type: JanaBiz.DbXml..::.XmlContainer
The target container for the lookup operation.
uri
Type: System..::.String
The namespace of the node to be used. The default namespace is selected by passing a null string.
name
Type: System..::.String
The name of the element or attribute node to be used.
index
Type: System..::.String

Identifies the index to be used for the lookup operation. The value supplied here must be a valid index. See AddIndex(String, String, String) for a description of valid index specifications, with the exceptions that only one index can be specified, and substring indexes are not supported.

A string that represents the indexing strategy. The string must contain the following information in the following order:

Copy Code
unique-{path type}-{node type}-{key type}-{syntax}

where:

unique indicates that the indexed value is unique in the container. If this keyword does not appear on the index string, then the indexed value is not required to be unique in the container.

{path type} is either node or edge.

{node type} is one of element, attribute, or metadata. If metadata is specified, then {path type} must be node.

{key type} is one of presence or equality.

{syntax} identifies the type of information being indexed. It must be one of the following values:

Copy Code
            none
            anyURI
            base64Binary
            boolean
            date
            dateTime
            dayTimeDuration
            decimal
            double
            duration
            float
            gDay
            gMonth
            gMonthDay
            gYear
            gYearMonth
            hexBinary
            Notation
            QName
            string
            time
            yearMonthDuration
            untypedAtomic

Note that if {key type} is presence, then {syntax} must be none or simply not specified.

For example, examples index strings are:

Copy Code
unique-node-element-presence

Copy Code
node-element-equality-string

Copy Code
node-attribute-equality-decimal

Copy Code
edge-element-presence-none

xmlValue
Type: JanaBiz.DbXml..::.XmlValue
The value to be used as the single value for an equality or inequality lookup, or as the lower bound of a range lookup. An empty value is specified using an uninitialized XmlValue object.
op
Type: JanaBiz.DbXml..::.XmlIndexLookupOperation
The comparison operation to be performed. See XmlIndexLookup for valid operations.

Return Value

Remarks

The constructed object can be further configured, and used with the Execute(XmlQueryContext) method to perform the lookup operation.

See Also

XmlManager Class
CreateIndexLookup Overload


CreateInputStream Method

[image]

.NET Framework Class Library
XmlManager..::.CreateInputStream Method
XmlManager Class See Also Send Feedback

Returns a XmlInputStream for the Stream.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateInputStream ( _
    stream As Stream _
) As XmlInputStream
C#
public XmlInputStream CreateInputStream(
    Stream stream
)
Visual C++
public:
XmlInputStream^ CreateInputStream(
    Stream^ stream
)
JavaScript
function createInputStream(stream);

Parameters

stream
Type: System.IO..::.Stream
A Stream from which the XmlInputStream should be created.

Return Value

Remarks

Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent.

The input stream must be passed to one of these methods, or the underlying memory will leak. It cannot be deleted from Java code. Note that there is no attempt to ensure that the file referenced contains well-formed or valid XML. Exceptions may be thrown at the time that this input stream is actually read if the stream does not contain well-formed, or valid XML.

See Also

XmlManager Class


CreateLocalFileInputStream Method

[image]

.NET Framework Class Library
XmlManager..::.CreateLocalFileInputStream Method
XmlManager Class See Also Send Feedback

Returns a XmlInputStream to the file filename.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateLocalFileInputStream ( _
    fileName As String _
) As XmlInputStream
C#
public XmlInputStream CreateLocalFileInputStream(
    string fileName
)
Visual C++
public:
XmlInputStream^ CreateLocalFileInputStream(
    String^ fileName
)
JavaScript
function createLocalFileInputStream(fileName);

Parameters

fileName
Type: System..::.String
The file to which you want an input stream formed.

Return Value

Remarks

Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent.

The input stream must be passed to one of these methods, or the underlying memory will leak. It cannot be deleted from Java code. Note that there is no attempt to ensure that the file referenced contains well-formed or valid XML. Exceptions may be thrown at the time that this input stream is actually read if the stream does not contain well-formed, or valid XML.

See Also

XmlManager Class


CreateQueryContext Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CreateQueryContext Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CreateQueryContext()()() | Creates a new XmlQueryContext object.
CreateQueryContext(XmlQueryContextEvaluationType) | Creates a new XmlQueryContext object.
CreateQueryContext(XmlQueryContextReturnType) | Creates a new XmlQueryContext object. From version 2.4.13 DeadValues is no longer used, always LiveValues
CreateQueryContext(XmlQueryContextReturnType, XmlQueryContextEvaluationType) | Creates a new XmlQueryContext object.

See Also

XmlManager Class
XmlManager Members


CreateQueryContext Method

[image]

.NET Framework Class Library
XmlManager..::.CreateQueryContext Method
XmlManager Class See Also Send Feedback

Creates a new XmlQueryContext object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateQueryContext As XmlQueryContext
C#
public XmlQueryContext CreateQueryContext()
Visual C++
public:
XmlQueryContext^ CreateQueryContext()
JavaScript
function createQueryContext();

Return Value

See Also

XmlManager Class
CreateQueryContext Overload


CreateQueryContext Method (XmlQueryContextEvaluationType)

[image]

.NET Framework Class Library
XmlManager..::.CreateQueryContext Method (XmlQueryContextEvaluationType)
XmlManager Class See Also Send Feedback

Creates a new XmlQueryContext object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateQueryContext ( _
    evaluationType As XmlQueryContextEvaluationType _
) As XmlQueryContext
C#
public XmlQueryContext CreateQueryContext(
    XmlQueryContextEvaluationType evaluationType
)
Visual C++
public:
XmlQueryContext^ CreateQueryContext(
    XmlQueryContextEvaluationType evaluationType
)
JavaScript
function createQueryContext(evaluationType);

Parameters

evaluationType
Type: JanaBiz.DbXml..::.XmlQueryContextEvaluationType
The evaluation type must be specified as either: Eager or Lazy.

Return Value

See Also

XmlManager Class
CreateQueryContext Overload


CreateQueryContext Method (XmlQueryContextReturnType)

[image]

.NET Framework Class Library
XmlManager..::.CreateQueryContext Method (XmlQueryContextReturnType)
XmlManager Class See Also Send Feedback

Creates a new XmlQueryContext object. From version 2.4.13 DeadValues is no longer used, always LiveValues

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateQueryContext ( _
    returnType As XmlQueryContextReturnType _
) As XmlQueryContext
C#
public XmlQueryContext CreateQueryContext(
    XmlQueryContextReturnType returnType
)
Visual C++
public:
XmlQueryContext^ CreateQueryContext(
    XmlQueryContextReturnType returnType
)
JavaScript
function createQueryContext(returnType);

Parameters

returnType
Type: JanaBiz.DbXml..::.XmlQueryContextReturnType
Specifies whether to return live or dead values: LiveValues or DeadValues

Return Value

See Also

XmlManager Class
CreateQueryContext Overload


CreateQueryContext Method (XmlQueryContextReturnType, XmlQueryContextEvaluationType)

[image]

.NET Framework Class Library
XmlManager..::.CreateQueryContext Method (XmlQueryContextReturnType, XmlQueryContextEvaluationType)
XmlManager Class See Also Send Feedback

Creates a new XmlQueryContext object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateQueryContext ( _
    returnType As XmlQueryContextReturnType, _
    evaluationType As XmlQueryContextEvaluationType _
) As XmlQueryContext
C#
public XmlQueryContext CreateQueryContext(
    XmlQueryContextReturnType returnType,
    XmlQueryContextEvaluationType evaluationType
)
Visual C++
public:
XmlQueryContext^ CreateQueryContext(
    XmlQueryContextReturnType returnType,
    XmlQueryContextEvaluationType evaluationType
)
JavaScript
function createQueryContext(returnType, evaluationType);

Parameters

returnType
Type: JanaBiz.DbXml..::.XmlQueryContextReturnType
Specifies whether to return live or dead values: LiveValues or DeadValues
evaluationType
Type: JanaBiz.DbXml..::.XmlQueryContextEvaluationType
The evaluation type must be specified as either: Eager or Lazy.

Return Value

See Also

XmlManager Class
CreateQueryContext Overload


CreateResults Method

[image]

.NET Framework Class Library
XmlManager..::.CreateResults Method
XmlManager Class See Also Send Feedback

Instantiates an new, empty XmlResults object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateResults As XmlResults
C#
public XmlResults CreateResults()
Visual C++
public:
XmlResults^ CreateResults()
JavaScript
function createResults();

Return Value

Remarks

You can then use Add(XmlValue) to add XmlValue objects to this result set.

See Also

XmlManager Class


CreateStandardInputStream Method

[image]

.NET Framework Class Library
XmlManager..::.CreateStandardInputStream Method
XmlManager Class See Also Send Feedback

Returns an XmlInputStream to the console.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateStandardInputStream As XmlInputStream
C#
public XmlInputStream CreateStandardInputStream()
Visual C++
public:
XmlInputStream^ CreateStandardInputStream()
JavaScript
function createStandardInputStream();

Return Value

Remarks

Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent.

If the input stream is passed to either of these methods, it will be adopted, and deleted. If it is not passed, it is the responsibility of the user to delete the object.

See Also

XmlManager Class


CreateTransaction Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CreateTransaction Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CreateTransaction()()() | Creates a new XmlTransaction object by adopting the provided transaction handle.
CreateTransaction(DbTransaction) | Creates a new XmlTransaction object by adopting the provided transaction handle.
CreateTransaction(XmlTransactionConfig) | Creates a new XmlTransaction object.

See Also

XmlManager Class
XmlManager Members


CreateTransaction Method

[image]

.NET Framework Class Library
XmlManager..::.CreateTransaction Method
XmlManager Class See Also Send Feedback

Creates a new XmlTransaction object by adopting the provided transaction handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTransaction As XmlTransaction
C#
public XmlTransaction CreateTransaction()
Visual C++
public:
XmlTransaction^ CreateTransaction()
JavaScript
function createTransaction();

Return Value

Remarks

If transactions were not initialized when this XmlManager object was opened then this method throws an exception.

See Also

XmlManager Class
CreateTransaction Overload


CreateTransaction Method (DbTransaction)

[image]

.NET Framework Class Library
XmlManager..::.CreateTransaction Method (DbTransaction)
XmlManager Class See Also Send Feedback

Creates a new XmlTransaction object by adopting the provided transaction handle.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTransaction ( _
    dbTransaction As DbTransaction _
) As XmlTransaction
C#
public XmlTransaction CreateTransaction(
    DbTransaction dbTransaction
)
Visual C++
public:
XmlTransaction^ CreateTransaction(
    DbTransaction^ dbTransaction
)
JavaScript
function createTransaction(dbTransaction);

Parameters

dbTransaction
Type: JanaBiz.Db..::.DbTransaction
A transaction handle to adopt. If the returned XmlTransaction is not committed or aborted, the state of the underlying transaction is left unchanged. This allows a transaction to be controlled external to its XmlTransaction

Return Value

Remarks

If transactions were not initialized when this XmlManager object was opened then this method throws an exception.

See Also

XmlManager Class
CreateTransaction Overload


CreateTransaction Method (XmlTransactionConfig)

[image]

.NET Framework Class Library
XmlManager..::.CreateTransaction Method (XmlTransactionConfig)
XmlManager Class See Also Send Feedback

Creates a new XmlTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateTransaction ( _
    transactionConfig As XmlTransactionConfig _
) As XmlTransaction
C#
public XmlTransaction CreateTransaction(
    XmlTransactionConfig transactionConfig
)
Visual C++
public:
XmlTransaction^ CreateTransaction(
    XmlTransactionConfig^ transactionConfig
)
JavaScript
function createTransaction(transactionConfig);

Parameters

transactionConfig
Type: JanaBiz.DbXml..::.XmlTransactionConfig
The configuration object to use for transaction creation.

Return Value

Remarks

If transactions were not initialized when this XmlManager object was opened then this method throws an exception.

See Also

XmlManager Class
CreateTransaction Overload


CreateUpdateContext Method

[image]

.NET Framework Class Library
XmlManager..::.CreateUpdateContext Method
XmlManager Class See Also Send Feedback

Instantiates a new, default, XmlUpdateContext object

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateUpdateContext As XmlUpdateContext
C#
public XmlUpdateContext CreateUpdateContext()
Visual C++
public:
XmlUpdateContext^ CreateUpdateContext()
JavaScript
function createUpdateContext();

Return Value

Remarks

This object is used for XmlContainer and [!:XmlModify] operations that add, delete, and modify documents, and documents in containers.

See Also

XmlManager Class


CreateURLInputStream Method

[image] [image]

.NET Framework Class Library
XmlManager..::.CreateURLInputStream Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
CreateURLInputStream(String, String) | Creates an XmlInputStream from the identified URL.
CreateURLInputStream(String, String, String) | Creates an XmlInputStream from the identified URL.

See Also

XmlManager Class
XmlManager Members


CreateURLInputStream Method (String, String)

[image]

.NET Framework Class Library
XmlManager..::.CreateURLInputStream Method (String, String)
XmlManager Class See Also Send Feedback

Creates an XmlInputStream from the identified URL.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateURLInputStream ( _
    baseId As String, _
    systemId As String _
) As XmlInputStream
C#
public XmlInputStream CreateURLInputStream(
    string baseId,
    string systemId
)
Visual C++
public:
XmlInputStream^ CreateURLInputStream(
    String^ baseId,
    String^ systemId
)
JavaScript
function createURLInputStream(baseId, systemId);

Parameters

baseId
Type: System..::.String
The base system id URL which provides the base for any relative id part.
systemId
Type: System..::.String
The possibly relative system id URL. If its relative its based on baseId, else its taken as is.

Return Value

Remarks

File URLs are always supported by this method. URLs that require network access (for example, http://...) are supported only if Xerces was compiled with socket support. Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent.

If the input stream is passed to either of these methods, it will be adopted, and deleted. If it is not passed, it is the responsibility of the user to delete the object. Note that there is no attempt to ensure that the URI referenced contains well-formed or valid XML. Exceptions may be thrown at the time that this input stream is actually read if the stream does not contain well-formed, or valid XML.

See Also

XmlManager Class
CreateURLInputStream Overload


CreateURLInputStream Method (String, String, String)

[image]

.NET Framework Class Library
XmlManager..::.CreateURLInputStream Method (String, String, String)
XmlManager Class See Also Send Feedback

Creates an XmlInputStream from the identified URL.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateURLInputStream ( _
    baseId As String, _
    systemId As String, _
    publicId As String _
) As XmlInputStream
C#
public XmlInputStream CreateURLInputStream(
    string baseId,
    string systemId,
    string publicId
)
Visual C++
public:
XmlInputStream^ CreateURLInputStream(
    String^ baseId,
    String^ systemId,
    String^ publicId
)
JavaScript
function createURLInputStream(baseId, systemId, publicId);

Parameters

baseId
Type: System..::.String
The base system id URL which provides the base for any relative id part.
systemId
Type: System..::.String
The possibly relative system id URL. If its relative its based on baseId, else its taken as is.
publicId
Type: System..::.String
The optional public id to set. This is just passed on to the parent class for storage.

Return Value

Remarks

File URLs are always supported by this method. URLs that require network access (for example, http://...) are supported only if Xerces was compiled with socket support. Use this input stream with PutDocument(String, String, XmlUpdateContext) or StreamContent.

If the input stream is passed to either of these methods, it will be adopted, and deleted. If it is not passed, it is the responsibility of the user to delete the object. Note that there is no attempt to ensure that the URI referenced contains well-formed or valid XML. Exceptions may be thrown at the time that this input stream is actually read if the stream does not contain well-formed, or valid XML.

See Also

XmlManager Class
CreateURLInputStream Overload


Dispose Method

[image] [image]

.NET Framework Class Library
XmlManager..::.Dispose Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlManager Class
XmlManager Members


DumpContainer Method

[image]

.NET Framework Class Library
XmlManager..::.DumpContainer Method
XmlManager Class See Also Send Feedback

Dumps the contents of the specified container to the specified output stream. The container can be reconstructed by a call to LoadContainer(String, String, XmlUpdateContext).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub DumpContainer ( _
    name As String, _
    fileName As String _
)
C#
public void DumpContainer(
    string name,
    string fileName
)
Visual C++
public:
void DumpContainer(
    String^ name,
    String^ fileName
)
JavaScript
function dumpContainer(name, fileName);

Parameters

name
Type: System..::.String
The name of the container to be dumped.
fileName
Type: System..::.String
The output file name to which the container is to be dumped.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open. The container must be have been opened at least once; the system throws an exception if the underlying files have not yet been created.

See Also

XmlManager Class


ExistsContainer Method

[image]

.NET Framework Class Library
XmlManager..::.ExistsContainer Method
XmlManager Class See Also Send Feedback

See if a container exists. Returns the format version if it is a valid container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ExistsContainer ( _
    name As String _
) As Boolean
C#
public bool ExistsContainer(
    string name
)
Visual C++
public:
bool ExistsContainer(
    String^ name
)
JavaScript
function existsContainer(name);

Parameters

name
Type: System..::.String
The name of the container.

Return Value

Returns falseFalsefalsefalse (False in Visual Basic) if the file named either does not exist or is not a container.

See Also

XmlManager Class


LoadContainer Method

[image]

.NET Framework Class Library
XmlManager..::.LoadContainer Method
XmlManager Class See Also Send Feedback

Loads data from the specified file into the container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub LoadContainer ( _
    name As String, _
    fileName As String, _
    updateContext As XmlUpdateContext _
)
C#
public void LoadContainer(
    string name,
    string fileName,
    XmlUpdateContext updateContext
)
Visual C++
public:
void LoadContainer(
    String^ name,
    String^ fileName,
    XmlUpdateContext^ updateContext
)
JavaScript
function loadContainer(name, fileName, updateContext);

Parameters

name
Type: System..::.String
The name of the container to load.
fileName
Type: System..::.String
The filename from which the container is to be loaded.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext

Remarks

The container's existing contents are discarded and replaced with the documents from the stream.

The specified input stream should contain data as created by DumpContainer(String, String).

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must be have been opened at least once; the system throws an exception if the underlying files have not yet been created.

See Also

XmlManager Class


OpenContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.OpenContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
OpenContainer(String) | Opens a container, returning a handle to an XmlContainer object.
OpenContainer(XmlTransaction, String) | Opens a container, returning a handle to an XmlContainer object.
OpenContainer(String, XmlContainerConfig) | Opens a container, returning a handle to an XmlContainer object.
OpenContainer(XmlTransaction, String, XmlContainerConfig) | Opens a container, returning a handle to an XmlContainer object.

See Also

XmlManager Class
XmlManager Members


OpenContainer Method (String)

[image]

.NET Framework Class Library
XmlManager..::.OpenContainer Method (String)
XmlManager Class See Also Send Feedback

Opens a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenContainer ( _
    name As String _
) As XmlContainer
C#
public XmlContainer OpenContainer(
    string name
)
Visual C++
public:
XmlContainer^ OpenContainer(
    String^ name
)
JavaScript
function openContainer(name);

Parameters

name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.

Return Value

Remarks

Use CreateContainer(String) to create and open a new container.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
OpenContainer Overload


OpenContainer Method (XmlTransaction, String)

[image]

.NET Framework Class Library
XmlManager..::.OpenContainer Method (XmlTransaction, String)
XmlManager Class See Also Send Feedback

Opens a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenContainer ( _
    transaction As XmlTransaction, _
    name As String _
) As XmlContainer
C#
public XmlContainer OpenContainer(
    XmlTransaction transaction,
    string name
)
Visual C++
public:
XmlContainer^ OpenContainer(
    XmlTransaction^ transaction,
    String^ name
)
JavaScript
function openContainer(transaction, name);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
The transaction handle to use for this container creation.
name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.

Return Value

Remarks

Use CreateContainer(String) to create and open a new container.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
OpenContainer Overload


OpenContainer Method (String, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.OpenContainer Method (String, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Opens a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenContainer ( _
    name As String, _
    containerConfig As XmlContainerConfig _
) As XmlContainer
C#
public XmlContainer OpenContainer(
    string name,
    XmlContainerConfig containerConfig
)
Visual C++
public:
XmlContainer^ OpenContainer(
    String^ name,
    XmlContainerConfig^ containerConfig
)
JavaScript
function openContainer(name, containerConfig);

Parameters

name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
The configuration settings for the container.

Return Value

Remarks

Use CreateContainer(String) to create and open a new container.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
OpenContainer Overload


OpenContainer Method (XmlTransaction, String, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.OpenContainer Method (XmlTransaction, String, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Opens a container, returning a handle to an XmlContainer object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function OpenContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    containerConfig As XmlContainerConfig _
) As XmlContainer
C#
public XmlContainer OpenContainer(
    XmlTransaction transaction,
    string name,
    XmlContainerConfig containerConfig
)
Visual C++
public:
XmlContainer^ OpenContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlContainerConfig^ containerConfig
)
JavaScript
function openContainer(transaction, name, containerConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
The transaction handle to use for this container creation.
name
Type: System..::.String
The container's name. The container is created relative to the underlying environment's home directory (see XmlManager for more information) unless an absolute path is used for the name; in that case the container is created in the location identified by the path. The name provided here must be unique for the environment or an exception is thrown.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
The configuration settings for the container.

Return Value

Remarks

Use CreateContainer(String) to create and open a new container.

Containers always remain open until the last handle referencing the container is destroyed.

See Also

XmlManager Class
OpenContainer Overload


Prepare Method

[image] [image]

.NET Framework Class Library
XmlManager..::.Prepare Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
Prepare(String, XmlQueryContext) | Compile an XQuery expression into an XmlQueryExpression object.
Prepare(XmlTransaction, String, XmlQueryContext) | Compile an XQuery expression into an XmlQueryExpression object.

See Also

XmlManager Class
XmlManager Members


Prepare Method (String, XmlQueryContext)

[image]

.NET Framework Class Library
XmlManager..::.Prepare Method (String, XmlQueryContext)
XmlManager Class See Also Send Feedback

Compile an XQuery expression into an XmlQueryExpression object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Prepare ( _
    xquery As String, _
    queryContext As XmlQueryContext _
) As XmlQueryExpression
C#
public XmlQueryExpression Prepare(
    string xquery,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlQueryExpression^ Prepare(
    String^ xquery,
    XmlQueryContext^ queryContext
)
JavaScript
function prepare(xquery, queryContext);

Parameters

xquery
Type: System..::.String
The XQuery query string to compile.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.

Return Value

Remarks

You can then run the XQuery expression repeatedly using Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Prepare Overload


Prepare Method (XmlTransaction, String, XmlQueryContext)

[image]

.NET Framework Class Library
XmlManager..::.Prepare Method (XmlTransaction, String, XmlQueryContext)
XmlManager Class See Also Send Feedback

Compile an XQuery expression into an XmlQueryExpression object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Prepare ( _
    transaction As XmlTransaction, _
    xquery As String, _
    queryContext As XmlQueryContext _
) As XmlQueryExpression
C#
public XmlQueryExpression Prepare(
    XmlTransaction transaction,
    string xquery,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlQueryExpression^ Prepare(
    XmlTransaction^ transaction,
    String^ xquery,
    XmlQueryContext^ queryContext
)
JavaScript
function prepare(transaction, xquery, queryContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
xquery
Type: System..::.String
The XQuery query string to compile.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.

Return Value

Remarks

You can then run the XQuery expression repeatedly using Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Prepare Overload


Query Method

[image] [image]

.NET Framework Class Library
XmlManager..::.Query Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
Query(String, XmlQueryContext) | Executes a query in the context of the XmlManager object.
Query(XmlTransaction, String, XmlQueryContext) | Executes a query in the context of the XmlManager object.
Query(String, XmlQueryContext, XmlDocumentConfig) | Executes a query in the context of the XmlManager object.
Query(XmlTransaction, String, XmlQueryContext, XmlDocumentConfig) | Executes a query in the context of the XmlManager object.

See Also

XmlManager Class
XmlManager Members


Query Method (String, XmlQueryContext)

[image]

.NET Framework Class Library
XmlManager..::.Query Method (String, XmlQueryContext)
XmlManager Class See Also Send Feedback

Executes a query in the context of the XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Query ( _
    xquery As String, _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Query(
    string xquery,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Query(
    String^ xquery,
    XmlQueryContext^ queryContext
)
JavaScript
function query(xquery, queryContext);

Parameters

xquery
Type: System..::.String
The XQuery query string.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.

Return Value

Remarks

This method is the equivalent of calling Prepare(String, XmlQueryContext) and then Execute(XmlQueryContext) on the prepared query.

The scope of the query can be restricted using one of the XQuery navigational functions. For example:

Copy Code
"collection('mycontainer.dbxml')/foo"
or
Copy Code
"doc('dbxml:/mycontainer.dbxml/mydoc.xml')/foo/@attr1='bar'"

The scope of a query can also be controlled by passing an appropriate contextItem object to Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Query Overload


Query Method (XmlTransaction, String, XmlQueryContext)

[image]

.NET Framework Class Library
XmlManager..::.Query Method (XmlTransaction, String, XmlQueryContext)
XmlManager Class See Also Send Feedback

Executes a query in the context of the XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Query ( _
    transaction As XmlTransaction, _
    xquery As String, _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Query(
    XmlTransaction transaction,
    string xquery,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Query(
    XmlTransaction^ transaction,
    String^ xquery,
    XmlQueryContext^ queryContext
)
JavaScript
function query(transaction, xquery, queryContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
xquery
Type: System..::.String
The XQuery query string.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.

Return Value

Remarks

This method is the equivalent of calling Prepare(String, XmlQueryContext) and then Execute(XmlQueryContext) on the prepared query.

The scope of the query can be restricted using one of the XQuery navigational functions. For example:

Copy Code
"collection('mycontainer.dbxml')/foo"
or
Copy Code
"doc('dbxml:/mycontainer.dbxml/mydoc.xml')/foo/@attr1='bar'"

The scope of a query can also be controlled by passing an appropriate contextItem object to Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Query Overload


Query Method (String, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlManager..::.Query Method (String, XmlQueryContext, XmlDocumentConfig)
XmlManager Class See Also Send Feedback

Executes a query in the context of the XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Query ( _
    xquery As String, _
    queryContext As XmlQueryContext, _
    documentConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Query(
    string xquery,
    XmlQueryContext queryContext,
    XmlDocumentConfig documentConfig
)
Visual C++
public:
XmlResults^ Query(
    String^ xquery,
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ documentConfig
)
JavaScript
function query(xquery, queryContext, documentConfig);

Parameters

xquery
Type: System..::.String
The XQuery query string.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.
documentConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Remarks

This method is the equivalent of calling Prepare(String, XmlQueryContext) and then Execute(XmlQueryContext) on the prepared query.

The scope of the query can be restricted using one of the XQuery navigational functions. For example:

Copy Code
"collection('mycontainer.dbxml')/foo"
or
Copy Code
"doc('dbxml:/mycontainer.dbxml/mydoc.xml')/foo/@attr1='bar'"

The scope of a query can also be controlled by passing an appropriate contextItem object to Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Query Overload


Query Method (XmlTransaction, String, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlManager..::.Query Method (XmlTransaction, String, XmlQueryContext, XmlDocumentConfig)
XmlManager Class See Also Send Feedback

Executes a query in the context of the XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Query ( _
    transaction As XmlTransaction, _
    xquery As String, _
    queryContext As XmlQueryContext, _
    documentConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Query(
    XmlTransaction transaction,
    string xquery,
    XmlQueryContext queryContext,
    XmlDocumentConfig documentConfig
)
Visual C++
public:
XmlResults^ Query(
    XmlTransaction^ transaction,
    String^ xquery,
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ documentConfig
)
JavaScript
function query(transaction, xquery, queryContext, documentConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
xquery
Type: System..::.String
The XQuery query string.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this query.
documentConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
Configuration settings for this operation.

Return Value

Remarks

This method is the equivalent of calling Prepare(String, XmlQueryContext) and then Execute(XmlQueryContext) on the prepared query.

The scope of the query can be restricted using one of the XQuery navigational functions. For example:

Copy Code
"collection('mycontainer.dbxml')/foo"
or
Copy Code
"doc('dbxml:/mycontainer.dbxml/mydoc.xml')/foo/@attr1='bar'"

The scope of a query can also be controlled by passing an appropriate contextItem object to Execute(XmlQueryContext).

Note that this method is suitable for performing one-off queries. If you want to execute a query more than once, you should use Prepare(String, XmlQueryContext) to compile the expression, and then use Execute(XmlQueryContext) to run it.

This method returns an XmlResults object. You then iterate over the results set contained in that object using Next()()() and Previous()()().

For more information on querying containers and documents, see the Berkeley DB XML Getting Started Guide.

See Also

XmlManager Class
Query Overload


RegisterCompression Method

[image]

.NET Framework Class Library
XmlManager..::.RegisterCompression Method
XmlManager Class See Also Send Feedback

Identifies by name an XmlCompression object to be used for compression. This object is used to compress document data before it is stored in the database and to decompress it after it is retrieved from the database. The registered compression will be used for data in any container that is created using an XmlContainerConfig object that has the compression name set as the registered name. When a container is created with user defined compression whenever it is opened again the user defined compression must be registered under the same name or the attempt to open the container will fail.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterCompression ( _
    name As String, _
    compression As XmlCompression _
)
C#
public void RegisterCompression(
    string name,
    XmlCompression compression
)
Visual C++
public:
void RegisterCompression(
    String^ name,
    XmlCompression^ compression
)
JavaScript
function registerCompression(name, compression);

Parameters

name
Type: System..::.String
compression
Type: JanaBiz.DbXml..::.XmlCompression

See Also

XmlManager Class


RegisterResolver Method

[image]

.NET Framework Class Library
XmlManager..::.RegisterResolver Method
XmlManager Class See Also Send Feedback

Identifies an XmlResolver object to be used for file resolution.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RegisterResolver ( _
    resolver As XmlResolver _
)
C#
public void RegisterResolver(
    XmlResolver resolver
)
Visual C++
public:
void RegisterResolver(
    XmlResolver^ resolver
)
JavaScript
function registerResolver(resolver);

Parameters

resolver
Type: JanaBiz.DbXml..::.XmlResolver
The XmlResolver instance to be used for file resolution.

Remarks

This object is used by the underlying XercesC DOM or SAX parsers to locate data based on URIs, or public and system ids. Custom XmlResolver objects can be created by applications to provide a mechanism to name and retrieve collections, documents, and XML entities external to Berkeley DB XML.

See Also

XmlManager Class


ReindexContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.ReindexContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
ReindexContainer(String, XmlUpdateContext) | Reindex a container.
ReindexContainer(XmlTransaction, String, XmlUpdateContext) | Reindex a container.
ReindexContainer(String, XmlUpdateContext, XmlContainerConfig) | Reindex a container.
ReindexContainer(XmlTransaction, String, XmlUpdateContext, XmlContainerConfig) | Reindex a container.

See Also

XmlManager Class
XmlManager Members


ReindexContainer Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.ReindexContainer Method (String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Reindex a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReindexContainer ( _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReindexContainer(
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReindexContainer(
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function reindexContainer(name, updateContext);

Parameters

name
Type: System..::.String
The name of the container to reindex.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext for the opeartion.

Remarks

Remove indexes and reindex the container, to change the indexing mode between node-level and document-level indexes.

The container should be backed up before using this method. This method may take a very long time, depending on the size of the container, and should not be used casually.

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

See Also

XmlManager Class
ReindexContainer Overload


ReindexContainer Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.ReindexContainer Method (XmlTransaction, String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Reindex a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReindexContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void ReindexContainer(
    XmlTransaction transaction,
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void ReindexContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function reindexContainer(transaction, name, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the container to reindex.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext for the opeartion.

Remarks

Remove indexes and reindex the container, to change the indexing mode between node-level and document-level indexes.

The container should be backed up before using this method. This method may take a very long time, depending on the size of the container, and should not be used casually.

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

See Also

XmlManager Class
ReindexContainer Overload


ReindexContainer Method (String, XmlUpdateContext, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.ReindexContainer Method (String, XmlUpdateContext, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Reindex a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReindexContainer ( _
    name As String, _
    updateContext As XmlUpdateContext, _
    containerConfig As XmlContainerConfig _
)
C#
public void ReindexContainer(
    string name,
    XmlUpdateContext updateContext,
    XmlContainerConfig containerConfig
)
Visual C++
public:
void ReindexContainer(
    String^ name,
    XmlUpdateContext^ updateContext,
    XmlContainerConfig^ containerConfig
)
JavaScript
function reindexContainer(name, updateContext, containerConfig);

Parameters

name
Type: System..::.String
The name of the container to reindex.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext for the opeartion.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
XmlContainerConfig. For document indexes, pass null, for node indexes, use new XmlContainerConfig().IndexNodes=true. See XmlContainerConfig.

Remarks

Remove indexes and reindex the container, to change the indexing mode between node-level and document-level indexes.

The container should be backed up before using this method. This method may take a very long time, depending on the size of the container, and should not be used casually.

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

See Also

XmlManager Class
ReindexContainer Overload


ReindexContainer Method (XmlTransaction, String, XmlUpdateContext, XmlContainerConfig)

[image]

.NET Framework Class Library
XmlManager..::.ReindexContainer Method (XmlTransaction, String, XmlUpdateContext, XmlContainerConfig)
XmlManager Class See Also Send Feedback

Reindex a container.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ReindexContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    updateContext As XmlUpdateContext, _
    containerConfig As XmlContainerConfig _
)
C#
public void ReindexContainer(
    XmlTransaction transaction,
    string name,
    XmlUpdateContext updateContext,
    XmlContainerConfig containerConfig
)
Visual C++
public:
void ReindexContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlUpdateContext^ updateContext,
    XmlContainerConfig^ containerConfig
)
JavaScript
function reindexContainer(transaction, name, updateContext, containerConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the container to reindex.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext for the opeartion.
containerConfig
Type: JanaBiz.DbXml..::.XmlContainerConfig
XmlContainerConfig. For document indexes, pass null, for node indexes, use new XmlContainerConfig().IndexNodes=true. See XmlContainerConfig.

Remarks

Remove indexes and reindex the container, to change the indexing mode between node-level and document-level indexes.

The container should be backed up before using this method. This method may take a very long time, depending on the size of the container, and should not be used casually.

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

See Also

XmlManager Class
ReindexContainer Overload


RemoveContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.RemoveContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
RemoveContainer(String) | Removes the underlying file for the container from the file system in the context of a transaction.
RemoveContainer(XmlTransaction, String) | Removes the underlying file for the container from the file system in the context of a transaction.

See Also

XmlManager Class
XmlManager Members


RemoveContainer Method (String)

[image]

.NET Framework Class Library
XmlManager..::.RemoveContainer Method (String)
XmlManager Class See Also Send Feedback

Removes the underlying file for the container from the file system in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveContainer ( _
    name As String _
)
C#
public void RemoveContainer(
    string name
)
Visual C++
public:
void RemoveContainer(
    String^ name
)
JavaScript
function removeContainer(name);

Parameters

name
Type: System..::.String
The name of the container to be removed.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying file has not yet been created.

See Also

XmlManager Class
RemoveContainer Overload


RemoveContainer Method (XmlTransaction, String)

[image]

.NET Framework Class Library
XmlManager..::.RemoveContainer Method (XmlTransaction, String)
XmlManager Class See Also Send Feedback

Removes the underlying file for the container from the file system in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveContainer ( _
    transaction As XmlTransaction, _
    name As String _
)
C#
public void RemoveContainer(
    XmlTransaction transaction,
    string name
)
Visual C++
public:
void RemoveContainer(
    XmlTransaction^ transaction,
    String^ name
)
JavaScript
function removeContainer(transaction, name);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the container to be removed.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying file has not yet been created.

See Also

XmlManager Class
RemoveContainer Overload


RenameContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.RenameContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
RenameContainer(String, String) | Removes the underlying file for the container from the file system in the context of a transaction.
RenameContainer(XmlTransaction, String, String) | Removes the underlying file for the container from the file system in the context of a transaction.

See Also

XmlManager Class
XmlManager Members


RenameContainer Method (String, String)

[image]

.NET Framework Class Library
XmlManager..::.RenameContainer Method (String, String)
XmlManager Class See Also Send Feedback

Removes the underlying file for the container from the file system in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RenameContainer ( _
    oldName As String, _
    newName As String _
)
C#
public void RenameContainer(
    string oldName,
    string newName
)
Visual C++
public:
void RenameContainer(
    String^ oldName,
    String^ newName
)
JavaScript
function renameContainer(oldName, newName);

Parameters

oldName
Type: System..::.String
The name of the container whose name you want to change.
newName
Type: System..::.String
The new container name.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying file has not yet been created.

See Also

XmlManager Class
RenameContainer Overload


RenameContainer Method (XmlTransaction, String, String)

[image]

.NET Framework Class Library
XmlManager..::.RenameContainer Method (XmlTransaction, String, String)
XmlManager Class See Also Send Feedback

Removes the underlying file for the container from the file system in the context of a transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RenameContainer ( _
    transaction As XmlTransaction, _
    oldName As String, _
    newName As String _
)
C#
public void RenameContainer(
    XmlTransaction transaction,
    string oldName,
    string newName
)
Visual C++
public:
void RenameContainer(
    XmlTransaction^ transaction,
    String^ oldName,
    String^ newName
)
JavaScript
function renameContainer(transaction, oldName, newName);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from.
oldName
Type: System..::.String
The name of the container whose name you want to change.
newName
Type: System..::.String
The new container name.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying file has not yet been created.

See Also

XmlManager Class
RenameContainer Overload


SetLogCategory Method

[image]

.NET Framework Class Library
XmlManager..::.SetLogCategory Method
XmlManager Class See Also Send Feedback

Enable or disable a category of log messages.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetLogCategory ( _
    category As LogCategory, _
    enabled As Boolean _
)
C#
public static void SetLogCategory(
    LogCategory category,
    bool enabled
)
Visual C++
public:
static void SetLogCategory(
    LogCategory category,
    bool enabled
)
JavaScript
JanaBiz.DbXml.XmlManager.setLogCategory = function(category, enabled);

Parameters

category
Type: JanaBiz.DbXml..::.LogCategory
The log category to enable or disable.
enabled
Type: System..::.Boolean
Whether to enable or disable the category.

Remarks

Berkeley DB XML can be configured to generate a stream of messages to help application debugging. The messages are categorized by subsystem, and by importance. The messages are sent to the output stream that is configured in the Berkeley DB dbenvironment associated with the XmlManager generating the message. The output is sent to System.err if no environment is associated with the XmlManager.

See Also

XmlManager Class


SetLogLevel Method

[image]

.NET Framework Class Library
XmlManager..::.SetLogLevel Method
XmlManager Class See Also Send Feedback

Enable or disable log messages of a given level of importance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Sub SetLogLevel ( _
    level As LogLevel, _
    enabled As Boolean _
)
C#
public static void SetLogLevel(
    LogLevel level,
    bool enabled
)
Visual C++
public:
static void SetLogLevel(
    LogLevel level,
    bool enabled
)
JavaScript
JanaBiz.DbXml.XmlManager.setLogLevel = function(level, enabled);

Parameters

level
Type: JanaBiz.DbXml..::.LogLevel
The log level to enable or disable.
enabled
Type: System..::.Boolean
Whether to enable or disable the importance level.

Remarks

Berkeley DB XML can be configured to generate a stream of messages to help application debugging. The messages are categorized by subsystem, and by importance. The messages are sent to the output stream that is configured in the Berkeley DB environment associated with the XmlManager generating the message. The output is sent to System.err if no dbenvironment is associated with the XmlManager.

See Also

XmlManager Class


TruncateContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.TruncateContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
TruncateContainer(String, XmlUpdateContext) | Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.
TruncateContainer(XmlTransaction, String, XmlUpdateContext) | Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

See Also

XmlManager Class
XmlManager Members


TruncateContainer Method (String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.TruncateContainer Method (String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub TruncateContainer ( _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void TruncateContainer(
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void TruncateContainer(
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function truncateContainer(name, updateContext);

Parameters

name
Type: System..::.String
The name of the container to be compacted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext

See Also

XmlManager Class
TruncateContainer Overload


TruncateContainer Method (XmlTransaction, String, XmlUpdateContext)

[image]

.NET Framework Class Library
XmlManager..::.TruncateContainer Method (XmlTransaction, String, XmlUpdateContext)
XmlManager Class See Also Send Feedback

Compacts the content of the container.The container must be closed; the system throws an exception if the container is open.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub TruncateContainer ( _
    transaction As XmlTransaction, _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void TruncateContainer(
    XmlTransaction transaction,
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void TruncateContainer(
    XmlTransaction^ transaction,
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function truncateContainer(transaction, name, updateContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the transaction parameter is an XmlTransaction handle returned from CreateTransaction()()().
name
Type: System..::.String
The name of the container to be compacted.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext

See Also

XmlManager Class
TruncateContainer Overload


UpgradeContainer Method

[image]

.NET Framework Class Library
XmlManager..::.UpgradeContainer Method
XmlManager Class See Also Send Feedback

Upgrades the container from a previous version of Berkeley DB XML, or Berkeley DB, to the current version.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub UpgradeContainer ( _
    name As String, _
    updateContext As XmlUpdateContext _
)
C#
public void UpgradeContainer(
    string name,
    XmlUpdateContext updateContext
)
Visual C++
public:
void UpgradeContainer(
    String^ name,
    XmlUpdateContext^ updateContext
)
JavaScript
function upgradeContainer(name, updateContext);

Parameters

name
Type: System..::.String
The name of the container to be upgraded.
updateContext
Type: JanaBiz.DbXml..::.XmlUpdateContext
The XmlUpdateContext object to be used for this operation.

Remarks

Container upgrades are done in place and are destructive. For example, if pages need to be allocated and no disk space is available, the container may be left corrupted. Backups should be made before containers are upgraded. See Upgrading databases for more information.

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

See Also

XmlManager Class


VerifyContainer Method

[image] [image]

.NET Framework Class Library
XmlManager..::.VerifyContainer Method
XmlManager Class See Also Send Feedback

Overload List

Name | Description
VerifyContainer(String, String) | Checks that the container data files are not corrupt, and optionally writes the salvaged container data to the specified file.
VerifyContainer(String, String, XmlVerifyConfig) | Checks that the container data files are not corrupt, and optionally writes the salvaged container data to the specified file.

See Also

XmlManager Class
XmlManager Members


VerifyContainer Method (String, String)

[image]

.NET Framework Class Library
XmlManager..::.VerifyContainer Method (String, String)
XmlManager Class See Also Send Feedback

Checks that the container data files are not corrupt, and optionally writes the salvaged container data to the specified file.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub VerifyContainer ( _
    name As String, _
    fileName As String _
)
C#
public void VerifyContainer(
    string name,
    string fileName
)
Visual C++
public:
void VerifyContainer(
    String^ name,
    String^ fileName
)
JavaScript
function verifyContainer(name, fileName);

Parameters

name
Type: System..::.String
The name of the container to be verified.
fileName
Type: System..::.String
The name of the file into which salvaged container data is to be dumped, or a null reference.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying files have not yet been created.

See Also

XmlManager Class
VerifyContainer Overload


VerifyContainer Method (String, String, XmlVerifyConfig)

[image]

.NET Framework Class Library
XmlManager..::.VerifyContainer Method (String, String, XmlVerifyConfig)
XmlManager Class See Also Send Feedback

Checks that the container data files are not corrupt, and optionally writes the salvaged container data to the specified file.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub VerifyContainer ( _
    name As String, _
    fileName As String, _
    xmlVerifyConfig As XmlVerifyConfig _
)
C#
public void VerifyContainer(
    string name,
    string fileName,
    XmlVerifyConfig xmlVerifyConfig
)
Visual C++
public:
void VerifyContainer(
    String^ name,
    String^ fileName,
    XmlVerifyConfig^ xmlVerifyConfig
)
JavaScript
function verifyContainer(name, fileName, xmlVerifyConfig);

Parameters

name
Type: System..::.String
The name of the container to be verified.
fileName
Type: System..::.String
The name of the file into which salvaged container data is to be dumped, or a null reference.
xmlVerifyConfig
Type: JanaBiz.DbXml..::.XmlVerifyConfig
The configuration settings for this operation.

Remarks

The container must be closed by calling the XmlContainer.Dispose()()() method or the Close()()() method; the system throws an exception if the container is open.

The container must have been opened at least once; the system throws an exception if the underlying files have not yet been created.

See Also

XmlManager Class
VerifyContainer Overload


XmlManager Properties

[image] [image]

.NET Framework Class Library
XmlManager Properties
XmlManager Class See Also Send Feedback

The XmlManager type exposes the following members.

Properties

Name | Description
Config | The configuration object for this XmlManager instance.
DbEnvironment | Returns the DbEnvironment object for the XmlManager.
DefaultCompressionName | Gets or sets the name of the default compression algorithm used by containers. If the compression algorithm is users implemented then it must be registered with the XmlManager using the given name using the function RegisterCompression(String, XmlCompression).
DefaultContainerConfig | The default flags used for containers opened and created by this XmlManager object.
DefaultContainerType | The default type used for containers opened and created by this XmlManager object.
DefaultPageSize | The size of the pages used to store documents in the database.
DefaultSequenceIncrement | The integer increment to be used when pre-allocating document ids for new documents
Home | Returns the home directory for the underlying database environment.
ImplicitTimezone | Gets the implicit timezone to be used for XQuery expressions, in offset in minutes from GMT and Sets the implicit timezone to be used for queries referring to dates and times in the context of the XmlManager.
Version | Gets the Berkeley DB XML release number.
VersionMajor | Gets the release's major version number.
VersionMinor | Gets the release's minor version number.
VersionPatch | Gets the release's patch version number.

See Also

XmlManager Class


Config Property

[image]

.NET Framework Class Library
XmlManager..::.Config Property
XmlManager Class See Also Send Feedback

The configuration object for this XmlManager instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Config As XmlManagerConfig
C#
public XmlManagerConfig Config { get; }
Visual C++
public:
property XmlManagerConfig^ Config {
    XmlManagerConfig^ get ();
}
JavaScript
function get_config();

See Also

XmlManager Class


DbEnvironment Property

[image]

.NET Framework Class Library
XmlManager..::.DbEnvironment Property
XmlManager Class See Also Send Feedback

Returns the DbEnvironment object for the XmlManager.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbEnvironment As DbEnvironment
C#
public DbEnvironment DbEnvironment { get; }
Visual C++
public:
property DbEnvironment^ DbEnvironment {
    DbEnvironment^ get ();
}
JavaScript
function get_dbEnvironment();

Field Value

the DbEnvironment object for the XmlManager.

See Also

XmlManager Class


DefaultCompressionName Property

[image]

.NET Framework Class Library
XmlManager..::.DefaultCompressionName Property
XmlManager Class See Also Send Feedback

Gets or sets the name of the default compression algorithm used by containers. If the compression algorithm is users implemented then it must be registered with the XmlManager using the given name using the function RegisterCompression(String, XmlCompression).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultCompressionName As String
C#
public string DefaultCompressionName { get; set; }
Visual C++
public:
property String^ DefaultCompressionName {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_defaultCompressionName();
function set_defaultCompressionName(value);

See Also

XmlManager Class


DefaultContainerConfig Property

[image]

.NET Framework Class Library
XmlManager..::.DefaultContainerConfig Property
XmlManager Class See Also Send Feedback

The default flags used for containers opened and created by this XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultContainerConfig As XmlContainerConfig
C#
public XmlContainerConfig DefaultContainerConfig { get; set; }
Visual C++
public:
property XmlContainerConfig^ DefaultContainerConfig {
    XmlContainerConfig^ get ();
    void set (XmlContainerConfig^ value);
}
JavaScript
function get_defaultContainerConfig();
function set_defaultContainerConfig(value);

See Also

XmlManager Class


DefaultContainerType Property

[image]

.NET Framework Class Library
XmlManager..::.DefaultContainerType Property
XmlManager Class See Also Send Feedback

The default type used for containers opened and created by this XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultContainerType As XmlContainerType
C#
public XmlContainerType DefaultContainerType { get; set; }
Visual C++
public:
property XmlContainerType DefaultContainerType {
    XmlContainerType get ();
    void set (XmlContainerType value);
}
JavaScript
function get_defaultContainerType();
function set_defaultContainerType(value);

See Also

XmlManager Class


DefaultPageSize Property

[image]

.NET Framework Class Library
XmlManager..::.DefaultPageSize Property
XmlManager Class See Also Send Feedback

The size of the pages used to store documents in the database.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultPageSize As Long
C#
public long DefaultPageSize { get; set; }
Visual C++
public:
property long long DefaultPageSize {
    long long get ();
    void set (long long value);
}
JavaScript
function get_defaultPageSize();
function set_defaultPageSize(value);

Field Value

The page size in bytes.

Remarks

The size is specified in bytes in the range 512 bytes to 64K bytes, and the page size must be a power-of-two.

The system selects a page size based on the underlying file system I/O block size if one is not explicitly set by the application. The default page size has a lower limit of 512 bytes and an upper limit of 16K bytes. Documents that are larger than a single page are stored on multiple pages.

The property will only affect containers created after it is set. It has no effect on existing containers.

See Also

XmlManager Class


DefaultSequenceIncrement Property

[image]

.NET Framework Class Library
XmlManager..::.DefaultSequenceIncrement Property
XmlManager Class See Also Send Feedback

The integer increment to be used when pre-allocating document ids for new documents

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultSequenceIncrement As Long
C#
public long DefaultSequenceIncrement { get; set; }
Visual C++
public:
property long long DefaultSequenceIncrement {
    long long get ();
    void set (long long value);
}
JavaScript
function get_defaultSequenceIncrement();
function set_defaultSequenceIncrement(value);

Field Value

The increment to use for pre-allocated IDs.

See Also

XmlManager Class


Home Property

[image]

.NET Framework Class Library
XmlManager..::.Home Property
XmlManager Class See Also Send Feedback

Returns the home directory for the underlying database environment.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Home As String
C#
public string Home { get; }
Visual C++
public:
property String^ Home {
    String^ get ();
}
JavaScript
function get_home();

Field Value

the home directory for the underlying database environment.

Remarks

XmlContainer files are placed relative to this directory unless an absolute path is used for the container name.

See Also

XmlManager Class


ImplicitTimezone Property

[image]

.NET Framework Class Library
XmlManager..::.ImplicitTimezone Property
XmlManager Class See Also Send Feedback

Gets the implicit timezone to be used for XQuery expressions, in offset in minutes from GMT and Sets the implicit timezone to be used for queries referring to dates and times in the context of the XmlManager.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ImplicitTimezone As Integer
C#
public int ImplicitTimezone { get; set; }
Visual C++
public:
property int ImplicitTimezone {
    int get ();
    void set (int value);
}
JavaScript
function get_implicitTimezone();
function set_implicitTimezone(value);

See Also

XmlManager Class


Version Property

[image]

.NET Framework Class Library
XmlManager..::.Version Property
XmlManager Class See Also Send Feedback

Gets the Berkeley DB XML release number.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Version As String
C#
public static string Version { get; }
Visual C++
public:
static property String^ Version {
    String^ get ();
}
JavaScript
JanaBiz.DbXml.XmlManager.get_version = function();

Field Value

the Berkeley DB XML release number.

See Also

XmlManager Class


VersionMajor Property

[image]

.NET Framework Class Library
XmlManager..::.VersionMajor Property
XmlManager Class See Also Send Feedback

Gets the release's major version number.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionMajor As Integer
C#
public static int VersionMajor { get; }
Visual C++
public:
static property int VersionMajor {
    int get ();
}
JavaScript
JanaBiz.DbXml.XmlManager.get_versionMajor = function();

Field Value

The release's major version number.

See Also

XmlManager Class


VersionMinor Property

[image]

.NET Framework Class Library
XmlManager..::.VersionMinor Property
XmlManager Class See Also Send Feedback

Gets the release's minor version number.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionMinor As Integer
C#
public static int VersionMinor { get; }
Visual C++
public:
static property int VersionMinor {
    int get ();
}
JavaScript
JanaBiz.DbXml.XmlManager.get_versionMinor = function();

Field Value

The release's minor version number.

See Also

XmlManager Class


VersionPatch Property

[image]

.NET Framework Class Library
XmlManager..::.VersionPatch Property
XmlManager Class See Also Send Feedback

Gets the release's patch version number.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property VersionPatch As Integer
C#
public static int VersionPatch { get; }
Visual C++
public:
static property int VersionPatch {
    int get ();
}
JavaScript
JanaBiz.DbXml.XmlManager.get_versionPatch = function();

Field Value

The release's patch version number.

See Also

XmlManager Class


XmlManagerConfig Class

[image]

.NET Framework Class Library
XmlManagerConfig Class
Members See Also Send Feedback

Used to configure an XmlManager instance via its constructors.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlManagerConfig _
    Inherits FlagsBase
C#
public class XmlManagerConfig : FlagsBase
Visual C++
public ref class XmlManagerConfig : public FlagsBase
JavaScript
JanaBiz.DbXml.XmlManagerConfig = function();

Type.createClass(
    'JanaBiz.DbXml.XmlManagerConfig',
    JanaBiz.Bridge.FlagsBase);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.DbXml..::.XmlManagerConfig

See Also

XmlManagerConfig Members


XmlManagerConfig Members

[image] [image]

.NET Framework Class Library
XmlManagerConfig Members
XmlManagerConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlManagerConfig type exposes the following members.

Constructors

Name | Description
XmlManagerConfig | Initializes the XmlManagerConfig class.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
AdoptEnvironment | If set, the XmlManager object will close and delete the underlying DbEnv object at the end of the XmlManager's life.
AllowAutoOpen | If set, XQuery queries that reference unopened containers will automatically open those containers, and close them when references resulting from the query are released. By default, a query will fail if it refers to containers that are not open.
AllowExternalAccess | If set, this flag allows XQuery queries to access data sources external to the container, such as files on disk or http URIs. By default, such access is not allowed.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlManagerConfig Class


XmlManagerConfig Constructor

[image]

.NET Framework Class Library
XmlManagerConfig Constructor
XmlManagerConfig Class See Also Send Feedback

Initializes the XmlManagerConfig class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlManagerConfig()
Visual C++
public:
XmlManagerConfig()
JavaScript
JanaBiz.DbXml.XmlManagerConfig = function();

See Also

XmlManagerConfig Class


XmlManagerConfig Methods

[image] [image]

.NET Framework Class Library
XmlManagerConfig Methods
XmlManagerConfig Class See Also Send Feedback

The XmlManagerConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlManagerConfig Class


XmlManagerConfig Properties

[image] [image]

.NET Framework Class Library
XmlManagerConfig Properties
XmlManagerConfig Class See Also Send Feedback

The XmlManagerConfig type exposes the following members.

Properties

Name | Description
AdoptEnvironment | If set, the XmlManager object will close and delete the underlying DbEnv object at the end of the XmlManager's life.
AllowAutoOpen | If set, XQuery queries that reference unopened containers will automatically open those containers, and close them when references resulting from the query are released. By default, a query will fail if it refers to containers that are not open.
AllowExternalAccess | If set, this flag allows XQuery queries to access data sources external to the container, such as files on disk or http URIs. By default, such access is not allowed.

See Also

XmlManagerConfig Class


AdoptEnvironment Property

[image]

.NET Framework Class Library
XmlManagerConfig..::.AdoptEnvironment Property
XmlManagerConfig Class See Also Send Feedback

If set, the XmlManager object will close and delete the underlying DbEnv object at the end of the XmlManager's life.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AdoptEnvironment As Boolean
C#
public bool AdoptEnvironment { get; set; }
Visual C++
public:
property bool AdoptEnvironment {
    bool get ();
    void set (bool value);
}
JavaScript
function get_adoptEnvironment();
function set_adoptEnvironment(value);

See Also

XmlManagerConfig Class


AllowAutoOpen Property

[image]

.NET Framework Class Library
XmlManagerConfig..::.AllowAutoOpen Property
XmlManagerConfig Class See Also Send Feedback

If set, XQuery queries that reference unopened containers will automatically open those containers, and close them when references resulting from the query are released. By default, a query will fail if it refers to containers that are not open.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowAutoOpen As Boolean
C#
public bool AllowAutoOpen { get; set; }
Visual C++
public:
property bool AllowAutoOpen {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowAutoOpen();
function set_allowAutoOpen(value);

See Also

XmlManagerConfig Class


AllowExternalAccess Property

[image]

.NET Framework Class Library
XmlManagerConfig..::.AllowExternalAccess Property
XmlManagerConfig Class See Also Send Feedback

If set, this flag allows XQuery queries to access data sources external to the container, such as files on disk or http URIs. By default, such access is not allowed.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property AllowExternalAccess As Boolean
C#
public bool AllowExternalAccess { get; set; }
Visual C++
public:
property bool AllowExternalAccess {
    bool get ();
    void set (bool value);
}
JavaScript
function get_allowExternalAccess();
function set_allowExternalAccess(value);

See Also

XmlManagerConfig Class


XmlMetaData Class

[image]

.NET Framework Class Library
XmlMetaData Class
Members See Also Send Feedback

Metadata item returned by MoveNext()()() and Current.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlMetaData _
    Inherits InvocationHandle
C#
public class XmlMetaData : InvocationHandle
Visual C++
public ref class XmlMetaData : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlMetaData = function();

Type.createClass(
    'JanaBiz.DbXml.XmlMetaData',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Metadata can contain an arbitrarily complex set of information. Typically it contains information about the document that you do not or can not include in the document itself. As an example, you could carry information about the date and time a document was added to the container, last modified, or possibly an expiration time. Metadata might also be used to store information about the document that is external to BDB XML, such as the on-disk location where the document was originally stored, or possibly notes about the document that might be useful to the document's maintainer.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlMetaData

See Also

XmlMetaData Members


XmlMetaData Members

[image] [image]

.NET Framework Class Library
XmlMetaData Members
XmlMetaData Class Constructors Methods Properties See Also Send Feedback

The XmlMetaData type exposes the following members.

Constructors

Name | Description
XmlMetaData | Initializes a new instance of the XmlMetaData class.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Name | The name of the meta data item.
Uri | The namespace URI of the meta data item.
Value | The value of the meta data item.

See Also

XmlMetaData Class


XmlMetaData Constructor

[image]

.NET Framework Class Library
XmlMetaData Constructor
XmlMetaData Class See Also Send Feedback

Initializes a new instance of the XmlMetaData class.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    uri As String, _
    name As String, _
    xmlValue As XmlValue _
)
C#
public XmlMetaData(
    string uri,
    string name,
    XmlValue xmlValue
)
Visual C++
public:
XmlMetaData(
    String^ uri,
    String^ name,
    XmlValue^ xmlValue
)
JavaScript
JanaBiz.DbXml.XmlMetaData = function(uri, name, xmlValue);

Parameters

uri
Type: System..::.String
The namespace URI of the meta data item.
name
Type: System..::.String
The name of the meta data item.
xmlValue
Type: JanaBiz.DbXml..::.XmlValue
The value of the meta data item.

See Also

XmlMetaData Class


XmlMetaData Methods

[image] [image]

.NET Framework Class Library
XmlMetaData Methods
XmlMetaData Class See Also Send Feedback

The XmlMetaData type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlMetaData Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlMetaData..::.Dispose Method
XmlMetaData Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlMetaData Class
XmlMetaData Members


XmlMetaData Properties

[image] [image]

.NET Framework Class Library
XmlMetaData Properties
XmlMetaData Class See Also Send Feedback

The XmlMetaData type exposes the following members.

Properties

Name | Description
Name | The name of the meta data item.
Uri | The namespace URI of the meta data item.
Value | The value of the meta data item.

See Also

XmlMetaData Class


Name Property

[image]

.NET Framework Class Library
XmlMetaData..::.Name Property
XmlMetaData Class See Also Send Feedback

The name of the meta data item.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name { get; }
Visual C++
public:
property String^ Name {
    String^ get ();
}
JavaScript
function get_name();

See Also

XmlMetaData Class


Uri Property

[image]

.NET Framework Class Library
XmlMetaData..::.Uri Property
XmlMetaData Class See Also Send Feedback

The namespace URI of the meta data item.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Uri As String
C#
public string Uri { get; }
Visual C++
public:
property String^ Uri {
    String^ get ();
}
JavaScript
function get_uri();

See Also

XmlMetaData Class


Value Property

[image]

.NET Framework Class Library
XmlMetaData..::.Value Property
XmlMetaData Class See Also Send Feedback

The value of the meta data item.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Value As XmlValue
C#
public XmlValue Value { get; }
Visual C++
public:
property XmlValue^ Value {
    XmlValue^ get ();
}
JavaScript
function get_value();

See Also

XmlMetaData Class


XmlMetaDataIterator Class

[image]

.NET Framework Class Library
XmlMetaDataIterator Class
Members See Also Send Feedback

Provides an iterator over an XmlDocument's metadata.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlMetaDataIterator _
    Inherits InvocationHandle _
    Implements IEnumerator
C#
public class XmlMetaDataIterator : InvocationHandle,
    IEnumerator
Visual C++
public ref class XmlMetaDataIterator : public InvocationHandle,
    IEnumerator
JavaScript
JanaBiz.DbXml.XmlMetaDataIterator = function();

Type.createClass(
    'JanaBiz.DbXml.XmlMetaDataIterator',
    JanaBiz.Bridge.InvocationHandle,
    IEnumerator);

Remarks

Metadata is set on a XmlDocument's with SetMetaData(XmlMetaData) You can also use GetMetaData(String, String)to return a specific metadata item.

This object is instantiated using MetaDataIterator

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlMetaDataIterator

See Also

XmlMetaDataIterator Members


XmlMetaDataIterator Members

[image] [image]

.NET Framework Class Library
XmlMetaDataIterator Members
XmlMetaDataIterator Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlMetaDataIterator type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
Reset | Sets the iterator to the beginning of the XmlDocument's metadata list.
ToString | (Inherited from Object.)

Properties

Name | Description
Current | コレクション内の現在の要素を取得します。

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlMetaDataIterator Class


XmlMetaDataIterator Methods

[image] [image]

.NET Framework Class Library
XmlMetaDataIterator Methods
XmlMetaDataIterator Class See Also Send Feedback

The XmlMetaDataIterator type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
Reset | Sets the iterator to the beginning of the XmlDocument's metadata list.
ToString | (Inherited from Object.)

See Also

XmlMetaDataIterator Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlMetaDataIterator..::.Dispose Method
XmlMetaDataIterator Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlMetaDataIterator Class
XmlMetaDataIterator Members


MoveNext Method

[image]

.NET Framework Class Library
XmlMetaDataIterator..::.MoveNext Method
XmlMetaDataIterator Class See Also Send Feedback

列挙子をコレクションの次の要素に進めます。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveNext As Boolean
C#
public bool MoveNext()
Visual C++
public:
virtual bool MoveNext() sealed
JavaScript
function moveNext();

Return Value

列挙子が次の要素に正常に進んだ場合は trueTruetruetrue (True in Visual Basic)。列挙子がコレクションの末尾を越えた場合は falseFalsefalsefalse (False in Visual Basic)。

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が作成された後に、コレクションが変更されました。

See Also

XmlMetaDataIterator Class


Reset Method

[image]

.NET Framework Class Library
XmlMetaDataIterator..::.Reset Method
XmlMetaDataIterator Class See Also Send Feedback

Sets the iterator to the beginning of the XmlDocument's metadata list.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset
C#
public void Reset()
Visual C++
public:
virtual void Reset() sealed
JavaScript
function reset();

Implements

IEnumerator..::.Reset()()()

See Also

XmlMetaDataIterator Class


XmlMetaDataIterator Properties

[image] [image]

.NET Framework Class Library
XmlMetaDataIterator Properties
XmlMetaDataIterator Class See Also Send Feedback

The XmlMetaDataIterator type exposes the following members.

Properties

Name | Description
Current | コレクション内の現在の要素を取得します。

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlMetaDataIterator Class


IEnumerator.Current Property

[image]

.NET Framework Class Library
XmlMetaDataIterator..::.IEnumerator..::.Current Property
XmlMetaDataIterator Class See Also Send Feedback

コレクション内の現在の要素を取得します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
C#
Object IEnumerator.Current { get; }
Visual C++
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
JavaScript
JavaScript does not support explicit interface implementations.

Field Value

Implements

IEnumerator..::.Current

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が、コレクションの最初の要素の前、または最後の要素の後に位置しています。

See Also

XmlMetaDataIterator Class


Current Property

[image]

.NET Framework Class Library
XmlMetaDataIterator..::.Current Property
XmlMetaDataIterator Class See Also Send Feedback

コレクション内の現在の要素を取得します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As XmlMetaData
C#
public XmlMetaData Current { get; }
Visual C++
public:
property XmlMetaData^ Current {
    XmlMetaData^ get ();
}
JavaScript
function get_current();

Field Value

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が、コレクションの最初の要素の前、または最後の要素の後に位置しています。

See Also

XmlMetaDataIterator Class


XmlNode Class

[image]

.NET Framework Class Library
XmlNode Class
Members See Also Send Feedback

The abstract class that represents a XmlNode.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlNode _
    Inherits InvocationHandle
C#
public class XmlNode : InvocationHandle
Visual C++
public ref class XmlNode : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlNode = function();

Type.createClass(
    'JanaBiz.DbXml.XmlNode',
    JanaBiz.Bridge.InvocationHandle);

Remarks

This class aims to implement all the features of a read only W3C DOM node. It adds special support for retrieving an attribute's owner element.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlNode
JanaBiz.DbXml..::.XmlDocument

See Also

XmlNode Members
JanaBiz.DbXml Namespace
System..::.IDisposable
IDisposable..::.Dispose()()()
JanaBiz.DbXml..::.XmlDocument


XmlNode Members

[image] [image]

.NET Framework Class Library
XmlNode Members
XmlNode Class Methods Properties See Also Send Feedback

The XmlNode type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | 現在の Object を表す String を返します。 (Overrides Object..::.ToString()()().)

Properties

Name | Description
Attributes | Returns returns a XmlResults that contains all of the attributes appearing on this node.
FirstChild | Returns a XmlNode that current node's first child node.
LastChild | Returns a XmlNode that current node's last child node.
LocalName | Returns the node's local name.
NamespaceUri | Returns the URI used for the node's namespace.
NextSibling | Returns a XmlNode that the sibling node immediately following this node in the document.
NodeHandle | Returns a String handle that can be used to directly reference nodes within a document by using GetNode(String)
NodeName | Returns the name of the node contained in this XmlValue.
NodeType | Returns the short value for this node's XercesC GetNodeType.
NodeValue | Returns the node's value. The value of each type list in following: Attribute the attribute's value CDATASection the content of CDATA section Comment the content of comment Document null DocumentFragment null DocumentType null Element null Entity null EntityReference null Notation null ProcessingInstruction all contents not including target Text the value of text SignificantWhitespace whitespace, carriage, return char newline,tab etc. Whitespace whitespace, carriage, return char newline,tab etc. XmlDeclaration declaration content such as the content between <?xml and ?>
OwnerDocument | The owner document of this node, as defined by the W3C DOM specification.
OwnerElement | The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node.
ParentNode | Returns a XmlNode that current node's parent.
Prefix | Returns the prefix set for the node's namespace.
PreviousSibling | Returns the sibling node immediately preceding this node in the document.

See Also

XmlNode Class


XmlNode Methods

[image] [image]

.NET Framework Class Library
XmlNode Methods
XmlNode Class See Also Send Feedback

The XmlNode type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | 現在の Object を表す String を返します。 (Overrides Object..::.ToString()()().)

See Also

XmlNode Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlNode..::.Dispose Method
XmlNode Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlNode Class
XmlNode Members


ToString Method

[image]

.NET Framework Class Library
XmlNode..::.ToString Method
XmlNode Class See Also Send Feedback

現在の Object を表す String を返します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

現在の Object を表す String。

See Also

XmlNode Class


XmlNode Properties

[image] [image]

.NET Framework Class Library
XmlNode Properties
XmlNode Class See Also Send Feedback

The XmlNode type exposes the following members.

Properties

Name | Description
Attributes | Returns returns a XmlResults that contains all of the attributes appearing on this node.
FirstChild | Returns a XmlNode that current node's first child node.
LastChild | Returns a XmlNode that current node's last child node.
LocalName | Returns the node's local name.
NamespaceUri | Returns the URI used for the node's namespace.
NextSibling | Returns a XmlNode that the sibling node immediately following this node in the document.
NodeHandle | Returns a String handle that can be used to directly reference nodes within a document by using GetNode(String)
NodeName | Returns the name of the node contained in this XmlValue.
NodeType | Returns the short value for this node's XercesC GetNodeType.
NodeValue | Returns the node's value. The value of each type list in following: Attribute the attribute's value CDATASection the content of CDATA section Comment the content of comment Document null DocumentFragment null DocumentType null Element null Entity null EntityReference null Notation null ProcessingInstruction all contents not including target Text the value of text SignificantWhitespace whitespace, carriage, return char newline,tab etc. Whitespace whitespace, carriage, return char newline,tab etc. XmlDeclaration declaration content such as the content between <?xml and ?>
OwnerDocument | The owner document of this node, as defined by the W3C DOM specification.
OwnerElement | The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node.
ParentNode | Returns a XmlNode that current node's parent.
Prefix | Returns the prefix set for the node's namespace.
PreviousSibling | Returns the sibling node immediately preceding this node in the document.

See Also

XmlNode Class


Attributes Property

[image]

.NET Framework Class Library
XmlNode..::.Attributes Property
XmlNode Class See Also Send Feedback

Returns returns a XmlResults that contains all of the attributes appearing on this node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Attributes As XmlResults
C#
public virtual XmlResults Attributes { get; }
Visual C++
public:
virtual property XmlResults^ Attributes {
    XmlResults^ get ();
}
JavaScript
function get_attributes();

See Also

XmlNode Class


FirstChild Property

[image]

.NET Framework Class Library
XmlNode..::.FirstChild Property
XmlNode Class See Also Send Feedback

Returns a XmlNode that current node's first child node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property FirstChild As XmlNode
C#
public virtual XmlNode FirstChild { get; }
Visual C++
public:
virtual property XmlNode^ FirstChild {
    XmlNode^ get ();
}
JavaScript
function get_firstChild();

See Also

XmlNode Class


LastChild Property

[image]

.NET Framework Class Library
XmlNode..::.LastChild Property
XmlNode Class See Also Send Feedback

Returns a XmlNode that current node's last child node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LastChild As XmlNode
C#
public virtual XmlNode LastChild { get; }
Visual C++
public:
virtual property XmlNode^ LastChild {
    XmlNode^ get ();
}
JavaScript
function get_lastChild();

Return Value

See Also

XmlNode Class


LocalName Property

[image]

.NET Framework Class Library
XmlNode..::.LocalName Property
XmlNode Class See Also Send Feedback

Returns the node's local name.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property LocalName As String
C#
public virtual string LocalName { get; }
Visual C++
public:
virtual property String^ LocalName {
    String^ get ();
}
JavaScript
function get_localName();

Remarks

For example, if a node has the namespace prefix, "prefix," and its qualified name is prefix:name, then 'name' is the local name.

See Also

XmlNode Class


NamespaceUri Property

[image]

.NET Framework Class Library
XmlNode..::.NamespaceUri Property
XmlNode Class See Also Send Feedback

Returns the URI used for the node's namespace.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NamespaceUri As String
C#
public virtual string NamespaceUri { get; }
Visual C++
public:
virtual property String^ NamespaceUri {
    String^ get ();
}
JavaScript
function get_namespaceUri();

See Also

XmlNode Class


NextSibling Property

[image]

.NET Framework Class Library
XmlNode..::.NextSibling Property
XmlNode Class See Also Send Feedback

Returns a XmlNode that the sibling node immediately following this node in the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NextSibling As XmlNode
C#
public virtual XmlNode NextSibling { get; }
Visual C++
public:
virtual property XmlNode^ NextSibling {
    XmlNode^ get ();
}
JavaScript
function get_nextSibling();

Remarks

If the current node had no siblings following it in the document, a null node is returned.

See Also

XmlNode Class


NodeHandle Property

[image]

.NET Framework Class Library
XmlNode..::.NodeHandle Property
XmlNode Class See Also Send Feedback

Returns a String handle that can be used to directly reference nodes within a document by using GetNode(String)

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NodeHandle As String
C#
public string NodeHandle { get; }
Visual C++
public:
property String^ NodeHandle {
    String^ get ();
}
JavaScript
function get_nodeHandle();

See Also

XmlNode Class


NodeName Property

[image]

.NET Framework Class Library
XmlNode..::.NodeName Property
XmlNode Class See Also Send Feedback

Returns the name of the node contained in this XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NodeName As String
C#
public virtual string NodeName { get; }
Visual C++
public:
virtual property String^ NodeName {
    String^ get ();
}
JavaScript
function get_nodeName();

See Also

XmlNode Class


NodeType Property

[image]

.NET Framework Class Library
XmlNode..::.NodeType Property
XmlNode Class See Also Send Feedback

Returns the short value for this node's XercesC GetNodeType.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NodeType As XmlNodeType
C#
public virtual XmlNodeType NodeType { get; }
Visual C++
public:
virtual property XmlNodeType NodeType {
    XmlNodeType get ();
}
JavaScript
function get_nodeType();

See Also

XmlNode Class


NodeValue Property

[image]

.NET Framework Class Library
XmlNode..::.NodeValue Property
XmlNode Class See Also Send Feedback

Returns the node's value. The value of each type list in following: Attribute the attribute's value CDATASection the content of CDATA section Comment the content of comment Document null DocumentFragment null DocumentType null Element null Entity null EntityReference null Notation null ProcessingInstruction all contents not including target Text the value of text SignificantWhitespace whitespace, carriage, return char newline,tab etc. Whitespace whitespace, carriage, return char newline,tab etc. XmlDeclaration declaration content such as the content between <?xml and ?>

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property NodeValue As String
C#
public virtual string NodeValue { get; }
Visual C++
public:
virtual property String^ NodeValue {
    String^ get ();
}
JavaScript
function get_nodeValue();

See Also

XmlNode Class


OwnerDocument Property

[image]

.NET Framework Class Library
XmlNode..::.OwnerDocument Property
XmlNode Class See Also Send Feedback

The owner document of this node, as defined by the W3C DOM specification.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OwnerDocument As XmlDocument
C#
public virtual XmlDocument OwnerDocument { get; }
Visual C++
public:
virtual property XmlDocument^ OwnerDocument {
    XmlDocument^ get ();
}
JavaScript
function get_ownerDocument();

See Also

XmlNode Class


OwnerElement Property

[image]

.NET Framework Class Library
XmlNode..::.OwnerElement Property
XmlNode Class See Also Send Feedback

The owner element of this attribute node, as defined by the W3C DOM specification. If the current node is an attribute node, returns a XmlNode that contains this attribute node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property OwnerElement As XmlNode
C#
public virtual XmlNode OwnerElement { get; }
Visual C++
public:
virtual property XmlNode^ OwnerElement {
    XmlNode^ get ();
}
JavaScript
function get_ownerElement();

See Also

XmlNode Class


ParentNode Property

[image]

.NET Framework Class Library
XmlNode..::.ParentNode Property
XmlNode Class See Also Send Feedback

Returns a XmlNode that current node's parent.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property ParentNode As XmlNode
C#
public virtual XmlNode ParentNode { get; }
Visual C++
public:
virtual property XmlNode^ ParentNode {
    XmlNode^ get ();
}
JavaScript
function get_parentNode();

See Also

XmlNode Class


Prefix Property

[image]

.NET Framework Class Library
XmlNode..::.Prefix Property
XmlNode Class See Also Send Feedback

Returns the prefix set for the node's namespace.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Prefix As String
C#
public virtual string Prefix { get; }
Visual C++
public:
virtual property String^ Prefix {
    String^ get ();
}
JavaScript
function get_prefix();

See Also

XmlNode Class


PreviousSibling Property

[image]

.NET Framework Class Library
XmlNode..::.PreviousSibling Property
XmlNode Class See Also Send Feedback

Returns the sibling node immediately preceding this node in the document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property PreviousSibling As XmlNode
C#
public virtual XmlNode PreviousSibling { get; }
Visual C++
public:
virtual property XmlNode^ PreviousSibling {
    XmlNode^ get ();
}
JavaScript
function get_previousSibling();

See Also

XmlNode Class


XmlNodeType Enumeration

[image]

.NET Framework Class Library
XmlNodeType Enumeration
See Also Send Feedback

An enumeration for specifying node types.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlNodeType
C#
public enum XmlNodeType
Visual C++
public enum class XmlNodeType
JavaScript
JanaBiz.DbXml.XmlNodeType = function();
JanaBiz.DbXml.XmlNodeType.createEnum('JanaBiz.DbXml.XmlNodeType', false);

Members

Member name | Description
Element | Node type returned by NodeType
Attribute | Node type returned by NodeType
Text | Node type returned by NodeType
CDATA | Node type returned by NodeType
EntityReference | Node type returned by NodeType
Entity | Node type returned by NodeType
ProcessingInstruction | Node type returned by NodeType
Comment | Node type returned by NodeType
Document | Node type returned by NodeType
DocumentType | Node type returned by NodeType
DocumentFragment | Node type returned by NodeType
Notation | Node type returned by NodeType

See Also


XmlQueryContext Class

[image]

.NET Framework Class Library
XmlQueryContext Class
Members See Also Send Feedback

The XmlQueryContext class encapsulates the context within which a query is performed against an XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlQueryContext _
    Inherits InvocationHandle
C#
public class XmlQueryContext : InvocationHandle
Visual C++
public ref class XmlQueryContext : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlQueryContext = function();

Type.createClass(
    'JanaBiz.DbXml.XmlQueryContext',
    JanaBiz.Bridge.InvocationHandle);

Remarks

The context includes namespace mappings, variable bindings, and flags that indicate how the query result set should be determined and returned to the caller. Multiple queries can be executed within the same XmlQueryContext However, XmlQueryContext is not thread-safe, and can only be used by one thread at a time.

XmlQueryContext objects are instantiated using CreateQueryContext()()()

XmlQueryContext allows you to define whether queries executed within the context are to be evaluated lazily or eagerly, and whether the query is to return live or dead values. For detailed descriptions of these parameters see ReturnType and EvaluationType Note that these values are also set when you create a query context using CreateQueryContext()()()

The XQuery syntax permits expressions to refer to namespace prefixes, and to define them. The XmlQueryContext class provides namespace management methods so that the caller may manage the namespace prefix to URI mapping outside of a query. By default the prefix "dbxml" is defined to be "http://www.sleepycat.com/2002/dbxml".

The XQuery syntax also permits expressions to refer to externally defined variables. The XmlQueryContext class provides methods that allow the caller to manage the externally-declared variable to value bindings.

A copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlQueryContext

See Also

XmlQueryContext Members


XmlQueryContext Members

[image] [image]

.NET Framework Class Library
XmlQueryContext Members
XmlQueryContext Class Methods Properties See Also Send Feedback

The XmlQueryContext type exposes the following members.

Methods

Name | Description
ClearNamespaces | Remove all namespace mappings from the query context.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetNamespace | Returns the namespace URI for the specified prefix. An empty string is returned if no URI is defined for the prefix.
GetType | (Inherited from Object.)
GetVariableValue | Returns the value that is bound to the specified variable.
GetVariableValues | Returns the XmlResults object representing the sequence of values that is bound to the specified variable.
InterruptQuery | Interrupt the in-progress query using this XmlQueryContext.
MemberwiseClone | (Inherited from Object.)
RemoveNamespace | Remove the namespace prefix to URI mapping for the specified prefix. A call to this method with a prefix that has no existing mapping is ignored.
SetNamespace | Maps the specified URI to the specified namespace prefix.
SetVariableValue | Overloaded.
ToString | (Inherited from Object.)

Properties

Name | Description
BaseUri | The base URI used for relative paths in query expressions.
DebugListener | Gets or sets the XmlDebugListener associated with this query context. Associates an XmlDebugListener instance with the query context in order to debug queries. In order to prepare a query that contains debugging information an XmlDebugListener must be set on the XmlQueryContext used when the query is prepared. A different XmlDebugListener object (or none) can be set for the query evaluation.
DefaultCollection | The default collection is that which is used by fn:collection() without any arguments in an XQuery expression.
EvaluationType | Allows the application to set the query evaluation type to "eager" or "lazy".
QueryTimeoutSeconds | The query timeout that will cause a query using this XmlQueryContext to terminate if the query time exceeds the timeout value.
ReturnType | The ReturnType method allows the application to define whether the query should return live or dead document values.

See Also

XmlQueryContext Class


XmlQueryContext Methods

[image] [image]

.NET Framework Class Library
XmlQueryContext Methods
XmlQueryContext Class See Also Send Feedback

The XmlQueryContext type exposes the following members.

Methods

Name | Description
ClearNamespaces | Remove all namespace mappings from the query context.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetNamespace | Returns the namespace URI for the specified prefix. An empty string is returned if no URI is defined for the prefix.
GetType | (Inherited from Object.)
GetVariableValue | Returns the value that is bound to the specified variable.
GetVariableValues | Returns the XmlResults object representing the sequence of values that is bound to the specified variable.
InterruptQuery | Interrupt the in-progress query using this XmlQueryContext.
MemberwiseClone | (Inherited from Object.)
RemoveNamespace | Remove the namespace prefix to URI mapping for the specified prefix. A call to this method with a prefix that has no existing mapping is ignored.
SetNamespace | Maps the specified URI to the specified namespace prefix.
SetVariableValue | Overloaded.
ToString | (Inherited from Object.)

See Also

XmlQueryContext Class


ClearNamespaces Method

[image]

.NET Framework Class Library
XmlQueryContext..::.ClearNamespaces Method
XmlQueryContext Class See Also Send Feedback

Remove all namespace mappings from the query context.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ClearNamespaces
C#
public void ClearNamespaces()
Visual C++
public:
void ClearNamespaces()
JavaScript
function clearNamespaces();

See Also

XmlQueryContext Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlQueryContext..::.Dispose Method
XmlQueryContext Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlQueryContext Class
XmlQueryContext Members


GetNamespace Method

[image]

.NET Framework Class Library
XmlQueryContext..::.GetNamespace Method
XmlQueryContext Class See Also Send Feedback

Returns the namespace URI for the specified prefix. An empty string is returned if no URI is defined for the prefix.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetNamespace ( _
    prefix As String _
) As String
C#
public string GetNamespace(
    string prefix
)
Visual C++
public:
String^ GetNamespace(
    String^ prefix
)
JavaScript
function getNamespace(prefix);

Parameters

prefix
Type: System..::.String
The namespace prefix whose URI mapping is required.

Return Value

See Also

XmlQueryContext Class


GetVariableValue Method

[image]

.NET Framework Class Library
XmlQueryContext..::.GetVariableValue Method
XmlQueryContext Class See Also Send Feedback

Returns the value that is bound to the specified variable.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariableValue ( _
    name As String _
) As XmlValue
C#
public XmlValue GetVariableValue(
    string name
)
Visual C++
public:
XmlValue^ GetVariableValue(
    String^ name
)
JavaScript
function getVariableValue(name);

Parameters

name
Type: System..::.String
The name of the variable whose value is required.

Return Value

Remarks

The value bound to the specified variable, or a null reference (nullNothingnullptra null reference (Nothing in Visual Basic) in Visual Basic) if no value is found.

See Also

XmlQueryContext Class


GetVariableValues Method

[image]

.NET Framework Class Library
XmlQueryContext..::.GetVariableValues Method
XmlQueryContext Class See Also Send Feedback

Returns the XmlResults object representing the sequence of values that is bound to the specified variable.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function GetVariableValues ( _
    name As String _
) As XmlResults
C#
public XmlResults GetVariableValues(
    string name
)
Visual C++
public:
XmlResults^ GetVariableValues(
    String^ name
)
JavaScript
function getVariableValues(name);

Parameters

name
Type: System..::.String

Return Value

Remarks

If there is no value binding then the value is set to the null value (IsNull()()() returns true).

See Also

XmlQueryContext Class


InterruptQuery Method

[image]

.NET Framework Class Library
XmlQueryContext..::.InterruptQuery Method
XmlQueryContext Class See Also Send Feedback

Interrupt the in-progress query using this XmlQueryContext.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub InterruptQuery
C#
public void InterruptQuery()
Visual C++
public:
void InterruptQuery()
JavaScript
function interruptQuery();

See Also

XmlQueryContext Class


RemoveNamespace Method

[image]

.NET Framework Class Library
XmlQueryContext..::.RemoveNamespace Method
XmlQueryContext Class See Also Send Feedback

Remove the namespace prefix to URI mapping for the specified prefix. A call to this method with a prefix that has no existing mapping is ignored.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub RemoveNamespace ( _
    prefix As String _
)
C#
public void RemoveNamespace(
    string prefix
)
Visual C++
public:
void RemoveNamespace(
    String^ prefix
)
JavaScript
function removeNamespace(prefix);

Parameters

prefix
Type: System..::.String
The namespace prefix to be removed.

See Also

XmlQueryContext Class


SetNamespace Method

[image]

.NET Framework Class Library
XmlQueryContext..::.SetNamespace Method
XmlQueryContext Class See Also Send Feedback

Maps the specified URI to the specified namespace prefix.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetNamespace ( _
    prefix As String, _
    uri As String _
)
C#
public void SetNamespace(
    string prefix,
    string uri
)
Visual C++
public:
void SetNamespace(
    String^ prefix,
    String^ uri
)
JavaScript
function setNamespace(prefix, uri);

Parameters

prefix
Type: System..::.String
The namespace prefix.
uri
Type: System..::.String
The namespace URI.

See Also

XmlQueryContext Class


SetVariableValue Method

[image] [image]

.NET Framework Class Library
XmlQueryContext..::.SetVariableValue Method
XmlQueryContext Class See Also Send Feedback

Overload List

Name | Description
SetVariableValue(String, XmlResults) | Creates an externally-declared XQuery sequence variable by binding the specified XmlResults object to the specified variable name.
SetVariableValue(String, XmlValue) | Creates an externally-declared XQuery sequence variable by binding the specified XmlResults object to the specified variable name.

See Also

XmlQueryContext Class
XmlQueryContext Members


SetVariableValue Method (String, XmlResults)

[image]

.NET Framework Class Library
XmlQueryContext..::.SetVariableValue Method (String, XmlResults)
XmlQueryContext Class See Also Send Feedback

Creates an externally-declared XQuery sequence variable by binding the specified XmlResults object to the specified variable name.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetVariableValue ( _
    name As String, _
    value As XmlResults _
)
C#
public void SetVariableValue(
    string name,
    XmlResults value
)
Visual C++
public:
void SetVariableValue(
    String^ name,
    XmlResults^ value
)
JavaScript
function setVariableValue(name, value);

Parameters

name
Type: System..::.String
The name of the variable to bind. Within the XQuery query, the variable can be referenced using the normal $name syntax.
value
Type: JanaBiz.DbXml..::.XmlResults
The set of values to bind to the named variable.

See Also

XmlQueryContext Class
SetVariableValue Overload


SetVariableValue Method (String, XmlValue)

[image]

.NET Framework Class Library
XmlQueryContext..::.SetVariableValue Method (String, XmlValue)
XmlQueryContext Class See Also Send Feedback

Creates an externally-declared XQuery sequence variable by binding the specified XmlResults object to the specified variable name.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub SetVariableValue ( _
    name As String, _
    value As XmlValue _
)
C#
public void SetVariableValue(
    string name,
    XmlValue value
)
Visual C++
public:
void SetVariableValue(
    String^ name,
    XmlValue^ value
)
JavaScript
function setVariableValue(name, value);

Parameters

name
Type: System..::.String
The name of the variable to bind. Within the XQuery query, the variable can be referenced using the normal $name syntax.
value
Type: JanaBiz.DbXml..::.XmlValue
The set of values to bind to the named variable.

Remarks

This method allows a sequence of values to be bound to an XQuery variable.

See Also

XmlQueryContext Class
SetVariableValue Overload


XmlQueryContext Properties

[image] [image]

.NET Framework Class Library
XmlQueryContext Properties
XmlQueryContext Class See Also Send Feedback

The XmlQueryContext type exposes the following members.

Properties

Name | Description
BaseUri | The base URI used for relative paths in query expressions.
DebugListener | Gets or sets the XmlDebugListener associated with this query context. Associates an XmlDebugListener instance with the query context in order to debug queries. In order to prepare a query that contains debugging information an XmlDebugListener must be set on the XmlQueryContext used when the query is prepared. A different XmlDebugListener object (or none) can be set for the query evaluation.
DefaultCollection | The default collection is that which is used by fn:collection() without any arguments in an XQuery expression.
EvaluationType | Allows the application to set the query evaluation type to "eager" or "lazy".
QueryTimeoutSeconds | The query timeout that will cause a query using this XmlQueryContext to terminate if the query time exceeds the timeout value.
ReturnType | The ReturnType method allows the application to define whether the query should return live or dead document values.

See Also

XmlQueryContext Class


BaseUri Property

[image]

.NET Framework Class Library
XmlQueryContext..::.BaseUri Property
XmlQueryContext Class See Also Send Feedback

The base URI used for relative paths in query expressions.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property BaseUri As String
C#
public string BaseUri { get; set; }
Visual C++
public:
property String^ BaseUri {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_baseUri();
function set_baseUri(value);

Remarks

For example, a base URI of 'file:///export/expression/', And a relative path of '../another/expression', resolves to 'file:///export/another/expression'.

dbxml:/ is the default base URI for BDB XML. You an change the base URI using BaseUri.

See Also

XmlQueryContext Class


DebugListener Property

[image]

.NET Framework Class Library
XmlQueryContext..::.DebugListener Property
XmlQueryContext Class See Also Send Feedback

Gets or sets the XmlDebugListener associated with this query context.

Associates an XmlDebugListener instance with the query context in order to debug queries. In order to prepare a query that contains debugging information an XmlDebugListener must be set on the XmlQueryContext used when the query is prepared. A different XmlDebugListener object (or none) can be set for the query evaluation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DebugListener As XmlDebugListener
C#
public XmlDebugListener DebugListener { get; set; }
Visual C++
public:
property XmlDebugListener^ DebugListener {
    XmlDebugListener^ get ();
    void set (XmlDebugListener^ value);
}
JavaScript
function get_debugListener();
function set_debugListener(value);

See Also

XmlQueryContext Class


DefaultCollection Property

[image]

.NET Framework Class Library
XmlQueryContext..::.DefaultCollection Property
XmlQueryContext Class See Also Send Feedback

The default collection is that which is used by fn:collection() without any arguments in an XQuery expression.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property DefaultCollection As String
C#
public string DefaultCollection { get; set; }
Visual C++
public:
property String^ DefaultCollection {
    String^ get ();
    void set (String^ value);
}
JavaScript
function get_defaultCollection();
function set_defaultCollection(value);

See Also

XmlQueryContext Class


EvaluationType Property

[image]

.NET Framework Class Library
XmlQueryContext..::.EvaluationType Property
XmlQueryContext Class See Also Send Feedback

Allows the application to set the query evaluation type to "eager" or "lazy".

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property EvaluationType As XmlQueryContextEvaluationType
C#
public XmlQueryContextEvaluationType EvaluationType { get; set; }
Visual C++
public:
property XmlQueryContextEvaluationType EvaluationType {
    XmlQueryContextEvaluationType get ();
    void set (XmlQueryContextEvaluationType value);
}
JavaScript
function get_evaluationType();
function set_evaluationType(value);

Remarks

Eager evaluation means that the whole query is executed and its resultant values derived and stored in-memory before evaluation of the query is completed. Lazy evaluation means that minimal processing is performed before the query is completed, and the remaining processing is deferred until the result set is enumerated. As each call to Next()()() is called the next resultant value is determined.

See Also

XmlQueryContext Class


QueryTimeoutSeconds Property

[image]

.NET Framework Class Library
XmlQueryContext..::.QueryTimeoutSeconds Property
XmlQueryContext Class See Also Send Feedback

The query timeout that will cause a query using this XmlQueryContext to terminate if the query time exceeds the timeout value.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property QueryTimeoutSeconds As Integer
C#
public int QueryTimeoutSeconds { get; set; }
Visual C++
public:
property int QueryTimeoutSeconds {
    int get ();
    void set (int value);
}
JavaScript
function get_queryTimeoutSeconds();
function set_queryTimeoutSeconds(value);

Remarks

The execution of the query will throw an DbXmlException with the OperationTimeout if the timeout occurs.

See Also

XmlQueryContext Class


ReturnType Property

[image]

.NET Framework Class Library
XmlQueryContext..::.ReturnType Property
XmlQueryContext Class See Also Send Feedback

The ReturnType method allows the application to define whether the query should return live or dead document values.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Property ReturnType As XmlQueryContextReturnType
C#
public XmlQueryContextReturnType ReturnType { get; set; }
Visual C++
public:
property XmlQueryContextReturnType ReturnType {
    XmlQueryContextReturnType get ();
    void set (XmlQueryContextReturnType value);
}
JavaScript
function get_returnType();
function set_returnType(value);

See Also

XmlQueryContext Class


XmlQueryContextEvaluationType Enumeration

[image]

.NET Framework Class Library
XmlQueryContextEvaluationType Enumeration
See Also Send Feedback

The evaluation type must be specified as either.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlQueryContextEvaluationType
C#
public enum XmlQueryContextEvaluationType
Visual C++
public enum class XmlQueryContextEvaluationType
JavaScript
JanaBiz.DbXml.XmlQueryContextEvaluationType = function();
JanaBiz.DbXml.XmlQueryContextEvaluationType.createEnum('JanaBiz.DbXml.XmlQueryContextEvaluationType', false);

Members

Member name | Description
Eager | Evaluate the whole query immediatly.
Lazy | Evaluate the query as the result set is iterated over.

See Also


XmlQueryContextReturnType Enumeration

[image]

.NET Framework Class Library
XmlQueryContextReturnType Enumeration
See Also Send Feedback

The type parameter specifies which of documents or values to return.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlQueryContextReturnType
C#
public enum XmlQueryContextReturnType
Visual C++
public enum class XmlQueryContextReturnType
JavaScript
JanaBiz.DbXml.XmlQueryContextReturnType = function();
JanaBiz.DbXml.XmlQueryContextReturnType.createEnum('JanaBiz.DbXml.XmlQueryContextReturnType', false);

Members

Member name | Description
DeadValues | Return dead (copied) nodes from the documents that match the XPath expression.
LiveValues | Return live (non-copied) nodes that match the XPath expression, along with a reference to their document.

See Also


XmlQueryExpression Class

[image]

.NET Framework Class Library
XmlQueryExpression Class
Members See Also Send Feedback

An XmlQueryExpression represents a parsed XQuery expression, and is created by a call to Prepare(String, XmlQueryContext).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlQueryExpression _
    Inherits InvocationHandle
C#
public class XmlQueryExpression : InvocationHandle
Visual C++
public ref class XmlQueryExpression : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlQueryExpression = function();

Type.createClass(
    'JanaBiz.DbXml.XmlQueryExpression',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Parsed XQuery expressions are useful because they allow the cost of query parsing and optimization to be amortized over many evaluations.

The copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

This object is free threaded, and can be safely shared among threads in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlQueryExpression

See Also

XmlQueryExpression Members


XmlQueryExpression Members

[image] [image]

.NET Framework Class Library
XmlQueryExpression Members
XmlQueryExpression Class Methods Properties See Also Send Feedback

The XmlQueryExpression type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
IsUpdateExpression | whether or not expresion is updating expression
Query | Returns the query as a string
QueryPlan | Returns the queryplan as a string

See Also

XmlQueryExpression Class


XmlQueryExpression Methods

[image] [image]

.NET Framework Class Library
XmlQueryExpression Methods
XmlQueryExpression Class See Also Send Feedback

The XmlQueryExpression type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Execute | Overloaded.
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlQueryExpression Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlQueryExpression..::.Dispose Method
XmlQueryExpression Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlQueryExpression Class
XmlQueryExpression Members


Execute Method

[image] [image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method
XmlQueryExpression Class See Also Send Feedback

Overload List

Name | Description
Execute(XmlQueryContext) | Evaluates (runs) an XQuery query that was previously prepared by Prepare(String, XmlQueryContext) and returns an XmlResults set.
Execute(XmlQueryContext, XmlDocumentConfig) | Evaluates (runs) an XQuery query that was previously prepared by Prepare(String, XmlQueryContext) and returns an XmlResults set.
Execute(XmlTransaction, XmlQueryContext) | Evaluates the XQuery expression against the containers and documents identified by the query, from within the scope of the provided XmlTransaction object.
Execute(XmlValue, XmlQueryContext) | Evaluates the XQuery expression against the provided context item in the given query context.
Execute(XmlTransaction, XmlQueryContext, XmlDocumentConfig) | Evaluates the XQuery expression against the containers and documents identified by the query, from within the scope of the provided XmlTransaction object, with configuration.
Execute(XmlTransaction, XmlValue, XmlQueryContext) | Evaluates the XQuery expression against the provided context item in the given query context, from within the scope of the provided XmlTransaction object.
Execute(XmlValue, XmlQueryContext, XmlDocumentConfig) | Evaluates the XQuery expression against the provided context item in the given query context with configuration.
Execute(XmlTransaction, XmlValue, XmlQueryContext, XmlDocumentConfig) | Evaluates the XQuery expression against the provided context item, from within the scope of the provided XmlTransaction object.

See Also

XmlQueryExpression Class
XmlQueryExpression Members


Execute Method (XmlQueryContext)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlQueryContext)
XmlQueryExpression Class See Also Send Feedback

Evaluates (runs) an XQuery query that was previously prepared by Prepare(String, XmlQueryContext) and returns an XmlResults set.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Execute(
    XmlQueryContext^ queryContext
)
JavaScript
function execute(queryContext);

Parameters

queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlQueryContext, XmlDocumentConfig)
XmlQueryExpression Class See Also Send Feedback

Evaluates (runs) an XQuery query that was previously prepared by Prepare(String, XmlQueryContext) and returns an XmlResults set.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    queryContext As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlQueryContext queryContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(queryContext, docConfig);

Parameters

queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The configuration settings for the execution.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlTransaction, XmlQueryContext)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlTransaction, XmlQueryContext)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the containers and documents identified by the query, from within the scope of the provided XmlTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlQueryContext^ queryContext
)
JavaScript
function execute(transaction, queryContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlValue, XmlQueryContext)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlValue, XmlQueryContext)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the provided context item in the given query context.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    contextItem As XmlValue, _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlValue contextItem,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Execute(
    XmlValue^ contextItem,
    XmlQueryContext^ queryContext
)
JavaScript
function execute(contextItem, queryContext);

Parameters

contextItem
Type: JanaBiz.DbXml..::.XmlValue
The XmlValue object to perform the query against.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlTransaction, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlTransaction, XmlQueryContext, XmlDocumentConfig)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the containers and documents identified by the query, from within the scope of the provided XmlTransaction object, with configuration.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    queryContext As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlQueryContext queryContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(transaction, queryContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The configuration settings for the execution.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlTransaction, XmlValue, XmlQueryContext)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlTransaction, XmlValue, XmlQueryContext)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the provided context item in the given query context, from within the scope of the provided XmlTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    contextItem As XmlValue, _
    queryContext As XmlQueryContext _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlValue contextItem,
    XmlQueryContext queryContext
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlValue^ contextItem,
    XmlQueryContext^ queryContext
)
JavaScript
function execute(transaction, contextItem, queryContext);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
contextItem
Type: JanaBiz.DbXml..::.XmlValue
The XmlValue object to perform the query against.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlValue, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlValue, XmlQueryContext, XmlDocumentConfig)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the provided context item in the given query context with configuration.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    contextItem As XmlValue, _
    queryContext As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlValue contextItem,
    XmlQueryContext queryContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlValue^ contextItem,
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(contextItem, queryContext, docConfig);

Parameters

contextItem
Type: JanaBiz.DbXml..::.XmlValue
The XmlValue object to perform the query against.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The configuration settings for the execution.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


Execute Method (XmlTransaction, XmlValue, XmlQueryContext, XmlDocumentConfig)

[image]

.NET Framework Class Library
XmlQueryExpression..::.Execute Method (XmlTransaction, XmlValue, XmlQueryContext, XmlDocumentConfig)
XmlQueryExpression Class See Also Send Feedback

Evaluates the XQuery expression against the provided context item, from within the scope of the provided XmlTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Execute ( _
    transaction As XmlTransaction, _
    contextItem As XmlValue, _
    queryContext As XmlQueryContext, _
    docConfig As XmlDocumentConfig _
) As XmlResults
C#
public XmlResults Execute(
    XmlTransaction transaction,
    XmlValue contextItem,
    XmlQueryContext queryContext,
    XmlDocumentConfig docConfig
)
Visual C++
public:
XmlResults^ Execute(
    XmlTransaction^ transaction,
    XmlValue^ contextItem,
    XmlQueryContext^ queryContext,
    XmlDocumentConfig^ docConfig
)
JavaScript
function execute(transaction, contextItem, queryContext, docConfig);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If the operation is to be transaction-protected, the txn parameter is an XmlTransaction handle returned from CreateTransaction()()().
contextItem
Type: JanaBiz.DbXml..::.XmlValue
The XmlValue object to perform the query against.
queryContext
Type: JanaBiz.DbXml..::.XmlQueryContext
The XmlQueryContext to use for this evaluation.
docConfig
Type: JanaBiz.DbXml..::.XmlDocumentConfig
The configuration settings for the execution.

Return Value

See Also

XmlQueryExpression Class
Execute Overload


XmlQueryExpression Properties

[image] [image]

.NET Framework Class Library
XmlQueryExpression Properties
XmlQueryExpression Class See Also Send Feedback

The XmlQueryExpression type exposes the following members.

Properties

Name | Description
IsUpdateExpression | whether or not expresion is updating expression
Query | Returns the query as a string
QueryPlan | Returns the queryplan as a string

See Also

XmlQueryExpression Class


IsUpdateExpression Property

[image]

.NET Framework Class Library
XmlQueryExpression..::.IsUpdateExpression Property
XmlQueryExpression Class See Also Send Feedback

whether or not expresion is updating expression

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsUpdateExpression As Boolean
C#
public bool IsUpdateExpression { get; }
Visual C++
public:
property bool IsUpdateExpression {
    bool get ();
}
JavaScript
function get_isUpdateExpression();

See Also

XmlQueryExpression Class


Query Property

[image]

.NET Framework Class Library
XmlQueryExpression..::.Query Property
XmlQueryExpression Class See Also Send Feedback

Returns the query as a string

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Query As String
C#
public string Query { get; }
Visual C++
public:
property String^ Query {
    String^ get ();
}
JavaScript
function get_query();

Return Value

See Also

XmlQueryExpression Class


QueryPlan Property

[image]

.NET Framework Class Library
XmlQueryExpression..::.QueryPlan Property
XmlQueryExpression Class See Also Send Feedback

Returns the queryplan as a string

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryPlan As String
C#
public string QueryPlan { get; }
Visual C++
public:
property String^ QueryPlan {
    String^ get ();
}
JavaScript
function get_queryPlan();

Return Value

See Also

XmlQueryExpression Class


XmlResolver Class

[image]

.NET Framework Class Library
XmlResolver Class
Members See Also Send Feedback

Provides an unimplemented base class that is used for file resolution policy.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public MustInherit Class XmlResolver _
    Inherits InvocationHandle
C#
public abstract class XmlResolver : InvocationHandle
Visual C++
public ref class XmlResolver abstract : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlResolver = function();

Type.createClass(
    'JanaBiz.DbXml.XmlResolver',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Implementations of this class are used for URI resolution, or for public and system ids resolution. XmlResolver implementations are identified for use using RegisterResolver(XmlResolver).

The XmlResolver class allows applications to provide named access to application-specific objects, such as documents, collections of documents, DTDs, and XML schema. Berkeley DB XML can resolve references to names within a container, or a file system; applications can create XmlResolver instances that can resolve entities in other locations.

For an example of an XmlResolver implementation, see the Berkeley DB XML distribution file test/cpp/util/TestResolver.cpp.

If an application uses multiple threads, custom implementations of XmlResolver must be free threaded, and allow multiple, simultaneous calls for resolution.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlResolver

See Also

XmlResolver Members


XmlResolver Members

[image] [image]

.NET Framework Class Library
XmlResolver Members
XmlResolver Class Constructors Methods See Also Send Feedback

The XmlResolver type exposes the following members.

Constructors

Name | Description
XmlResolver | Creates a new XmlResolver instance.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ResolveCollection | When implemented, should resolve a URI to an XmlResults. If the URI cannot be resolved by this resolver, this method should return falseFalsefalsefalse (False in Visual Basic). Otherwise, it should return trueTruetruetrue (True in Visual Basic).
ResolveDocument | When implemented, should resolve a URI to an XmlValue. If the URI cannot be resolved by this resolver, this method should return . Otherwise, it should return trueTruetruetrue (True in Visual Basic).
ResolveEntity | When implemented, should resolve a System ID and Public ID to a new XmlInputStream. If the IDs cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.
ResolveExternalFunction | When implemented this method resolves a unigue combination of function URI, function name and number of arguments into an instance of XmlExternalFunction used to implement an XQuery extension function. If the URI, name and arguments cannot be resolved null is returned. It may return a singleton or a new instance. Memory management of the returned object depends on the implementation of the XmlResolver and the XmlExternalFunction instance. Singletons are usually owned by XmlResolver while new instances must be deleted by Close()()().
ResolveModule | When implemented, should resolve a module location and namespace to a new XmlInputStream.
ResolveModuleLocation | When implemented, should resolve a module namespace to list of strings that are locations for the files that comprise the module.
ResolveSchema | When implemented, should resolve schema location and namespace information to a new XmlInputStream. If this information cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.
ToString | (Inherited from Object.)

See Also

XmlResolver Class


XmlResolver Constructor

[image]

.NET Framework Class Library
XmlResolver Constructor
XmlResolver Class See Also Send Feedback

Creates a new XmlResolver instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New
C#
protected XmlResolver()
Visual C++
protected:
XmlResolver()
JavaScript
JanaBiz.DbXml.XmlResolver = function();

See Also

XmlResolver Class


XmlResolver Methods

[image] [image]

.NET Framework Class Library
XmlResolver Methods
XmlResolver Class See Also Send Feedback

The XmlResolver type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ResolveCollection | When implemented, should resolve a URI to an XmlResults. If the URI cannot be resolved by this resolver, this method should return falseFalsefalsefalse (False in Visual Basic). Otherwise, it should return trueTruetruetrue (True in Visual Basic).
ResolveDocument | When implemented, should resolve a URI to an XmlValue. If the URI cannot be resolved by this resolver, this method should return . Otherwise, it should return trueTruetruetrue (True in Visual Basic).
ResolveEntity | When implemented, should resolve a System ID and Public ID to a new XmlInputStream. If the IDs cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.
ResolveExternalFunction | When implemented this method resolves a unigue combination of function URI, function name and number of arguments into an instance of XmlExternalFunction used to implement an XQuery extension function. If the URI, name and arguments cannot be resolved null is returned. It may return a singleton or a new instance. Memory management of the returned object depends on the implementation of the XmlResolver and the XmlExternalFunction instance. Singletons are usually owned by XmlResolver while new instances must be deleted by Close()()().
ResolveModule | When implemented, should resolve a module location and namespace to a new XmlInputStream.
ResolveModuleLocation | When implemented, should resolve a module namespace to list of strings that are locations for the files that comprise the module.
ResolveSchema | When implemented, should resolve schema location and namespace information to a new XmlInputStream. If this information cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.
ToString | (Inherited from Object.)

See Also

XmlResolver Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlResolver..::.Dispose Method
XmlResolver Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlResolver Class
XmlResolver Members


ResolveCollection Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveCollection Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve a URI to an XmlResults. If the URI cannot be resolved by this resolver, this method should return falseFalsefalsefalse (False in Visual Basic). Otherwise, it should return trueTruetruetrue (True in Visual Basic).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveCollection ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    uri As String, _
    results As XmlResults _
) As Boolean
C#
public virtual bool ResolveCollection(
    XmlTransaction transaction,
    XmlManager manager,
    string uri,
    XmlResults results
)
Visual C++
public:
virtual bool ResolveCollection(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ uri,
    XmlResults^ results
)
JavaScript
function resolveCollection(transaction, manager, uri, results);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
uri
Type: System..::.String
The URI to resolve.
results
Type: JanaBiz.DbXml..::.XmlResults
The XmlResults object in which the results of the resolution are to be placed.

Return Value

See Also

XmlResolver Class


ResolveDocument Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveDocument Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve a URI to an XmlValue. If the URI cannot be resolved by this resolver, this method should return . Otherwise, it should return trueTruetruetrue (True in Visual Basic).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveDocument ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    uri As String, _
    value As XmlValue _
) As Boolean
C#
public virtual bool ResolveDocument(
    XmlTransaction transaction,
    XmlManager manager,
    string uri,
    XmlValue value
)
Visual C++
public:
virtual bool ResolveDocument(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ uri,
    XmlValue^ value
)
JavaScript
function resolveDocument(transaction, manager, uri, value);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
uri
Type: System..::.String
The URI to resolve.
value
Type: JanaBiz.DbXml..::.XmlValue
The XmlValue object in which the results of the resolution are to be placed.

Return Value

See Also

XmlResolver Class


ResolveEntity Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveEntity Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve a System ID and Public ID to a new XmlInputStream. If the IDs cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveEntity ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    systemId As String, _
    publicId As String _
) As XmlInputStream
C#
public virtual XmlInputStream ResolveEntity(
    XmlTransaction transaction,
    XmlManager manager,
    string systemId,
    string publicId
)
Visual C++
public:
virtual XmlInputStream^ ResolveEntity(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ systemId,
    String^ publicId
)
JavaScript
function resolveEntity(transaction, manager, systemId, publicId);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
systemId
Type: System..::.String
The System ID to resolve.
publicId
Type: System..::.String
The Public ID to resolve.

Return Value

A stream containing the results of the resolution.

See Also

XmlResolver Class


ResolveExternalFunction Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveExternalFunction Method
XmlResolver Class See Also Send Feedback

When implemented this method resolves a unigue combination of function URI, function name and number of arguments into an instance of XmlExternalFunction used to implement an XQuery extension function. If the URI, name and arguments cannot be resolved null is returned. It may return a singleton or a new instance. Memory management of the returned object depends on the implementation of the XmlResolver and the XmlExternalFunction instance. Singletons are usually owned by XmlResolver while new instances must be deleted by Close()()().

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveExternalFunction ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    uri As String, _
    name As String, _
    numberOfArgs As UInteger _
) As XmlExternalFunction
C#
public virtual XmlExternalFunction ResolveExternalFunction(
    XmlTransaction transaction,
    XmlManager manager,
    string uri,
    string name,
    uint numberOfArgs
)
Visual C++
public:
virtual XmlExternalFunction^ ResolveExternalFunction(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ uri,
    String^ name,
    unsigned int numberOfArgs
)
JavaScript
function resolveExternalFunction(transaction, manager, uri, name, numberOfArgs);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
uri
Type: System..::.String
The namespace URI of the function to resolve.
name
Type: System..::.String
The name of the function to resolve.
numberOfArgs
Type: System..::.UInt32
The number of arguments passed to the function.

Return Value

An instance of XmlExternalFunction if the function can be resolved, or null.

See Also

XmlResolver Class


ResolveModule Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveModule Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve a module location and namespace to a new XmlInputStream.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveModule ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    moduleLocation As String, _
    nameSpace As String _
) As XmlInputStream
C#
public virtual XmlInputStream ResolveModule(
    XmlTransaction transaction,
    XmlManager manager,
    string moduleLocation,
    string nameSpace
)
Visual C++
public:
virtual XmlInputStream^ ResolveModule(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ moduleLocation,
    String^ nameSpace
)
JavaScript
function resolveModule(transaction, manager, moduleLocation, nameSpace);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
moduleLocation
Type: System..::.String
The location of the module to resolve.
nameSpace
Type: System..::.String
The namespace of the module to resolve.

Return Value

Remarks

If the location and namespace cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.

See Also

XmlResolver Class


ResolveModuleLocation Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveModuleLocation Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve a module namespace to list of strings that are locations for the files that comprise the module.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveModuleLocation ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    nameSpace As String, _
    results As XmlResults _
) As Boolean
C#
public virtual bool ResolveModuleLocation(
    XmlTransaction transaction,
    XmlManager manager,
    string nameSpace,
    XmlResults results
)
Visual C++
public:
virtual bool ResolveModuleLocation(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ nameSpace,
    XmlResults^ results
)
JavaScript
function resolveModuleLocation(transaction, manager, nameSpace, results);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
nameSpace
Type: System..::.String
The module namespace to resolve.
results
Type: JanaBiz.DbXml..::.XmlResults
The XmlResults object in which the results of the resolution are to be placed.

Return Value

Remarks

The strings are returned as XmlValue objects in an XmlResults object. If the module namespace cannot be resolved by this resolver, this method should return falseFalsefalsefalse (False in Visual Basic). Otherwise, it should return trueTruetruetrue (True in Visual Basic).

See Also

XmlResolver Class


ResolveSchema Method

[image]

.NET Framework Class Library
XmlResolver..::.ResolveSchema Method
XmlResolver Class See Also Send Feedback

When implemented, should resolve schema location and namespace information to a new XmlInputStream. If this information cannot be resolved by this resolver, this method should return null. The XmlInputStream object will be deleted by the caller.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveSchema ( _
    transaction As XmlTransaction, _
    manager As XmlManager, _
    schemaLocation As String, _
    nameSpace As String _
) As XmlInputStream
C#
public virtual XmlInputStream ResolveSchema(
    XmlTransaction transaction,
    XmlManager manager,
    string schemaLocation,
    string nameSpace
)
Visual C++
public:
virtual XmlInputStream^ ResolveSchema(
    XmlTransaction^ transaction,
    XmlManager^ manager,
    String^ schemaLocation,
    String^ nameSpace
)
JavaScript
function resolveSchema(transaction, manager, schemaLocation, nameSpace);

Parameters

transaction
Type: JanaBiz.DbXml..::.XmlTransaction
If a transaction is in force, a pointer to the XmlTransaction object; otherwise, null.
manager
Type: JanaBiz.DbXml..::.XmlManager
The XmlManager object associated with the operation.
schemaLocation
Type: System..::.String
The location where the schema resides.
nameSpace
Type: System..::.String
The namespace used by the schema.

Return Value

A stream containing the results of the resolution.

See Also

XmlResolver Class


XmlResults Class

[image]

.NET Framework Class Library
XmlResults Class
Members See Also Send Feedback

The XmlResults class encapsulates the results of a query or other lookup operation. XmlResults is a collection of XmlValue objects, which may represent any one of the supported types.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlResults _
    Inherits InvocationHandle _
    Implements IEnumerator
C#
public class XmlResults : InvocationHandle, IEnumerator
Visual C++
public ref class XmlResults : public InvocationHandle,
    IEnumerator
JavaScript
JanaBiz.DbXml.XmlResults = function();

Type.createClass(
    'JanaBiz.DbXml.XmlResults',
    JanaBiz.Bridge.InvocationHandle,
    IEnumerator);

Remarks

An XmlResults object is created by executing a query or calling Execute(XmlQueryContext) There are several ways that a query is performed. One is to call Query(String, XmlQueryContext) directly. This mechanism is appropriate for one-shot queries that will not be repeated.

A second approach is to create an XmlQueryExpression using Prepare(String, XmlQueryContext). You then execute the query expression using Execute(XmlQueryContext). This approach is appropriate for queries that will be performed more than once as it means that the expense of compiling the query can be amortized across multiple queries.

Note that when you perform a query, you must provide an XmlQueryContext object. Using this object, you can indicate whether you want the query to be performed eagerly or lazily. If eager evaluation is specified (the default), then the resultant values are stored within the XmlResults object. If lazy evaluation is selected, then the resultant values will be computed as needed. In this case the XmlResults object will maintain a reference to the affected containers (XmlContainer), query context (XmlQueryContext), and expression (XmlQueryExpression).

The XmlResults class provides an iteration interface tthrough the Next()()() method. Next()()() method returns falseFalsefalsefalse (False in Visual Basic) and the null value when no more results are available (IsNull returns trueTruetruetrue (True in Visual Basic)). Reset()()() method can be called to reset the iterator, and the subsequent call to the MoveNext()()() method and Current will return the first value of the result set.

The copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlResults

See Also

XmlResults Members


XmlResults Members

[image] [image]

.NET Framework Class Library
XmlResults Members
XmlResults Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlResults type exposes the following members.

Methods

Name | Description
Add | Adds the specified XmlValue to the end of the results set.
AsEventWriter | Returns an instance of XmlEventWriter that can be used to write events to construct content in the XmlResults object. Multiple nodes and/or atomic values can be written. The XmlResults object can then be bound to a variable using SetVariableValue(String, XmlResults) and used in queries. The XmlResults instance must be newly constructed from XmlManager.createResults() and empty or an exception is thrown. Please note that only one active XmlEventWriter is allowed for an XmlResults object.
ConcatResults | Concatenates the XmlValue objects from one XmlResults instance into another. The current result set must be eagerly evaluated and may be empty or not. Copied values are appended to the set and no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. Existing XmlValue objects in the instance are not modified. Resources associated with the XmlResults instance must eventually be released by calling Dispose()()().
CopyResults | Returns a copy of the XmlResults object. The copy is a new, eager object that includes transient copies of all XmlValue objects from the current object. The copies no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. This interface copies a single XmlResults object. Multiple objects can be concatenated into a single XmlResults using ConcatResults(XmlResults). Resources associated with the returned object must eventually be released by calling Dispose()()().
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IsNull | Return true if this is an uninitialized object
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
MovePrevious | Moves the XmlResults enumerator to the previous XmlValue object.
Reset | 列挙子を初期位置、つまりコレクションの最初の要素の前に設定します。
ToString | (Inherited from Object.)

Properties

Name | Description
Current | The current XmlValue object in the enumeration.
EvaluationType | Gets the evaluation type of the XmlResults object. It is either Eager or Lazy , depending on how it was created.
Size | If a query was processed with eager evaluation, a call to the Size method returns the number of values in the result set. If the query was processed with lazy evaluation, a call to Size throws an exception.

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlResults Class


XmlResults Methods

[image] [image]

.NET Framework Class Library
XmlResults Methods
XmlResults Class See Also Send Feedback

The XmlResults type exposes the following members.

Methods

Name | Description
Add | Adds the specified XmlValue to the end of the results set.
AsEventWriter | Returns an instance of XmlEventWriter that can be used to write events to construct content in the XmlResults object. Multiple nodes and/or atomic values can be written. The XmlResults object can then be bound to a variable using SetVariableValue(String, XmlResults) and used in queries. The XmlResults instance must be newly constructed from XmlManager.createResults() and empty or an exception is thrown. Please note that only one active XmlEventWriter is allowed for an XmlResults object.
ConcatResults | Concatenates the XmlValue objects from one XmlResults instance into another. The current result set must be eagerly evaluated and may be empty or not. Copied values are appended to the set and no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. Existing XmlValue objects in the instance are not modified. Resources associated with the XmlResults instance must eventually be released by calling Dispose()()().
CopyResults | Returns a copy of the XmlResults object. The copy is a new, eager object that includes transient copies of all XmlValue objects from the current object. The copies no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. This interface copies a single XmlResults object. Multiple objects can be concatenated into a single XmlResults using ConcatResults(XmlResults). Resources associated with the returned object must eventually be released by calling Dispose()()().
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
IsNull | Return true if this is an uninitialized object
MemberwiseClone | (Inherited from Object.)
MoveNext | 列挙子をコレクションの次の要素に進めます。
MovePrevious | Moves the XmlResults enumerator to the previous XmlValue object.
Reset | 列挙子を初期位置、つまりコレクションの最初の要素の前に設定します。
ToString | (Inherited from Object.)

See Also

XmlResults Class


Add Method

[image]

.NET Framework Class Library
XmlResults..::.Add Method
XmlResults Class See Also Send Feedback

Adds the specified XmlValue to the end of the results set.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Add ( _
    xmlValue As XmlValue _
)
C#
public void Add(
    XmlValue xmlValue
)
Visual C++
public:
void Add(
    XmlValue^ xmlValue
)
JavaScript
function add(xmlValue);

Parameters

xmlValue
Type: JanaBiz.DbXml..::.XmlValue

Remarks

Note that if the XmlResults object was created as the result of a lazy evaluation, this method throws an exception. This method is used primarily for application resolution of collections in queries (see XmlResolver and CreateResults()()()).

See Also

XmlResults Class


AsEventWriter Method

[image]

.NET Framework Class Library
XmlResults..::.AsEventWriter Method
XmlResults Class See Also Send Feedback

Returns an instance of XmlEventWriter that can be used to write events to construct content in the XmlResults object. Multiple nodes and/or atomic values can be written. The XmlResults object can then be bound to a variable using SetVariableValue(String, XmlResults) and used in queries. The XmlResults instance must be newly constructed from XmlManager.createResults() and empty or an exception is thrown. Please note that only one active XmlEventWriter is allowed for an XmlResults object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function AsEventWriter As XmlEventWriter
C#
public XmlEventWriter AsEventWriter()
Visual C++
public:
XmlEventWriter^ AsEventWriter()
JavaScript
function asEventWriter();

Return Value

See Also

XmlResults Class


ConcatResults Method

[image]

.NET Framework Class Library
XmlResults..::.ConcatResults Method
XmlResults Class See Also Send Feedback

Concatenates the XmlValue objects from one XmlResults instance into another.

The current result set must be eagerly evaluated and may be empty or not. Copied values are appended to the set and no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. Existing XmlValue objects in the instance are not modified. Resources associated with the XmlResults instance must eventually be released by calling Dispose()()().

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub ConcatResults ( _
    from As XmlResults _
)
C#
public void ConcatResults(
    XmlResults from
)
Visual C++
public:
void ConcatResults(
    XmlResults^ from
)
JavaScript
function concatResults(from);

Parameters

from
Type: JanaBiz.DbXml..::.XmlResults

See Also

XmlResults Class


CopyResults Method

[image]

.NET Framework Class Library
XmlResults..::.CopyResults Method
XmlResults Class See Also Send Feedback

Returns a copy of the XmlResults object. The copy is a new, eager object that includes transient copies of all XmlValue objects from the current object. The copies no longer reference database objects. This means that they can be used outside of transactions, but also means that operations on the new object will not affect containers. This interface copies a single XmlResults object. Multiple objects can be concatenated into a single XmlResults using ConcatResults(XmlResults). Resources associated with the returned object must eventually be released by calling Dispose()()().

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CopyResults As XmlResults
C#
public XmlResults CopyResults()
Visual C++
public:
XmlResults^ CopyResults()
JavaScript
function copyResults();

Return Value

See Also

XmlResults Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlResults..::.Dispose Method
XmlResults Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlResults Class
XmlResults Members


IsNull Method

[image]

.NET Framework Class Library
XmlResults..::.IsNull Method
XmlResults Class See Also Send Feedback

Return true if this is an uninitialized object

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function IsNull As Boolean
C#
public bool IsNull()
Visual C++
public:
bool IsNull()
JavaScript
function isNull();

Return Value

See Also

XmlResults Class


MoveNext Method

[image]

.NET Framework Class Library
XmlResults..::.MoveNext Method
XmlResults Class See Also Send Feedback

列挙子をコレクションの次の要素に進めます。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function MoveNext As Boolean
C#
public bool MoveNext()
Visual C++
public:
virtual bool MoveNext() sealed
JavaScript
function moveNext();

Return Value

列挙子が次の要素に正常に進んだ場合は trueTruetruetrue (True in Visual Basic)。列挙子がコレクションの末尾を越えた場合は falseFalsefalsefalse (False in Visual Basic)。

Implements

IEnumerator..::.MoveNext()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が作成された後に、コレクションが変更されました。

See Also

XmlResults Class


MovePrevious Method

[image]

.NET Framework Class Library
XmlResults..::.MovePrevious Method
XmlResults Class See Also Send Feedback

Moves the XmlResults enumerator to the previous XmlValue object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function MovePrevious As Boolean
C#
public bool MovePrevious()
Visual C++
public:
bool MovePrevious()
JavaScript
function movePrevious();

Return Value

trueTruetruetrue (True in Visual Basic) if the previous enumerated XmlValue object exists, otherwise falseFalsefalsefalse (False in Visual Basic).

See Also

XmlResults Class


Reset Method

[image]

.NET Framework Class Library
XmlResults..::.Reset Method
XmlResults Class See Also Send Feedback

列挙子を初期位置、つまりコレクションの最初の要素の前に設定します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Reset
C#
public void Reset()
Visual C++
public:
virtual void Reset() sealed
JavaScript
function reset();

Implements

IEnumerator..::.Reset()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が作成された後に、コレクションが変更されました。

See Also

XmlResults Class


XmlResults Properties

[image] [image]

.NET Framework Class Library
XmlResults Properties
XmlResults Class See Also Send Feedback

The XmlResults type exposes the following members.

Properties

Name | Description
Current | The current XmlValue object in the enumeration.
EvaluationType | Gets the evaluation type of the XmlResults object. It is either Eager or Lazy , depending on how it was created.
Size | If a query was processed with eager evaluation, a call to the Size method returns the number of values in the result set. If the query was processed with lazy evaluation, a call to Size throws an exception.

Explicit Interface Implementations

Name | Description
IEnumerator..::.Current | コレクション内の現在の要素を取得します。

See Also

XmlResults Class


IEnumerator.Current Property

[image]

.NET Framework Class Library
XmlResults..::.IEnumerator..::.Current Property
XmlResults Class See Also Send Feedback

コレクション内の現在の要素を取得します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private ReadOnly Property Current As Object
    Implements IEnumerator.Current
C#
Object IEnumerator.Current { get; }
Visual C++
private:
virtual property Object^ Current {
    Object^ get () sealed = IEnumerator::Current::get;
}
JavaScript
JavaScript does not support explicit interface implementations.

Field Value

Implements

IEnumerator..::.Current

Exceptions

Exception | Condition
System..::.InvalidOperationException | 列挙子が、コレクションの最初の要素の前、または最後の要素の後に位置しています。

See Also

XmlResults Class


Current Property

[image]

.NET Framework Class Library
XmlResults..::.Current Property
XmlResults Class See Also Send Feedback

The current XmlValue object in the enumeration.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Current As XmlValue
C#
public XmlValue Current { get; }
Visual C++
public:
property XmlValue^ Current {
    XmlValue^ get ();
}
JavaScript
function get_current();

See Also

XmlResults Class


EvaluationType Property

[image]

.NET Framework Class Library
XmlResults..::.EvaluationType Property
XmlResults Class See Also Send Feedback

Gets the evaluation type of the XmlResults object. It is either Eager or Lazy , depending on how it was created.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EvaluationType As XmlQueryContextEvaluationType
C#
public XmlQueryContextEvaluationType EvaluationType { get; }
Visual C++
public:
property XmlQueryContextEvaluationType EvaluationType {
    XmlQueryContextEvaluationType get ();
}
JavaScript
function get_evaluationType();

See Also

XmlResults Class


Size Property

[image]

.NET Framework Class Library
XmlResults..::.Size Property
XmlResults Class See Also Send Feedback

If a query was processed with eager evaluation, a call to the Size method returns the number of values in the result set. If the query was processed with lazy evaluation, a call to Size throws an exception.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
C#
public int Size { get; }
Visual C++
public:
property int Size {
    int get ();
}
JavaScript
function get_size();

Return Value

See Also

XmlResults Class


XmlStackFrame Class

[image]

.NET Framework Class Library
XmlStackFrame Class
Members See Also Send Feedback

The XmlStackFrame class provides stack trace information about an executing query to the methods of XmlDebugListener. XmlStackFrame objects describe a stack frame in the stack trace and includes a pointer to the previous stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public NotInheritable Class XmlStackFrame _
    Inherits InvocationHandle
C#
public sealed class XmlStackFrame : InvocationHandle
Visual C++
public ref class XmlStackFrame sealed : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlStackFrame = function();

Type.createClass(
    'JanaBiz.DbXml.XmlStackFrame',
    JanaBiz.Bridge.InvocationHandle);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlStackFrame

See Also

XmlStackFrame Members


XmlStackFrame Members

[image] [image]

.NET Framework Class Library
XmlStackFrame Members
XmlStackFrame Class Methods Properties See Also Send Feedback

The XmlStackFrame type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Query | Prepares and executes the query given in the dynamic context of the stack frame. This can be used to examine the value of the context item (".") or variables ("$var") for a given stack frame as well as other parts of the dynamic context. Users may find that the context item and variables present in their original query do not exist during query execution due to optimization performed by DB XML.
ToString | (Inherited from Object.)

Properties

Name | Description
PreviousStackFrame | Returns the previous stack frame or null if this is the first stack frame.
QueryColumn | Returns the column number of the position in the query represented by this stack frame.
QueryFile | Returns the URI of the query represented by this stack frame.
QueryLine | Returns the line number of the position in the query represented by this stack frame.
QueryPlan | Returns the query plan of the sub-expression represented by this stack frame.

See Also

XmlStackFrame Class


XmlStackFrame Methods

[image] [image]

.NET Framework Class Library
XmlStackFrame Methods
XmlStackFrame Class See Also Send Feedback

The XmlStackFrame type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Query | Prepares and executes the query given in the dynamic context of the stack frame. This can be used to examine the value of the context item (".") or variables ("$var") for a given stack frame as well as other parts of the dynamic context. Users may find that the context item and variables present in their original query do not exist during query execution due to optimization performed by DB XML.
ToString | (Inherited from Object.)

See Also

XmlStackFrame Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlStackFrame..::.Dispose Method
XmlStackFrame Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlStackFrame Class
XmlStackFrame Members


Query Method

[image]

.NET Framework Class Library
XmlStackFrame..::.Query Method
XmlStackFrame Class See Also Send Feedback

Prepares and executes the query given in the dynamic context of the stack frame. This can be used to examine the value of the context item (".") or variables ("$var") for a given stack frame as well as other parts of the dynamic context. Users may find that the context item and variables present in their original query do not exist during query execution due to optimization performed by DB XML.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Query ( _
    queryString As String _
) As XmlResults
C#
public XmlResults Query(
    string queryString
)
Visual C++
public:
XmlResults^ Query(
    String^ queryString
)
JavaScript
function query(queryString);

Parameters

queryString
Type: System..::.String
queryString - The query expression to prepare and execute.

Return Value

See Also

XmlStackFrame Class


XmlStackFrame Properties

[image] [image]

.NET Framework Class Library
XmlStackFrame Properties
XmlStackFrame Class See Also Send Feedback

The XmlStackFrame type exposes the following members.

Properties

Name | Description
PreviousStackFrame | Returns the previous stack frame or null if this is the first stack frame.
QueryColumn | Returns the column number of the position in the query represented by this stack frame.
QueryFile | Returns the URI of the query represented by this stack frame.
QueryLine | Returns the line number of the position in the query represented by this stack frame.
QueryPlan | Returns the query plan of the sub-expression represented by this stack frame.

See Also

XmlStackFrame Class


PreviousStackFrame Property

[image]

.NET Framework Class Library
XmlStackFrame..::.PreviousStackFrame Property
XmlStackFrame Class See Also Send Feedback

Returns the previous stack frame or null if this is the first stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousStackFrame As XmlStackFrame
C#
public XmlStackFrame PreviousStackFrame { get; }
Visual C++
public:
property XmlStackFrame^ PreviousStackFrame {
    XmlStackFrame^ get ();
}
JavaScript
function get_previousStackFrame();

Return Value

Returns the previous stack frame or null if this is the first stack frame.

See Also

XmlStackFrame Class


QueryColumn Property

[image]

.NET Framework Class Library
XmlStackFrame..::.QueryColumn Property
XmlStackFrame Class See Also Send Feedback

Returns the column number of the position in the query represented by this stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryColumn As Integer
C#
public int QueryColumn { get; }
Visual C++
public:
property int QueryColumn {
    int get ();
}
JavaScript
function get_queryColumn();

Return Value

See Also

XmlStackFrame Class


QueryFile Property

[image]

.NET Framework Class Library
XmlStackFrame..::.QueryFile Property
XmlStackFrame Class See Also Send Feedback

Returns the URI of the query represented by this stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryFile As String
C#
public string QueryFile { get; }
Visual C++
public:
property String^ QueryFile {
    String^ get ();
}
JavaScript
function get_queryFile();

Return Value

Returns the URI of the query represented by this stack frame.

See Also

XmlStackFrame Class


QueryLine Property

[image]

.NET Framework Class Library
XmlStackFrame..::.QueryLine Property
XmlStackFrame Class See Also Send Feedback

Returns the line number of the position in the query represented by this stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryLine As Integer
C#
public int QueryLine { get; }
Visual C++
public:
property int QueryLine {
    int get ();
}
JavaScript
function get_queryLine();

Return Value

Returns the line number of the position in the query represented by this stack frame.

See Also

XmlStackFrame Class


QueryPlan Property

[image]

.NET Framework Class Library
XmlStackFrame..::.QueryPlan Property
XmlStackFrame Class See Also Send Feedback

Returns the query plan of the sub-expression represented by this stack frame.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryPlan As String
C#
public string QueryPlan { get; }
Visual C++
public:
property String^ QueryPlan {
    String^ get ();
}
JavaScript
function get_queryPlan();

Return Value

Returns the query plan of the sub-expression represented by this stack frame.

See Also

XmlStackFrame Class


XmlStatistics Class

[image]

.NET Framework Class Library
XmlStatistics Class
Members See Also Send Feedback

The XmlStatistics class encapsulates statistical information about the number of keys in existence for a given index.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlStatistics _
    Inherits InvocationHandle
C#
public class XmlStatistics : InvocationHandle
Visual C++
public ref class XmlStatistics : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlStatistics = function();

Type.createClass(
    'JanaBiz.DbXml.XmlStatistics',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Statistics are available for the total number of keys currently in use by the index, as well as the total number of unique keys in use by the index. Use NumberOfIndexedKeys and NumberOfUniqueKeys,respectively, to retrieve these values.

Be aware that the number the number of keys maintained for an index is a function of the number and size of documents stored in the container And of the type of index being examined.

XmlStatistics objects are instantiated by LookupStatistics(String, String, String)

This object is free threaded, and can be safely shared among threads in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlStatistics

See Also

XmlStatistics Members


XmlStatistics Members

[image] [image]

.NET Framework Class Library
XmlStatistics Members
XmlStatistics Class Methods Properties See Also Send Feedback

The XmlStatistics type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
NumberOfIndexedKeys | Returns the total number of keys contained by the index for which statistics are being reported.
NumberOfUniqueKeys | Returns the number of unique keys contained in the index for which statistics are being reported.

See Also

XmlStatistics Class


XmlStatistics Methods

[image] [image]

.NET Framework Class Library
XmlStatistics Methods
XmlStatistics Class See Also Send Feedback

The XmlStatistics type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlStatistics Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlStatistics..::.Dispose Method
XmlStatistics Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlStatistics Class
XmlStatistics Members


XmlStatistics Properties

[image] [image]

.NET Framework Class Library
XmlStatistics Properties
XmlStatistics Class See Also Send Feedback

The XmlStatistics type exposes the following members.

Properties

Name | Description
NumberOfIndexedKeys | Returns the total number of keys contained by the index for which statistics are being reported.
NumberOfUniqueKeys | Returns the number of unique keys contained in the index for which statistics are being reported.

See Also

XmlStatistics Class


NumberOfIndexedKeys Property

[image]

.NET Framework Class Library
XmlStatistics..::.NumberOfIndexedKeys Property
XmlStatistics Class See Also Send Feedback

Returns the total number of keys contained by the index for which statistics are being reported.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NumberOfIndexedKeys As Integer
C#
public int NumberOfIndexedKeys { get; }
Visual C++
public:
property int NumberOfIndexedKeys {
    int get ();
}
JavaScript
function get_numberOfIndexedKeys();

See Also

XmlStatistics Class


NumberOfUniqueKeys Property

[image]

.NET Framework Class Library
XmlStatistics..::.NumberOfUniqueKeys Property
XmlStatistics Class See Also Send Feedback

Returns the number of unique keys contained in the index for which statistics are being reported.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NumberOfUniqueKeys As Integer
C#
public int NumberOfUniqueKeys { get; }
Visual C++
public:
property int NumberOfUniqueKeys {
    int get ();
}
JavaScript
function get_numberOfUniqueKeys();

Remarks

There are likely to be many more keys than unique keys in the index because a given key can appear multiple times, once for each document feature on each document that it is referencing.

See Also

XmlStatistics Class


XmlTransaction Class

[image]

.NET Framework Class Library
XmlTransaction Class
Members See Also Send Feedback

The XmlTransaction class is the handle for a transaction. It encapsulates a DbTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlTransaction _
    Inherits InvocationHandle
C#
public class XmlTransaction : InvocationHandle
Visual C++
public ref class XmlTransaction : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlTransaction = function();

Type.createClass(
    'JanaBiz.DbXml.XmlTransaction',
    JanaBiz.Bridge.InvocationHandle);

Remarks

Methods of the XmlTransaction class are used to rollback and commit the transaction. XmlTransaction handles are provided to XmlContainer, XmlManager And other objects that query and modify documents and containers in order to transactionally protect those database operations.

XmlTransaction objects are instantiated using CreateTransaction()()()

XmlTransaction handles are not free-threaded; transactions handles may be used by multiple threads, but only serially, that is, the application must serialize access to the XmlTransaction handle. Once the Rollback()()() or Commit()()() methods are called, the handle may not be accessed again, regardless of the method's return. In addition, parent transactions may not issue any operations while they have active child transactions (child transactions that have not yet been committed or rollbacked) except for Rollback()()() and Commit()()().

If the object is used after a commit or rollback, an exception is thrown.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlTransaction

See Also

XmlTransaction Members


XmlTransaction Members

[image] [image]

.NET Framework Class Library
XmlTransaction Members
XmlTransaction Class Methods Properties See Also Send Feedback

The XmlTransaction type exposes the following members.

Methods

Name | Description
Commit | End the transaction.
CommitNoSync | End the transaction without flushing the log.
CommitSync | End the transaction and synchronously flush the log.
CreateChild | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Rollback | Rollbacks this instance.
ToString | (Inherited from Object.)

Properties

Name | Description
DbTransaction | The GetDbTransaction method returns a pointer to the DbTransaction object encapsulated by this XmlTransaction object.

See Also

XmlTransaction Class


XmlTransaction Methods

[image] [image]

.NET Framework Class Library
XmlTransaction Methods
XmlTransaction Class See Also Send Feedback

The XmlTransaction type exposes the following members.

Methods

Name | Description
Commit | End the transaction.
CommitNoSync | End the transaction without flushing the log.
CommitSync | End the transaction and synchronously flush the log.
CreateChild | Overloaded.
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
Rollback | Rollbacks this instance.
ToString | (Inherited from Object.)

See Also

XmlTransaction Class


Commit Method

[image]

.NET Framework Class Library
XmlTransaction..::.Commit Method
XmlTransaction Class See Also Send Feedback

End the transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Commit
C#
public void Commit()
Visual C++
public:
void Commit()
JavaScript
function commit();

Remarks

Whether the log is flushed synchronously is determined by the settings for the database environment (the default is to flush the log).

After this method has been called, regardless of its return, the XmlTransaction handle may not be accessed again. If this method encounters an error, the transaction and all child transactions of the transaction are aborted.

See Also

XmlTransaction Class


CommitNoSync Method

[image]

.NET Framework Class Library
XmlTransaction..::.CommitNoSync Method
XmlTransaction Class See Also Send Feedback

End the transaction without flushing the log.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitNoSync
C#
public void CommitNoSync()
Visual C++
public:
void CommitNoSync()
JavaScript
function commitNoSync();

Remarks

This means the transaction will exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); that is, database integrity will be maintained, but it is possible that this transaction may be undone during recovery.

After this method has been called, regardless of its return, the XmlTransaction handle may not be accessed again. If this method encounters an error, the transaction and all child transactions of the transaction are aborted.

See Also

XmlTransaction Class


CommitSync Method

[image]

.NET Framework Class Library
XmlTransaction..::.CommitSync Method
XmlTransaction Class See Also Send Feedback

End the transaction and synchronously flush the log.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub CommitSync
C#
public void CommitSync()
Visual C++
public:
void CommitSync()
JavaScript
function commitSync();

Remarks

This means the transaction will exhibit all of the ACID (atomicity, consistency, isolation, and durability) properties.

After this method has been called, regardless of its return, the XmlTransaction handle may not be accessed again. If this method encounters an error, the transaction and all child transactions of the transaction are aborted.

See Also

XmlTransaction Class


CreateChild Method

[image] [image]

.NET Framework Class Library
XmlTransaction..::.CreateChild Method
XmlTransaction Class See Also Send Feedback

Overload List

Name | Description
CreateChild()()() | The CreateChild method creates a child transaction of this transaction.
CreateChild(XmlTransactionConfig) | The CreateChild method creates a child transaction of this transaction.

See Also

XmlTransaction Class
XmlTransaction Members


CreateChild Method

[image]

.NET Framework Class Library
XmlTransaction..::.CreateChild Method
XmlTransaction Class See Also Send Feedback

The CreateChild method creates a child transaction of this transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChild As XmlTransaction
C#
public XmlTransaction CreateChild()
Visual C++
public:
XmlTransaction^ CreateChild()
JavaScript
function createChild();

Return Value

See Also

XmlTransaction Class
CreateChild Overload


CreateChild Method (XmlTransactionConfig)

[image]

.NET Framework Class Library
XmlTransaction..::.CreateChild Method (XmlTransactionConfig)
XmlTransaction Class See Also Send Feedback

The CreateChild method creates a child transaction of this transaction.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function CreateChild ( _
    transactionConfig As XmlTransactionConfig _
) As XmlTransaction
C#
public XmlTransaction CreateChild(
    XmlTransactionConfig transactionConfig
)
Visual C++
public:
XmlTransaction^ CreateChild(
    XmlTransactionConfig^ transactionConfig
)
JavaScript
function createChild(transactionConfig);

Parameters

transactionConfig
Type: JanaBiz.DbXml..::.XmlTransactionConfig

Return Value

See Also

XmlTransaction Class
CreateChild Overload


Dispose Method

[image] [image]

.NET Framework Class Library
XmlTransaction..::.Dispose Method
XmlTransaction Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlTransaction Class
XmlTransaction Members


Rollback Method

[image]

.NET Framework Class Library
XmlTransaction..::.Rollback Method
XmlTransaction Class See Also Send Feedback

Rollbacks this instance.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Rollback
C#
public void Rollback()
Visual C++
public:
void Rollback()
JavaScript
function rollback();

Remarks

Cause an abnormal termination of the transaction. All write operations previously performed within the scope of the transaction are undone. Before this method returns, any locks held by the transaction will have been released.

In the case of nested transactions, aborting a parent transaction causes all children (unresolved or not) of the parent transaction to be rollback.

After this method has been called, regardless of its return, the XmlTransaction method handle may not be accessed again.

See Also

XmlTransaction Class


XmlTransaction Properties

[image] [image]

.NET Framework Class Library
XmlTransaction Properties
XmlTransaction Class See Also Send Feedback

The XmlTransaction type exposes the following members.

Properties

Name | Description
DbTransaction | The GetDbTransaction method returns a pointer to the DbTransaction object encapsulated by this XmlTransaction object.

See Also

XmlTransaction Class


DbTransaction Property

[image]

.NET Framework Class Library
XmlTransaction..::.DbTransaction Property
XmlTransaction Class See Also Send Feedback

The GetDbTransaction method returns a pointer to the DbTransaction object encapsulated by this XmlTransaction object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbTransaction As DbTransaction
C#
public DbTransaction DbTransaction { get; }
Visual C++
public:
property DbTransaction^ DbTransaction {
    DbTransaction^ get ();
}
JavaScript
function get_dbTransaction();

Return Value

See Also

XmlTransaction Class


XmlTransactionConfig Class

[image]

.NET Framework Class Library
XmlTransactionConfig Class
Members See Also Send Feedback

A class that specifies the configuration of a XmlManager object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlTransactionConfig _
    Inherits DbTransactionConfig
C#
public class XmlTransactionConfig : DbTransactionConfig
Visual C++
public ref class XmlTransactionConfig : public DbTransactionConfig
JavaScript
JanaBiz.DbXml.XmlTransactionConfig = function();

Type.createClass(
    'JanaBiz.DbXml.XmlTransactionConfig',
    JanaBiz.Db.DbTransactionConfig);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.Db..::.DbTransactionConfig
JanaBiz.DbXml..::.XmlTransactionConfig

See Also

XmlTransactionConfig Members


XmlTransactionConfig Members

[image] [image]

.NET Framework Class Library
XmlTransactionConfig Members
XmlTransactionConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlTransactionConfig type exposes the following members.

Constructors

Name | Description
XmlTransactionConfig |

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Degree2 | This transaction will have degree 2 isolation. (Inherited from DbTransactionConfig.)
DirtyRead | All read operations performed by the transaction may read modified but not yet committed data. (Inherited from DbTransactionConfig.)
NoSync | Do not synchronously flush the log when this transaction commits or prepares. (Inherited from DbTransactionConfig.)
NoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock. (Inherited from DbTransactionConfig.)
ReadCommitted | The transaction for read committed isolation. (Inherited from DbTransactionConfig.)
ReadUncommitted | The read operations performed by the transaction are configured to return modified but not yet committed data. (Inherited from DbTransactionConfig.)
Sync | Synchronously flush the log when this transaction commits or prepares. (Inherited from DbTransactionConfig.)
WriteNoSync | The transaction to write but not synchronously flush the log it when commits.Return if the transaction is configured to write but not synchronously flush the log it when commits. (Inherited from DbTransactionConfig.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlTransactionConfig Class


XmlTransactionConfig Constructor

[image]

.NET Framework Class Library
XmlTransactionConfig Constructor
XmlTransactionConfig Class See Also Send Feedback

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlTransactionConfig()
Visual C++
public:
XmlTransactionConfig()
JavaScript
JanaBiz.DbXml.XmlTransactionConfig = function();

See Also

XmlTransactionConfig Class


XmlTransactionConfig Methods

[image] [image]

.NET Framework Class Library
XmlTransactionConfig Methods
XmlTransactionConfig Class See Also Send Feedback

The XmlTransactionConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlTransactionConfig Class


XmlTransactionConfig Properties

[image] [image]

.NET Framework Class Library
XmlTransactionConfig Properties
XmlTransactionConfig Class See Also Send Feedback

The XmlTransactionConfig type exposes the following members.

Properties

Name | Description
Degree2 | This transaction will have degree 2 isolation. (Inherited from DbTransactionConfig.)
DirtyRead | All read operations performed by the transaction may read modified but not yet committed data. (Inherited from DbTransactionConfig.)
NoSync | Do not synchronously flush the log when this transaction commits or prepares. (Inherited from DbTransactionConfig.)
NoWait | If a lock is unavailable for any Berkeley DB operation performed in the context of this transaction, cause the operation to return DB_LOCK_DEADLOCK or throw a DbDeadlockException immediately instead of blocking on the lock. (Inherited from DbTransactionConfig.)
ReadCommitted | The transaction for read committed isolation. (Inherited from DbTransactionConfig.)
ReadUncommitted | The read operations performed by the transaction are configured to return modified but not yet committed data. (Inherited from DbTransactionConfig.)
Sync | Synchronously flush the log when this transaction commits or prepares. (Inherited from DbTransactionConfig.)
WriteNoSync | The transaction to write but not synchronously flush the log it when commits.Return if the transaction is configured to write but not synchronously flush the log it when commits. (Inherited from DbTransactionConfig.)

See Also

XmlTransactionConfig Class


XmlUpdateContext Class

[image]

.NET Framework Class Library
XmlUpdateContext Class
Members See Also Send Feedback

The XmlUpdateContext class encapsulates the context within which update operations are performed against an XmlContainer.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlUpdateContext _
    Inherits InvocationHandle
C#
public class XmlUpdateContext : InvocationHandle
Visual C++
public ref class XmlUpdateContext : public InvocationHandle
JavaScript
JanaBiz.DbXml.XmlUpdateContext = function();

Type.createClass(
    'JanaBiz.DbXml.XmlUpdateContext',
    JanaBiz.Bridge.InvocationHandle);

Remarks

A copy constructor and assignment operator are provided for this class. The class is implemented using a handle-body idiom. When a handle is copied both handles maintain a reference to the same body.

XmlUpdateContext objects are instantiated using CreateUpdateContext()()()

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlUpdateContext

See Also

XmlUpdateContext Members


XmlUpdateContext Members

[image] [image]

.NET Framework Class Library
XmlUpdateContext Members
XmlUpdateContext Class Methods See Also Send Feedback

The XmlUpdateContext type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlUpdateContext Class


XmlUpdateContext Methods

[image] [image]

.NET Framework Class Library
XmlUpdateContext Methods
XmlUpdateContext Class See Also Send Feedback

The XmlUpdateContext type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Equals | (Inherited from Object.)
Finalize | Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection. (Inherited from InvocationHandle.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

See Also

XmlUpdateContext Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlUpdateContext..::.Dispose Method
XmlUpdateContext Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlUpdateContext Class
XmlUpdateContext Members


XmlValue Class

[image]

.NET Framework Class Library
XmlValue Class
Members See Also Send Feedback

The XmlValue class encapsulates the value of a node in an XML document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlValue _
    Inherits InvocationHandle _
    Implements ICloneable
C#
public class XmlValue : InvocationHandle, ICloneable
Visual C++
public ref class XmlValue : public InvocationHandle,
    ICloneable
JavaScript
JanaBiz.DbXml.XmlValue = function();

Type.createClass(
    'JanaBiz.DbXml.XmlValue',
    JanaBiz.Bridge.InvocationHandle,
    ICloneable);

Remarks

The type of the value may be any one of the class constants. There are convenience operators for specially handling the types of String, Double, and Boolean, as well as a constructor to make an XmlValue from XmlDocument.

The XmlValue class provides several constructors, each of which maps a C++ type or Berkeley DB XML class onto an appropriate XmlValue type. The following table lists the constructor parameter mappings.

The XmlValue class implements a set of methods that test if the XmlValue is of a named type. The XmlValue class also implements a set of methods that return the XmlValue as a value of a specified type. If the XmlValue is of type variable and no query context is provided when calling the test or cast methods, or no binding can be found for the variable, an exception is thrown.

In addition to type conversion, the XmlValue class also provides DOM-like navigation functions. Using these, you can retrieve features from the underlying document, such as the parent, an attribute, or a child of the current node.

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.InvocationHandle
JanaBiz.DbXml..::.XmlValue

See Also

XmlValue Members


XmlValue Members

[image] [image]

.NET Framework Class Library
XmlValue Members
XmlValue Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlValue type exposes the following members.

Constructors

Name | Description
XmlValue | Overloaded.

Methods

Name | Description
Assign
Assigns from the specified XmlValue.
Clone
現在のインスタンスのコピーである新しいオブジェクトを作成します。
Dispose | Overloaded.
Equals | Overloaded.
Finalize
Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection.
(Inherited from InvocationHandle.)
GetHashCode
特定の型のハッシュ関数として機能します。ハッシュ アルゴリズムや、ハッシュ テーブルのようなデータ構造での使用に適しています。
(Overrides Object..::.GetHashCode()()().)
GetType | (Inherited from Object.)
IsValueType
Indicates whether the XmlValue is of the specified XmlValueType.
MemberwiseClone | (Inherited from Object.)
ToBinary
Returns the value as a Binary
ToBoolean
Returns the value as a Boolean
ToDocument
Returns the value as an XmlDocument
ToEventReader
Returns the value as an XmlEventReader.
ToNode
Returns the value as a XercesC DOMNode.

Return Value

this method is removed from version 2.4.13
ToNumber
Returns the value as a Double.
ToString
現在の Object を表す String を返します。
(Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | XmlValue の 2 つの指定したインスタンスが等しいかどうかを判断します。
Inequality | XmlValue の 2 つの指定したインスタンスが等しくないかどうかを判断します。

Properties

Name | Description
IsBoolean | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type Boolean.
IsNode | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is of type Node -- a DOM node.
IsNull | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue has no value (type None).
IsNumber | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of the numeric types, such as Double, Float, etc.
IsString | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type String.
NodeHandle | Returns a string handle representing an XmlValue of type XmlValue::NODE, which can be used to construct a new XmlValue object representing the same node, at a later time, using XmlContainer::getNode. The handle returned encodes its document ID; however, it does not include its container. Matching a node handle to container is the responsibility of the caller. Node handles are guaranteed to remain stable in the absence of modifications to a document. If a document is modified, a handle may cease to exist, or may belong to a different node. If the node type is not XmlValue::NODE, XmlException::INVALID_VALUE is thrown.
TypeName | Returns the type name of the XmlValue.
TypeURI | Returns the type URI of the XmlValue.
ValueType | Returns the type of the XmlValue, which will be one of the XmlValue class constants.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

XmlValue Class


XmlValue Constructor

[image] [image]

.NET Framework Class Library
XmlValue Constructor
XmlValue Class See Also Send Feedback

Overload List

Name | Description
XmlValue()()() | Public constructor. Creates empty object.
XmlValue(XmlDocument) | Construct a value from a document.
XmlValue(XmlValue) | Construct a value from a XmlValue.
XmlValue(Boolean) | Construct a value from a bool.
XmlValue(Double) | Construct a value from a double.
XmlValue(String) | Construct a value from a string.
XmlValue(XmlValueType, XmlData) | Construct a typed value from a XmlData.
XmlValue(XmlValueType, String) | Construct a typed value from a string.
XmlValue(String, String, String) | Construct a typed value, where the type is defined by a URI and name, from a string.

See Also

XmlValue Class
XmlValue Members


XmlValue Constructor

[image]

.NET Framework Class Library
XmlValue Constructor
XmlValue Class See Also Send Feedback

Public constructor. Creates empty object.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlValue()
Visual C++
public:
XmlValue()
JavaScript
JanaBiz.DbXml.XmlValue = function();

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (XmlDocument)

[image]

.NET Framework Class Library
XmlValue Constructor (XmlDocument)
XmlValue Class See Also Send Feedback

Construct a value from a document.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As XmlDocument _
)
C#
public XmlValue(
    XmlDocument value
)
Visual C++
public:
XmlValue(
    XmlDocument^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(value);

Parameters

value
Type: JanaBiz.DbXml..::.XmlDocument

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (XmlValue)

[image]

.NET Framework Class Library
XmlValue Constructor (XmlValue)
XmlValue Class See Also Send Feedback

Construct a value from a XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As XmlValue _
)
C#
public XmlValue(
    XmlValue value
)
Visual C++
public:
XmlValue(
    XmlValue^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(value);

Parameters

value
Type: JanaBiz.DbXml..::.XmlValue

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (Boolean)

[image]

.NET Framework Class Library
XmlValue Constructor (Boolean)
XmlValue Class See Also Send Feedback

Construct a value from a bool.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As Boolean _
)
C#
public XmlValue(
    bool value
)
Visual C++
public:
XmlValue(
    bool value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(value);

Parameters

value
Type: System..::.Boolean

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (Double)

[image]

.NET Framework Class Library
XmlValue Constructor (Double)
XmlValue Class See Also Send Feedback

Construct a value from a double.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As Double _
)
C#
public XmlValue(
    double value
)
Visual C++
public:
XmlValue(
    double value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(value);

Parameters

value
Type: System..::.Double

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (String)

[image]

.NET Framework Class Library
XmlValue Constructor (String)
XmlValue Class See Also Send Feedback

Construct a value from a string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)
C#
public XmlValue(
    string value
)
Visual C++
public:
XmlValue(
    String^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(value);

Parameters

value
Type: System..::.String

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (XmlValueType, XmlData)

[image]

.NET Framework Class Library
XmlValue Constructor (XmlValueType, XmlData)
XmlValue Class See Also Send Feedback

Construct a typed value from a XmlData.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    xmlValueType As XmlValueType, _
    value As XmlData _
)
C#
public XmlValue(
    XmlValueType xmlValueType,
    XmlData value
)
Visual C++
public:
XmlValue(
    XmlValueType xmlValueType,
    XmlData^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(xmlValueType, value);

Parameters

xmlValueType
Type: JanaBiz.DbXml..::.XmlValueType
value
Type: JanaBiz.DbXml..::.XmlData

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (XmlValueType, String)

[image]

.NET Framework Class Library
XmlValue Constructor (XmlValueType, String)
XmlValue Class See Also Send Feedback

Construct a typed value from a string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    xmlValueType As XmlValueType, _
    value As String _
)
C#
public XmlValue(
    XmlValueType xmlValueType,
    string value
)
Visual C++
public:
XmlValue(
    XmlValueType xmlValueType,
    String^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(xmlValueType, value);

Parameters

xmlValueType
Type: JanaBiz.DbXml..::.XmlValueType
value
Type: System..::.String

See Also

XmlValue Class
XmlValue Overload


XmlValue Constructor (String, String, String)

[image]

.NET Framework Class Library
XmlValue Constructor (String, String, String)
XmlValue Class See Also Send Feedback

Construct a typed value, where the type is defined by a URI and name, from a string.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    typeURI As String, _
    typeName As String, _
    value As String _
)
C#
public XmlValue(
    string typeURI,
    string typeName,
    string value
)
Visual C++
public:
XmlValue(
    String^ typeURI,
    String^ typeName,
    String^ value
)
JavaScript
JanaBiz.DbXml.XmlValue = function(typeURI, typeName, value);

Parameters

typeURI
Type: System..::.String
URI defining the type.
typeName
Type: System..::.String
Name of the type.
value
Type: System..::.String
The XmlValue object value.

See Also

XmlValue Class
XmlValue Overload


XmlValue Methods

[image] [image]

.NET Framework Class Library
XmlValue Methods
XmlValue Class See Also Send Feedback

The XmlValue type exposes the following members.

Methods

Name | Description
Assign
Assigns from the specified XmlValue.
Clone
現在のインスタンスのコピーである新しいオブジェクトを作成します。
Dispose | Overloaded.
Equals | Overloaded.
Finalize
Releases unmanaged resources and performs other cleanup operations before the InvocationHandle is reclaimed by garbage collection.
(Inherited from InvocationHandle.)
GetHashCode
特定の型のハッシュ関数として機能します。ハッシュ アルゴリズムや、ハッシュ テーブルのようなデータ構造での使用に適しています。
(Overrides Object..::.GetHashCode()()().)
GetType | (Inherited from Object.)
IsValueType
Indicates whether the XmlValue is of the specified XmlValueType.
MemberwiseClone | (Inherited from Object.)
ToBinary
Returns the value as a Binary
ToBoolean
Returns the value as a Boolean
ToDocument
Returns the value as an XmlDocument
ToEventReader
Returns the value as an XmlEventReader.
ToNode
Returns the value as a XercesC DOMNode.

Return Value

this method is removed from version 2.4.13
ToNumber
Returns the value as a Double.
ToString
現在の Object を表す String を返します。
(Overrides Object..::.ToString()()().)

Operators

Name | Description
Equality | XmlValue の 2 つの指定したインスタンスが等しいかどうかを判断します。
Inequality | XmlValue の 2 つの指定したインスタンスが等しくないかどうかを判断します。

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。

See Also

XmlValue Class


ICloneable.Clone Method

[image]

.NET Framework Class Library
XmlValue..::.ICloneable..::.Clone Method
XmlValue Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone
C#
Object ICloneable.Clone()
Visual C++
private:
virtual Object^ Clone() sealed = ICloneable::Clone
JavaScript
JavaScript does not support explicit interface implementations.

Return Value

このインスタンスのコピーである新しいオブジェクト。

Implements

ICloneable..::.Clone()()()

See Also

XmlValue Class


Assign Method

[image]

.NET Framework Class Library
XmlValue..::.Assign Method
XmlValue Class See Also Send Feedback

Assigns from the specified XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub Assign ( _
    otherValue As XmlValue _
)
C#
public void Assign(
    XmlValue otherValue
)
Visual C++
public:
void Assign(
    XmlValue^ otherValue
)
JavaScript
function assign(otherValue);

Parameters

otherValue
Type: JanaBiz.DbXml..::.XmlValue
The other value.

See Also

XmlValue Class


Clone Method

[image]

.NET Framework Class Library
XmlValue..::.Clone Method
XmlValue Class See Also Send Feedback

現在のインスタンスのコピーである新しいオブジェクトを作成します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Clone As XmlValue
C#
public XmlValue Clone()
Visual C++
public:
XmlValue^ Clone()
JavaScript
function clone();

Return Value

このインスタンスのコピーである新しいオブジェクト。

See Also

XmlValue Class


Dispose Method

[image] [image]

.NET Framework Class Library
XmlValue..::.Dispose Method
XmlValue Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)
Dispose(Boolean) | アンマネージ リソースの解放およびリセットに関連付けられているアプリケーション定義のタスクを実行します。 (Inherited from InvocationHandle.)

See Also

XmlValue Class
XmlValue Members


Equality Operator

[image]

.NET Framework Class Library
XmlValue..::.Equality Operator
XmlValue Class See Also Send Feedback

XmlValue の 2 つの指定したインスタンスが等しいかどうかを判断します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator = ( _
    left As XmlValue, _
    right As XmlValue _
) As Boolean
C#
public static bool operator ==(
    XmlValue left,
    XmlValue right
)
Visual C++
public:
static bool operator ==(
    XmlValue^ left,
    XmlValue^ right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: JanaBiz.DbXml..::.XmlValue
XmlValue
right
Type: JanaBiz.DbXml..::.XmlValue
XmlValue

Return Value

left が right に等しい場合は trueTruetruetrue (True in Visual Basic) 。それ以外の場合は falseFalsefalsefalse (False in Visual Basic) 。

See Also

XmlValue Class


Equals Method

[image] [image]

.NET Framework Class Library
XmlValue..::.Equals Method
XmlValue Class See Also Send Feedback

Overload List

Name | Description
Equals(XmlValue) | Determines if two XmlValue objects represent the same value. It returns trueTruetruetrue (True in Visual Basic) if the two XmlValue objects represent the same value.
Equals(Object) | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Overrides Object..::.Equals(Object).)

See Also

XmlValue Class
XmlValue Members


Equals Method (XmlValue)

[image]

.NET Framework Class Library
XmlValue..::.Equals Method (XmlValue)
XmlValue Class See Also Send Feedback

Determines if two XmlValue objects represent the same value. It returns trueTruetruetrue (True in Visual Basic) if the two XmlValue objects represent the same value.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function Equals ( _
    otherValue As XmlValue _
) As Boolean
C#
public bool Equals(
    XmlValue otherValue
)
Visual C++
public:
bool Equals(
    XmlValue^ otherValue
)
JavaScript
function equals(otherValue);

Parameters

otherValue
Type: JanaBiz.DbXml..::.XmlValue
another XmlValue

Return Value

See Also

XmlValue Class
Equals Overload


Equals Method (Object)

[image]

.NET Framework Class Library
XmlValue..::.Equals Method (Object)
XmlValue Class See Also Send Feedback

指定した Object が、現在の Object と等しいかどうかを判断します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
C#
public override bool Equals(
    Object obj
)
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override
JavaScript
function equals(obj);

Parameters

obj
Type: System..::.Object
現在の Object と比較する Object。

Return Value

指定した Object が現在の Object と等しい場合は trueTruetruetrue (True in Visual Basic)。それ以外の場合は falseFalsefalsefalse (False in Visual Basic)。

See Also

XmlValue Class
Equals Overload


GetHashCode Method

[image]

.NET Framework Class Library
XmlValue..::.GetHashCode Method
XmlValue Class See Also Send Feedback

特定の型のハッシュ関数として機能します。ハッシュ アルゴリズムや、ハッシュ テーブルのようなデータ構造での使用に適しています。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
C#
public override int GetHashCode()
Visual C++
public:
virtual int GetHashCode() override
JavaScript
function getHashCode();

Return Value

現在の Object のハッシュ コード。

See Also

XmlValue Class


Inequality Operator

[image]

.NET Framework Class Library
XmlValue..::.Inequality Operator
XmlValue Class See Also Send Feedback

XmlValue の 2 つの指定したインスタンスが等しくないかどうかを判断します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As XmlValue, _
    right As XmlValue _
) As Boolean
C#
public static bool operator !=(
    XmlValue left,
    XmlValue right
)
Visual C++
public:
static bool operator !=(
    XmlValue^ left,
    XmlValue^ right
)
JavaScript
JavaScript does not support overloaded operators.

Parameters

left
Type: JanaBiz.DbXml..::.XmlValue
XmlValue
right
Type: JanaBiz.DbXml..::.XmlValue
XmlValue

Return Value

left が right と等しくない場合は trueTruetruetrue (True in Visual Basic) 。それ以外の場合は falseFalsefalsefalse (False in Visual Basic) 。

See Also

XmlValue Class


IsValueType Method

[image]

.NET Framework Class Library
XmlValue..::.IsValueType Method
XmlValue Class See Also Send Feedback

Indicates whether the XmlValue is of the specified XmlValueType.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function IsValueType ( _
    valueType As XmlValueType _
) As Boolean
C#
public bool IsValueType(
    XmlValueType valueType
)
Visual C++
public:
bool IsValueType(
    XmlValueType valueType
)
JavaScript
function isValueType(valueType);

Parameters

valueType
Type: JanaBiz.DbXml..::.XmlValueType
an XmlValueType

See Also

XmlValue Class


ToBinary Method

[image]

.NET Framework Class Library
XmlValue..::.ToBinary Method
XmlValue Class See Also Send Feedback

Returns the value as a Binary

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToBinary As XmlData
C#
public XmlData ToBinary()
Visual C++
public:
XmlData^ ToBinary()
JavaScript
function toBinary();

Return Value

See Also

XmlValue Class


ToBoolean Method

[image]

.NET Framework Class Library
XmlValue..::.ToBoolean Method
XmlValue Class See Also Send Feedback

Returns the value as a Boolean

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToBoolean As Boolean
C#
public bool ToBoolean()
Visual C++
public:
bool ToBoolean()
JavaScript
function toBoolean();

Return Value

See Also

XmlValue Class


ToDocument Method

[image]

.NET Framework Class Library
XmlValue..::.ToDocument Method
XmlValue Class See Also Send Feedback

Returns the value as an XmlDocument

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToDocument As XmlDocument
C#
public XmlDocument ToDocument()
Visual C++
public:
XmlDocument^ ToDocument()
JavaScript
function toDocument();

Return Value

See Also

XmlValue Class


ToEventReader Method

[image]

.NET Framework Class Library
XmlValue..::.ToEventReader Method
XmlValue Class See Also Send Feedback

Returns the value as an XmlEventReader.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToEventReader As XmlEventReader
C#
public XmlEventReader ToEventReader()
Visual C++
public:
XmlEventReader^ ToEventReader()
JavaScript
function toEventReader();

Return Value

Returns the value as an XmlEventReader.

See Also

XmlValue Class


ToNode Method

[image]

.NET Framework Class Library
XmlValue..::.ToNode Method
XmlValue Class See Also Send Feedback

Returns the value as a XercesC DOMNode.

Return Value

this method is removed from version 2.4.13

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToNode As XmlNode
C#
public XmlNode ToNode()
Visual C++
public:
XmlNode^ ToNode()
JavaScript
function toNode();

See Also

XmlValue Class


ToNumber Method

[image]

.NET Framework Class Library
XmlValue..::.ToNumber Method
XmlValue Class See Also Send Feedback

Returns the value as a Double.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Function ToNumber As Double
C#
public double ToNumber()
Visual C++
public:
double ToNumber()
JavaScript
function toNumber();

Return Value

See Also

XmlValue Class


ToString Method

[image]

.NET Framework Class Library
XmlValue..::.ToString Method
XmlValue Class See Also Send Feedback

現在の Object を表す String を返します。

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString As String
C#
public override string ToString()
Visual C++
public:
virtual String^ ToString() override
JavaScript
function toString();

Return Value

現在の Object を表す String。

See Also

XmlValue Class


XmlValue Properties

[image] [image]

.NET Framework Class Library
XmlValue Properties
XmlValue Class See Also Send Feedback

The XmlValue type exposes the following members.

Properties

Name | Description
IsBoolean | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type Boolean.
IsNode | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is of type Node -- a DOM node.
IsNull | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue has no value (type None).
IsNumber | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of the numeric types, such as Double, Float, etc.
IsString | Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type String.
NodeHandle | Returns a string handle representing an XmlValue of type XmlValue::NODE, which can be used to construct a new XmlValue object representing the same node, at a later time, using XmlContainer::getNode. The handle returned encodes its document ID; however, it does not include its container. Matching a node handle to container is the responsibility of the caller. Node handles are guaranteed to remain stable in the absence of modifications to a document. If a document is modified, a handle may cease to exist, or may belong to a different node. If the node type is not XmlValue::NODE, XmlException::INVALID_VALUE is thrown.
TypeName | Returns the type name of the XmlValue.
TypeURI | Returns the type URI of the XmlValue.
ValueType | Returns the type of the XmlValue, which will be one of the XmlValue class constants.

See Also

XmlValue Class


IsBoolean Property

[image]

.NET Framework Class Library
XmlValue..::.IsBoolean Property
XmlValue Class See Also Send Feedback

Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type Boolean.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBoolean As Boolean
C#
public bool IsBoolean { get; }
Visual C++
public:
property bool IsBoolean {
    bool get ();
}
JavaScript
function get_isBoolean();

See Also

XmlValue Class


IsNode Property

[image]

.NET Framework Class Library
XmlValue..::.IsNode Property
XmlValue Class See Also Send Feedback

Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is of type Node -- a DOM node.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNode As Boolean
C#
public bool IsNode { get; }
Visual C++
public:
property bool IsNode {
    bool get ();
}
JavaScript
function get_isNode();

See Also

XmlValue Class


IsNull Property

[image]

.NET Framework Class Library
XmlValue..::.IsNull Property
XmlValue Class See Also Send Feedback

Returns trueTruetruetrue (True in Visual Basic) if the XmlValue has no value (type None).

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNull As Boolean
C#
public bool IsNull { get; }
Visual C++
public:
property bool IsNull {
    bool get ();
}
JavaScript
function get_isNull();

See Also

XmlValue Class


IsNumber Property

[image]

.NET Framework Class Library
XmlValue..::.IsNumber Property
XmlValue Class See Also Send Feedback

Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of the numeric types, such as Double, Float, etc.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsNumber As Boolean
C#
public bool IsNumber { get; }
Visual C++
public:
property bool IsNumber {
    bool get ();
}
JavaScript
function get_isNumber();

See Also

XmlValue Class


IsString Property

[image]

.NET Framework Class Library
XmlValue..::.IsString Property
XmlValue Class See Also Send Feedback

Returns trueTruetruetrue (True in Visual Basic) if the XmlValue is one of type String.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsString As Boolean
C#
public bool IsString { get; }
Visual C++
public:
property bool IsString {
    bool get ();
}
JavaScript
function get_isString();

See Also

XmlValue Class


NodeHandle Property

[image]

.NET Framework Class Library
XmlValue..::.NodeHandle Property
XmlValue Class See Also Send Feedback

Returns a string handle representing an XmlValue of type XmlValue::NODE, which can be used to construct a new XmlValue object representing the same node, at a later time, using XmlContainer::getNode. The handle returned encodes its document ID; however, it does not include its container. Matching a node handle to container is the responsibility of the caller. Node handles are guaranteed to remain stable in the absence of modifications to a document. If a document is modified, a handle may cease to exist, or may belong to a different node. If the node type is not XmlValue::NODE, XmlException::INVALID_VALUE is thrown.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NodeHandle As String
C#
public string NodeHandle { get; }
Visual C++
public:
property String^ NodeHandle {
    String^ get ();
}
JavaScript
function get_nodeHandle();

See Also

XmlValue Class


TypeName Property

[image]

.NET Framework Class Library
XmlValue..::.TypeName Property
XmlValue Class See Also Send Feedback

Returns the type name of the XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeName As String
C#
public string TypeName { get; }
Visual C++
public:
property String^ TypeName {
    String^ get ();
}
JavaScript
function get_typeName();

See Also

XmlValue Class


TypeURI Property

[image]

.NET Framework Class Library
XmlValue..::.TypeURI Property
XmlValue Class See Also Send Feedback

Returns the type URI of the XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TypeURI As String
C#
public string TypeURI { get; }
Visual C++
public:
property String^ TypeURI {
    String^ get ();
}
JavaScript
function get_typeURI();

See Also

XmlValue Class


ValueType Property

[image]

.NET Framework Class Library
XmlValue..::.ValueType Property
XmlValue Class See Also Send Feedback

Returns the type of the XmlValue, which will be one of the XmlValue class constants.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ValueType As XmlValueType
C#
public XmlValueType ValueType { get; }
Visual C++
public:
property XmlValueType ValueType {
    XmlValueType get ();
}
JavaScript
function get_valueType();

See Also

XmlValue Class


XmlValueType Enumeration

[image]

.NET Framework Class Library
XmlValueType Enumeration
See Also Send Feedback

Enumeration representing the primitive schema type of the XmlValue.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration XmlValueType
C#
public enum XmlValueType
Visual C++
public enum class XmlValueType
JavaScript
JanaBiz.DbXml.XmlValueType = function();
JanaBiz.DbXml.XmlValueType.createEnum('JanaBiz.DbXml.XmlValueType', false);

Members

Member name | Description
None | none.
Node | A node value.
AnyURI | A value with a primitive schema type of xs:anyURI
Base64Binary | A value with a primitive schema type of xs:base64Binary
Boolean | A value with a primitive schema type of xs:boolean
Date | A value with a primitive schema type of xs:date format: YYYY-MM-DD see: http://www.w3.org/TR/xmlschema-2/#date
DateTime | A value with a primitive schema type of xs:dateTime format: YYYY-MM-DDThh:mm:ss[.sss] see: http://www.w3.org/TR/xmlschema-2/#dateTime
DayTimeDuration | A value with a primitive schema type of xs:dayTimeDuration format: PnYnMnDTnHnMnS see: http://www.w3.org/TR/xmlschema-2/#duration
Decimal | A value with a primitive schema type of xs:decimal
Double | A value with a primitive schema type of xs:double
Duration | A value with a primitive schema type of xs:duration duration format: PnYnMnDTnHnMnS see: http://www.w3.org/TR/xmlschema-2/#duration
Float | A value with a primitive schema type of xs:float
GDay | A value with a primitive schema type of xs:gDay gDay format: ---DD see: http://www.w3.org/TR/xmlschema-2/#gDay
GMonth | A value with a primitive schema type of xs:gMonth gMonth format: --MM see: http://www.w3.org/TR/xmlschema-2/#gMonth
GMonthDay | A value with a primitive schema type of xs:gMonthDay gMonthDay format: --MM-DD see: http://www.w3.org/TR/xmlschema-2/#gMonthDay
GYear | A value with a primitive schema type of xs:gYear gYear format: YYYY see: http://www.w3.org/TR/xmlschema-2/#gYear
GYearMonth | A value with a primitive schema type of xs:gYearMonth gYearMonth format: YYYY-MM see: http://www.w3.org/TR/xmlschema-2/#gYearMonth
HexBinary | A value with a primitive schema type of xs:hexBinary
Notation | A value with a primitive schema type of xs:NOTATION
QName | A value with a primitive schema type of xs:QName
String | A value with a primitive schema type of xs:string
Time | A value with a primitive schema type of xs:time format:hh:mm:ss see: http://www.w3.org/TR/xmlschema-2/#time
YearMonthDuration | A value with a primitive schema type of xs:yearMonthDuration format: PnYnM see: http://www.w3.org/TR/xmlschema-2/#duration
UntypedAtomic | A value with a primitive schema type of xs:untypedAtomic
Binary | A value with a primitive schema type of binary

See Also


XmlVerifyConfig Class

[image]

.NET Framework Class Library
XmlVerifyConfig Class
Members See Also Send Feedback

Specifies the attributes of a verification operation.

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Class XmlVerifyConfig _
    Inherits DbVerifyConfig
C#
public class XmlVerifyConfig : DbVerifyConfig
Visual C++
public ref class XmlVerifyConfig : public DbVerifyConfig
JavaScript
JanaBiz.DbXml.XmlVerifyConfig = function();

Type.createClass(
    'JanaBiz.DbXml.XmlVerifyConfig',
    JanaBiz.Db.DbVerifyConfig);

Inheritance Hierarchy

System..::.Object
JanaBiz.Bridge..::.FlagsBase
JanaBiz.Db..::.DbVerifyConfig
JanaBiz.DbXml..::.XmlVerifyConfig

See Also

XmlVerifyConfig Members


XmlVerifyConfig Members

[image] [image]

.NET Framework Class Library
XmlVerifyConfig Members
XmlVerifyConfig Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The XmlVerifyConfig type exposes the following members.

Constructors

Name | Description
XmlVerifyConfig |

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Properties

Name | Description
Aggressive | Output all the key/data pairs in the file that can be found. (Inherited from DbVerifyConfig.)
NoOrderCheck | Skip the database checks for btree and duplicate sort order and for hashing. (Inherited from DbVerifyConfig.)
OrderCheckOnly | Only perform the order check. (Inherited from DbVerifyConfig.)
Printable | Use printable format for salvage. (Inherited from DbVerifyConfig.)
Salvage | Write the key/data pairs from all databases in the file to the file stream named in the outfile parameter. (Inherited from DbVerifyConfig.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlVerifyConfig Class


XmlVerifyConfig Constructor

[image]

.NET Framework Class Library
XmlVerifyConfig Constructor
XmlVerifyConfig Class See Also Send Feedback

Namespace: JanaBiz.DbXml
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public XmlVerifyConfig()
Visual C++
public:
XmlVerifyConfig()
JavaScript
JanaBiz.DbXml.XmlVerifyConfig = function();

See Also

XmlVerifyConfig Class


XmlVerifyConfig Methods

[image] [image]

.NET Framework Class Library
XmlVerifyConfig Methods
XmlVerifyConfig Class See Also Send Feedback

The XmlVerifyConfig type exposes the following members.

Methods

Name | Description
Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetHashCode | (Inherited from Object.)
GetType | (Inherited from Object.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Object.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone | 現在のインスタンスのコピーである新しいオブジェクトを作成します。 (Inherited from FlagsBase.)

See Also

XmlVerifyConfig Class


XmlVerifyConfig Properties

[image] [image]

.NET Framework Class Library
XmlVerifyConfig Properties
XmlVerifyConfig Class See Also Send Feedback

The XmlVerifyConfig type exposes the following members.

Properties

Name | Description
Aggressive | Output all the key/data pairs in the file that can be found. (Inherited from DbVerifyConfig.)
NoOrderCheck | Skip the database checks for btree and duplicate sort order and for hashing. (Inherited from DbVerifyConfig.)
OrderCheckOnly | Only perform the order check. (Inherited from DbVerifyConfig.)
Printable | Use printable format for salvage. (Inherited from DbVerifyConfig.)
Salvage | Write the key/data pairs from all databases in the file to the file stream named in the outfile parameter. (Inherited from DbVerifyConfig.)

See Also

XmlVerifyConfig Class


JanaBiz.DbXml.Exceptions Namespace

[image]

.NET Framework Class Library
JanaBiz.DbXml.Exceptions Namespace
Send Feedback

Classes

Class | Description
DbXmlException | Represention of an error condition that has occurred within the Berkeley DB XML system. The system throws an DbXmlException if an API method call results in an error condition.

Enumerations

Enumeration | Description
DbXmlExceptionCode | Enumeration representing the classification of DbXmlException.


DbXmlException Class

[image]

.NET Framework Class Library
DbXmlException Class
Members See Also Send Feedback

Represention of an error condition that has occurred within the Berkeley DB XML system. The system throws an DbXmlException if an API method call results in an error condition.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DbXmlException _
    Inherits ApplicationException _
    Implements ISerializable
C#
[SerializableAttribute]
public class DbXmlException : ApplicationException,
    ISerializable
Visual C++
[SerializableAttribute]
public ref class DbXmlException : public ApplicationException,
    ISerializable
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function();

Type.createClass(
    'JanaBiz.DbXml.Exceptions.DbXmlException',
    ApplicationException,
    ISerializable);

Remarks

This object is not thread-safe, and can only be safely used by one thread at a time in an application.

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
JanaBiz.DbXml.Exceptions..::.DbXmlException

See Also

DbXmlException Members
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Members

[image] [image]

.NET Framework Class Library
DbXmlException Members
DbXmlException Class Constructors Methods Properties See Also Send Feedback

The DbXmlException type exposes the following members.

Constructors

Name | Description
DbXmlException | Overloaded.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

Properties

Name | Description
Data | (Inherited from Exception.)
DbErrorCode | Gets the Berkeley DB error number for an XmlException with DatabaseError.
ExceptionCode | Gets the code.
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
QueryColumn | Returns the column within the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].
QueryFile | If the exception code is [!:DbXmlExceptionCode.XPathParserError], this property returns the name of the module containing the error if it is available; otherwise it returns null. Use QueryLine and QueryColumn to get more information.
QueryLine | Returns the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor

[image] [image]

.NET Framework Class Library
DbXmlException Constructor
DbXmlException Class See Also Send Feedback

Overload List

Name | Description
DbXmlException()()() | Creates a new DbXmlException instance.
DbXmlException(String) | Initializes a new instance of the DbXmlException class.
DbXmlException(DbXmlExceptionCode, String) | Initializes a new instance of the DbXmlException class.
DbXmlException(SerializationInfo, StreamingContext) | Initializes a new instance of the DbXmlException class.
DbXmlException(String, Exception) | Initializes a new instance of the DbXmlException class.
DbXmlException(DbXmlExceptionCode, Int32, String) | Creates a new DbXmlException instance.
DbXmlException(DbXmlExceptionCode, String, Exception) | Initializes a new instance of the DbXmlException class.
DbXmlException(DbXmlExceptionCode, Int32, String, Exception) | Creates a new DbXmlException instance.
DbXmlException(DbXmlExceptionCode, Int32, String, Int32, Int32, String) | Initializes a new instance of the DbXmlException class.
DbXmlException(DbXmlExceptionCode, Int32, String, Int32, Int32, String, Exception) | Initializes a new instance of the DbXmlException class.

See Also

DbXmlException Class
DbXmlException Members
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor

[image]

.NET Framework Class Library
DbXmlException Constructor
DbXmlException Class See Also Send Feedback

Creates a new DbXmlException instance.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New
C#
public DbXmlException()
Visual C++
public:
DbXmlException()
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function();

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (String)

[image]

.NET Framework Class Library
DbXmlException Constructor (String)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
C#
public DbXmlException(
    string message
)
Visual C++
public:
DbXmlException(
    String^ message
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(message);

Parameters

message
Type: System..::.String
The message.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, String)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, String)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    message As String _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    string message
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    String^ message
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, message);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The DbXml exception code.
message
Type: System..::.String
The message.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (SerializationInfo, StreamingContext)

[image]

.NET Framework Class Library
DbXmlException Constructor (SerializationInfo, StreamingContext)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
protected DbXmlException(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
protected:
DbXmlException(
    SerializationInfo^ info,
    StreamingContext context
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
シリアル化されたオブジェクト データを保持するオブジェクト。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報。

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (String, Exception)

[image]

.NET Framework Class Library
DbXmlException Constructor (String, Exception)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
C#
public DbXmlException(
    string message,
    Exception innerException
)
Visual C++
public:
DbXmlException(
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(message, innerException);

Parameters

message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, Int32, String)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, Int32, String)
DbXmlException Class See Also Send Feedback

Creates a new DbXmlException instance.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    dbErrorCode As Integer, _
    message As String _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    string message
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    String^ message
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, dbErrorCode, message);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The DbXml exception code.
dbErrorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, String, Exception)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, String, Exception)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    message As String, _
    innerException As Exception _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, message, innerException);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The DbXml exception code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Exception)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Exception)
DbXmlException Class See Also Send Feedback

Creates a new DbXmlException instance.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    dbErrorCode As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    string message,
    Exception innerException
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, dbErrorCode, message, innerException);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The DbXml exception code.
dbErrorCode
Type: System..::.Int32
The Db error code.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Int32, Int32, String)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Int32, Int32, String)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    dbErrorCode As Integer, _
    queryFile As String, _
    queryLine As Integer, _
    queryColumn As Integer, _
    message As String _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    string queryFile,
    int queryLine,
    int queryColumn,
    string message
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    String^ queryFile,
    int queryLine,
    int queryColumn,
    String^ message
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, dbErrorCode, queryFile, queryLine, queryColumn, message);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The db XML exception code.
dbErrorCode
Type: System..::.Int32
The db error code.
queryFile
Type: System..::.String
The query file.
queryLine
Type: System..::.Int32
The query line.
queryColumn
Type: System..::.Int32
The query column.
message
Type: System..::.String
The message.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Int32, Int32, String, Exception)

[image]

.NET Framework Class Library
DbXmlException Constructor (DbXmlExceptionCode, Int32, String, Int32, Int32, String, Exception)
DbXmlException Class See Also Send Feedback

Initializes a new instance of the DbXmlException class.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Sub New ( _
    dbXmlExceptionCode As DbXmlExceptionCode, _
    dbErrorCode As Integer, _
    queryFile As String, _
    queryLine As Integer, _
    queryColumn As Integer, _
    message As String, _
    innerException As Exception _
)
C#
public DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    string queryFile,
    int queryLine,
    int queryColumn,
    string message,
    Exception innerException
)
Visual C++
public:
DbXmlException(
    DbXmlExceptionCode dbXmlExceptionCode,
    int dbErrorCode,
    String^ queryFile,
    int queryLine,
    int queryColumn,
    String^ message,
    Exception^ innerException
)
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlException = function(dbXmlExceptionCode, dbErrorCode, queryFile, queryLine, queryColumn, message, innerException);

Parameters

dbXmlExceptionCode
Type: JanaBiz.DbXml.Exceptions..::.DbXmlExceptionCode
The db XML exception code.
dbErrorCode
Type: System..::.Int32
The db error code.
queryFile
Type: System..::.String
The query file.
queryLine
Type: System..::.Int32
The query line.
queryColumn
Type: System..::.Int32
The query column.
message
Type: System..::.String
The message.
innerException
Type: System..::.Exception
The inner exception.

See Also

DbXmlException Class
DbXmlException Overload
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Methods

[image] [image]

.NET Framework Class Library
DbXmlException Methods
DbXmlException Class See Also Send Feedback

The DbXmlException type exposes the following members.

Methods

Name | Description
Equals | (Inherited from Object.)
Finalize | (Inherited from Object.)
GetBaseException | (Inherited from Exception.)
GetHashCode | (Inherited from Object.)
GetObjectData | 派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。 (Overrides Exception..::.GetObjectData(SerializationInfo, StreamingContext).)
GetType | (Inherited from Exception.)
MemberwiseClone | (Inherited from Object.)
ToString | (Inherited from Exception.)

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


GetObjectData Method

[image]

.NET Framework Class Library
DbXmlException..::.GetObjectData Method
DbXmlException Class See Also Send Feedback

派生クラスでオーバーライドされた場合は、その例外に関する情報を使用して SerializationInfo を設定します。

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter := True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
C#
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter = true)]
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual C++
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter = true)]
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
JavaScript
function getObjectData(info, context);

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
スローされている例外に関するシリアル化済みオブジェクト データを保持している SerializationInfo。
context
Type: System.Runtime.Serialization..::.StreamingContext
転送元または転送先に関するコンテキスト情報を含んでいる StreamingContext。

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)
_Exception..::.GetObjectData(SerializationInfo, StreamingContext)

Exceptions

Exception | Condition
System..::.ArgumentNullException | info パラメータが null 参照 (Visual Basic の場合は nullNothingnullptra null reference (Nothing in Visual Basic)) です。

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


DbXmlException Properties

[image] [image]

.NET Framework Class Library
DbXmlException Properties
DbXmlException Class See Also Send Feedback

The DbXmlException type exposes the following members.

Properties

Name | Description
Data | (Inherited from Exception.)
DbErrorCode | Gets the Berkeley DB error number for an XmlException with DatabaseError.
ExceptionCode | Gets the code.
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
QueryColumn | Returns the column within the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].
QueryFile | If the exception code is [!:DbXmlExceptionCode.XPathParserError], this property returns the name of the module containing the error if it is available; otherwise it returns null. Use QueryLine and QueryColumn to get more information.
QueryLine | Returns the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


DbErrorCode Property

[image]

.NET Framework Class Library
DbXmlException..::.DbErrorCode Property
DbXmlException Class See Also Send Feedback

Gets the Berkeley DB error number for an XmlException with DatabaseError.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbErrorCode As Integer
C#
public int DbErrorCode { get; }
Visual C++
public:
property int DbErrorCode {
    int get ();
}
JavaScript
function get_dbErrorCode();

Field Value

The database error code.

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


ExceptionCode Property

[image]

.NET Framework Class Library
DbXmlException..::.ExceptionCode Property
DbXmlException Class See Also Send Feedback

Gets the code.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExceptionCode As DbXmlExceptionCode
C#
public DbXmlExceptionCode ExceptionCode { get; }
Visual C++
public:
property DbXmlExceptionCode ExceptionCode {
    DbXmlExceptionCode get ();
}
JavaScript
function get_exceptionCode();

Field Value

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


QueryColumn Property

[image]

.NET Framework Class Library
DbXmlException..::.QueryColumn Property
DbXmlException Class See Also Send Feedback

Returns the column within the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryColumn As Integer
C#
public int QueryColumn { get; }
Visual C++
public:
property int QueryColumn {
    int get ();
}
JavaScript
function get_queryColumn();

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


QueryFile Property

[image]

.NET Framework Class Library
DbXmlException..::.QueryFile Property
DbXmlException Class See Also Send Feedback

If the exception code is [!:DbXmlExceptionCode.XPathParserError], this property returns the name of the module containing the error if it is available; otherwise it returns null. Use QueryLine and QueryColumn to get more information.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryFile As String
C#
public string QueryFile { get; }
Visual C++
public:
property String^ QueryFile {
    String^ get ();
}
JavaScript
function get_queryFile();

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


QueryLine Property

[image]

.NET Framework Class Library
DbXmlException..::.QueryLine Property
DbXmlException Class See Also Send Feedback

Returns the line of the XQuery expression that contains the error causing the exception, in the case of [!:DbXmlExceptionCode.XPathParserError].

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueryLine As Integer
C#
public int QueryLine { get; }
Visual C++
public:
property int QueryLine {
    int get ();
}
JavaScript
function get_queryLine();

See Also

DbXmlException Class
JanaBiz.DbXml.Exceptions Namespace


DbXmlExceptionCode Enumeration

[image]

.NET Framework Class Library
DbXmlExceptionCode Enumeration
See Also Send Feedback

Enumeration representing the classification of DbXmlException.

Namespace: JanaBiz.DbXml.Exceptions
Assembly: JanaBiz.DbXml (in JanaBiz.DbXml.dll)

Syntax

Visual Basic (Declaration)
Public Enumeration DbXmlExceptionCode
C#
public enum DbXmlExceptionCode
Visual C++
public enum class DbXmlExceptionCode
JavaScript
JanaBiz.DbXml.Exceptions.DbXmlExceptionCode = function();
JanaBiz.DbXml.Exceptions.DbXmlExceptionCode.createEnum('JanaBiz.DbXml.Exceptions.DbXmlExceptionCode', false);

Members

Member name | Description
InternalError | An internal error occured.
ContainerOpen | The container is open.
ContainerClosed | The container is closed.
NullPointer | null pointer exception
IndexerParserError | XML Indexer could not parse a document.
DatabaseError | Berkeley DB reported a database problem.
QueryParserError | The query parser was unable to parse the expression.
Unused1Error | Unused
QueryEvaluationError | The query evaluator was unable to execute the expression.
Unused2Error | Unused
LazyEvaluation | XmlResults is lazily evaluated.
DocumentNotFound | The specified document could not be found
ContainerExists | The container already exists.
UnknownIndex | The indexing strategy name is unknown.
InvalidValue | An invalid parameter was passed.
VersionMismatch | The container version and the dbxml library version are not compatible.
EventError | Error using the event reader
ContainerNotFound | The specified container could not be found
TransactionError | An XmlTransaction has already been committed or aborted
UniqueError | A uniqueness constraint has been violated
NoMemoryError | An operation was unable to allocate memory
OperationTimeout | A query operation timed out.
OperationInterrupted | A query operation was interrupted by the application.

See Also

JanaBiz.DbXml.Exceptions Namespace